Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-02-2017 09:57:48

IP Man
Membre
Lieu : Cameroun
Distrib. : Débian Gnome 8.1
Inscription : 19-02-2017
Site Web

Impossible d'installer les pakages

Bonjour à vous,
svp j'essai depuis d'installer nagios sur Debian. J'ai essayé en offline, avec des packages que mon encadreur m'a remis, la configuration de l'interface web ne marche pas.
Quand je fais

root@lepro:/home/ipman/Bureau/Cours/nagios-4.0.5#make install-webconf


j'ai le message

/usr/bin/install -c -m 644 sample-config/httpd.conf /etc/httpd/conf .d/nagios.conf
/usr/bin/install: impossible de créer le fichier standard <</etc/httpd/conf.d/nagios.conf>>: Aucun fichier ou dossier de ce type
Makefile:295: recipe for target 'install-webconf' failed
make:***[install-webconf] Error 1


Je ne sais pas quoi faire.
Alors, j'ai décidé de faire l'installation online,

J'ai téléchargé les pakages mysql-server-4.1, php4-gd, etc avec la commande

wget packages.debian.org/stable/doc/apache4.doc



ou


wget packages.debian.org/stable/web/php4-gd



etc
et j'ai tout sauvegardé dans le dossier /nagios/download

Seulement quand je veux installer, je fais

root@lepro:/nagios/download# apt-get install mysql-server-4.1



je recois le message

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
E: Impossible de trouver le paquet mysql-server-4.1
E: Impossible de trouver de paquet correspondant à l'expression rationnelle «*mysql-server-4.1*»



Je ne sais pas pourquoi, alors que le paquet est bel et bien là
Merci de votre aide.

PS, si sur le forum il y a déjà eu un sujet pareil, svp je voudrai le lien parce que je n'ai pas trouvé et le temps joue contre moi, svp
Merci


Le Pro Informatique

Hors ligne

#2 19-02-2017 10:24:53

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible d'installer les pakages

Bonjour

si tu est en jessie 8.xx
le méta-paquet  =>  https://packages.debian.org/fr/jessie/mysql-server

il va t installer mysql-server-5.5


apt-get install mysql-server
 



nota : version disponible sur jessie

la version de php (méta-paquet )  =>  https://packages.debian.org/fr/jessie/php5

il faut apache installé je suppose  =>   https://packages.debian.org/jessie/apache2

pour nagios je sais pas , mais les versions que tu donne sur ton post ne correspondes pas a debian jessie

la version dans jessie  =>  https://packages.debian.org/fr/jessie/nagios3

il te faut au minimum nagios3 , nagios-plugins et nagios3-doc

Dernière modification par robert2a (19-02-2017 10:45:12)

Hors ligne

#3 19-02-2017 10:45:20

IP Man
Membre
Lieu : Cameroun
Distrib. : Débian Gnome 8.1
Inscription : 19-02-2017
Site Web

Re : Impossible d'installer les pakages

robert2a a écrit :



il faut apache installé je suppose



Bonjour et merci pour ton aide.
Déjà oui, j'utilise Jessie

Comment installer apache?


Le Pro Informatique

Hors ligne

#4 19-02-2017 10:50:28

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible d'installer les pakages

avec  apt-get install


apt-get install apache2
 



puis (pour php)


apt-get install php5
 



nota : je te conseille de lire les cahiers de l admin debian (wheezy ou jessie )  pour apprendre l utilisation de debian (de nagios , apache et php  )  wink

Dernière modification par robert2a (19-02-2017 10:54:25)

Hors ligne

#5 19-02-2017 10:53:44

IP Man
Membre
Lieu : Cameroun
Distrib. : Débian Gnome 8.1
Inscription : 19-02-2017
Site Web

Re : Impossible d'installer les pakages

robert2a a écrit :

avec  apt-get install


apt-get install apache2
 



c'est ce que je fais, et le resultat est que la derniere version de apache est déjà installée, la version apache2


Le Pro Informatique

Hors ligne

#6 19-02-2017 10:56:02

IP Man
Membre
Lieu : Cameroun
Distrib. : Débian Gnome 8.1
Inscription : 19-02-2017
Site Web

Re : Impossible d'installer les pakages

Le soucis est au niveau de mysql-server, php qui refusent de s'installer, et de la configuration de l'interface web de nagios (parce que c'est ça qui m'interesse le plus, vu que mon projet porte sur l'administration reseau avec nagios)

Le Pro Informatique

Hors ligne

#7 19-02-2017 10:56:25

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Impossible d'installer les pakages

donc il est installé , passe a php puis a nagios (ton probléme est les mauvaises versions de paquet , si tu installe a partir de jessie avec apt-get install , cela doit fonctionner .

je t ai mit les liens vers les bon paquets au dessus


apt-get install nagios3
 



si tu tape localhost (ou 127.0.0.1) dans ton navigateur il doit répondre "it's work" il me semble (fonctionnement correct pour apache )
après faut tout configurer .....

Dernière modification par robert2a (19-02-2017 11:01:31)

Hors ligne

#8 19-02-2017 11:00:38

IP Man
Membre
Lieu : Cameroun
Distrib. : Débian Gnome 8.1
Inscription : 19-02-2017
Site Web

Re : Impossible d'installer les pakages

Ok, merci
Je vais essayer, merci beaucoup

Le Pro Informatique

Hors ligne

Pied de page des forums