Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-02-2017 20:21:47

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[Résolu] Faire lire mes .htaccess

Bonjour à vous,

mon code a toujours bien fonctionné (PHP) jusqu'à l'installation de mon nouveau serveur Apache2.

Je soupçonne donc que mes configuration Apache2 et PHP-7 puissent porter quelqu'anomalie.

En effet, je reçois un message d'erreur lors de l'exploitation de ob_start.  Or  http://php.net/manual/fr/function.ob-start.php parle en ces termes: 

Avertissement

Quelques serveurs web (par exemple Apache) modifient le dossier de travail d'un script lorsqu'il appelle une fonction de rappel. Vous pouvez revenir à un comportement normal en ajoutant chdir(dirname($_SERVER['SCRIPT_FILENAME'])) dans votre fonction de rappel.



Je crois donc qu'il me faudrait définir un répertoire temporaire dans la configuration php.ini ou dans mes configurations d'Apache2.
Peut-être suffit-il de définir des droits d'écriture à un répertoire bien existant.
J'apprécierais votre aide.

Merci.

Dernière modification par Patriboom (24-02-2017 04:12:46)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 23-02-2017 07:34:05

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Faire lire mes .htaccess

C'est une question de droits accordés, j'en suis sûr, mais je n'arrive pas à recréer ce que j'avais avant:
De mon HDD précédent j'ai recopié à l'identique les fichiers, la base de données et les droits de celle-ci.
Ne restent que les droits accordés aux fichiers qui semblent être différents.

C'est la gestion "laraval" qui fait suer  (banque de codes PHP).  Je n'ai pas choisi d'utiliser ce spagetthi, non, ça vient avec un outil fort utile « Bugs », un gestionnaire de billets de travail (tickets).  J'aimerais retrouver mon outil de travail.

Une piste?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#3 23-02-2017 07:36:33

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Faire lire mes .htaccess

J'y pense, peut-être ai-je oublié d'installer un module complémentaire d'apache ?    scratchhead.gif

Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 23-02-2017 16:25:44

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Faire lire mes .htaccess

C'est bien ce que je pensais: problème de configuration

Voici mon seul fichier du répertoire  /etc/apache2/sites-enabled


<VirtualHost *:80>
  #ServerName www.example.com

  ServerAdmin webmaster@localhost
  DocumentRoot /var/www/html

  #LogLevel info ssl:warn

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

  # For most configuration files from conf-available/, which are
  #Include conf-available/serve-cgi-bin.conf

  <Directory "/home/patrick/MesSites">
    Options FollowSymLinks
    AllowOverride None
  </Directory>
  <Directory "/home/patrick/MesSites">
    AllowOverride All
    Order allow,deny
    Require all granted
    allow from all
  </Directory>
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
 




J'ai éliminé les commentaires du document.

Peut-être y a-t-il incohérence entre /var/www/html et /home/patrick/MesSites   Est-ce la source du problème ?   J'en doute.
J'essaie cela pour vous rassurer.  Si je laisse le présent message affiché, c'est parce que cette solution n'est pas la bonne.

Versions:
- Debian Jessie
- Appache 2.4

Merci de votre aide.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#5 24-02-2017 04:12:20

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Faire lire mes .htaccess

C'est bon, merci de m'avoir lu.

Le module rewrite n'avait pas été appelé.  Installé, mais jamais appelé.  Quelle étrange chose, non!

Si ça vous arrive:
1) donnez la propriété suivante à vos fichiers et répertoire :  propriétaire =  usager   groupe:  www-data
2) Assurez-vous que soit démarré le module rewrite à chaque démarrage du serveur apache2
3) Donnez le droit à vos sites de ré-écrire les .htaccess.

En commandes, ça donnera:


chown -R usager:www-data /var/www/htlm/MesSites
ln -s ln -s ../mods-available/rewrite.load /etc/apache2/mods-enabled/rewrite.load
pico /etc/apache2/sites-available/000-default.conf
 



Dans votre fichier 000-default.conf, vous créerez des commandes semblables à ceci:


      <Directory "/var/www/html/MesSites">
          AllowOverride All
          DirectoryIndex "index.php"
        </Directory>
 




Au plaisir.


Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums