Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-02-2017 18:52:32

CloDeClo
Membre
Distrib. : Debian-Facile-9-6-amd64 (stretch à jour)
Noyau : 4.18.0-0.bpo.1-amd64 (backports)
(G)UI : Debian-Facile-9 (XFCE)
Inscription : 24-02-2017

installation de Flash Player [résolu]

Bonjour,
je ne suis pas loin de convaincre une Me Michu de conserver son vieil ordinateur XP dégénéré en passant à HandyLinux.2.5  (I386 !) au lieu d'acheter un nouveau PC en W10.
Mais un incontournable : pouvoir pluzzer FR3 PBLV est une figure imposée !....

Je pensais qu'il n'y avait aucun souci : il suffirait de télécharger FlashPlayer quand FireFox me le demanderai.
Naïveté totale, trop présomptueux, je me suis ramassé un rejet de FireFox qui ne savait pas (tout comme moi !) traiter l'URL apt:adobe-flashplugin?channel=$distro-partner...
Je suis reparti piteux et chez moi (en HL.2.5 mais AMD64) j'ai tenté d'installer ce fichu Adobe Flash Player...

Face à une foultitude de pages contradictoires sur le sujet, face à des paquets browser-plugin-freshplayer-pepperflash qui n'existent pas (plus ?) ou qui ont changé de nom (PPAPI NPAPI ???), il n'y avait encore rien là-dessus sur ce forum et j'allais appeler à l'aide sur ce forum.
Depuis, je pense avoir résolu l'affaire, mais je vois que je me suis fait griller. Je vais quand même poster ce que j'avais préparé bien que je fasse un doublon de
Pb Install lecteur flash !!! et Flashplugin-nonfree - Firefox 51.0.1 - créer le plugin
Il y a quelques petits points de détail différents et je procède souvent d'une autre manière  : si cela peut aider à comprendre et soulager un peu les neurones de ceux qui voudraient faire cette installation...
Autre préambule : tout cela a l'air de bouger à une vitesse folle, donc tout ce qui a marché pour moi ne marchera que tant que cela marchera...

Adobe Flash Player semble exister en version 24.0.0.221 pour FireFox-Linux  (NPAPI) et Chrome (PPAPI) d'après
http://www.adobe.com/software/flash/about/

Je me suis inspiré de http://ubuntuhandbook.org/index.php/201 … ra-ubuntu/ où le point de départ est le navigateur Chrome
c'est à dire que
j'ai installé le navigateur Chromium via Synaptic (recherche sur chromium et sélection des 3 paquets chromium, chromium-l10n pour vous éviter de chercher bêtement pourquoi le menu reste en anglais alors que vous avez sélectionné la langue Fr, et pepperflashplugin-nonfree)
j'ai téléchargé l'archive FP 24.0 PPAPI "installer=FP_24.0_for_Linux_64-bit_(.tar.gz)-_PPAPI" en optant pour "Linux (64-bit)" + ".tar.gz for Linux" sur la page get-flashplayer
j'ai décompressé cette archive vers un dossier ***/PPAPI puis transféré le fichier ***/PPAPI/libpepflashplayer.so dans le dossier /usr/lib/pepperflashplugin-nonfree en entrant sudo thunar dans une terminal et effectuant couper-coller
Et ça roule pour Chrome sur http://pluzz.francetv.fr/videos/plus_belle_la_vie.html
Me Michu pourra très certainement pluzzer avec Chrome si je fais pareil chez elle en sélectionnant Linux (32-bit).

Pour poursuivre avec FireFox, c'est le même principe mais avec NPAPI...
j'ai téléchargé l'archive FP 24.0 NPAPI "installer=FP_24.0_for_Linux_64-bit_(.tar.gz)-_NPAPI" en optant pour "Linux (64-bit)" + ".tar.gz for Linux" sur la page get-flashplayer
j'ai décompressé cette archive vers un dossier ***/NPAPI puis transféré le fichier ***/NPAPI/libpepflashplayer.so dans mon dossier de plug-in qui pour moi se trouve en /usr/lib/mozilla/plugins/ en entrant sudo thunar dans une terminal et effectuant couper-coller.
Je lance FireFox sur http://pluzz.francetv.fr/videos/plus_belle_la_vie.html, ça ne marche pas car il faut encore aller dans le menu Outils / Modules complémentaires / Plugins et passer de "ne jamais activer " à "activer à la demande" ou "toujours"

Je mettrai ce sujet résolu si cela marche aussi bien chez Me Michu (passage sous 8 jours).

Dernière modification par CloDeClo (05-03-2017 15:16:06)

Hors ligne

#2 25-02-2017 19:06:56

IceF0x
Membre
Distrib. : Jessie 8.7
Noyau : Linux 3.16.0-4-amd64
(G)UI : OpenBox
Inscription : 05-02-2012

Re : installation de Flash Player [résolu]

wget https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/linux64/flash_player_npapi_linux.x86_64.tar.gz


vive la ligne de commande cthulhu.gif

Edit: n'oublie pas que les vieux CPU ne supporte pas le greffon flash car il n'est plus compilé avec les anciennes instruction jugées obsolète par adobe.

Dernière modification par IceF0x (25-02-2017 19:10:21)


1475862269.gif

Hors ligne

#3 25-02-2017 20:39:27

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : installation de Flash Player [résolu]

Bonsoir
ce paquet ne fait pas l' affaire =>  https://packages.debian.org/fr/jessie/f … in-nonfree

tu peut l installer par synaptic ou en console graphique


apt-get install flashplugin-nonfree
 


tu la pour wheezy ,jessie et stretch
nota : je connais pas le résultat ma religion m interdit ce genre de choses  tongue   wink

description


This package will download the Flash Player from Adobe.  It is a
Netscape/Mozilla type plugin.  Any browser based on Netscape or Mozilla can
use the Flash Player.  See https://wiki.debian.org/FlashPlayer for a list of
browsers currently supported in Debian.

WARNING: Installing this Debian package causes the
Adobe Flash Player to be downloaded from www.adobe.com.
The End User License Agreement of the Adobe Flash Player
is available at www.adobe.com.
 

Dernière modification par robert2a (25-02-2017 20:40:26)

Hors ligne

#4 25-02-2017 20:48:02

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : installation de Flash Player [résolu]

@robert2a : ce paquet a un bug actuellement et ne met pas à jour vers la dernière version et du coup je ne sais même pas s'il installe flash si on l'installe pour la première fois.

Hors ligne

#5 25-02-2017 22:45:36

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : installation de Flash Player [résolu]

Bonsoir
c'est pour cela que j'ai précisé que je ne l'ai pas testé , donc pas la solution   hmm

Hors ligne

#6 25-02-2017 22:56:05

Trefix
Adhérent(e)
Lieu : 48
Distrib. : kiss0s Stretch + bpo
Noyau : linux 4.9.0-8-amd64
(G)UI : fluxbox par arnault
Inscription : 15-02-2015

Re : installation de Flash Player [résolu]

IceF0x a écrit :

n'oublie pas que les vieux CPU ne supportent pas le greffon flash

Je n'ai pas attendu d'être vieux pour ne plus supporter Flash tongue


HL > DF // Les cahiers du débutant // DFLinux
.
JE SUIS toujours abonné à CHARLIE

Hors ligne

#7 26-02-2017 00:18:06

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : installation de Flash Player [résolu]

toujours en forme Trefix smile

[mode aéré]

Hors ligne

#8 26-02-2017 16:52:39

Atapaz
Membre
Distrib. : Debian stable
Noyau : Linux 4.9.0-3-amd64
(G)UI : KDE
Inscription : 07-07-2016

Re : installation de Flash Player [résolu]

Salut,

Je viens de faire une installation de Debian stable, et dans les choses que j'ai dû faire, il y a eu flashplayer. Donc, effectivement, lors de la première installation de flashplugin-nonfree, ça déconne.
J'ai eu la solution sur le wiki de Debian : .

Plouc en exil

Hors ligne

#9 26-02-2017 20:08:05

CloDeClo
Membre
Distrib. : Debian-Facile-9-6-amd64 (stretch à jour)
Noyau : 4.18.0-0.bpo.1-amd64 (backports)
(G)UI : Debian-Facile-9 (XFCE)
Inscription : 24-02-2017

Re : installation de Flash Player [résolu]

Merci à tous...merci.gif

Pour une affaire que je croyais réglée, je crains qu'une fois de plus je ne me sois montré naïf voire inconscient !...
J'ai bien fait de maintenir mon post malgré les doublonnages...
Ce que j'ai retenu de ces diverses réactions :

Donc ce qui marche chez moi (AMD64) risque fort de ne pas marcher sur l'ordinausore !... Me Michu va-t-elle devoir se payer un nouveau PC ?. Je vous en reparlerai.

Les lignes de commande... ouais !, j'ai vu ça dans le cahier du débutant... J'aime bien comprendre ce que je fais et s'il n'y a pas un commentaire clair à coté (souvent absent, juste un script de commandes !) je suis très méfiant et c'est épuisant de comprendre le but. Désolé, on ne se refait pas... Quand l'interface graphique permet de le faire de manière plus sécurisée je n'hésite pas.
C'est aussi pourquoi je préfère passer par le site https://get.adobe.com/flashplayer/otherversions/ pour savoir ce que je télécharge... Je ne suis peut-être pas le seul débutant dans ce cas...

Ce qui m'inquiète le plus, c'est ce débat sur flashplugin-nonfree; je croyais que justement pepperflashplugin-nonfree était là pour ça et je n'ai pas constaté de dysfonctionnement en l'utilisant... Encore à côté de la plaque ?

à suivre...

Hors ligne

#10 04-03-2017 18:54:07

CloDeClo
Membre
Distrib. : Debian-Facile-9-6-amd64 (stretch à jour)
Noyau : 4.18.0-0.bpo.1-amd64 (backports)
(G)UI : Debian-Facile-9 (XFCE)
Inscription : 24-02-2017

Re : installation de Flash Player [résolu]

Bonjour,
retour de mon passage chez ma Me Michu...
Comme vous me l'aviez annoncé, ça ne marche pas en I386 ! pas de pepperflash !ops.gif

Mais j'ai sauvé l'honneur en réussissant à installer CAPTV : j'ai suivi sans anicroche le tutoriel https://handylinux.org/forum/viewtopic.php?id=618 (merci.gifexcellent, merci chaluold_geek.gif)
Puis j'ai convaincu ma Me Michu que c'était mieux de télécharger au plus tôt en heure creuse pour pouvoir visionner sans souci en heure chargée et même plus de huit jours après...

Je vais donc mettre "résolu" bien que cela reste sans solution.
Merci à tousyes.gif

Hors ligne

#11 04-03-2017 19:07:16

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : installation de Flash Player [résolu]

J'ai mis à jour ce tuto ici :
https://debian-facile.org/utilisateurs: … os:captvty
Normalement avec la version sur le forum de handylinux, on ne peut plus télécharger ie8 avec winetricks

Hors ligne

#12 05-03-2017 10:09:25

CloDeClo
Membre
Distrib. : Debian-Facile-9-6-amd64 (stretch à jour)
Noyau : 4.18.0-0.bpo.1-amd64 (backports)
(G)UI : Debian-Facile-9 (XFCE)
Inscription : 24-02-2017

Re : installation de Flash Player [résolu]

Bonjour,
je n'ai rencontré aucune difficulté en suivant ce tutoriel https://handylinux.org/forum/viewtopic.php?id=618 pour l'ordinausore  I386.
Du coup j'ai voulu procéder à l'installation de CAPTV chez moi (en AMD64) en suivant https://debian-facile.org/utilisateurs: … os:captvty.

Là tout va bien jusqu'à l'installation de Framework .Net 4 :

 clodeclo@H-Linux ~
 $ export WINEARCH=win32
 clodeclo@H-Linux ~
 $ /usr/bin/winetricks dotnet40
------------------------------------------------------
wine cmd.exe /c echo '%ProgramFiles%' returned empty string, error message 'wine: '/home/claudie/.wine' is a 64-bit installation, it cannot be used with a 32-bit wineserver.'
------------------------------------------------------
 clodeclo@H-Linux ~


J'ai pourtant bien installé le paquet wine-bin:i386 comme le montre le résultat de recherche sur "wine" dans Synaptic :
79gybJhEw.paquets-wine-05032017.s.png

crash.gifJ'ai foiré quelque chose ? Est ce parce que j'avais déjà mis wine (certainement 64-bit) avant ?sos.gif

PS : peut-être devrais ouvrir un autre sujet ?scratchhead.gif

Hors ligne

#13 05-03-2017 10:21:58

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : installation de Flash Player [résolu]

Oui, un nouveau post c'est bien pour captv et 32bits.

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#14 05-03-2017 10:33:38

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : installation de Flash Player [résolu]

yep et C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. pour la première question
--
choco ö/ smolski
/x\->[]

[mode aéré]

Hors ligne

#15 05-03-2017 10:43:35

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : installation de Flash Player [résolu]

Si tu n'as pas eu de souci pour télécharger ie8, le bug de l'adresse internet est peut être corriger, à vérifier.
A bientôt sur l'autre fil wink

Hors ligne

#16 05-03-2017 15:15:14

CloDeClo
Membre
Distrib. : Debian-Facile-9-6-amd64 (stretch à jour)
Noyau : 4.18.0-0.bpo.1-amd64 (backports)
(G)UI : Debian-Facile-9 (XFCE)
Inscription : 24-02-2017

Re : installation de Flash Player [résolu]

Bonjour,
bien, clôture de ce sujet.
Je mets résolu bien que la solution soit un peu bancale...

En résumé :
pour pouvoir pluzzer avec un PC 32-bits, il faudrait installer le plug-in Flash Player...
L'installation de Flash Player qui a été appliquée avec succès sur une machine 64-bits n'est pas possible sur PC 32-bits.
Pour accéder aux replays, l'installation de CAPTV est un palliatif acceptable et sur machine 32-bit il n'y a qu'un problème avec IE  (il me semble effectivement que j'ai dû retoucher quelque chose, adresse ou version ?; mais j'ai trouvé très vite sur les forums...)

Par contre l'installation de CAPTV sur machine 64-bit semble poser d'autres problèmes (voir la discussion https://debian-facile.org/viewtopic.php?id=17148 )

yes.gifEt encore merci à tous pour votre supportmerci.gif

Hors ligne

Pied de page des forums