Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-08-2009 11:55:37

limbergh
Membre
Inscription : 12-08-2009

[RESOLU]xorg.conf vide???

Bonjour,

je fais de nouveaux appels à vous. J'ai installé les paquets nvidia via ce wiki avec la méthode Installation du pilote propriétaire avec les dépôts Debian


Mais après avoir réussi toute l'installation sans problème, j'ai voulu éditer le fichier /etc/X11/xorg.conf
pour changer nv par nvidia dans la section Device, à coté de Driver.

Seulement mon fichier est vide!!! Je ne sais pas ce que je dois mettre dedans...
Merci d'avance pour vos interventions... wink

Dernière modification par limbergh (19-08-2009 13:58:14)

Hors ligne

#2 19-08-2009 12:47:16

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [RESOLU]xorg.conf vide???

Salut,

chez moi j'ai simplement ceci (rien d'autre)

Section "Device"
    Identifier    "GeForce 9800 GTX"
    Driver          "nvidia"
        Option        "NoLogo"
EndSection


change juste l'"identifier" mets le nom de ta carte, ça n'a pas d'importance.

Hors ligne

#3 19-08-2009 12:55:40

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [RESOLU]xorg.conf vide???

Salut limbergh

Moi perso je préfére la méthode avec le fichier .run pour installer le pilote proprio.
En plus, avec cette méthode, tu peux générer un xorg.conf à partir de l'outil Nvidia settings.

Bon courage smile
damien

logo_3dminfographie_signature.png

Hors ligne

#4 19-08-2009 13:57:32

limbergh
Membre
Inscription : 12-08-2009

Re : [RESOLU]xorg.conf vide???

Nckel ça fonctionne neos... Avec modification de ma carte graphique smile

Je ne vois pas bien la différence entre la méthode Installation du pilote propriétaire avec les dépôts Debian et la méthode le fichier .run pour installer le pilote proprio..  Ca installe le même fichier non?

Dernière modification par limbergh (19-08-2009 13:59:18)

Hors ligne

#5 19-08-2009 15:07:31

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [RESOLU]xorg.conf vide???

Salut limbergh,

Quand tu installes le pilote via le .run, ton gestionnaire de paquets ne sait pas qu'il est installé. Tu as (entre autres) de grandes chances d'aboutir à un écran noir après une mise à jour du noyau Linux avec une belle erreur de X.org.

En l'installant via les dépôts Debian, le pilote est automatiquement mis à jour en même temps que le noyau.

Le .run étant plus récent, il existe cependant des cas où il est obligatoire de l'utiliser (CG récente non supportée par celui de Debian). Mais d'une manière générale et pour n'importe quel logiciel, il est préférable d'utiliser les dépôts Debian si c'est possible. C'est plus propre et ça pose moins de problèmes.

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#6 19-08-2009 15:10:51

limbergh
Membre
Inscription : 12-08-2009

Re : [RESOLU]xorg.conf vide???

ok wink merci beaucoup pour ta réponse...

Hors ligne

#7 03-09-2009 09:56:54

sigurd
Membre
Inscription : 03-09-2009

Re : [RESOLU]xorg.conf vide???

J'ai une geforce 9800 GT sur Debian Lenny 5.02 AMD64.

J'ai suivi la méthode d'install que Neos préconises pour Nvidia. J'ai ajouté la carte graphique dans xorg.conf avec le pilote nvidia (rien d'autre dans le Xorg.conf).

Ca marche bien sauf que les videos sont lues avec des couleurs aberrantes (comme si elles étaient en négatif) que ce soit avec VLC ou Totem.

Je précise que les videos sont très fluides.

Une idée ?

Hors ligne

#8 04-09-2009 13:59:22

sigurd
Membre
Inscription : 03-09-2009

Re : [RESOLU]xorg.conf vide???

J'ai trouvé : il s'agit simplement du paramétrage de la sortie dans les lecteurs.

Pour Totem, lancer gstreamer-properties, allez dans l'onglet "Video", et choisissez "X Window System (No Xv)".

Pour VLC, aller dans le menu, préférences, video et choisir la sortie X Window.

Ca marche nickel.

Hors ligne

#9 04-09-2009 16:41:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]xorg.conf vide???

Tchap !

Ben il me semble que cette actualité mérite d'être au wiki DF.
Copié là :
http://debian-facile.org/wiki/manuel:nv … _en_stable

Et l'intervention de mani est à la suite aussi dans le même tuto...
Comme quoi : on cauze.. on cauze... il en reste toujours quelque chose en fait !

Et viva le libre ! big_smile

Merci les amis !

Tchibâââ ! big_smile

Dernière modification par smolski (04-09-2009 17:55:50)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums