Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-03-2017 19:57:25

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

[RESOLU] dualboot win8.1 pas de GRUB

Bonjour, je vous serai reconnaissant de bien vouloir m'éclairer quant à la situation suivante.

Pour faire une install en dual boot debian jessie stable / windprout 8.1 sur un hp probook 470 g2 livré avec un bios M74 version .01.41 (05/19/2016), j'ai suivis les conseils de la doc suivante https://debian-facile.org/doc:install:d … -de-l-uefi

Je pense avoir suivi correctement la procédure en live USB faisant un partitionnement automatique /home séparé dans l'espace non attribué libéré depuis windows.
Arrivé à la phase d'installation de GRUB, j'ai rencontrer la même situation que celle décrite par l'image https://debian-facile.org/images//file- … 1f038d.png

Voyant ce qui indiquait que la nouvelle installation était le seul système sur cet ordinateur, alors que ce n'était pas le cas, j'ai d'abord, en revenant en arrière, quitté l'installation par le menu d'installation et n'ai donc pas installé GRUB.

Ensuite, j'ai effacé les partitions debian depuis windows, et refait l'install jusqu'au bout (installation GRUB comme décrite).

GRUB ne se lançant pas, j'ai essayer l'astuce en fin d'article : Résolution des problèmes/Grub ne se lance pas, puis divers option de boot (secure boot ou pas, avec ou sans cms etc)

j'ai booter sur bot-repair live usb, n'ai pas lancer de réparation mais demandé un rapport posté ici -> http://paste.ubuntu.com/24147144/

je n'ai pas accès dans le bios à la modification de l'option "démarrage rapide" qui est cochée par défaut (c'est le cas de le dire !) ou alors sous des conditions (hpsparekey et autre) que j'ai du mal à cerner.

j'ai tenté de la désactiver au travers de la gestion de l’énergie de windows 8.1, le démarage semble plus lent en effet mais je crois que l'option reste cochée dans le bios (il faut que je vérifie).

Voilà, si l'un d'entre vous a une idée, je suis donc preneur !

Dernière modification par loo-e (15-03-2017 03:37:57)


"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#2 11-03-2017 20:16:55

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] dualboot win8.1 pas de GRUB

Tu as fait l'installation en mode BIOS/legacy, et non en mode EFI comme il aurait fallu. Par conséquent c'est GRUB BIOS qui a été installé dans le MBR du disque et une partition "BIOS boot" au lieu d'installer GRUB EFI dans la partition système EFI /dev/sda2 où se trouve déjà le chargeur EFI de Windows. Et comme avec la plupart des firmwares UEFI, c'est le boot EFI qui a la priorité sur le boot legacy.

Tu dois pouvoir forcer le démarrage sur GRUB BIOS en réglant l'amorçage en mode BIOS/legacy (ça s'appelle aussi CSM), ou au moins manuellement en déclenchant l'ouverture du menu de démarrage de la machine (voir la doc ou l'écran d'accueil pour la touche ou combinaison de touches). Mais même dans ce cas, GRUB BIOS ne supportera pas le dual boot avec un Windows installé en mode EFI.

Avec quoi as-tu fait l'installation ? Quelle image, quel support, quelle méthode pour mettre l'image sur le support ?

Dernière modification par raleur (11-03-2017 23:09:41)

En ligne

#3 11-03-2017 21:40:55

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

Re : [RESOLU] dualboot win8.1 pas de GRUB

bonjour raleur !

j'ai fait l'installation a partir d'une cle USB bootable contenant debian-live-8.5.0-amd64-xfce-desktop et utiliser Rufus pour la créer.

"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#4 11-03-2017 21:44:25

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

Re : [RESOLU] dualboot win8.1 pas de GRUB

et je confirme qu'en effet, j'ai du faire l'installation en mode bios/legacy pour pouvoir booter sur l'usb afin de faire l'installation.

"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#5 11-03-2017 21:54:38

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] dualboot win8.1 pas de GRUB

Double erreur :
- Les programmes comme Rufus ne sont pas recommandés (il est trop facile de ne pas écrire l'image comme il faut), et pas utiles non plus
- les images live de Jessie ne sont pas compatibles avec l'amorçage EFI. Il faut utiliser une image d'installation de la même architecture que le firmware UEFI (amd64 pour 64 bits ou i386 pour 32 bits, la plupart sont 64 bits mais il existe quelques machines avec un firmware 32 bits), ou une image d'installation multiarch qui contient les deux.

En ligne

#6 11-03-2017 21:58:47

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] dualboot win8.1 pas de GRUB

Je viens de survoler le tutoriel, il devrait être beaucoup plus catégorique sur les outils et images recommandés et déconseillés voire qui ne marchent pas.

Dernière modification par raleur (11-03-2017 21:59:14)

En ligne

#7 11-03-2017 22:13:12

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

Re : [RESOLU] dualboot win8.1 pas de GRUB

ok, dont si je comprends bien tu me conseillerai d'utiliser une image desktop.

pour ce qui est de l'architecture de UEFI, si j'en croit Microcosoft :

"En mode UEFI, la version de Windows doit correspondre à l’architecture du PC. Un PC UEFI 64 bits ne peut démarrer que des versions 64 bits de Windows. Un PC 32 bits ne peut démarrer que des versions 32 bits de Windows. Dans certains cas, en mode BIOS hérité, il est possible d’exécuter une version 32 bits de Windows sur un PC 64 bits, en supposant que le fabricant prenne en charge le mode BIOS hérité 32 bits sur le PC."

l'architecture de mon systeme étant en 64 bit, je n'entre pas dans le troisième cas évoqué pour le mode legacy et si il y a correspondance entre les architecture UEFI et système comme ils semblent le dirent, alors ma machine est en UEFI 64 bit.

Me trompe-je ?

Ainsi une installation desktop 64 bit était ce qu'il me fallait faire.

Je n'ai pas de problème à refaire un installation de ce type, mais n'ai-je pas mis déjà un peu le bazar !

"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#8 11-03-2017 22:38:06

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

Re : [RESOLU] dualboot win8.1 pas de GRUB

Et dire que je pensais avoir correctement suivi la doc, mais je viens de relire :

"Les images lives sont une solution pour tester la compatibilité de votre matériel mais elles ne sont pas (encore) amorçables en mode UEFI !
Aussi, tester et installer sur du matériel relativement récent nécessite de désactiver ce mode dans le Bios. Si ce n'est pas possible, préférer les images d'installation normale proposées précédemment. "

"Autant pour moi" disait-on vêtu de kaki.

"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#9 11-03-2017 23:09:11

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] dualboot win8.1 pas de GRUB

loo-e a écrit :

tu me conseillerai d'utiliser une image desktop


Si tu parles d'une image Debian live comme debian-live-8.7.1-amd64-cinnamon-desktop.iso, non, au contraire puisqu'elle n'est pas amorçable en mode EFI.
Il faut utiliser une image d'installation (du type debian-8.7.1-*).

loo-e a écrit :

"En mode UEFI, la version de Windows doit correspondre à l’architecture du PC. Un PC UEFI 64 bits ne peut démarrer que des versions 64 bits de Windows. Un PC 32 bits ne peut démarrer que des versions 32 bits de Windows. Dans certains cas, en mode BIOS hérité, il est possible d’exécuter une version 32 bits de Windows sur un PC 64 bits


Je m'en doutais, mais n'en avais pas la certitude. Merci de l'avoir confirmé. Encore une limitation de Windows après celle concernant le format de table de partition. Par comparaison, Linux 64 bits peut très bien s'installer et fonctionner sur un PC UEFI 32 bits. Linux 32 bits peut tourner sur un PC UEFI 64 bits, mais il ne pourra pas communiquer avec le firmware pour la gestion des entrées d'amorçage

loo-e a écrit :

"Les images lives sont une solution pour tester la compatibilité de votre matériel mais elles ne sont pas (encore) amorçables en mode UEFI !


Je ne trouve pas cette phrase dans le tutoriel mentionné dans ton message initial.

Dernière modification par raleur (11-03-2017 23:10:58)

En ligne

#10 12-03-2017 00:07:27

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

Re : [RESOLU] dualboot win8.1 pas de GRUB

Moi non plus je ne l'avais pas vue mais elle est en fin du chapitre "choisir son type d'image", sur un beau fond rouge avec une main semblant dire "STOP ! ATTENTION !". Typiquement le genre de chose à coté desquelles il m'arrive de passer.:/
Ce qui s'est passé , c'est que je l'ai testée,puis installée plusieurs jours après. Et comme j'ai déjà fais quelques installations dans un passé exempt UEFI, confiant, j'ai du reprendre la doc plus bas.

Je télécharge actuellement ceci : debian-8.7.1-amd64-lxde-CD-1.iso

Ca te semble coller ? Sinon, comment vérifie-t-on l'architecture du firmware de UEFI ?

"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#11 12-03-2017 00:45:11

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] dualboot win8.1 pas de GRUB

loo-e a écrit :

elle est en fin du chapitre "choisir son type d'image", sur un beau fond rouge avec une main semblant dire "STOP ! ATTENTION !"


Ce chapitre n'existe pas dans la page https://debian-facile.org/doc:install:d … -de-l-uefi. Tu dois confondre avec une autre documentation.

loo-e a écrit :

Sinon, comment vérifie-t-on l'architecture du firmware de UEFI ?


En regardant l'architecture du Windows qui est installé, si on en croit la citation de Microsoft dans ton message précédent.
Ou alors tu montes la partition système EFI (/dev/sda2), et tu regardes si son répertoire EFI/boot contient un fichier bootia32.efi ou bootx64.efi.

EDIT : on a déjà l'information dans le rapport de boot repair : bootx64.efi -> firmware 64 bits.

Dernière modification par raleur (12-03-2017 00:46:54)

En ligne

#12 12-03-2017 03:39:20

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : [RESOLU] dualboot win8.1 pas de GRUB

loo-e a écrit :

Rufus

je peux confirmer pour avoir testé ce soir que rufus n'est pas adapté pour l'uefi (pour mbr, pas testé).
en utilisant Gpt & image Iso, les firmwares non-free n'ont pas été extraits.
en utilisant, imageDD, ça va mieux en apparence, install complète, mais grub mal installé. en mode recovery, erreur de bootstrap)
en utilisant win32diskimager, RAS, installation et démarrage correct
en allant sur le site de rufus, j'ai renoncé à allé plus loin, il est signalé dans les issues que les images iso-hybrides debian (comme d'autres) ne sont pas bien faites, et que ce n'est pas la faute de rufus hmm
me semble plus un outil pour installer des windows.

win32diskimager est le soft préconisé par le tuto indiqué dans le premier post et celui officiellement recommandé par debian.


[mode aéré]

Hors ligne

#13 12-03-2017 04:36:06

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [RESOLU] dualboot win8.1 pas de GRUB

Ah !
À modifier dans le tuto df alors, pour rufus... smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#14 12-03-2017 05:04:00

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : [RESOLU] dualboot win8.1 pas de GRUB

j'avais pas vu oui
--
suffit pas de le dire, fait (10pts? :)

[mode aéré]

Hors ligne

#15 12-03-2017 05:12:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [RESOLU] dualboot win8.1 pas de GRUB

10 pts ?
Holà holà... Y faudrait d'abord changer le statut et le réglement df, faire une étude de marché, tout ça... tu n'en es pas encore revenu là, escroc !
... character0260.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#16 12-03-2017 05:15:08

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : [RESOLU] dualboot win8.1 pas de GRUB

radin, une petite ag et hop!

[mode aéré]

Hors ligne

#17 12-03-2017 07:11:55

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

Re : [RESOLU] dualboot win8.1 pas de GRUB

Merci pour vos réponses.

Alors,...

Pour l'installation j'ai bien suivi la doc qui suit : https://debian-facile.org/doc:install:d … -de-l-uefi

C'est en voulant relire que je me suis planté et ai pris en compte la page qui l'introduit ( https://debian-facile.org/doc:install:install ) et parlé du bandeau rouge.

Une nouvelle installation de debian-8.7.1-amd64-lxde-CD-1.iso à l'aide de win32diskimager devrait fonctionner ou bien j'ai mis le waï dans le MBR

raleur a écrit :

Tu as fait l'installation en mode BIOS/legacy, et non en mode EFI comme il aurait fallu. Par conséquent c'est GRUB BIOS qui a été installé dans le MBR du disque et une partition "BIOS boot" au lieu d'installer GRUB EFI dans la partition système EFI /dev/sda2 où se trouve déjà le chargeur EFI de Windows. Et comme avec la plupart des firmwares UEFI, c'est le boot EFI qui a la priorité sur le boot legacy.



Si quelqu'un connait un lien synthétique qui explique comment tout cela fonctionne (GRUB BIOS, GRUB EFI, chargeur EFI, firmware UEFI), je suis preneur.
Sinon je continu à lire et à recoller les morceaux.

@smolski et kyodev : "ne nous fachons pas"


"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#18 12-03-2017 08:46:35

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] dualboot win8.1 pas de GRUB

Bonjour smile
Il y a un point que je ne comprends pas dans le fil. Je pensais avoir compris que lorsque le PC a un BIOS UEFI, il ne peut pas booter sur une Live-ISO de Jessie et que l'on doit utiliser l'iso netinstall. Or ici loo-e indique dans le premier message qu'il a partitionné le disque dur en LiveUSB, est-ce une erreur de formulation et le partitionnement a eu lieu avec une ISO non Live qui installe Debian et dans le suivant une installation avec un Live.

loo-e a écrit :


j'ai fait l'installation a partir d'une cle USB bootable contenant debian-live-8.5.0-amd64-xfce-desktop.

Hors ligne

#19 12-03-2017 10:51:25

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [RESOLU] dualboot win8.1 pas de GRUB

chalu a écrit :

Il y a un point que je ne comprends pas dans le fil. Je pensais avoir compris que lorsque le PC a un BIOS UEFI, il ne peut pas booter sur une Live-ISO de Jessie et que l'on doit utiliser l'iso netinstall



tu peux tout à fait booter et installer depuis un live sur un pc en uefi, deux conditions, que le secure-boot soit désactivé et que les modules de prise en charge bios soit présents (CSM)
les soucis commences quand c'est tu veux un dual-boot et que les autres os sont installé en UEFI


"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#20 12-03-2017 12:31:33

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : [RESOLU] dualboot win8.1 pas de GRUB

loo-e a écrit :

Une nouvelle installation de debian-8.7.1-amd64-lxde-CD-1.iso à l'aide de win32diskimager devrait fonctionner
@smolski et kyodev : "ne nous fachons pas"

Oui, pour avoir un dual-boot, c'est le mieux, seulement uefi, clé avec win32diskimager.

aaff si, smolski est pervers le dimanche matin, faut pas y faire attention  smile


[mode aéré]

Hors ligne

#21 12-03-2017 12:39:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [RESOLU] dualboot win8.1 pas de GRUB

C'est le hic !.. vin de mess'  hic...
... happy0167.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#22 12-03-2017 16:09:16

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

Re : [RESOLU] dualboot win8.1 pas de GRUB

A ta santé smolsky !

Salut chalut. j'ai effectivement procédé à l'install en modifiant les option de démarage du BIOS. "Normalement" en UEFI (avec le systeme windows d'origine), je l'ai passé en legacy et désactivé l'option secure boot pour démarer sur la clef USB et faire l'installation et ainsi le partitionnement. Ce qui fut à l'origine de mes déboires (panique pas smolsky).

Je suis en train de voir comment restorer le mbr depuis windows, pour que ce soit propre (même si windows se lance encore et même plus que je ne le souhaite hmm )

Et après suppression des partition debian depuis bindobs je refait l'installation comme indiqué dans mon dernier post (merci kyodev pour la confirmation), sans secure boot, en UEFI, avec CMS (salut et merci severian).

... et je vous en reparle.

"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#23 12-03-2017 19:01:01

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : [RESOLU] dualboot win8.1 pas de GRUB

windows n'est pas en mbr, severian te parlais pour (c'est pas forcement obligatoire) démarrer tes live sur cd.

vu win8 et la date de ton pc, sauf si installation "exotique", ça m'etonnerait.

loo-e a écrit :

avec CMS


tuto a écrit :

Désactivé le mode CSM ou Launch CSM le mettre en mode DISABLED ou NEVER.

Dernière modification par kyodev (12-03-2017 19:05:22)


[mode aéré]

Hors ligne

#24 15-03-2017 03:11:08

loo-e
Membre
Distrib. : debian 8.7.1 64 + windows 8.1 (en préretraite)
Noyau : linux
(G)UI : lxde (en test)
Inscription : 09-03-2017

Re : [RESOLU] dualboot win8.1 pas de GRUB

Resultat des courses ... (pardon pour l'attente, j'ai été un peu occupé par ailleurs et ce fût un peu plus long que prévu)

Voici ce que j'ai fais :

1-suppression des partition debian depuis l'utilitaire de gestion des disques de windows

2-reparation du boot avec le lecteur de récupération de Windows (que j'avais consciencieusement crée avant de tenter l'installation en dual boot).
   Comme expliqué dans ce lien : http://fr.stealthsettings.com/cum-repar … ows-8.html
   Un peu bizarre le site et mal traduit ("fenêtre" écrit à la place de "windows") mais l'essntiel y est (il s'agit de l'usage de la commande "bootrec")
   L'idée étant de remettre tout en ordre, pour savoir ou j'en suis en cas de difficultés de boot après l'install. Faire un brin de ménage quoi.

3-création d'une clé usb bootable contenant "debian-8.7.1-amd64-lxde-CD-1.iso" avec win32diskimager.

4-installation de debian depuis la clé usb en changeant l'ordre d'amorçage dans le bios, sans secure boot, en UEFI, avec CMS. Et là normalement ça roule, au démarrage suivant s'ouvre l'écran de Grub dans lequel on peu (enfin) choisir l'os sur lequel booter, et on peut ecrire "résolu" dans le titre de ce poste.

Pour qui lirait ce post pour le même problème, la solution est donc celle que je viens de détailler.

Mais, pour d'autres raisons, cela ne c'est pas exactement passé comme prévu.

4.1-arrivé à l'étape de configuration de la carte réseau qui sert ensuite à effectuer des téléchargements pour finaliser l'installation, dans le cas de mon ordi il faut installer des drivers "non-free" depuis une autre clé usb. Or quelle ne fut pas ma surprise de constater que j'avais confondu mes clés et utilisé celle qui contenais les drivers pour y mettre la debian bootable.
Qu'à celà ne tienne, je reboot sur windule et remet les drivers sur une clé (pas celle de debian, je vous rassure) et me prépare à réinstaller gaiement.

4.2-impossible de booter sur la clé. Retour sous winchose, je regarde son contenu et plus de debian, juste un dossier UEFI. (je n'ai toujour pas compris pourquoi)

4.3-je reprends win32diskimager pour refaire la clé d'installation et il m'y remet la même chose. Et comme j'avais laissé l'autre clé branchée, elle y a eu droit aussi.

4.4-je recommence avec win32diskimager et rebelote. En regardant les propriétés des clés, je constate qu'elles n'ont plus qu'une capacité d'environs 700 MO.

4.5-j'y remèdie en suivant les instructions données dans le 8eme post (de Tristan.1234P) de ce forum :
      http://forums.cnetfrance.fr/topic/19614 … ge-resolu/

4.6-je remet les drivers sur la clé usb et pour l'iso de debian...    je grave sur un CD.

5-installation de débian.

5.1-"YOUHOUUU !!!!"

Tout ça pour vous remercier encore pour vos précieux conseils, rappeler qu'il n'y a pas de place pour l'étourderie lorsqu'on fait ce genre de manip que sont les installations, et dire que win32diskimager est à utiliser avec précaution (et accessoirement encombrer le forum en y racontant ma vie parce que je n'ai pas d'amis - snif !).

Il me reste maintenant à trouver comment mettre "résolu" dans le titre.

"Si on te frappe avec un bâton, tu en veux à celui qui tient le bâton, pas au bâton lui-même. Celui qui te frappe n’est-il pas tenu lui-même par la haine ?"

Hors ligne

#25 15-03-2017 07:00:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [RESOLU] dualboot win8.1 pas de GRUB

Pour le résolu, c'est le tuto en lien, là :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

Merci du retour détaillé de cette résolution, je l'ai lue avec beaucoup de plaisir et te complimente pour ta ténacité en t'assurant de surcroît de mon amitié.

Jojo la frite big_smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums