Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-08-2009 21:23:54

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

[Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Bonjour,

Voilà, j'ai ouvert le site de deezer pour écouter de la musique.
deezer demande d'installer adobe flashplayer 10.0.
Je télécharge donc le paquet deb de flashplayer et l'installe.
Redémarre iceweasel.
Et toujours le même message disant que le système d'exploitation que j'utilise ne fonctionne pas avec adobe flahplayer.
Bizarre non sad

J'ai désactivé Shockwave flash 9.0 dans les modules complémentaires de iceweasel, c'est mieux, mais quand je fais une recherche, il m'affiche une page blanche.

J'ai rencontré le même problème chez une amie qui ne pouvait éxécuter une recherche d'un artiste pendant que la lecture d'un morceau était en cours.
La seule solution que j'ai trouvé sur le moment était d'ouvrir un nouvel onglet et de lancer la recherche sur celui-ci pendant que l'autre onglet était utilisé pour lire un titre.
Pas cool quand même...

Je savais que le flash et GNU/Linux ne travaillais pas bien ensemble mais à ce point là.

La solution chez moi est d'utiliser le navigateur web epiphany.
Mais ce n'ai pas une véritable solution.

Est-il possible de faire fonctionner deezer correctement avec iceweasel ?
Merci d'avance.

damien

logo_3dminfographie_signature.png

Hors ligne

#2 23-08-2009 21:43:30

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Bjr,
Pas de problème sur cette page > http://www.deezer.com/fr/music/radios/r … -covers-41
Sur mon pc flashplayer-mozilla n'est pas installé, mais flashplugin-nonfree oui

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 23-08-2009 21:54:37

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Merci phlinux.

Je ne suis pas chez moi donc pas de GNU/Linux debian à utiliser, mais j'essayerais plus tard.
A bientôt

logo_3dminfographie_signature.png

Hors ligne

#4 23-08-2009 22:08:17

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Salut,

j'ai le même problème que Damien, à savoir que le moteur de recherche de Deezer ne fonctionne pas avec IW.
La page de Deezer donné par phlinux s'affiche correctement et les liens fonctionnent bien ... excepté le moteur de recherche.

Sur mon pc flashplayer-mozilla fonctionne mieux que flashplugin-nonfree mais il faudra toutefois que je refasse un test

Par contre http://www.jiwa.fr fonctionne impec

J'ai donc arrété de chercher une solution. Je devrais peut-être m'inscrire sur le forum Deezer et signaler que suite à ce souci j'ai changé de crèmerie.

* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#5 24-08-2009 03:54:20

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Salut damien

En passant cela fait un bon bout de temps que je n'ai pas eu de tes nouvelles, j'espère que tout va bien, que les choses se sont replacées.

Je n'ai pas démarré sous lenny pour tester, mais la version de flashplayer-mozilla qui se trouvent dans debian-multimedia installe flash-player 10.0 comme tu peux le constater ici.

Il faudrait que tu nous disent quel paquet tu as installé au juste pour avoir le plugin Flash.

Ajout : petit test rapide sous sid. Le moteur de recherche ne fonctionne pas très bien en effet. On dirait qu'il n'aime pas trop Adblock Plus. Il semble fonctionner avec Epiphany. Bon je n'ai pas le temps pour le moment de creuser davantage la question.

À la prochaine
Martin

Dernière modification par martinux_qc (24-08-2009 04:08:53)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#6 24-08-2009 12:44:11

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Re-
Bizarre ce moteur de recherche Deezer.
Perso il ne fonctionne pas sur le site, mais va très bien quand je l'ajoute à la barre de recherche IW (module Add to Search Bar) .
Une bonne occasion de conseiller cette méthode

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#7 24-08-2009 14:20:38

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

phlinux a écrit :

Bizarre ce moteur de recherche Deezer.
Perso il ne fonctionne pas sur le site, mais va très bien quand je l'ajoute à la barre de recherche IW (module Add to Search Bar) .
Une bonne occasion de conseiller cette méthode


Ah oui cela fonctionne bien ainsi.
Merci pour le conseil de ce module.

Bye. Tophe


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#8 25-08-2009 02:55:12

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

phlinux a écrit :

Re-
Bizarre ce moteur de recherche Deezer.
Perso il ne fonctionne pas sur le site, mais va très bien quand je l'ajoute à la barre de recherche IW (module Add to Search Bar) .
Une bonne occasion de conseiller cette méthode


En effet c'est un bon compromis. Merci donc pour la solution. Sinon cela doit être leur site qui est mal foutu ; une erreur dans leur codage probablement.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 25-08-2009 14:10:29

Chris
Membre
Lieu : Bourgogne
Distrib. : Jessie 64
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : kde
Inscription : 15-11-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Hello,

J'ai pas trouvé le module IW...:rolleyes: J'ai trouvé iWEBTOOL, iWant, et quelques autres...IW, je ne sais pas ce que c'est. Si quelqu'un veut m'éclairer...

Une remarque/suggestion : je ne peux pas utiliser simultanément skype et flashplayer. Pas de son soit dans l'un, soit dans l'autre. En furetant, j'ai trouvé quelques commentaires accusant pulseaudio. Et des manip' bien alambiquées pour le désactiver.

Comme j'étais déjà bien occupé à faire marcher Skype 32bits sous Lenny64, et la sortie DVI/HDMI (alors que seule fonctionne correctement la sortie DVI/VGA), j'ai laissé courir.
Mais il y a peut-être une piste à creuser dans cette direction...

Amicalement

Chris

Hors ligne

#10 25-08-2009 14:37:00

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Bonjour,

IW = iceweasel
et le module s'appelle exactement : Add to Search Bar

Je ne me servais jamais de tels modules mais c'est finalement très pratique et pas seulement pour Deezer.

> installer le module  dans IW (> onglet "Outils" > Catalogue > Parcourir tous les modules complémentaires)
> aller sur le site désiré (celui de Deezer en l'occurence)
> clic droit sur la barre du moteur de recherche (celui de Deezer en l'occurence)
> choisir : "ajouter à la barre de recherche"
> se rendre dans la barre de recherche du module Add to Search Bar (à droite dans la barre de navigation de IW
> et cliquer sur "ajouter à la barre de recherche"

J'imagine que tu sais faire mais je pense aux newbies

Bye.

* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#11 25-08-2009 22:07:23

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Merci à tous

J'ai vraiment un gros problème avec deezer sur IW.
Il ne m'affiche même pas le lecteur ????
J'ai essayé le module complémentaire mais toujours pas de lecteur.
En revanche avec Epiphany, le lecteur est bien là smile

J'ai éxecuté cette commande que ma conseillé capitaine fab.

rm -r ~/.adobe


Peut-être le problème viens de là ?
Je n'en sais rien...

Est-ce que si je fais une mise à jour en version squeeze le problème entre IW et le flash serait résolu ?

A bientôt !

damien


logo_3dminfographie_signature.png

Hors ligne

#12 26-08-2009 04:03:12

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Salut Damien

Avant de faire une mise à jour vers squeeze, c'est un peu radical comme solution juste pour un site qui pose problème, dis quel plugin tu utilises exactement. Passer sous squeeze peut aider pour des trucs mais apporter d'autres problèmes.

Je viens de démarrer sur lenny pour tester la chose. Si je vais sur la page que phlinux donne en lien, je peux afficher cette dernière et je peux écouter de la musique. Pour ma part, j'ai le plugin flash pris sur le site de debian-multimedia. Pour ma part, lorsqu'un .deb existe je ne suis pas très chaud à l'idée de prendre un paquet sur un site officiel, ici le site adobe. Si ce n'est déjà fait, tu pourrais essayer d'enlever toute trace du plugin adobe (l'enlever puiis faire la commande conseillée) puis installer le .deb dont je te parle.

As-tu des extensions comme Adblock Plus ou Flashblock installées avec IW ?

Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#13 26-08-2009 12:40:47

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Merci martin

J'ai le module Adblock Plus d'installé.
Je l'avais installé sur le moment pour je ne sais plus quelle raison.
Mais je ne l'utilise pas.
Je l'ai donc désinstallé mais toujours le même problème.

Je n'arrive pas à désinstaller le plugin Adobe Shockwave flash.
Je peux que le désactiver.

logo_3dminfographie_signature.png

Hors ligne

#14 26-08-2009 13:19:08

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Re-
Le plugin Adobe Shockwave flash c'est pour la version Windows de firefox non ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#15 27-08-2009 03:01:49

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Salut

1) Ton plugin tu l'as installé comment, avec quelle commande ?

Ajout: je viens de consulter la page dont j'ai mis le lien dans le message ci-dessous. Il n'y aurait un truc pour enlever (uninstaller) comme celui pour installer ?

2) Tu as essayé d'installer le paquet flashplayer-mozilla ? Tu fais par la suite un

# update-alternatives --config flash-mozilla.so


pour être certain de bien utiliser le bon plugin et tu lances IW.

Martin

Dernière modification par martinux_qc (27-08-2009 03:06:33)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#16 27-08-2009 03:04:27

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

phlinux a écrit :

Re-
Le plugin Adobe Shockwave flash c'est pour la version Windows de firefox non ?


Salut

Regarde cette page. Cela existe aussi pour Linux. Il y a aussi la méthode décrite sur cette page.

Dernière modification par martinux_qc (27-08-2009 03:08:25)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#17 27-08-2009 12:01:12

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

re-
Ok. Merci pour la recherche.

A Damien de jouer

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#18 24-10-2009 00:30:58

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Voilà j'ai téléchargé le paquet deb de flashplayer sur le lien que tu m'a proposé martin_mtl
http://www.debian-multimedia.org/dists/ … ozilla.php

# dpkg -i flashplayer-mozilla_10.0.32.18-0.0_i386.deb


Et voilà ce qu'il me dit

dpkg : concernant flashplayer-mozilla_10.0.32.18-0.0_i386.deb contenant flashplayer-mozilla :
flashplayer-mozilla entre en conflit avec flashplugin-nonfree
  « adobe-flashplugin » fournit « flashplugin-nonfree » et est présent ainsi de  « installé ».
dpkg : erreur de traitement de flashplayer-mozilla_10.0.32.18-0.0_i386.deb (--install) :
paquets en conflit - flashplayer-mozilla non installé
Des erreurs ont été rencontrées pendant l'exécution :
flashplayer-mozilla_10.0.32.18-0.0_i386.deb


Je décide donc de désinstaller flashplugin-nonfree avec aptitude remove

Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.


Mais toujours le même message d'erreur concernant dpkg -i flashplayer-mozilla_10.0.32.18-0.0_i386.deb

En mode graphique d'installation du paquet deb
Il me met un message en rouge

Error: Breaks exisiting package 'adobe-flashplugin' conflict: flashplayer-mozilla ( )


Je décide donc de désinstaller adobe-flashplugin.
Puis je retente l'install de flashplayer-mozilla_10.0.32.18-0.0_i386.deb
Et voici le détail du début d'install

dpkg : retirer adobe-flashplugin en faveur de flashplayer-mozilla ...
dpkg : oui, suppression de adobe-flashplugin en faveur de flashplayer-mozilla.
(Lecture de la base de données... 275998 fichiers et répertoires déjà installés.)
Dépaquetage de flashplayer-mozilla (à partir de flashplayer-mozilla_10.0.32.18-0.0_i386.deb) ...
update-alternatives: error: pas d'alternatives pour iceape-flashplugin.
update-alternatives: error: pas d'alternatives pour iceape-flashplugin.
dpkg : erreur de traitement de flashplayer-mozilla_10.0.32.18-0.0_i386.deb (--install) :
le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 2
postinst called with argument `abort-remove'
dpkg : erreur lors du nettoyage :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
flashplayer-mozilla_10.0.32.18-0.0_i386.deb


martin_mtl a écrit :

1) Ton plugin tu l'as installé comment, avec quelle commande ?

Ajout: je viens de consulter la page dont j'ai mis le lien dans le message ci-dessous. Il n'y aurait un truc pour enlever (uninstaller) comme celui pour installer ?


J'ai fait une erreur j'ai installé le .deb que proposait adobe flashplayer.
En me disant vu que c'est un paquet deb il n'y aurait pas de soucis sauf que c'est un deb version Ubuntu.
Oups mad

Que faire ? Je suis complètement perdu...

Le passage en squeeze n'a rien changé le flash ne fonctionne pas chez moi.


logo_3dminfographie_signature.png

Hors ligne

#19 25-10-2009 19:16:50

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Salut

Je ne sais pas où tu en es rendu avec ton problème mais voici ce que je verrais. Je commencerais par enlever les anciens paquets, le .deb pour Ubuntu et les autres s'il y en a. Il faudrait enlever tous les libflashplayer.so pour éviter les conflits et repartir sur une base propre. Deuxièmement, j'ajouterais à mon sources.list le dépôt pour debian-multimedia et mettrais dans le fichier preferences une priorité basse pour aller chercher seulement ce que je veux (200 par exemple pour avoir les mises à jour des paquets), puis j'installerais flashplayer-mozilla. Sinon, tu as une raison particulière pour ne pas mettre le dépôt debian-multimedia dans ton sources.list et aller chercher les paquets individuellement ?


En ce qui concerne les paquets flashplayer-mozilla et flashplugin-nonfree c'est l'un ou l'autre. En passant par aptitude, apt-get ou synaptic, l'installation de l'un provoque automatiquement l'enlèvement de l'autre.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#20 25-10-2009 20:31:32

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Plugin Shockwave flash 10 ne fonctionne pas avec iceweasel

Merci martin

Voici ce que j'ai fait

# rm -r ~/.adobe
# rm /home/usr/.mozilla/plugins/libflashplayer.so
# rm /usr/lib/flashplayer-mozilla/libflashplayer.so
# rm /usr/lib/mozilla/plugins/*.so
# aptitude remove libflash-mozplugin libflashsupport flashplugin-nonfree
# ln -s /usr/lib/libssl3.so.1d /usr/lib/libssl3.so
# ln -s /usr/lib/libnss3.so.1d /usr/lib/libnss3.so
# ln -s /usr/lib/libnspr4.so.0d /usr/lib/libnspr4.so


J'ai fermé iceweasel
Puis

# dpkg -i flashplayer-mozilla_10.0.32.18-0.0_i386.deb


Ca fonctionne maintenant smile


logo_3dminfographie_signature.png

Hors ligne

Pied de page des forums