Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-03-2017 18:28:45

Albator_123
Membre
Distrib. : Debian 8.7
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-02-2017

HD Graphics 530 non reconnue

Bonjour à tous,

j'installe debian sur un lenovo récent avec une carte intel HD 530 et celle ci n'est pas bien reconnue.
Alors qu'avec Kali 2016.2 elle marche nikel.

Mon kernel est le 3.16.0-4-amd64 et même avec le dernier kernel des backports -> meme resultat -> Affichage pas très beau et résolution bloquée qur 800*600.

lspci avec debian : 00:02.0 VGA compatible controller: Intel Corporation Device 1912 (rev 06)
alors qu'avec Kali il m'affiche bien un driver intel Graphic HD 530...

Auriez vous des idées svp?

Merci

Hors ligne

#2 21-03-2017 18:42:42

èfpé
Membre
Inscription : 10-07-2016

Re : HD Graphics 530 non reconnue

Bonsoir,

Un firmware fourni par le paquet firmware-misc-nonfree pourrait très probablement aider (cf. i915 et Skylake, par exemple).

Hors ligne

#3 21-03-2017 18:44:25

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : HD Graphics 530 non reconnue

oui avec une installation de stretch , matériel mieux reconnu.
tu a un processeur SkyLake a priori , c'est une tour ou un portable ?

pour jessie + blackport ton installation est mauvaise ça devrait fonctionner
il y a des paquets relatif a intel aussi a mettre a jour

grillé par èfpé , il a commencé a te donner un début de réponse

Dernière modification par robert2a (21-03-2017 18:46:19)

Hors ligne

#4 21-03-2017 18:50:41

Albator_123
Membre
Distrib. : Debian 8.7
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-02-2017

Re : HD Graphics 530 non reconnue

Bonjour et merci a vous deux.
Je vais me depecher de tester ce packet.
Oui c'est une tour avec un I5 Gen. 6.
Ben l'install est normale rien a signaler.
Update et upgrade ne donne aucune maj a faire.

Je teste le paquet firmware-misc-nonfree et reviens au plus vite.

Hors ligne

#5 21-03-2017 18:54:25

Albator_123
Membre
Distrib. : Debian 8.7
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-02-2017

Re : HD Graphics 530 non reconnue

le lien semble contenir ma carte en question.
Franchement si c'est ca je ne te remercierai jamais assez et je te tirerai mon chapeau...
Car cela fait des jours que je galere...
J'ai mis a jour le noyau et compagnie mais personne ne semble parler de ce paquet bien caché.

Hors ligne

#6 21-03-2017 19:08:23

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : HD Graphics 530 non reconnue

il y a pas mal de post sur le sujet , n'oublie pas de le prendre dans les backports.
il y a aussi le xserver-xorg-video-intel , mais KMS risque de mieux fonctionner.

a voir dans /var/log/Xorg.0.log comment s'initialise ton serveur X

pense aussi aux fichiers (paquets ) relatif a DRI et GLX (pour la partie 3D )

nota : la désinstallation du paquet "xserver-xorg-video-intel " risque d'améliorer les choses (avec le dernier noyau des backports )
a vérifier quand meme avant wink

ps: ce paquet (le firmware ) permet de prendre en charge KabyLake et SkyLake , les 2 derniers gpu des processeurs intel du meme nom

nota : c'est un paquet non-free pense a modifier ton "sources.list" si pas déja fait

Dernière modification par robert2a (21-03-2017 19:18:26)

Hors ligne

#7 22-03-2017 20:48:35

Albator_123
Membre
Distrib. : Debian 8.7
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-02-2017

Re : HD Graphics 530 non reconnue

Bonjour,

Alors retour :

- Backports ajouté et installation de firmware-misc-nonfree

On me parle de stretch mais stretch n'est pas encore stable!
Je ne peux pas l'installer...

Résolution :

- Passage au noyau 4.8 et là tt va bien!

Hors ligne

Pied de page des forums