Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-07-2007 17:55:56

ptitgui
Membre
Inscription : 29-07-2007

[Réglé]apache2 et vhosts

bonjour tout le monde
J'ai un probleme avec apache2 et ses vhosts j'ai réussi a crée mes fichier de configuration dans   /etc/apache2/sites-available et fait les lien dans /etc/apache2/sites-enabled avec la commande "a2ensite nom du fichier host" j'ai reloader apache2 et quand j'ouvre firefox que je tapper le nom de mon vhost ca me met : serveur introuvable donc si quelqu'un aurrai une solution

je vous remerci

P.S. je vous met un de mes fichier vhost

<VirtualHost IPpublic:80>
    ServerName     www.mondomaine.org
    DocumentRoot     /var/www
    ServerAlias    www
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /var/www>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog /etc/apache2/log/www-error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /etc/apache2/log/www-access.log combined
    ServerSignature On

   Alias /doc/ "/usr/share/doc/"
   <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
AddDefaultCharset iso-8859-1
</VirtualHost>

Dernière modification par ptitgui (16-08-2007 17:07:34)

Hors ligne

#2 29-07-2007 18:28:10

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [Réglé]apache2 et vhosts

j'connais pas trop en réseau, mais il ne devrait pas y avoir une ip là
<VirtualHost IPpublic IP:80>

Hors ligne

#3 29-07-2007 18:47:49

ptitgui
Membre
Inscription : 29-07-2007

Re : [Réglé]apache2 et vhosts

aparament il fut mettre soit une ip ou bien une petite etoile (*) mais les 2 ne fonctionne pas

Hors ligne

#4 29-07-2007 21:33:09

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]apache2 et vhosts

Salut

Si ton site est a la racine de /var/www il te suffit normalement simplement, pour le voir, de saisir dans ton navigateur

localhost


ou

127.0.0.1


@+

Hors ligne

#5 29-07-2007 22:11:52

ptitgui
Membre
Inscription : 29-07-2007

Re : [Réglé]apache2 et vhosts

le problème qui ce pose c'est que j'héberge plusieur site, avec une ip fixe et un nom de domaine (mondomaine.org) et je voudrai avoir : site1.mondomaine.org  site2.mondomaine.org etc...
je pense que j'ai du mal formuler mon premier poste désoler

Dernière modification par ptitgui (30-07-2007 03:41:22)

Hors ligne

#6 30-07-2007 10:08:23

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]apache2 et vhosts

oula...je n'héberge qu'un seul site actuellement, j'ai bien essayé de trouver la solution mais ça dépasse mes pitites compétences en ce domaine.

Si cobex4 passe par là il te donnera surement la réponse.

Hé ho!!!! cobex4!!! on a besoin d'un spécialiste serveur à la table 4!!!! lol

EDIT: quoi qu'il en soit je te laisse pas tomber et je retourne à mes recherches dès que je suis rentré du boulot ce soir wink

Hors ligne

#7 30-07-2007 11:25:19

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]apache2 et vhosts

Je viens de trouver cette doc, pas eu le temps de tester car je dois partir

A ce soir big_smile

Hors ligne

#8 30-07-2007 12:53:17

ptitgui
Membre
Inscription : 29-07-2007

Re : [Réglé]apache2 et vhosts

merci syb je lit la doc (que je ne connaissait pas )et je voi si ca fonction si c'est le cas je vais mettre un petit resolu a mon premier post

Hors ligne

#9 30-07-2007 15:34:18

ptitgui
Membre
Inscription : 29-07-2007

Re : [Réglé]apache2 et vhosts

Bonjour
j'ai suivit le tuto mais ca ne fonctionne toujour pas sad y aurrai t il un paquet special d'apache pour les vhost ?

Hors ligne

#10 30-07-2007 21:49:23

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]apache2 et vhosts

Bon...j'ai un petit peu avancé dans mes investigations smile si je te dis des bétises cobex4 me corrigera, dans tous les cas je viens de tester chez moi (en local) et ça marche.

Pour commencer un seul de tes vhosts doit contenir cette ligne (chez moi c'est le vhost principal)

NameVirtualHost IP:Port


ou

NameVirtualHost *


Ensuite pour faire mon essai j'ai recréé un autre vhost pour un forum en test en copiant celui par defaut

cp defaut forum


Il faut indiquer le chemin de ton site (ca je pense qu'il ne doit pas y avoir de problème) et j'ai ensuite rempli la première ligne comme ceci (c'est à partir de la que je fais peut être des bêtises mais en local ca marche)

<VirtualHost forum:80>


Ensuite je suis allé lui attribuer une adresse ip dans mon /etc/hosts

127.0.1.1      forum


Un petit redemarrage d'apache2

invoke-rc.d apache2 reload


Et mon forum est maintenant disponible via l'adresse http://127.0.1.1/ ou http://forum/

@+

Hors ligne

#11 01-08-2007 20:55:20

ptitgui
Membre
Inscription : 29-07-2007

Re : [Réglé]apache2 et vhosts

bonjour
desoler cobex4 mais la config que tu ma passer pour le vhost ne fonctionne pas (du moin chez moi) mais je pense que ca doit venir d'ailleur mais pas d'apache2

Hors ligne

#12 01-08-2007 23:41:54

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]apache2 et vhosts

Alors il est vrai qu'au départ (sans faire mes vhosts, enfin juste celui par defaut modifié) j'accédais à mes sites comme ceci

http://localhost (pour le pricipal)
http://localhost/forum/
httl://localhost/puntal/


Voici mes trois vhosts

Le pricipal (defaut), à noter que seul celui là comporte la première ligne NameVirtualHost *

NameVirtualHost *
<VirtualHost *>
  ServerAdmin webmaster@localhost
 
  DocumentRoot /var/www/spip
  <Directory />
    Options FollowSymLinks
    AllowOverride None
  </Directory>
  <Directory /var/www/spip>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                #RedirectMatch ^/$ /apache2-default/
  </Directory>

  ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
  <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
  </Directory>

  ErrorLog /var/log/apache2/error.log

  # Possible values include: debug, info, notice, warn, error, crit,
  # alert, emerg.
  LogLevel warn

  CustomLog /var/log/apache2/access.log combined
  ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


Celui pour le forum

<VirtualHost forum:80>
  ServerAdmin webmaster@localhost
 
  DocumentRoot /var/www/forum/
  <Directory />
    Options FollowSymLinks
    AllowOverride None
  </Directory>
  <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                #RedirectMatch ^/$ /apache2-default/
  </Directory>

  ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
  <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
  </Directory>

  ErrorLog /var/log/apache2/error.log

  # Possible values include: debug, info, notice, warn, error, crit,
  # alert, emerg.
  LogLevel warn

  CustomLog /var/log/apache2/access.log combined
  ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


et enfin celui pour puntal

<VirtualHost puntal:80>
  ServerAdmin webmaster@localhost
 
  DocumentRoot /var/www/puntal/
  <Directory />
    Options FollowSymLinks
    AllowOverride None
  </Directory>
  <Directory /var/www/puntal>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                #RedirectMatch ^/$ /apache2-default/
  </Directory>

  ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
  <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
  </Directory>

  ErrorLog /var/log/apache2/error.log

  # Possible values include: debug, info, notice, warn, error, crit,
  # alert, emerg.
  LogLevel warn

  CustomLog /var/log/apache2/access.log combined
  ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


Ensuite pour que

http://forum

ou

http://puntal


marche dans mon naviguateur il a fallu que je leur attribut une ip dans mon /etc/hosts, exemple:

127.0.0.1       localhost
127.0.1.1       forum
127.0.2.1       puntal


Maintenant pour acceder à mon forum j'ai le choix entre

http://127.0.1.1 ou http://forum


et pour puntal

http://puntal ou http://127.0.2.1


Après j'insiste sur le fait que moi c'est pour du local, mais en local ça marche très bien smile

@+

EDITION:
il ne faut pas oublier de redemarrer apache2

Hors ligne

#13 01-08-2007 23:55:16

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [Réglé]apache2 et vhosts

une question as tu une ip fixe ? ou utilise tu une ip avec dyndns ou no-ip ?

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#14 02-08-2007 13:48:30

ptitgui
Membre
Inscription : 29-07-2007

Re : [Réglé]apache2 et vhosts

Bonjour tout le monde
j'ai une ip fixe et un nom de domaine chez dyndns

Hors ligne

#15 02-08-2007 20:42:23

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]apache2 et vhosts

Ça n'a pas fonctionné ptitgui?

Hors ligne

#16 05-08-2007 19:29:28

ptitgui
Membre
Inscription : 29-07-2007

Re : [Réglé]apache2 et vhosts

non desoler ca ne fonctionne pas

Hors ligne

#17 05-08-2007 22:22:00

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [Réglé]apache2 et vhosts

Et les logs disent quoi ?

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#18 16-08-2007 17:06:49

ptitgui
Membre
Inscription : 29-07-2007

Re : [Réglé]apache2 et vhosts

Bonjour tout le monde

      Bon voila j'ai mit un peut de temps mais j'ai trouver d' ou venais le problème : cela venait de mon fournisseur de nom de domaine (dyndns.com) il y a une petite option a cocher lors de la création d' un nom de domaine. Donc faites attention pour les personnes qui son dans le même cas que moi : vérifier toutes les options de dyndns .
Sur ce je remercie quand même les personnes qui mon aider tout au long de ma configuration d' apache et de mes vhosts
Bonne journée a tous et salut
P.S. peut etre a plus tard sur le forum ou sur le chan d'irc

Hors ligne

#19 16-08-2007 18:01:59

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]apache2 et vhosts

Te serait-il possible, si tu as un peu de temps, d'expliquer comment tu as procédé? ceci servirait éventuellement à d'autres car ce sujet reste souvent flou...un petit pas à pas que l'on pourrait éventuellement mettre dans le wiki big_smile

ptitgui a écrit :

P.S. peut etre a plus tard sur le forum ou sur le chan d'irc


Ah bah vi! tu vas bien revenir nous voir quand même wink

@+

Hors ligne

Pied de page des forums