Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-03-2017 15:29:17

Kraven
Membre
Inscription : 29-03-2017

Erreur avec update, impossible de récupérer les paquets[Résolu]

Bonjour,

J'ai installée une VM Debian 8.7 sous VMWare, au départ tout allait bien mais à un moment donné je ne peux plus faire de apt-get update.
Je ne comprends pas pourquoi. Je suis en nat sur ma machine, j'ai essayé de passé en bridge en me disant que j'avais peut être pas accès à internet.
Je n'arrive plus à ping 8.8.8.8.
J'ai lu beaucoup de forum par rapport à ces erreurs mais rien ne fonctionne donc me voici.

Voici le retour de mon apt-get update:

sudo apt-get update



[sudo]
Err http://security.debian.org jessie/updates InRelease

Err http://security.debian.org jessie/updates Release.gpg
  Ne parvient pas à résoudre « Server »
Err http://ftp.fr.debian.org jessie InRelease

Err http://ftp.fr.debian.org jessie-updates InRelease

Err http://ftp.fr.debian.org jessie Release.gpg
  Ne parvient pas à résoudre « Server »
Err http://ftp.fr.debian.org jessie-updates Release.gpg
  Ne parvient pas à résoudre « Server »
Lecture des listes de paquets... Fait
W: Impossible de récupérer http://ftp.fr.debian.org/debian/dists/jessie/InReleas                       e

W: Impossible de récupérer http://security.debian.org/dists/jessie/updates/InRel                       ease

W: Impossible de récupérer http://ftp.fr.debian.org/debian/dists/jessie-updates/                       InRelease

W: Impossible de récupérer http://security.debian.org/dists/jessie/updates/Relea                       se.gpg  Ne parvient pas à résoudre « Server »

W: Impossible de récupérer http://ftp.fr.debian.org/debian/dists/jessie/Release.                       gpg  Ne parvient pas à résoudre « Server »

W: Impossible de récupérer http://ftp.fr.debian.org/debian/dists/jessie-updates/                       Release.gpg  Ne parvient pas à résoudre « Server »

W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés,                        ou les anciens ont été utilisés à la place.
 



Voici mon ifconfig:

sudo ifconfig


eth0      Link encap:Ethernet  HWaddr 00:0c:29:a3:1b:f0
          inet adr:192.168.31.138  Bcast:192.168.31.255  Masque:255.255.255.0
          adr inet6: fe80::20c:29ff:fea3:1bf0/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:303 errors:0 dropped:0 overruns:0 frame:0
          TX packets:139 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:24939 (24.3 KiB)  TX bytes:19226 (18.7 KiB)

lo        Link encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
 




Voici mon /etc/apt/sources.list:

cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 20170116-10:57]/ jessie main

#deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 20170116-10:57]/ jessie main

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main
 




Merci pour votre aide.

Dernière modification par Kraven (29-03-2017 16:41:28)

Hors ligne

#2 29-03-2017 15:56:39

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

les redirections debian sont là pour pallier les défaillances des miroirs, donc à ta place j'essayerais ça:


deb http://deb.debian.org/debian jessie main contrib non-free
deb http://deb.debian.org/debian-security jessie/updates main contrib non-free
 

tout simplement. j'ai adapté de stretch, fait l'hypothèse que tu n'utilises pas les src, que tu pourrais commenter pour gagner du temps. enlève contrib ou non-free si tu veux


[mode aéré]

Hors ligne

#3 29-03-2017 16:09:07

Kraven
Membre
Inscription : 29-03-2017

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

Merci !! Mon dieu j'avais essayé tellement de chose ! Et juste ça a suffit à tout refaire marcher !
Merci beaucoup !

Hors ligne

#4 29-03-2017 16:50:25

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

de rien

[mode aéré]

Hors ligne

#5 29-03-2017 18:28:51

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

Bonjour,
tu as gardé le dépôt qui finit par jessie-updates ? Kyodev l'a oublié mais il faut le garder je pense smile

Edit : les redirections, c'est pas avec httpredir ?

Dernière modification par chalu (29-03-2017 20:09:46)

Hors ligne

#6 29-03-2017 20:04:55

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

chalu a écrit :

Kiodev l'a oublié

pff le kYo alors wink

deb http://deb.debian.org/debian/ jessie-updates main


[mode aéré]

Hors ligne

#7 29-03-2017 20:09:34

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

Ah zut excuse moi pour la faute sur ton pseudo ops.gif
et sinon un oubli c'est vite fait wink
je le précisais juste car ce n'est pas un truc détecté par un débutant qui lira le fil smile

Hors ligne

#8 29-03-2017 20:20:26

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

bon j'accepte les excuses et range le fouet alors wink
...
mais rassures toi, ça n'a AUCUNE importance

[mode aéré]

Hors ligne

#9 29-03-2017 22:54:35

Kraven
Membre
Inscription : 29-03-2017

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

J'avais gardé le tout et rajouté les "contrib non-free" sur tous en fait ^^
Merci !

Hors ligne

#10 29-03-2017 23:45:02

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

bonne initiative, me doutais qu'on pouvait compter sur toi ;)

[mode aéré]

Hors ligne

#11 30-03-2017 02:00:40

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.13.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

chalu a écrit :


Edit : les redirections, c'est pas avec httpredir ?



Salut

En fait c'est la même chose comme on peut le lire sur la page d'information de httpredir

Mais comme on le trouve d'ailleurs sur la page de référence de /etc/apt/sources.list du site officiel Debian, nous utilisons httpredir dans les pages de notre wiki et que par conséquent on optera plutôt, par exemple, pour :

deb http://httpredir.debian.org/debian jessie main


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#12 30-03-2017 06:30:49

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

non, la page httpredir, indique les deb...
ça a été annoncé l'année dernière sur les maillists debian
pour les différences, voir: https://debian-facile.org/viewtopic.php … 08#p219308
les httpredir ne sont pas fiables, la preuve

[mode aéré]

Hors ligne

#13 30-03-2017 07:40:49

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

Bonjour smile
D'où ma proposition dans l'autre fil de Modifier le wiki sur sources.list pour ajouter cette possibilité
Tu parles dans l'autre fil de https mais là je n'en vois ? Je crois qu'il faudrait en plus ajouter le paquet à installer pour prendre en charge le https car il me semble qu'il n'est pas installé par défaut. Pas certaine comme je ne fais pas de vraie installation en réel très souvent.
Le wiki
https://debian-facile.org/doc:systeme:a … st-de-base

Hors ligne

#14 30-03-2017 09:16:21

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

je testerai https aujourd'hui, le https est indiqué sur la page deb.debian.org

[mode aéré]

Hors ligne

#15 30-03-2017 11:55:34

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

voilà, testé:

apt install apt-transport-https
apt update

avec https://deb.debian.org/..., ça roule

par contre, sur une stretch 32b, apt-transport-https ne s'installe pas, j'investiguerai plus tard
fausse manip, qui par la même occasion me permet de signaler l'erreur sans apt-transport-https installé:
"E: Le pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé."

Dernière modification par kyodev (30-03-2017 14:37:20)


[mode aéré]

Hors ligne

#16 02-04-2017 23:17:41

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

après avoir passé un long moment, agréable et instructif, à discuter ce matin avec une dev debian:

* httpredir est un projet dont la maintenance est abandonnée, de fiabilité douteuse.
* deb est un projet en cours de test, mais remplaçant httpredir, avec https possible. L'url changera peut-être de nom à l'avenir. Parfait pour l'itinérance
* officiellement, les miroirs locaux sont toujours proposés

[mode aéré]

Hors ligne

#17 03-04-2017 19:24:50

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian testing/sid
Noyau : 4.9-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

c'est ennuyeux ... httpredir est proposé directement dans l'installeur Debian hmm

il va donc être retiré ? ... remarque ... tant mieux, ça me fera un chapitre de moins à faire sur les cahiers du débutant ! big_smile

nous sommes tous différents ... c'est notre point commun ...

Hors ligne

#18 03-04-2017 19:47:50

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

heu.. je ne pense pas officiellement, non.
j'étais chez eux pour une install, et j'ai posé la question quand j'ai vu  pour le choix des miroirs, qui est encore la liste traditionnelle, dans stretch rc2.

de ce que j'ai compris httpredir était en projet en test, maintenant abandonné (aperçu dans une liste),  à configurer manuellement, pouvant répondre à des besoins d'itinérance, mais n'a jamais été officiel pour les installations pures Debian.
juste une config possible manuelle.
et ce n'est pas dit que le principe de deb.debian.org soit adopté d'ici la sortie de stretch, ou perdurera sous ce nom.

[mode aéré]

Hors ligne

#19 03-04-2017 21:49:52

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian testing/sid
Noyau : 4.9-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

httpredir viré des cahiers du débutant. merci encore kyodev smile

nous sommes tous différents ... c'est notre point commun ...

Hors ligne

#20 12-04-2017 17:23:47

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

sur le manuel de reférence Debian, très "upToDate" :
il est indiqué Stretch en stable, Buster en testing  hmm
et des sources list en deb.debian.org:
manuals/debian-reference/ch02.fr.html#_debian_archive_basics

[mode aéré]

Hors ligne

#21 12-04-2017 17:36:46

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian testing/sid
Noyau : 4.9-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

ah bah non ... sont un peu trop en avance ...

perso, les cahiers "stretch" sortiront avec Debian "Stretch"... donc oui, la nuit de la sortie, je ferais la publication des cahiers stretch + la mise à jour des cahiers "Jessie" en oldstable + mise à jour du paquet dfl-doc pour jessie + mise à disposition du paquet dfl-doc pour stretch ... oui ... ça va être un peu agité mais je vois pas l'avantage de coller des infos en avance de 6 mois dans une doc en ligne hmm

nous sommes tous différents ... c'est notre point commun ...

Hors ligne

#22 12-04-2017 17:45:12

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

peut-être que Stretch sort demain à la surprise générale?
out.gif

[mode aéré]

Hors ligne

#23 12-04-2017 17:47:44

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian testing/sid
Noyau : 4.9-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : Erreur avec update, impossible de récupérer les paquets[Résolu]

oh comme je serais bien dans la mouise !!! lol

nous sommes tous différents ... c'est notre point commun ...

Hors ligne

Pied de page des forums