Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-04-2017 16:26:16

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

[Résolu] Firefox Adobe flash

Flash toujours et encore !.

Bonjour à tous.
J'ai installé XFCE AMD64 dernière version, sur une machine qui a déjà fonctionné parfaitement sous Handylinux avec Firefox (donc ça ne devrait pas être un pb matériel).

Voilà ce que j'ai fait :
a) mise à jour des dépôts

apt-get update




b) mise à jour des paquets

apt-get upgrade



c) installation de flashplugin-nonfree et

apt-get install flashplugin-nonfree




d) mise à jour de flashplugin

update-flashplugin-nonfree –install


Résultat

 root@Pizza-ThinkCentre-m58:/home/jbs# update-flashplugin-nonfree --install
--2017-04-01 15:53:09--  https://fpdownload.adobe.com/get/flashplayer/pdc/24.0.0.186/flash_player_npapi_linux.x86_64.tar.gz
Résolution de fpdownload.adobe.com (fpdownload.adobe.com)… 92.122.180.191
Connexion à fpdownload.adobe.com (fpdownload.adobe.com)|92.122.180.191|:443… connecté.
requête HTTP transmise, en attente de la réponse… 404 Not Found
2017-04-01 15:53:09 erreur 404 : Not Found.

ERROR: wget failed to download https://fpdownload.adobe.com/get/flashplayer/pdc/24.0.0.186/flash_player_npapi_linux.x86_64.tar.gz
More information might be available at:
  http://wiki.debian.org/FlashPlayer




J'ai déjà fait cette manœuvre sur une autre machine et tout a fonctionné et là je ne comprends pas ce qui se passe. Est-ce qu'il ne s'agirait pas d'un serveur indisponible momentanément ?.

Merci pour votre réponse.

Dernière modification par nounours (02-04-2017 20:20:48)


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#2 01-04-2017 16:32:44

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] Firefox Adobe flash

Beh, le site de adobe a changé la version et debian s'y est pas adapté en cherchant le binaire à la mauvaise adresse, épicétout. Je suis prêt à parier que tu as la même erreur si tu refais la tentative de màj où flash est déjà installé.

Du coup... Grmblm. Zont quoi les gens à vouloir cette technologie dangereuse à abandonner é_è

Dernière modification par otyugh (01-04-2017 16:34:41)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#3 01-04-2017 16:38:14

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Firefox Adobe flash

@otyugh
Merci.
Il n'y a donc rien à faire ?.
Flash est une saloperie mais il est encore et toujours utilisé sur le site de Pluzz par exemple.

N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#4 01-04-2017 16:48:35

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] Firefox Adobe flash

Donc faut boycotter ces sites et leur envoyer un courrier de plainte, et essayer d'amener le plus de monde à t'imiter plutôt que d'être un consommateur passif. Si tu as le temps c'est un devoir. La liberté demande des sacrifices. Refuser l'inacceptable, même au détriment du confort. Auto-extrêmisez-vous ! Seul responsable de tes habitude de vie, si tu as le confort de choisir, faut choisir pour laisser l'alternative ceux qui ne peuvent pas faute de ressource intellecutelle/temps/militantisme.

Solution ( la victoire du confort, hein... ) :

Download the latest release of the plugin in tar.gz format from https://get.adobe.com/flashplayer/
    Télécharger le plugin en .tar.gz à partir de https://get.adobe.com/flashplayer/

    As root, extract the tar.gz package and copy libflashplayer.so to /usr/lib/flashplugin-nonfree
    En root, extraire le paquet et copier libflashplayer.so dans /usr/lib/flashplugin-nonfree

    Give the file sane permission/ownership values:
    En lui donnant les permissions/propriétaires suivants :

  chmod 644 /usr/lib/flashplugin-nonfree/libflashplayer.so
  chown root:root /usr/lib/flashplugin-nonfree/libflashplayer.so



    Check that the relevant /etc/alternatives entry is correct
    Verifier que l'entrée dans /etc/alternatives est correcte

update-alternatives --list flash-mozilla.so should return /usr/lib/flashplugin-nonfree/libflashplayer.so


    If that's not the case, you can fix it with:

    Si ce n'est pas le cas vous pouvez réparer avec:

update-alternatives --quiet --install /usr/lib/mozilla/plugins/flash-mozilla.so flash-mozilla.so /usr/lib/flashplugin-nonfree/libflashplayer.so 50


Source: https://wiki.debian.org/FlashPlayer/#Troubleshooting

Dernière modification par otyugh (01-04-2017 16:56:56)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#5 01-04-2017 17:00:06

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Firefox Adobe flash

Salut smile

nounours a écrit :

Flash est une saloperie mais il est encore et toujours utilisé sur le site de Pluzz par exemple.

Pour la méthode light c'est techniquement possible avec youtube-dl. Sinon, il y a Kodi (ex XBMC) qui en est capable via un addon FReplay. Et ça, c'est cool sur un Raspberry-pi raccordé à la Télé tongue


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#6 01-04-2017 17:05:04

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] Firefox Adobe flash

J'ai fait un paquet .deb avec youtube-dl dedans pour un màj automatique et un frontend pour télécharger/regarder en streaming avec en 1 click. Je le test encore mais ça peux éventuellement t'intéresser si t'es pas trop dérangé d'attendre 10 seconde avant le chargement des vidéos.

J'utilise que ça depuis un-deux mois (ça permet de bloquer tout le javascript sur youtube, vimeo, dialymotion, et encore profiter des videos ; ainsi que d'extraire le son rapidement des videos, d'avoir une version HD/LD rapidement, ce genre de petit plus tongue).

J'ose juste pas encore le montrer (j'ai un complexe d'infériorité en programmation), mais je vais finir par me mettre un coup de pied au cul parce que ça marche très bien au fond tongue

Dernière modification par otyugh (01-04-2017 17:12:19)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#7 01-04-2017 17:21:37

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Firefox Adobe flash

@otyugh

Bon je vais essayer ton tuto.
Je vais ouvrir un autre post pour Flash et proposer un texte de protestation que je vais tacher d'envoyer à Pluzz.

N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#8 01-04-2017 17:24:32

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Firefox Adobe flash

Je l'ai fais l'année dernière le message de protestation. Il ne se sont même pas fendu d'une réponse hmm

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#9 01-04-2017 17:57:19

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Firefox Adobe flash

otyugh a écrit :

J'ai fait un paquet .deb avec youtube-dl dedans pour un màj automatique et un frontend pour télécharger/regarder en streaming avec en 1 click. Je le test encore mais ça peux éventuellement t'intéresser si t'es pas trop dérangé d'attendre 10 seconde avant le chargement des vidéos.

J'utilise que ça depuis un-deux mois (ça permet de bloquer tout le javascript sur youtube, vimeo, dialymotion, et encore profiter des videos ; ainsi que d'extraire le son rapidement des videos, d'avoir une version HD/LD rapidement, ce genre de petit plus tongue).

J'ose juste pas encore le montrer (j'ai un complexe d'infériorité en programmation), mais je vais finir par me mettre un coup de pied au cul parce que ça marche très bien au fond tongue



La machine sur laquelle j'ai ce pb est une machine destinée à faire des essais on peut tout se permettre.

Est ce que ça marche en utilisant Firefox de façon simple ou faut-il aller sur youtube nécessairement ?


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#10 01-04-2017 18:16:03

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] Firefox Adobe flash

nounours a écrit :

La machine sur laquelle j'ai ce pb est une machine destinée à faire des essais on peut tout se permettre.

Est ce que ça marche en utilisant Firefox de façon simple ou faut-il aller sur youtube nécessairement ?


Cobaye volontaire ? Je metterai le paquet en ligne bientôt alors tongue
Faut juste désigner la vidéo (pas besoin d'aller sur la page de la vidéo) ; selectionner l'url ou l'avoir copié dans le presse papier, puis lancer le script qui se charge du reste. Le script peut-être lancé via un un lanceur dans la barre de tâche, un raccourci clavier, un plugin de bouton dans firefox...

Dernière modification par otyugh (01-04-2017 18:16:33)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#11 02-04-2017 08:30:03

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Firefox Adobe flash

@otyugh
Re bonjour
J'ai essayé d'appliquer ton tuto (post #4), pas de pb pour télécharger, décompresser, copier le fichier libflashplayer.so dans /usr/lib/flashplugin-nonfree, permissions/propriétaires.

J'ai l'impression qu'il y a une erreur dans la commande suivante :

update-alternatives --list flash-mozilla.so should return /usr/lib/flashplugin-nonfree/libflashplayer.so


Résultat :

root@Pizza-ThinkCentre-m58:/home/jbs# update-alternatives --list flash-mozilla.so should return /usr/lib/flashplugin-nonfree/libflashplayer.so
update-alternatives: erreur: paramètre inconnu « should »  


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#12 02-04-2017 08:58:02

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Firefox Adobe flash

Bonjour smile
balise code mal placée je crois

update-alternatives --list flash-mozilla.so


should return (devrait retourner)

 /usr/lib/flashplugin-nonfree/libflashplayer.so

Hors ligne

#13 02-04-2017 09:33:20

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Firefox Adobe flash

@chalu
Bonjour et bon dimanche.
Résultat de

update-alternatives --list flash-mozilla.so


Résultat :

 root@Pizza-ThinkCentre-m58:/home/jbs# update-alternatives --list flash-mozilla.so
update-alternatives: erreur: pas d'alternatives pour flash-mozilla.so


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#14 02-04-2017 11:06:14

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Firefox Adobe flash

J'ai le bon retour chez moi.
Vérifions que le copier-coller est ok :

ls /usr/lib/flashplugin-nonfree/


si c'est bon tu auras le retour comprenant :

libflashplayer.so


chez moi j'ai aussi pubkey.asc dans le retour.
Donc si tu as le retour correct, tu corriges avec

update-alternatives --quiet --install /usr/lib/mozilla/plugins/flash-mozilla.so flash-mozilla.so /usr/lib/flashplugin-nonfree/libflashplayer.so 50


Je te donne le lien du wiki debian en français :
https://wiki.debian.org/fr/FlashPlayer# … r_manuelle

Hors ligne

#15 02-04-2017 11:32:37

tophechris94
Membre
Lieu : val de marne ( 94)
Distrib. : kali / kissOs
Noyau : Linux 4.9.0
(G)UI : openbox / lxde / fluxbox / etc....
Inscription : 08-07-2016
Site Web

Re : [Résolu] Firefox Adobe flash

Salut a tous , je vais vous lacher une bombe , vous n etes pas obligé d installer flash plugin qui est dans les depots .

il faut récuperer le fichier  libflashplayer.so  qui est  ici => http://labs.adobe.com/downloads/flashplayer.html

mettez  "libflashplayer.so" dans un dossier  plugins que vous avez crée ,  chez moi  c est ici 

/home/tophechris94/.mozilla/firefox/tm8cb5af.default/plugins


Maintenant faites gksu thunar prenez libflashplayer.so et mettez le dans

/usr/lib/mozilla/plugins/


Et vous avez le flashplugin a jour sans  avoir installé le flash des depots.

Dernière modification par tophechris94 (02-04-2017 12:38:37)


1480082419.gif
https://arpinux.org ☯  La logique est la base de tous ☯

Hors ligne

#16 02-04-2017 11:39:16

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Firefox Adobe flash

Oui smile
Le seul avantage du paquet des dépôts que je verrais c'est que lorsqu'il fonctionne on a la mise à jour automatique.
Je ne suis plus très sûre de la mise à jour automatique d'ailleurs car ça fait plusieurs mois que l'on est obligé de le faire à la main.
Après il doit être possible de faire un script qui ferait le travail de mise à jour.

Hors ligne

#17 02-04-2017 11:51:20

tophechris94
Membre
Lieu : val de marne ( 94)
Distrib. : kali / kissOs
Noyau : Linux 4.9.0
(G)UI : openbox / lxde / fluxbox / etc....
Inscription : 08-07-2016
Site Web

Re : [Résolu] Firefox Adobe flash

Pour regarder youtube  j  utilise browser-plugin-vlc qui est dans les depots + un script  ici  :
https://greasyfork.org/fr/scripts/1203-viewtube-gm
Il faut l extension greasemonkey aussi :
https://addons.mozilla.org/en-US/firefo … asemonkey/
Cela donne ca :
1491126656.png

Dernière modification par tophechris94 (02-04-2017 11:58:47)


1480082419.gif
https://arpinux.org ☯  La logique est la base de tous ☯

Hors ligne

#18 02-04-2017 12:59:59

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] Firefox Adobe flash

tophechris94 a écrit :

Salut a tous , je vais vous lacher une bombe , vous n etes pas obligé d installer flash plugin qui est dans les depots .


Oui, enfin, c'est la même chose, du coup.

Dernière modification par otyugh (02-04-2017 13:00:14)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#19 02-04-2017 14:37:54

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Firefox Adobe flash

Salut,
Ben sinon tu peux benner ton .deb je suis volontaire pour le tester

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#20 02-04-2017 16:16:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Firefox Adobe flash

Bonjour,

Le seul avantage du paquet des dépôts que je verrais c'est que lorsqu'il fonctionne on a la mise à jour automatique. Je ne suis plus très sûre de la mise à jour automatique d'ailleurs [...].


Effectivement, la mise à jour du plugin installé via le paquet 'officiel' n'a jamais été automatique, pour la bonne raison que Debian n'a jamais redistribué le plugin... il suffit pour s'en convaincre de lire le descriptif du paquet flashplugin-nonfree, voire de parcourir le script update-flashplugin-nonfree :

apt-cache show flashplugin-nonfree

et/ou

less /usr/sbin/update-flashplugin-nonfree


Pour du toutotomatic, il y a éventuellement le paquet flashplayer-mozilla du dépôt non officiel deb-multimedia (d'ailleurs récemment mentionné sur le forum), avec toutes les réserves indiquées sur le wiki.

Après il doit être possible de faire un script qui ferait le travail de mise à jour.


Oui, mais c'est plus ou moins trivial, selon le niveau de totomatisation recherché (la détection 'automatique' de l'architecture, notamment, rallonge la sauce concernant le nom du fichier à télécharger).

Dernière modification par èfpé (02-04-2017 16:28:42)

Hors ligne

#21 02-04-2017 20:20:04

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : Mate, Xfce
Inscription : 11-02-2012

Re : [Résolu] Firefox Adobe flash

ÇA MAAAARCHEEEE !!!!!!.

Merci à tous et à toutes.
C'est vraiment une me..de noire ce Flashplayer. Si j'ai bien compris la prochaine Débian devrait mettre fin a ce grand Bo....el.

Voila par le menu, le fil de l'aventure, pour les amateurs pas trop ''velus'' dans mon genre quoi.

1 - Télécharger le plugin en .tar.gz à partir de hs://get.adobe.com
On choisit les paquets pour linux évidemment.

2 - Extraire en faisant un clic droit sur le paquet (qui doit se trouver dans Téléchargement).

3 - Se placer dans /Téléchargement (si son a téléchargé le plugin en .tar.gz dans Téléchargement).

cd Téléchargement



4 - En root, copier libflashplayer.so dans /usr/lib/flashplugin-nonfree


cp libflashplayer.so /usr/lib/flashplugin-nonfree


5 - Donner les permissions/propriétaires suivants :

chmod 644 /usr/lib/flashplugin-nonfree/libflashplayer.so


chown root:root /usr/lib/flashplugin-nonfree/libflashplayer.so




6 - Vérifiez que les entrées /etc/alternatives appropriées sont correctes (cela ne devrait pas être nécessaire si le greffon fonctionnait correctement avant la mise à niveau, malheureusement il y  a un bug).

update-alternatives --list flash-mozilla.so


le retour de cette commande devrait retourner le résultat suivant :

/usr/lib/flashplugin-nonfree/libflashplayer.so


Dans mon cas j'ai :

root@Pizza-ThinkCentre-m58:/home/jbs# update-alternatives --list flash-mozilla.so
update-alternatives: erreur: pas d'alternatives pour flash-mozilla.so


D'où, réparation avec la commande suivante :

update-alternatives --quiet --install /usr/lib/mozilla/plugins/flash-mozilla.so flash-mozilla.so /usr/lib/flashplugin-nonfree/libflashplayer.so 50

Dernière modification par nounours (25-05-2017 07:06:35)


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

Pied de page des forums