Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-04-2017 22:12:36

Guy19550
Membre
Inscription : 10-08-2016

[Résolu] Nouvelle instal de Debian 8.5 XFCE sur Compaq Evo N600c

Bonjour,

J'espère qu'il y a une solution à l'audio... merci d'avance pour l'aide.

2wp2hxk.jpg

Est-il possible de supprimer ce lecteur de disquette ?
Windows XP, c'est bye bye à cause de Firefox qui refuse de s'installer à cause du CPU plus supporté. Firefox sous linux est ok. C'est un des meilleurs dans le genre que j'ai rencontré quand même, l'autre est un Dell LS500 entièrement reconnu sans problèmes. Les fabricants feraient bien de s'en inspirer lorsqu'ils viennent avec des produits nouveaux !

Pas d'audio, pas de wifi via un stick USB et messages d'erreurs au démarrage. J'ai essayé d'autres versions également, comme Debian 7, DF et HandyLinux 1.9 et quand j'ai voulu remettre l'image de Debian 8.5, j'ai eu ce message, voir la dernière ligne :

15dkq3r.jpg

Cela se produit assez souvent avec des tests multiples et quand cela arrive, les anciennes images de clonezilla ne sont plus utilisables. J'ai donc refait une nouvelle installation de Debian 8.5. Je pense que c'est lié au disque swap, sans en être certain.

Pour la wifi, c'est résolu avec le CD « tinstall ».

Pour l'audio, j'ai essayé ceci :

http://www.icculus.org/~mongoose/Compaq-Evo_N600c.html

Comme cela n'a rien donné de bon, j'ai reflashé la dernière image de clonezilla sur la partition.

L'installation de Handylinux indique au début de l'installation des problèmes de firmware, j'ai eu deux messages, le premier pour « ess/maestro3_assp_kernel.fw » et le second pour « ess/maestro3_assp_minisrc.fw ». Il y en a peut-être d'autres car le premier fichier que j'ai donné via un stick USB a été pris je pense, mais pas le second car le message réaparaît chaque fois, tant que l'on dit oui pour le reprendre et on fini alors par dire non et poursuivre l'installation. L'installation s'interrompt vers la fin de la procédure et pas moyen de la reprendre, pareil en recommençant.

J'ai stocké les fichiers téléchargés suivants sur le disque de Backup :
maestro3_assp_kernel.fw
maestro3_assp_minisrc.fw
J'ignore si la liste est complète, et il manque « ess/ » dans les fichiers téléchargés.

Je suis tombé sur ceci pour aller plus loin, mais encore rien fait à ce sujet :
https://raphaelhertzog.fr/2011/10/28/fi … -probleme/

Je n'ai rien dans le Bios pour mettre à l'heure. Tout a été bien configuré à l'installation mais j'ai eu à changer la batterie pour en tester une autre et à la suite de cela l'heure s'est déréglée.
Corrigé avec : date -s hh:mm:ss

Sudo apt-get update ne marche pas, mais
Su, mot de passe et ensuite
apt-get update
passe correctement.
apt-get upgrade passe correctement également.
Je sais aussi faire les updates via le paquet Synaptic en alternative.

Je dois encore essayer ceci :
Su, mot de passe... et ensuite
apt-get install ntp

Messages d'erreurs au démarrage :

2z7kbb9.jpg

Note : je ne vois rien pour  « ... minisrc.fw »
Et la vidéo me semble bonne sous Debian, sauf que j'ai dû utiliser Smplayer2 pour lire correctement les vidéos.

Radeon/R100_cp.bin ???
https://packages.debian.org/fr/jessie/f … ux-nonfree

j'ai trouvé le fichier mais je pense qu'il est peut-être aussi sur le CD de tinstall. C'est installé via le CD tinstall, tous les messages d'erreurs pour la vidéo disparaissent au démarrage et VLC sait maintenant lire les vidéos. Seul le problème audio subsiste et l'icône de la disquette. J'ai refait une image avec Clonezilla.

Quoi qu'il en soit pour l'audio, j'ai pour le moment de l'audio via un stick USB chinois reconnu sous Linux, mais j'aimerais bien m'en passer sur ce PC car cela prend la place de 2 prises USB.

Dernière modification par Guy19550 (11-04-2017 22:45:51)

En ligne

#2 10-04-2017 23:28:28

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Nouvelle instal de Debian 8.5 XFCE sur Compaq Evo N600c

Bonsoir,

Il ne serait pas inintéressant de confirmer les identifiants PCI de ce contrôleur audio :

lspci | grep audio

02:09.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 12)


Le module pilote snd-maestro3 requiert effectivement deux firmwares pour fonctionner :

ess/maestro3_assp_minisrc.fw
ess/maestro3_assp_kernel.fw


Note que 'ess/' ne fait pas partie du nom des fichiers, mais de leur chemin :

/lib/firmware/ess/maestro3_assp_minisrc.fw
/lib/firmware/ess/maestro3_assp_kernel.fw


Concernant ces firmwares : une source de confiance, ftp.alsa-project.org, et un tutoriel.

Dernière modification par èfpé (11-04-2017 01:12:12)

Hors ligne

#3 11-04-2017 01:22:45

Guy19550
Membre
Inscription : 10-08-2016

Re : [Résolu] Nouvelle instal de Debian 8.5 XFCE sur Compaq Evo N600c

J'ai retiré le stick audio pour passer les commandes.

guy@debian:~$ lspci -nnk | grep -iA 2 audio


02:09.0 Multimedia audio controller [0401]: ESS Technology ES1988 Allegro-1 [125d:1988] (rev 12)
  Subsystem: Compaq Computer Corporation Device [0e11:0094]
03:00.0 USB controller [0c03]: NEC Corporation OHCI USB Controller [1033:0035] (rev 43)
guy@debian:~$



guy@debian:~$ aplay -l


aplay: device_list:268: aucune carte son n'a été trouvée...
guy@debian:~$




Je regarde pour les deux liens, merci

Arf, le message précédent à changé, je vais refaire une passe...

guy@debian:~$ lspci | grep audio


02:09.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 12)
guy@debian:~$



Le premier lien, jamais vu avant. Je suppose qu'il faut télécharger ce qu'il faut. Le second lien je l'avais déjà vu, mais cela me semble trop compliqué pour moi et la probabilité de faire des erreurs est énorme selon mes connaissances. Je vais donc créer le répertoire qui convient, installer l'équivalent de Totalcommander pour voir ce que je fais (krusader) et essayer de copier les fichiers que j'ai trouvé du disque Backup vers le répertoire créé. Si ça marche pas, je reflashe l'image de la partition. Le point 4, je comprends plus ou moins, mais c'est obscur pour les points qui précèdent et d'autres qui suivent. Je refais une cafetière avant de poursuivre...

Dernière modification par Guy19550 (11-04-2017 02:17:06)

En ligne

#4 11-04-2017 16:43:17

mascarade
Membre
Lieu : Quebec
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : kde4
Inscription : 03-09-2013

Re : [Résolu] Nouvelle instal de Debian 8.5 XFCE sur Compaq Evo N600c

Salut!

Donc tu as ton firmware wifi et de carte son et video  qui ne marche pas. ( pour dire y'à une version non-officiel sur le site de debian qui est un net-install + firmware....) sa s'install comme un charme chez moi et sa detecte mes firmwares manquant.... smile  http://cdimage.debian.org/cdimage/unoff … -firmware/

Ensuite tu ne peux pas passer par sudo, est-ce vraiment nessessaire? As-tu editer /etc/sudoers? Sa s'effectu avec la commande :

visudo


Un peu d'info https://doc.ubuntu-fr.org/sudoers

L'erreur A starting job dev-disk-by-uuid : regarde ton fichier fstab (/etc/fstab) et avec la commande

blkid


tu peux verifier les uuid si il corresponde... y'à des chance que se soit ta swap....

Bonne chance smile

Dernière modification par mascarade (11-04-2017 16:43:57)

Hors ligne

#5 11-04-2017 17:42:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Nouvelle instal de Debian 8.5 XFCE sur Compaq Evo N600c

@Guy19550,

Il n'y a vraiment rien d'insurmontable dans cette histoire de firmwares (quant à moi, je ne comprends pas grand-chose à ce que tu racontes non plus wink) donc je reprends le tuto du wiki Debian en l'adaptant un peu :

cd ~/Téléchargements

wget ftp://ftp.alsa-project.org/pub/firmware/alsa-firmware-1.0.28.tar.bz2

tar -xjf alsa-firmware-1.0.28.tar.bz2

cd alsa-firmware-1.0.28

./configure # crée entre autres config.log config.status Makefile version

cd maestro3

make # crée entre autres maestro3_assp_kernel.fw maestro3_assp_minisrc.fw

mkdir /lib/firmware/ess

cp *fw /lib/firmware/ess

ls -lh /lib/firmware/ess

total 8,0K
-rw-r--r-- 1 root root 1,9K avril 11 17:04 maestro3_assp_kernel.fw
-rw-r--r-- 1 root root  786 avril 11 17:04 maestro3_assp_minisrc.fw


Selon l'installation du système, la commande './configure' peut produire une erreur :

./configure

checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/home/humain/Téléchargements/alsa-firmware-1.0.28':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details


L'installation du paquet gcc (plutôt que celle de build-essential) règle alors ce souci :

./configure

checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for as31... no
checking firmware installation directory... /lib/firmware
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating hdsploader/Makefile
config.status: creating mixartloader/Makefile
config.status: creating usx2yloader/Makefile
config.status: creating vxloader/Makefile
config.status: creating pcxhrloader/Makefile
config.status: creating echoaudio/Makefile
config.status: creating emu/Makefile
config.status: creating asihpi/Makefile
config.status: creating korg1212/Makefile
config.status: creating maestro3/Makefile
config.status: creating multisound/Makefile
config.status: creating sb16/Makefile
config.status: creating wavefront/Makefile
config.status: creating ymfpci/Makefile
config.status: creating aica/Makefile
config.status: creating ca0132/Makefile
config.status: creating cs46xx/Makefile
config.status: executing depfiles commands


Note : la version 1.0.28 a été choisie pour matcher avec la version installée d'ALSA.

Dernière modification par èfpé (01-06-2017 21:04:04)

Hors ligne

#6 11-04-2017 22:44:28

Guy19550
Membre
Inscription : 10-08-2016

Re : [Résolu] Nouvelle instal de Debian 8.5 XFCE sur Compaq Evo N600c

C'est fait depuis la nuit dernière, j'ai juste créé le répertoire adhoc en passant par la console de commande en mode root avec su (selon le point 4 du lien "tutoriel" du message 2. Ensuite Krusader en mode superutilisateur pour copier les deux fichiers dans ce répertoire. Ensuite redémarrage et tout a été détecté.

J'avais cependant une image de la partition avec VLC et SMplayer 2 désinstallé que j'avais abandonné puisque VLC marchait mieux à la suite du bon firmware de la carte carte graphique (pris via le CD de tinstall comme pour la wifi avant avec realteak pour le même CD de t install). J'ai malgré tout remis SMplayer2 car cela marche tout de même mieux que VLC sur ce PC. Et refait une image.

Le seul problème qui subsiste est ce lecteur de Disquette sur le bureau (que j'aimerais bien supprimer).

Cela a donc été résolu avec le CD de tinstall (wifi et carte vidéo) et le recopiage des deux fichiers pour l'audio trouvés sur internet dans le répertoire /lib/firmware/ess (créé par su... mot de passe ... mkdir... comme sous DOS - c'est compréhensible pour moi ainsi). Je n'ai donc suivi que le point 4 du lien tutoriel du message 2. Le reste est trop compliqué pour ma tête avec un important risque d'erreurs.

Il a été démarré plusieurs fois déjà, la carte vidéo est pratiquement toujours détectée, mais pas toujours.

Je vais mettre Résolu dans le premier message. Un grand merci.

En ligne

#7 11-04-2017 22:58:58

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Nouvelle instal de Debian 8.5 XFCE sur Compaq Evo N600c

Bonsoir,

Alors, oui, pour ce qui concerne l'icône du lecteur de disquette, tu peux regarder en GUI du côté de :

Applications > Paramètres > Bureau > Icônes /Icônes par défaut


Voir s'il n'y aurait pas une petite case à décocher... sinon désactiver le truc dans le BIOS ?

Dernière modification par èfpé (13-04-2017 16:54:54)

Hors ligne

#8 22-04-2017 16:01:13

Guy19550
Membre
Inscription : 10-08-2016

Re : [Résolu] Nouvelle instal de Debian 8.5 XFCE sur Compaq Evo N600c

Je vais voir s'il y a quelque chose à cet effet dans le Bios, je n'y avais pas pensé, merci. Le problème est qu'il n'est plus devant mes yeux pour le moment. Je vais mettre une remarque près du PC pour la prochaine utilisation.

Il y a effectivement une option dans le Bios pour mettre "Disable" pour ce lecteur de disquette. C'est mieux sans et l'icone qui disparaît du bureau. J'en profite pour revoir les installations antérieures sur les autres PC, vu qu'il y a du changement avec Icedove qui est remplacé par Thunderbird. Ici j'ai aussi rajouté je pense la fameuse ligne dans "sudoers machin" pour avoir accès avec sudo dans la console de commande (avec visudo cette fois, j'avais fait autrement avant).

C'est assez long, car je dois chaque fois refaire les images avec Clonezilla.

Dernière modification par Guy19550 (28-04-2017 03:57:00)

En ligne

Pied de page des forums