Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-04-2017 14:18:11

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

[ABANDON] problème de scan... sous debian wheezy gnome

Bonjour.
Curieux.
J'interviens sur une machine qui est sous wheezy/gnome
Que ce soit sous simple-scan, ou sous skanlite, la phase de numérisation me renvoie vers la webcam...
je suis a distance, je ne peux donc pas intervenir directement sur le matériel...
J'ai la machine sous Teamviewer... et j'ai procédé à une mise à jour, puis à une  installation de skanlite
Le lancement de l'un ou de l'autre de ces logiciels de scan échoue au moment de la numérisation (skanlite) ou me renvoie vers la webcam (simple-scan)
l'imprimante-scanner est une HP ENVY 4500
une idée ?
merci de vos lumière

Dernière modification par redelap (26-06-2017 17:39:50)


Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#2 25-04-2017 18:08:30

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [ABANDON] problème de scan... sous debian wheezy gnome

Bonjour smile
Ton imprimante scanner est selectionnable dans le logiciel de scan ? Tu la vois
Pour cette imprimante il faut au minimum la version 3.13.6 de hplip
Vérifie la version de hplip installé :

apt-cache policy hplip


pas sûr quelle soit suffisante sur whezzy

Hors ligne

#3 25-04-2017 19:04:11

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [ABANDON] problème de scan... sous debian wheezy gnome

Merci de ta réponse.
C'est la version 3.12.6.3.1 de HPLIP qui est installée.
Quand je lance simple-scan, il ne me propose que la webcam... et pas d'autre chose... et dans la fenêtre du scan de Simple-Scan, c'est ce que voit la webcam qui apparait !... Dans les préférences de simple-scan, il n'y a que la WebCam qui m'est proposée comme "source de numérisation"...
y'a des nœuds dans les fils...
En fait le scan ne "monte" pas, bien qu'allumé et connecté à l'ordi par câble USB

sad

Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#4 25-04-2017 19:05:35

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [ABANDON] problème de scan... sous debian wheezy gnome

le pilote n'est pas suffisant pour le scanner sad
As-tu une version plus récente dans les backports de whezzy comme c'est le cas sous jessie ?

Non je viens de vérifier, y a rien.
A mon avis tu auras du mal à installer le paquet de jessie car tu auras des dépendances qui n'iront pas
je ne sais pas si la version du site hp a plus de chance de passer

Hors ligne

#5 26-04-2017 15:37:40

psychlem
Membre
Lieu : Paris
Distrib. : Debian 8.7 Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Cinnamon 2.2.16
Inscription : 07-02-2017

Re : [ABANDON] problème de scan... sous debian wheezy gnome

Salut à tous ! 
As-tu vérifié que l'utilisateur est dans le groupe lp ?

Hors ligne

#6 26-04-2017 17:55:32

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [ABANDON] problème de scan... sous debian wheezy gnome

ce ne serait pas plutôt le groupe scanner ?

id chalu


uid=1000(chalu) gid=1000(chalu) groupes=1000(chalu),7(lp),20(dialout),24(cdrom),25(floppy),27(sudo),29(audio),44(video),46(plugdev),100(users),108(netdev),110(lpadmin),112(scanner),121(vboxusers)


Pour avoir eu une imprimante envy sur whezzy, je penche plutôot pour la version du driver hplip qui n'est pas suffisante et alors
Soit on passe à jessie et plus de problème car la version suffira pour l'imprimante de ce fil
soit on tente l'installation du paquet téléchargé sur le site hp

Hors ligne

#7 30-04-2017 11:47:54

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [ABANDON] problème de scan... sous debian wheezy gnome

L'installation du paquet hplip du site HP n'a donné aucun résultat...
C'est toujours la webcam qui prend la place du scan quand on lance un des logiciels de scan...
j'en perds mon latin...
La webcam aurait-elle changé de nom, ou d'adresse.., prenant celle du scan??

Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#8 30-04-2017 12:34:21

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [ABANDON] problème de scan... sous debian wheezy gnome

bonjour
Peut etre a tu la possibilité de changer la sources de numérisation avec le menu déroulant
1493548186.png1493548190.png

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 30-04-2017 16:58:08

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [ABANDON] problème de scan... sous debian wheezy gnome

Oui... bien entendu.. j'y suis allé.; mais je n'ai pas d'autre choix que la webcam...
le scan "ne monte " pas... Il n'existe pas dans la liste des sources possibles...
C'est comme si la webcam "avait pris la place" du scan...
L'ensemble compact imprimante et scan sont pourtant relié au PC par câble... et l'imprimante fonctionne...

Dernière modification par redelap (30-04-2017 16:58:36)


Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#10 30-04-2017 17:25:30

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [ABANDON] problème de scan... sous debian wheezy gnome

Bonjour smile
Tu n'as pas eu de message d'erreur en installant le paquet du site hp ?
Que renvoie

apt-cache policy hplip

Hors ligne

#11 02-05-2017 18:10:35

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [ABANDON] problème de scan... sous debian wheezy gnome

Voici la réponse à la question posée...

root@xxxxxxxxxxxx/maria# apt-cache policy hplip
hplip:
  Installé : 3.12.6-3.1+deb7u2
  Candidat : 3.12.6-3.1+deb7u2
 Table de version :
 *** 3.12.6-3.1+deb7u2 0
        500 http://security.debian.org/ wheezy/updates/main i386 Packages
        100 /var/lib/dpkg/status
     3.12.6-3.1+deb7u1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
        500 http://http.debian.net/debian/ wheezy/main i386 Packages
root@xxxxxxxxxxxxxx/maria#


bloc à supprimer si la commande n’affiche rien



Le port USB fonctionne (vérifié)
Le câble USB reliant l'imprimante compact est en bon état (Vérifié)
l'imprimante fonctionne

C'est donc essentiellement un problème de scan...
??????


Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#12 02-05-2017 19:54:46

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [ABANDON] problème de scan... sous debian wheezy gnome

Tu n'as pas la dernière version de hplip fournie par le site hp donc tu as toujours le problème de reconnaissance du scanner.
Vérifier dans system-config-printer que la version est bien 3.17.4
1493749684.png
Si ce n'est pas installé, il faut recommencer et sinon je ne vois pas d'où vient le problème.
Tu commences par débrancher l'imprimante et tu la supprimes du PC avec system-config-printer
Tu vas sur cette page chez HP : http://hplipopensource.com/hplip-web/in … index.html
Etape 1 : tu télécharges dans le dossier Téléchargements le fichier HPLIP 3.17.4.run en cliquant sur le lien Download HPLIP
Ensuite il faut suivre les instructions du site HP
Etape 2 : installation du pilote
Tu ouvres un terminal en utilisateur

cd ~/Téléchargements


sh hplip-3.17.4.run


Tu choisis le mode d'installation automatique en tapant a puis Entrée
Debian 7 devrait être détectée et l'installateur te demandera de confirmer en tapant y (pour yes) et Entrée
Tu rentres ton mot de passe root
Tu appuies sur Entrée pour continuer
Il devrait y avoir détection des paquets manquants (dépendances) s'il y en a et téléchargements de ceux-ci
L'installation se poursuit, fait attention aux messages pour les copier coller ici si ça n'aboutit pas
à la question :
HPLIP-3.12.6 exists, this may conflict with the new one being installed.
Do you want to ('i'= Remove and Install*, 'q'= Quit)?    :
répondre i et Entrée pour supprimer l'ancienne version de hplip et installer la nouvelle
Quand tu as le message re-start or re-plug your printer, tu la rebranches
et tu devrais avoir hp-setup qui se lance pour installer l'imprimante ou tu quittes et tu installes avec system-config-printer
ça devrait marcher aussi.

Je vais faire les manips pour voir comment ça se passe. Si tu n'as pas crée de compte root, il faut peut-être bien que tu fasses sudo sh hplip-3.17.4.run au début
Je vais tester dans une virtualbox pour voir ce que ça donne

Hors ligne

#13 07-05-2017 10:04:33

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [ABANDON] problème de scan... sous debian wheezy gnome

merci pour cette longue réponse... je ne pourrai tenter cette manip que dans quelques jours...
encore merci

Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#14 16-05-2017 15:06:31

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [ABANDON] problème de scan... sous debian wheezy gnome

Bon.. évolution....
Sauvegarder tout ce qui doit être sauvegardé.
Installer debian 8 jessie...
et on verra.. Je ne pourrai pas faire ça avant quelques semaines... Mais là cela devrai marcher...
Merci pour ce précieux descriptif.

Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#15 16-05-2017 16:37:54

Caribou22
Membre
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stretch
Noyau : 4.9 amd64
(G)UI : XFCE
Inscription : 10-11-2014
Site Web

Re : [ABANDON] problème de scan... sous debian wheezy gnome

redelap a écrit :

Bon.. évolution....
Sauvegarder tout ce qui doit être sauvegardé.
Installer debian 8 jessie...
et on verra.. Je ne pourrai pas faire ça avant quelques semaines... Mais là cela devrai marcher...
Merci pour ce précieux descriptif.



Bonjour,
Et ça devrait marcher du coup, comme la version de hplip de Jessie est suffisante smile https://packages.debian.org/fr/jessie/hplip (3.14.6)

Hors ligne

#16 19-05-2017 15:51:40

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [ABANDON] problème de scan... sous debian wheezy gnome

C'est bien ce qui me semble...
ça va se faire dans quelque temps... et cette machine recevra la 8.8.. peut-être la 9 ?
Mais là je vais attendre quand même que les plâtres sèchent bien...
merci de votre contribution

Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

Pied de page des forums