Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-09-2009 11:38:28

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

connecter ma Lenny à l'internet sur la Freebox (résolu)

Bonjour à tous,

Je suis déjà venu avec succès pour connecter ma Lenny LXDE sur Alice bas-débit en partage de connexion et IP fixes sur 3 PC's

Bon, j'ai abandonné Alice pour la liberté haut-débit avec la Freebox dernier modèle. J'ai configuré  2  PC's sous ubuntu jaunty 9.04 en partage de connexion et ça marche.

Reste à configurer ma LXDE.

Par où je commence ma config Internet ?

Merci de vos avis éclairés smile

Dernière modification par jrev (14-09-2009 20:06:03)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#2 12-09-2009 12:57:12

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Bjr,
Comme d'hab, par lire le wiki > http://debian-facile.org/wiki/manuel:interfaces

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 12-09-2009 14:05:40

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Merci,

Si j'édite le fichier /etc/network/interfaces :

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
    address 192.168.0.2
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 213.36.80.1


Je pense que je dois changer le gateway par l'ID de la freebox et le DNS d' Alice par les DNS de Free.fr
(déjà fait dans le fichier /etc/resolv.conf )

Ma freebox servant de switch pour 4 ports Ethernet je devrais pouvoir pinger mes PC's
Mais je reçois cette réponse :

Network unreachable

Dernière modification par jrev (12-09-2009 14:24:01)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#4 12-09-2009 14:18:07

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

re-
Oui c'est que je pense aussi.
A vérifier tout de même si les ip fixes sont dans la plage permise par la box.

Pour les dns je suis resté sur ma faim quant aux explications. Perso je ne sais pas où elles sont inscrites et je n'ai pas resolvconf d'installé, mais j'ai un resolv.conf

nameserver 192.168.1.1


Mon /etc/network/interfaces pour LiveBox

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
    address 192.168.1.3
    netmask    255.255.255.0
    gateway    192.168.1.1


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#5 12-09-2009 14:35:40

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

curieux : ta gateway a le même numéro que ton DNS

Chez moi avec ma connexion bas-débit Alice, j'avais configuré un PC comme routeur et son ID était
192.168.0.1 et le DNS d'Alice est le 213.36.80.1

As-tu plusieurs PC's connectés à la livebox ? Normalement la deuxième prise Ethernet est réservée à la télé mais on peut la configurer pour un deuxième PC

tout est OK chez toi ?

Dernière modification par jrev (12-09-2009 14:40:37)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#6 12-09-2009 14:43:37

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Les IP's fixes de free sont de 192.168.0.0 à 192.168.0.9 et les DHCP de 0.10 à 0.50

Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#7 12-09-2009 14:49:13

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

re-
Dans resolv.conf ce n'est pas un dns, mais effectivement ça semble être une redondance avec gateway.
Je ne suis pas sûr que ce soit utile dans toutes les config. Sauf que récemment sur un vieux bousin je pouvais "pinger" le réseau local, mais pas le web. Et c'est donc en inscrivant le nameserver que ça a fonctionné : c'est donc utile quand la config matérielle du pc ne permet pas une détection automatique de la passerelle vers l'extérieur

Oui j'ai un réseau local qui fonctionne : 4 pc dont 2 serveurs, tout en linux, ssh, nfs. J'alterne les serveurs sur la prise usb de la box (alors quand je lis que ça marche pas, ou mal, je rigole)

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#8 12-09-2009 15:57:10

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Salut,

Pour info, voici ma config pour une IP statique avec une Freebox :

cat /etc/network/interfaces


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0

# DHCP
# iface eth0 inet dhcp

# Static
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
gateway 192.168.0.254

auto eth0


Les DNS sont automatiques, je n'ai rien modifié ailleurs... (pas de réseau local chez moi par contre).


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#9 12-09-2009 19:39:58

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Ne faut-il pas tout d'abord s'assurer que les pings passent bien entre les 3 PC's ?

Il semble qu'il manque quelque chose de fondamental sur le PC debian à chaque ping j'ai

network is unreachable


sur les 2 autres configurés en IP fixes sous ubuntu les pings passent entre eux dans les deux sens


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#10 12-09-2009 21:56:09

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

re-
et ifconfig ça donne quoi ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#11 13-09-2009 09:31:20

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

debian:/home/jean# ifconfig
debian:/home/jean# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:a0:d1:bb:32:ab 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interruption:18 Adresse de base:0xa000

lo        Link encap:Boucle locale 
          LOOPBACK  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Voilà le résumé de l'histoire :

debian:/home/jean# ifconfig
debian:/home/jean# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:a0:d1:bb:32:ab 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interruption:18 Adresse de base:0xa000

lo        Link encap:Boucle locale 
          LOOPBACK  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



GNU nano 2.0.7        Fichier : /etc/network/interfaces                       

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.0.2
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 88.180.145.254

        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers


debian:/home/jean# ping 88.180.145.254
connect: Network is unreachable


au boot du PC j'ai une ligne  :

ifup could not read /etc/network/interfaces failed


j'ai fait un

#chmod 755 /etc/network/interfaces


pour le rendre exécutable
à l'extinction du Pc j'ai une ligne :

NFS-common utilities failed


Ce PC portable marchait parfaitement en bas-débit sous debian Lenny avec partage de dossiers  et d'Internet avec le PC routeur 192.168.0.1
Donc pas de problème matériel a priori cool
et le ping ne passe toujours pas vers la freebox sad

Dernière modification par jrev (13-09-2009 12:31:39)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#12 13-09-2009 13:07:13

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

re-
Le message nfs c'est normal il me semble : pas de connection sur le réseau local.

Le ifconfig montre bien que l'ethernet ne trouve pas de réseau

Dans le /etc/network/interfaces tu peux essayer de mettre la gateway par défaut de la FreeBox : gateway 192.168.0.254. Et tu relances

 # /etc/init.d/networking restart


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#13 13-09-2009 15:10:41

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Eh oui bien sûr :

debian:/home/jean# /etc/init.d/networking restart
Reconfiguring network interfaces.../etc/network/interfaces:18: option with empty value
ifdown: couldn't read interfaces file "/etc/network/interfaces"
/etc/network/interfaces:18: option with empty value
ifup: couldn't read interfaces file "/etc/network/interfaces"
failed.


J'ai effacé la ligne 18 puis :

jean@debian:~$ ping debian
connect: Network is unreachable
jean@debian:~$ ping jean
connect: Network is unreachable
jean@debian:~$ ping 192.168.0.254
connect: Network is unreachable


Je suis à peu près sûr que les DNS étaient précédemment indiqués dans /etc/resolv.conf comme aujourd'hui

jean@debian:~$ cat /etc/resolv.conf
nameserver 212.27.40.240
nameserver 213.27.40.241


le reset networking restart est maintenant correct sans alarme :)j'ai changé mon câble Ethernet, mais les pings ne passent pas même en local sur ping debian

Dernière modification par jrev (13-09-2009 15:33:48)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#14 13-09-2009 16:45:16

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Que faut-il faire sur Debian Lenny pour que ma carte Eth0 et la boucle locale obtiennent
une adresse Internet ?

Tout se passe-t-il dans le fichier /etc/network/interfaces ?

Rien d'autre à faire ? cool

Dernière modification par jrev (13-09-2009 16:47:36)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#15 13-09-2009 18:56:15

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

re-
C'est normalement pas plus compliqué que la manip donnée dans le wiki.

Donc perso dans /etc/network/interfaces je mettrais

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.0.2
        netmask 255.255.255.0
       gateway 192.168.0.254


Si ça ne fonctionne pas ajoute nameserver 192.168.0.254 dans resolv.conf et si toujours rien essaie en commentant

#iface eth0 inet static
        #address 192.168.0.2
        #netmask 255.255.255.0
       #gateway 192.168.0.254


et en inscrivant

iface eth0 inet dhcp


pour voir si ça marche en auto
Pense à relancer networking après chaque modif


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#16 13-09-2009 20:41:44

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Bonsoir phlinux,

et Merci pour ton aide. Après avoir revu le wiki et essayé en DHCP et en IP fixes rien ne passe.
Il est encore possible que la freebox ne fonctionne pas sur ce PC.

nous n'avons pas besoin de DNS pour pinguer les PC's en local. Donc la faute  est quelque chose de très basique.
Comme Ubuntu configure la connexion filaire d'une façon différente, je suis perdu.
Ce PC portable sous debian était un PC de test et j'avais appris un peu de Debian qui est une distro bien légère avec LXDE.

J'attends encore un peu avant de réinstaller le PC.
Merci encore et bonne soirée smile

Dernière modification par jrev (13-09-2009 20:42:49)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#17 13-09-2009 20:56:34

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

re-
ça donne quoi chez toi les fichiers ubuntu correspondants ? j'ai une jaunty dans un coin et c'est la même chose que sur debian (mis à la part les ip fixes bien sur)

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#18 13-09-2009 21:10:53

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

jean@jean:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback


jean@jean:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 212.27.40.240
nameserver 212.27.40.241


jean@jean:~$ cat /etc/hosts
127.0.0.1    localhost
127.0.1.1    jean

192.168.0.2    debian
192.168.0.3    lily

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


J'ai envoyé les adresses machines de mes modules eth0 sur ma page de free.fr de façon à recevoir l' IP fixe correspondant
Et voilà ! smile

jean@jean:~$ ping debian
PING debian (192.168.0.2) 56(84) bytes of data.
64 bytes from debian (192.168.0.2): icmp_seq=1 ttl=64 time=1.73 ms
64 bytes from debian (192.168.0.2): icmp_seq=2 ttl=64 time=0.271 ms
64 bytes from debian (192.168.0.2): icmp_seq=3 ttl=64 time=0.272 ms
64 bytes from debian (192.168.0.2): icmp_seq=4 ttl=64 time=0.270 ms
64 bytes from debian (192.168.0.2): icmp_seq=5 ttl=64 time=0.270 ms
64 bytes from debian (192.168.0.2): icmp_seq=6 ttl=64 time=0.230 ms


Surprise ! les pings  marchent dans les deux sens en DHCP ! C'est mieux que rien

Il y a un GUI pour changer de configuration quand tu te déplaces et te connectes ailleurs et c'est tout !

Dernière modification par jrev (13-09-2009 21:28:49)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#19 13-09-2009 21:27:06

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

re-
excuse mais je te suis plus là : ça marche ou pas depuis debian ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#20 13-09-2009 21:30:30

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Oui, ça marche en DHCP !  le problème est pour les IP fixes sad

jean@debian:~$ cat /etc/network/interfaces
# describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
#iface eth0 inet static
#    address 192.168.0.2
#    netmask 255.255.255.0
#    gateway 192.168.0.254

iface eth0 inet dhcp


Le seul intérêt des IP fixes pour moi c'est de pouvoir copier mes documents sur le PC d'à coté par un script lancé dans une console sur le client :

#!/bin/bash
SOURCE_DIRS=/media/nfs/
TARGET_DIR=/home/jean/documents
# monter le repertoire nfs
mount /media/nfs

rsync -av --del --stats $SOURCE_DIRS "$TARGET_DIR"

umount /media/nfs

echo "Backup Terminé"


Bonsoir à tous smile

Dernière modification par jrev (13-09-2009 21:47:47)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#21 14-09-2009 09:34:17

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

En y regardant de plus près, il suffit que le PC qui partage ses dossiers soit en IP fixe pour que le transfert se fasse à partir d'un autre PC du même réseau local smile

Je vais donc suivre cette piste...

Si quelqu'un trouve comment configurer un réseau local en IP fixes sous Debian cela m'intéresse smile

Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#22 14-09-2009 09:55:01

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

re-
1 - Il faut séparer le problème réseau local et l'accès internet : il est évident que le ping est juste un outil et que les pc devront partager des répertoires par un protocole autorisant l'accès. Sur Ubuntu c'est installé de base avec smb, je crois. Sur Debian c'est configurable à souhait avec nfs par exemple
2 - Il est étonnant que ça marche avec une box et pas avec l'autre. Tous les fichiers de config ont été passé en revue. Il suffit de remplacer le n° d'accès à la box et éventuellement les dns.

jrev a écrit :

Si quelqu'un trouve comment configurer un réseau local en IP fixes sous Debian cela m'intéresse smile


phlinux a écrit :

Oui j'ai un réseau local qui fonctionne : 4 pc dont 2 serveurs, tout en linux, ssh, nfs. J'alterne les serveurs sur la prise usb de la box (alors quand je lis que ça marche pas, ou mal, je rigole)

Dernière modification par phlinux (14-09-2009 09:56:31)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#23 14-09-2009 11:57:00

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

Salut,

Je ne me suis pas trop penché sur la config de mon IP fixe, mais si je me souviens bien ça ne fonctionnait pas si je ne mettais pas "auto eth0" dans le fichier interfaces (voir post #8). Si tu le rajoutes, ça donne quoi ?

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#24 14-09-2009 20:04:24

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

mani a écrit :

Salut,

Je ne me suis pas trop penché sur la config de mon IP fixe, mais si je me souviens bien ça ne fonctionnait pas si je ne mettais pas "auto eth0" dans le fichier interfaces (voir post #8). Si tu le rajoutes, ça donne quoi ?


Merci, c'est le mot de la fin, Effectivement ça marche !

Il serait peut-être bon d'ajouter un chapitre au wiki ?
smile

Dernière modification par jrev (14-09-2009 20:06:56)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#25 14-09-2009 20:25:08

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : connecter ma Lenny à l'internet sur la Freebox (résolu)

hop jrev un extrait du pourquoi et comment de auto ethx ici :

Automatiquement au démarrage

S'il n'est pas forcément souhaitable de démarrer automatiquement une interface filaire au démarrage quand celle-ci ne sert que rarement, il est en revanche nécessaire de démarrer certaines interfaces avec le système. En particulier, l'interface de loopback doit être démarrée très tôt par le système.

L'interface loopback présente sur le système s'appelle lo. On va y monter l'interface loop0 définie dans le fichier /etc/network/interfaces. Pour ce faire, la syntaxe est

auto lo=loop0

On notera qu'on peut de manière équivalente faire

auto lo=loop0
iface loop0 inet loopback

et

auto lo
iface lo inet loopback

La syntaxe et l'abus de notation valent bien sûr pour toutes les interfaces réseau.
Automatiquement lors du branchement d'un câble

Même chose avec allow-hotplug en lieu et place de auto. C'est alors udev qui lancera automatiquement l'interface choisie lors de l'insertion d'un câble (je ne sais pas trop ce qui se passe dans le cas d'une interface wifi)


venu de là : http://wiki.chezlefab.net/tuto_nix/config_network

Effectivement, à insérer dans le tuto DF où captnfab est un redacteur occasionnel aussi. wink

Yop !

Dernière modification par smolski (14-09-2009 20:26:45)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums