Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-05-2017 18:47:34

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

connexion capricieuse sous dflinux

Bonjour, je viens d'installer "dflinux-jessie-i386" sur un vieux pc portable IISONIC G200 L'installation par elle même s'est déroulé correctement mais pour ce qui est du réseau, j'ai un soucis. Ma box est reconnue, je rentre la clef de sécurité mais ça ne connecte pas. Ça tourne et ça revient à la fenêtre qui me demande la clef... Je précise que je ne connais rien à ce genre de système... roll  Merci d'avance pour votre aide. smile

Dernière modification par galyfa (05-05-2017 22:35:18)

Hors ligne

#2 05-05-2017 18:57:01

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : connexion capricieuse sous dflinux

Salut galyfa et bienvenue sur df !

Précise dans ton titre que tu utilises dflinux ainsi que dans ton profil :
Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Et hop le point choco df à Jojo ! smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 05-05-2017 20:20:26

Zalm
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome 3.22.2
Inscription : 28-04-2017

Re : connexion capricieuse sous dflinux

Hello !
Tu essaies donc de te connecter en WiFi; Peut-être serait-il plus simple de commencer par un câble Ethernet, juste pour voir ?
(Le WiFi plus tard...)

Hors ligne

#4 05-05-2017 23:32:43

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

Re : connexion capricieuse sous dflinux

Bonsoir et merci de m'aider. En RJ45 ça marche direct, impeccable. Mais pour un pc portable j'aimerai mieux la wifi !!
Pour info je suis certain que la carte wifi fonctionne puisque avant DFlinux j'avais essayé une vielle version d'Ubuntu et tout fonctionnait très bien. Malheureusement je n'arrive pas à installer une version plus récente... sad C'est pourquoi je me tourne vers Debian qui s'est installé sans problème. smile
Au fait j'ai voulu rentrer les info  dans mon profil mais je sais pas comment utiliser les codes "cat /etc/issue", "cat /etc/debian_version", etc. scratchhead.gif

Hors ligne

#5 06-05-2017 02:34:00

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : connexion capricieuse sous dflinux

galifa a écrit :

je sais pas comment utiliser les codes


  1. Tu ouvres un terminal user.

  2. Tu écris textuellement la commande sans faire de fôte de frappe.

  3. Tu valides la commande.

  4. Tu copie colle le résultat avec la souris et pas au clavier.


Force et courage.
... chevalier.gif


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#6 06-05-2017 08:18:22

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : connexion capricieuse sous dflinux

Bonjour. smile
Si ça marche en rj45 comme alors avec le câble ethernet par mettre à jour le système. Ton mot de passe de connexion te sera demandé pour avoir les droits administrateur.

sudo apt-get update


sudo apt-get dist-upgrade


Pour mettre à jour tu peux aussi utiliser Synaptic : tu le lances et saisis ton mon de passe, tu cliques sur le bouton Recharger puis tout mettre à niveau et tu valides.
Ensuite pour le WiFi, est-ce une carte interne au PC ou bien utilises tu une clé wifi ?
Pour une carte interne donne le retour de

lspci -k | grep -i network -A 2

Hors ligne

#7 06-05-2017 09:20:34

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Stretch 9.x & Backports
Noyau : Noyau Linux 4.9.0-3-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 30-06-2008

Re : connexion capricieuse sous dflinux

salut,

la mise à jour du système n'a pas été faite lors de l'installation ?

Dernière modification par mksmn (06-05-2017 09:22:29)


Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#8 06-05-2017 10:38:36

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

Re : connexion capricieuse sous dflinux

Bonjour, j'ai bien lu ces consignes ici : https://debian-facile.org/doc:systeme:infos-systeme mais je ne sais pas comment ouvrir un terminal...scratchhead.gif

Dernière modification par galyfa (06-05-2017 10:39:18)

Hors ligne

#9 06-05-2017 12:00:56

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : connexion capricieuse sous dflinux

mksmn a écrit :

salut,

la mise à jour du système n'a pas été faite lors de l'installation ?


Pas si la seule connexion est un wifi non fonctionnelle

galyfa a écrit :

Bonjour, j'ai bien lu ces consignes ici : https://debian-facile.org/doc:systeme:infos-systeme mais je ne sais pas comment ouvrir un terminal...scratchhead.gif


Regarde le lien dans ma signature sur les cahiers du débutant
Sinon tu peux faire la mise à jour depuis Synaptic
D'autre part il y a une documentation utilisateur très riche fournie avec DFlinux. On la retrouve en ligne ici : https://lescahiersdudebutant.fr/DFisos/ … sateur.pdf

Hors ligne

#10 11-05-2017 12:20:33

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

Re : connexion capricieuse sous dflinux

Bonjour, j'ai fait un peu de lecture, ça va un peu mieux ! Merci pour les conseils. J'ai fait mes MAJ, en RJ45 ça fonctionne bien. Voici les infos de la carte wifi (interne) :

mini_845948wifideb.jpg

Aussi il faudrait que je change l'ordre du boot car je n'avais pu installer que la version 586 (pour vieux pc) et le pc boot par défaut sur la 686, je dois choisir "autres option et sélectionner la 586 pour que mon système se lance.

mini_123035deb.jpg

Merci pour le suivi. smile

Hors ligne

#11 11-05-2017 12:35:51

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : connexion capricieuse sous dflinux

S'il boote sur 686-pae et que tu as le sytème qui se lance bien alors c'est bon, ton PC peut tourner avec du 686-pae
Normalement la compatibilité est testé à l'installation donc pas de souci.
Pour le WiFi, tu as une connexion mais elle se coupe c'est ça ou bien c'est toujours le problème avec le mot de passe ?
Si c'est le mot de passe, tu peux l'écrire dans une page mousepad pour vérifier les caractères et faire un copier-coller en faisant attention de ne pas avec d'espace avant.
j'ai eu un souci idiot comme ça une fois mot de passe refusé et j'avais une erreur de caractère un I pris pour un l et aussi un copier coller mais j'avais un espace au début en trop ... Je les cumule big_smile

Hors ligne

#12 11-05-2017 12:59:54

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

Re : connexion capricieuse sous dflinux

Re, malheureusement non, quand je le laisse booter par défaut sur le 686 ça ne fonctionne pas, je dois sélectionner le 586, et là ça marche. J'ai d'ailleurs fait mon installation avec le 586 car j'avais testé le 686, en vain.

Pour ce qui est de la wifi, je viens de tester avec un fichier texte et mon mot de passe est correct, c'est sur. En fait, la fenêtre de connexion s'ouvre, je rentre mon mot de passe, la fenêtre se ferme, ça tourne sur l'icône du réseau et au bout d'une minute la fenêtre s'ouvre à nouveau... mais pas de connexion... sad

Hors ligne

#13 11-05-2017 13:09:32

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : connexion capricieuse sous dflinux

Le problème vient peut être du fait que les mises à jour après le premier redémarrage n'ont pas été faites ou alors une iso pas conforme
Il y a une nouvelle iso de DFlinux qui est sortie, ça vaudrait peut être le coup de refaire une installation et les mises à jour après le premier démarrage en ayant le câble ethernet branché pour que tout se passe bien.

Hors ligne

#14 11-05-2017 13:26:35

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian testing/sid
Noyau : 4.9-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : connexion capricieuse sous dflinux

bonjour smile

sur DFLinux, il n'y a pas de suppression du kernel 686 comme sur HandyLinux. c'est la façon de faire Debian, ne pas virer les kernel, donc j'ai laissé... je vais peut-être réintéger cette option bien pratique

bref. pour ta carte wifi et ton matos, DFLinux dispose d'un outil bien pratique qui te donne toutes les infos de ta machine en graphique et depuis un menu wink https://lescahiersdudebutant.fr/DFisos/ … 565%2C0%5D tongue
2 clics, une copie ici, et voilà big_smile

nous sommes tous différents ... c'est notre point commun ...

Hors ligne

#15 11-05-2017 18:51:42

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

Re : connexion capricieuse sous dflinux

Re, j'ai téléchargé la dernière version que j'ai pu trouver ici : https://lescahiersdudebutant.fr/DFisos/
J'ai directement pris l'option "installer Debian", câble RJ45 branché. Toit s'est installé correctement mais mon problème reste le même, au redémarrage je dois choisir  option, puis le 586, sinon ça ne démarre pas. Au redémarrage du système j'ai accepté les MAJ mais la wifi ne fonctionne toujours pas, enfin le problème est le même qu'avant..., je rentre ma clef, ça tourne et la fenêtre réapparait....
Pour ce qui est de "info4help", impossible de le trouver je n'ai pas pu tester...

mini_366076pbwifi.jpg

Hors ligne

#16 11-05-2017 20:56:12

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : connexion capricieuse sous dflinux

Tu cliques en bas à droite dans la barre de menu sur l'icone debian debian.png et tu devrais avoir Info4help-web comme dans la documentation donnée en lien par arpinux

Hors ligne

#17 11-05-2017 21:54:43

èfpé
Membre
Inscription : 10-07-2016

Re : connexion capricieuse sous dflinux

Bonsoir galyfa,

Question : ce portable a-t-il déjà été connecté en Wi-Fi avec ce point d'accès-là (box, routeur, autre machin) en particulier ?

lspci -k | grep -i network -A 2

00:0b.0 Network controller: Intersil Corporation ISL3874 [Prism 2.5]/ISL3872 [Prism 3] (rev 01)
        Subsystem: Actiontec Electronics Inc Device 0462
        Kernel driver in use: hostap_pci


Il s'agit a priori d'un contrôleur Intersil ISL3874 (802.11b, année 2001) mais il pourrait être intéressant d'en avoir la certitude (une sombre histoire de firmware peut-être ?) avec le retour de :

lspci -nnk | grep -i network -A 2


Le paquet hostap-utils (conseillé par le wiki officiel) ne semble pas installé par défaut ; à noter également, ce fil non résolu...

Dernière modification par èfpé (11-05-2017 22:12:43)

Hors ligne

#18 11-05-2017 23:29:27

raleur
Membre
Inscription : 03-10-2014

Re : connexion capricieuse sous dflinux

galyfa a écrit :

quand je le laisse booter par défaut sur le 686 ça ne fonctionne pas


Que se passe-t-il exactement ?
Quel est le modèle de processeur mentionné dans /proc/cpuinfo ou par la commande "lscpu" ?

Hors ligne

#19 12-05-2017 00:15:56

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

Re : connexion capricieuse sous dflinux

Bonsoir, pour ce qui est de Info4help-web c'est ok, merci, voici :
https://paste.debian.net/932081/

Ce portable a déjà été connecté en wifi à cette box. J'avais testé par hasard un vieux Ubuntu 11.04 qui a tout de suite détecté le réseau wifi et après avoir rentré la clef de sécurité, connexion direct sans soucis ! Malheureusement cette version est trop vieille et les nouvelles ne fonctionnent pas sur ce pc... Voici le retour pour le contrôleur :

will@debian:~$

 lspci -nnk | grep -i network -A 2


00:0b.0 Network controller [0280]: Intersil Corporation ISL3874 [Prism 2.5]/ISL3872 [Prism 3] [1260:3873] (rev 01)
  Subsystem: Actiontec Electronics Inc Device [1668:0462]
  Kernel driver in use: hostap_pci


will@debian:~$

Pour ce qui est du boot lorsque, je laisse le pc faire tout seul j'ai une page bleu avec en titre GNU GRUB version ...
En dessous
DEBIAN GNU/LINUX
*Options avancés pour DEBIAN GNU/LINUX

Si je ne touche à rien j'ai un écran noir avec le curseur blanc qui clignote en haut à gauche de l'écran.
Si je choisis *Options avancés pour DEBIAN GNU/LINUX, je peux alors choisir DEBIAN GNU/LINUX avec linux 3.16.0.4--586 et la ça fonctionne.
Voici le retour pour le processeur :

will@debian:~$

 lscpu


Architecture :        i686
Mode(s) opératoire(s) des processeurs : 32-bit
Boutisme :            Little Endian
Processeur(s) :       1
Liste de processeur(s) en ligne : 0
Thread(s) par cœur : 1
Cœur(s) par socket : 1
Socket(s) :           1
Identifiant constructeur : GenuineIntel
Famille de processeur : 15
Modèle :             2
Nom de modèle :      Mobile Intel(R) Celeron(R) CPU 2.40GHz
Révision :           9
Vitesse du processeur en MHz : 2400.000
Vitesse maximale du processeur en MHz : 2400,0000
Vitesse minimale du processeur en MHz : 2400,0000
BogoMIPS :            4784.82
will@debian:~$



Merci. smile

Hors ligne

#20 13-05-2017 02:18:42

èfpé
Membre
Inscription : 10-07-2016

Re : connexion capricieuse sous dflinux

Bonsoir galyfa,

Alors, il semble que le contrôleur Wi-Fi est effectivement un ISL3874 [Prism 2.5] ; parvenir à faire fonctionner ce machin ne sera pas une sinécure, par ailleurs le débit serait faible (1,4 Mo/s max) et la sécurité pathétique (WEP de base, WPA/WPA2 avec les bons firmwares - si j'ai bien compris ce que j'ai lu ici ou ) ; bref, investir une petite dizaine d'euros dans un dongle 802.11n (genre TL-WN725N) pourrait grandement te simplifier la vie l'informatique.

Quant au boot, désinstaller le noyau inutile le rendrait déjà moins pénible ; pour lister l'existant :

dpkg -l | egrep 'linux-(h|i|l)'


Par contre un truc m'échappe, le système ne démarre pas sur le noyau 686-pae alors que le processeur n'est pas à proprement parler antédiluvien (début 2002 ?) et que l'option PAE apparaît dans le rapport info4help ; à confirmer peut-être avec :

cat /proc/cpuinfo | grep pae


Tu peux omettre le ' | grep pae' d'ailleurs, avec un seul cœur le retour ne sera pas très long.

Dernière modification par èfpé (13-05-2017 02:26:42)

Hors ligne

#21 13-05-2017 12:39:57

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

Re : connexion capricieuse sous dflinux

Bonjour et merci d'être toujours là !

Voici :

will@debian:~$

dpkg -l | egrep 'linux-(h|i|l)'


ii  linux-headers-3.16.0-4-586            3.16.43-2                            i386         Header files for Linux 3.16.0-4-586
ii  linux-headers-3.16.0-4-686-pae        3.16.43-2                            i386         Header files for Linux 3.16.0-4-686-pae
ii  linux-headers-3.16.0-4-common         3.16.43-2                            i386         Common header files for Linux 3.16.0-4
ii  linux-headers-586                     3.16+63                              i386         Header files for Linux 586 configuration (meta-package)
ii  linux-headers-686-pae                 3.16+63                              i386         Header files for Linux 686-pae configuration (meta-package)
ii  linux-image-3.16.0-4-586              3.16.43-2                            i386         Linux 3.16 for older PCs
ii  linux-image-3.16.0-4-686-pae          3.16.43-2                            i386         Linux 3.16 for modern PCs
ii  linux-image-586                       3.16+63                              i386         Linux for older PCs (meta-package)
ii  linux-image-686-pae                   3.16+63                              i386         Linux for modern PCs (meta-package)
ii  util-linux-locales                    2.25.2-6                             all          Locales files for util-linux


will@debian:~$


Et voila :

will@debian:~$

cat /proc/cpuinfo


processor : 0
vendor_id : GenuineIntel
cpu family  : 15
model   : 2
model name  : Mobile Intel(R) Celeron(R) CPU 2.40GHz
stepping  : 9
microcode : 0x2f
cpu MHz   : 2400.000
cache size  : 256 KB
fdiv_bug  : no
f00f_bug  : no
coma_bug  : no
fpu   : yes
fpu_exception : yes
cpuid level : 2
wp    : yes
flags   : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe pebs bts cid xtpr
bogomips  : 4785.08
clflush size  : 64
cache_alignment : 128
address sizes : 36 bits physical, 32 bits virtual
power management:



will@debian:~$


smile

Edit à jojo :
Correction pour mettre en évidence les Commandes user et leurs retours via les boutons du dessus.

Hors ligne

#22 13-05-2017 15:06:42

èfpé
Membre
Inscription : 10-07-2016

Re : connexion capricieuse sous dflinux

Re-,

Bon, il y aurait donc 4 (méta-)paquets à désinstaller et purger... que donne la simulation (option -s) suivante :

apt-get remove --purge -s linux-headers-3.16.0-4-686-pae linux-headers-686-pae linux-image-3.16.0-4-686-pae linux-image-686-pae


Ceci dit, j'aimerais que tu attendes d'autres avis (révision par les pairs/pères) avant de purger smile

Hors ligne

#23 13-05-2017 16:50:01

galyfa
Membre
Distrib. : DFlinux jessie i386
Inscription : 05-05-2017

Re : connexion capricieuse sous dflinux

Ok j'attendrai le feu vert. Voici :

will@debian:~$ apt-get remove --purge -s linux-headers-3.16.0-4-686-pae linux-headers-686-pae linux-image-3.16.0-4-686-pae linux-image-686-pae
NOTE: Ceci n'est qu'une simulation !
      apt-get a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  irqbalance libnuma1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-headers-3.16.0-4-686-pae* linux-headers-686-pae*
  linux-image-3.16.0-4-686-pae* linux-image-686-pae*
0 mis à jour, 0 nouvellement installés, 4 à enlever et 0 non mis à jour.
Purg linux-headers-686-pae [3.16+63]
Purg linux-headers-3.16.0-4-686-pae [3.16.43-2]
Purg linux-image-686-pae [3.16+63]
Purg linux-image-3.16.0-4-686-pae [3.16.43-2]
will@debian:~$

Edit à toto :
Voici comment on utilise les balises du forum, en l'occurence Commande root :

apt-get remove --purge -s linux-headers-3.16.0-4-686-pae linux-headers-686-pae linux-image-3.16.0-4-686-pae linux-image-686-pae


NOTE: Ceci n'est qu'une simulation !
      apt-get a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  irqbalance libnuma1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-headers-3.16.0-4-686-pae* linux-headers-686-pae*
  linux-image-3.16.0-4-686-pae* linux-image-686-pae*
0 mis à jour, 0 nouvellement installés, 4 à enlever et 0 non mis à jour.
Purg linux-headers-686-pae [3.16+63]
Purg linux-headers-3.16.0-4-686-pae [3.16.43-2]
Purg linux-image-686-pae [3.16+63]
Purg linux-image-3.16.0-4-686-pae [3.16.43-2]



Voir le tuto en choco df :
Voir le tuto : Le code, ça pique moins les yeux en couleur

Hors ligne

#24 13-05-2017 20:28:00

èfpé
Membre
Inscription : 10-07-2016

Re : connexion capricieuse sous dflinux

Re-,

Bon, le bureau de vote est fermé depuis 28 min, et 100 % des suffrages exprimés sont pour la manip :

sudo apt-get remove --purge linux-headers-3.16.0-4-686-pae linux-headers-686-pae linux-image-3.16.0-4-686-pae linux-image-686-pae


Plus sérieusement le paquet irqbalance est inutile avec un seul cœur, l'autre je connais pas.

Hors ligne

Pied de page des forums