Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-05-2017 20:43:26

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

mise a jour incomplette sid

Bonsoir
cela arrive souvent sous sid , proposition de paquets , mais pas tous en mise a jour


apt-get -s upgrade
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-core libreoffice-draw libreoffice-impress libreoffice-math
  libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder-bin libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-writer python3-uno
Les paquets suivants seront mis à jour :
  uno-libs3 ure
2 mis à jour, 0 nouvellement installés, 0 à enlever et 15 non mis à jour.
Inst uno-libs3 [5.2.6-2] (5.2.7-1 Debian:unstable [amd64]) [ure:amd64 ]
Inst ure [5.2.6-2] (5.2.7-1 Debian:unstable [amd64])
Conf uno-libs3 (5.2.7-1 Debian:unstable [amd64])
Conf ure (5.2.7-1 Debian:unstable [amd64])
 


je force jamais , et je ne fait pas la mise a jour des 2 paquets (j' attends que ça passe seul )
nota : la meme chose avec synaptic (17 paquets en mise a jour mais seulement 2 sélectionnés )

Hors ligne

#2 05-05-2017 23:08:16

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : mise a jour incomplette sid

Bonsoir,
Que veux tu dire par j'attends que ça passe ?
Si tu ne mets pas les 2 paquets à jour, je ne vois pas comment ils vont s'y mettre ?

Hors ligne

#3 06-05-2017 00:41:51

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : mise a jour incomplette sid

je ne fais rien a part mettre les nouveaux paquets (sans rapport avec libreoffice)
mettre a jour les 2 paquets ne fera  pas avancer les choses
je suppose que apt n'a aucun soucis pour mettre a jour dans l'ordre les paquets. (si besoin )
ce n'est pas un problème de dépendances.
il me semble que la dernière  fois que j'ai eu le cas j'ai put faire la mise a jour a la version suivante des mises a jours.
ma version est en stretch , je suis pas pressé  roll
mais je comprends pas ce qui se passe et le pourquoi .
ce que me dit "A Propos "


Version: 5.2.6.2
Build ID: 1:5.2.6-2
Threads CPU : 16; Version de l'OS :Linux 4.9; UI Render : par défaut; VCL : x11;
Locale : fr-FR (fr_FR.UTF-8); Calc: group
 



voila maintenant ça fonctionne , mais comme j'ai pas envie on verra demain
le détail en simulation


apt-get -s upgrade
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  fonts-opensymbol hwinfo libhd21 libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-help-fr libreoffice-impress libreoffice-java-common libreoffice-l10n-fr libreoffice-librelogo libreoffice-math libreoffice-ogltrans
  libreoffice-pdfimport libreoffice-report-builder libreoffice-report-builder-bin libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-galaxy libreoffice-style-tango libreoffice-wiki-publisher
  libreoffice-writer libtirpc1 python3-uno rpcbind uno-libs3 ure
34 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst libreoffice-base-drivers [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) [libreoffice-base:amd64 ]
Inst libreoffice-base [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-impress [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-draw [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-writer [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst uno-libs3 [5.2.6-2] (5.2.7-1 Debian:unstable [amd64]) [ure:amd64 ]
Inst libreoffice-ogltrans [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) [ure:amd64 ]
Inst ure [5.2.6-2] (5.2.7-1 Debian:unstable [amd64]) []
Inst python3-uno [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-sdbc-hsqldb [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-style-tango [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-style-galaxy [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-script-provider-js [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-script-provider-bsh [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-report-builder [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-pdfimport [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-l10n-fr [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-java-common [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-help-fr [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-common [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) [libreoffice-script-provider-python:amd64 ]
Inst libreoffice-script-provider-python [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all]) []
Inst libreoffice-report-builder-bin [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-math [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-base-core [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-avmedia-backend-gstreamer [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) []
Inst libreoffice-core [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64]) [libreoffice-sdbc-postgresql:amd64 ]
Inst libreoffice-sdbc-postgresql [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [amd64])
Inst fonts-opensymbol [2:102.7+LibO5.2.6-2] (2:102.7+LibO5.2.7-1 Debian:unstable [all])
Inst libtirpc1 [0.2.5-1.1] (0.2.5-1.2 Debian:unstable [amd64])
Inst libhd21 [21.40-1] (21.42-1 Debian:unstable [amd64])
Inst hwinfo [21.40-1] (21.42-1 Debian:unstable [amd64])
Inst libreoffice-librelogo [1:5.2.6-2] (1:5.2.7-1 Debian:unstable [all])
Inst libreoffice-wiki-publisher [1.2.0+LibO5.2.6-2] (1.2.0+LibO5.2.7-1 Debian:unstable [all])
Inst rpcbind [0.2.3-0.5+b1] (0.2.3-0.6 Debian:unstable [amd64])
Conf libreoffice-base-drivers (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-base (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-impress (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-draw (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-writer (1:5.2.7-1 Debian:unstable [amd64])
Conf uno-libs3 (5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-ogltrans (1:5.2.7-1 Debian:unstable [amd64])
Conf ure (5.2.7-1 Debian:unstable [amd64])
Conf python3-uno (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-sdbc-hsqldb (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-style-tango (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-style-galaxy (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-script-provider-js (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-script-provider-bsh (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-report-builder (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-pdfimport (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-l10n-fr (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-java-common (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-help-fr (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-common (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-script-provider-python (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-report-builder-bin (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-math (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-base-core (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-avmedia-backend-gstreamer (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-core (1:5.2.7-1 Debian:unstable [amd64])
Conf libreoffice-sdbc-postgresql (1:5.2.7-1 Debian:unstable [amd64])
Conf fonts-opensymbol (2:102.7+LibO5.2.7-1 Debian:unstable [all])
Conf libtirpc1 (0.2.5-1.2 Debian:unstable [amd64])
Conf libhd21 (21.42-1 Debian:unstable [amd64])
Conf hwinfo (21.42-1 Debian:unstable [amd64])
Conf libreoffice-librelogo (1:5.2.7-1 Debian:unstable [all])
Conf libreoffice-wiki-publisher (1.2.0+LibO5.2.7-1 Debian:unstable [all])
Conf rpcbind (0.2.3-0.6 Debian:unstable [amd64])
 



pour ce coup ci je dirai qu il manquait des paquets pour libreoffice et ça bloque (sans erreur)
la je suis passé a 37 paquets en attente de mise a jour

surement un conflit de versions , tous les paquets nécessaires  ont pas du rentrer ensemble , en mise a jour  ( libreoffice est un gros morceau tongue  )

Dernière modification par robert2a (06-05-2017 00:56:39)

Hors ligne

#4 06-05-2017 09:51:46

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.13.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : mise a jour incomplette sid

Salut,

Tu peux essayer avec aptitude ( en simulation -s ) ,
il sera plus bavard pour trouver le paquet qui te bloque la mise à jour de la suite libreoffice .

( mais bon faut être patient sous testing/sid ! big_smile  )

smile

Hors ligne

#5 06-05-2017 13:44:32

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.9.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : mise a jour incomplette sid

C’est parfaitement normal avec Debian Sid (et testing, même si c’est moins fréquent avec celle-ci) d’avoir des paquets qui ne peuvent pas immédiatement être mis à jour. Ça veut dire qu’une dépendance essentielle n’est pas encore arrivée dans les dépôts dans la version requise, et la plupart du temps celle-ci est disponible au plus tard après quelques jours.

Quand tu te retrouves dans cette situation, il n’y a aucun souci à effectuer la mise-à-jour "partielle" qui t’est proposée.

Jouer sous Debian ? Facile !

Hors ligne

#6 06-05-2017 15:53:52

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : mise a jour incomplette sid

oui c'est exactement ça , les paquets manquant sont arrivés quelques heures aprés.
je n'ai que les deux machines  Ryzen en sid , le reste restera en future stable.
quand sid aura repris un fonctionnement normal , j'ai bien l'intention de pas casser le système .
donc doucement sur les nouveaux paquets , éviter de me précipiter sur les mises a jours. roll
apt-listbugs installé , un autoclean peut etre , le dist-upgrade etc ....
jusqu' a présent cela c'est toujours trés mal terminé ,  une ré-installation ne me pose pas de problème , mais bon....... .  neutral

Hors ligne

#7 10-05-2017 18:53:20

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.13.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : mise a jour incomplette sid

L'autoclean, c'est à double tranchant, en nettoyant apt, tu perds les versions qui sont passées et qui peuvent servir à aptitude
pour remettre les dépendances d'aplomb :

man apt-get a écrit :

autoclean
    Tout comme clean, autoclean nettoie le référentiel local des paquets récupérés. La différence est qu'il supprime uniquement les paquets qui ne peuvent plus être téléchargés et qui sont grandement inutiles. On peut ainsi contrôler la taille de ce cache sur une longue période. Tant qu'elle n'est pas activée, l'option de configuration APT::Clean-Installed empêche la suppression de paquets installés.



Sinon clonezilla, ça aide bien pour avoir un filet de sécurité et c'est facile . smile

Hors ligne

Pied de page des forums