Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-05-2017 21:53:36

leoden
Membre
Distrib. : Debian 8.7 Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Mutter (Muffin / Cinnamon 2.2.16)
Inscription : 12-03-2017

Messages d'erreur lors de la première maj après installation

Tout est dans le titre, j'ai deux messages d'erreur lors de la première maj :

Celle-ci

W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169



Et celle-là

jbig2dec (0.12-1) unstable, urgency=medium x Licensing has changed to GNU Affero GPL (AGPL) Please ensure that all use complies with this new licence



Qu'est-ce que vous en pensez ? Et comment remédie t-on à ça ? Merci smile

Hors ligne

#2 12-05-2017 21:59:11

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Messages d'erreur lors de la première maj après installation

il faut installer le firmware realtek pour le premier message pour ta carte réseau filaire
et un sources.list correct

le sources.list se trouve dans /etc/apt/sources.list

il s'ouvre et se modifie avec nano


nano /etc/apt/sources.list
 




#debian jessie 8
deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ jessie-backports main contrib non-free
 



=> https://packages.debian.org/fr/jessie/firmware-realtek

mettre a jour le cache apt


apt-get update
 



installer le firmware


apt-get install firmware-realtek
 



redémarrer

le second message une modification de licence , je connais pas
ça ressemble a un message de apt-listchange  , a mon avis c'est juste "informatif" comme quoi sur un paquet la licence a été modifié

Dernière modification par robert2a (12-05-2017 22:15:27)

Hors ligne

#3 12-05-2017 22:19:08

leoden
Membre
Distrib. : Debian 8.7 Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Mutter (Muffin / Cinnamon 2.2.16)
Inscription : 12-03-2017

Re : Messages d'erreur lors de la première maj après installation

Merci pour ta réponse smile

J'ai le sources.list de base pour Debian stable, celui recommandé dans la docu wiki de DF (tout en libre) mais le firmware realtek et sans doute un truc non libre donc c'est pour ça que ça coince. Perso, j'aimerai garder tout en libre dans la mesure du possible, est-ce possible de se passer du firmware realtek ? A quoi il sert d'ailleurs ?
Même question pour jbig2dec. Qu'est-ce que c'est ?

Hors ligne

#4 12-05-2017 22:36:57

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Messages d'erreur lors de la première maj après installation

si ton réseau fonctionne bien tu n est pas obligé , tu risque d'avoir une surcharge des logs avec les erreurs.
pour  jbig2dec  je sais pas

Hors ligne

#5 13-05-2017 00:00:35

raleur
Membre
Inscription : 03-10-2014

Re : Messages d'erreur lors de la première maj après installation

leoden a écrit :

j'ai deux messages d'erreur


Non. Ce ne sont pas des erreurs.

Hors ligne

#6 13-05-2017 07:51:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Messages d'erreur lors de la première maj après installation

En préparation de la migration, je conseille de se mettre en backports, ce sera toujours ça de fait :

    # Debian Jessie, dépôt principal
    deb http://deb.debian.org/debian/ jessie main
    # Debian Jessie, mises-à-jour de sécurité
    deb http://security.debian.org/ jessie/updates main
    # Debian Jessie, mises-à-jour "volatiles"
    deb http://deb.debian.org/debian/ jessie-updates main
    # Debian Jessie, dépôt de rétroportages ("backports")
    deb http://deb.debian.org/debian jessie-backports main



Là : https://debian-facile.org/doc:systeme:a … -backports


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#7 13-05-2017 08:51:53

raleur
Membre
Inscription : 03-10-2014

Re : Messages d'erreur lors de la première maj après installation

En quoi l'ajout du dépôt backports prépare-t-il la migration ?

Hors ligne

#8 13-05-2017 09:41:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Messages d'erreur lors de la première maj après installation

raleur a écrit :

En quoi l'ajout du dépôt backports prépare-t-il la migration ?


Le dépôt des backports ajoute/met à jour des paquets de stretch valides pour le stable.
C'est bien sa fonction, non ?


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#9 13-05-2017 11:20:33

raleur
Membre
Inscription : 03-10-2014

Re : Messages d'erreur lors de la première maj après installation

Non. Les paquets de stable-backports sont reconstruits pour être installable sur stable. Ils sont distincts des paquets de la prochaine stable.
Lors de la mise à niveau vers la nouvelle stable, ils seront remplacés par les paquets de la nouvelle stable (si tout se passe bien - dans le temps il était conseillé de supprimer les paquets issus de backports avant la mise à niveau).

Hors ligne

#10 13-05-2017 11:30:50

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Messages d'erreur lors de la première maj après installation

raleur a écrit :

Non. Les paquets de stable-backports sont reconstruits pour être installable sur stable. Ils sont distincts des paquets de la prochaine stable.
Lors de la mise à niveau vers la nouvelle stable, ils seront remplacés par les paquets de la nouvelle stable (si tout se passe bien - dans le temps il était conseillé de supprimer les paquets issus de backports avant la mise à niveau).


Merci raleur.

Eh be... mais dans le temps, c'était : etch.. lenny ?
Il me semble avoir toujours migré depuis les backports installés sans problème depuis que j'utilise debian.

Chance ?
... caribou.gif

Une info à ajouter au tuto des backports peut-être ?


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#11 13-05-2017 11:38:45

Herve33
Membre
Lieu : Mérignac 33
Distrib. : DFlinux Stretch
Inscription : 21-09-2016

Re : Messages d'erreur lors de la première maj après installation

Ben on sera fixé très vite, ça devrait pas tarder !

DFlinux Stretch

Hors ligne

#12 13-05-2017 11:57:56

raleur
Membre
Inscription : 03-10-2014

Re : Messages d'erreur lors de la première maj après installation

smolski a écrit :

mais dans le temps, c'était : etch.. lenny ?


Probablement avant que les backports deviennent officiels, ce qui a dû arriver aux alentours de squeeze.

Hors ligne

#13 13-05-2017 13:00:35

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Messages d'erreur lors de la première maj après installation

@smolski
je t'ai déja prévenu pour les backports tongue tongue lol
attention aux firmwares qui change de nom , comme celui de ta carte video amd par exemple  wink  (entre jessie et stretch)
attention aux drivers video nonfree , lors du dist-upgrade risque de perdre le serveur X (mais bon certain retours sont positif )

Hors ligne

#14 13-05-2017 15:35:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Messages d'erreur lors de la première maj après installation

robert2a a écrit :

@smolski
je t'ai déja prévenu pour les backports tongue tongue lol
attention aux firmwares qui change de nom , comme celui de ta carte video amd par exemple  wink  (entre jessie et stretch)
attention aux drivers video nonfree , lors du dist-upgrade risque de perdre le serveur X (mais bon certain retours sont positif )


Je ne comprends pas la difficulté.
Si j'utilise les backports c'est parce que j'en ai besoin tout du long.
Comment se garer des paquets backports déjà en place puisque chaque mise à jour est nécessaire pour les maintenir et qu'on ne peut pas les supprimer ?
Une migration ne fait que les adapter, comment cela peut-il les casser depuis la old-stable ?

Peut-être et même certainement depuis testing et sid, mais stable ?

En fait, je ne migre que quelques mois après la migration officielle, c'est peut-être cela qui assure la transition...
... character0104.gif


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#15 13-05-2017 15:58:40

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Messages d'erreur lors de la première maj après installation

ça casse rien smolski , j'ai meme testé  wink
mais de dire que ça améliore le dist-upgrade vers stretch c'est faux tongue
comme t'explique raleur les paquets seront remplacés de toute manière par la version de stretch

la migration d une oldstable peu se faire vers stable , testing ou sid  (du moment que tu la fait avec les précautions habituelles)  et que tu est conscient des risques d une testing ou sid
d'attendre quelques mois aprés le passage a stable ne change rien non plus , mais si ça te rassure pourquoi pas . cool

de plus la oldstable est maintenu encore un certain temps , si la machine n'a pas de souci et que les versions ne posent pas de problème , le dist-upgrade n'est pas une obligation smile

Dernière modification par robert2a (13-05-2017 16:04:59)

Hors ligne

#16 13-05-2017 16:33:15

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Messages d'erreur lors de la première maj après installation

Merci de tous ces renseignements.

Oui, je vais conserver un délai pour la migration, il me semble que des ajustements sont encore faits, peut-être avec le non-libre que j'utilise ?
... animal0028.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#17 13-05-2017 18:56:21

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Messages d'erreur lors de la première maj après installation

pour suivre l'avancement de stretch =>  https://bugs.debian.org/release-critical/
on en est loin encore , regarde les courbes a la date de jessie stable (Avril 2015)
pour la courbe verte jamais en dessous de 110 (et ça fait le yoyo )
on verra pour Juin  ....  roll

nota : pour les nouvelles versions , uniquement stretch-backports , actuellement que bugs et sécurité sont traité (gel)

Dernière modification par robert2a (13-05-2017 19:09:01)

Hors ligne

#18 13-05-2017 19:14:34

Antidentity
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : Messages d'erreur lors de la première maj après installation

Désolé, je sais que c'est un peu off-topic par rapport au problème initial de leoden mais quelqu'un peut expliquer (par curiosité) comment ça se fait qu'il y a une chute brusque qui retombe quasi à 0 sur le graphique aux alentours du 12/2016 et 01/2017? Période de fêtes et liste non mise à jour? Les développeurs ne peuvent pas avoir corrigé autant de bugs en si peu de temps et revenir au même nombre après, si?

Hors ligne

#19 13-05-2017 19:38:00

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Messages d'erreur lors de la première maj après installation

robert2a a écrit :

uniquement stretch-backports


Là aussi je m'interroge, les backports ne sont que pour stable à partir de testing, un backport de testing à testing est alors un non sens ?


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#20 13-05-2017 21:17:59

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Messages d'erreur lors de la première maj après installation

@smolski

regarde ce lien  =>  http://ftp.fr.debian.org/debian/dists/s … backports/
ce n'est pas un backports de testing , mais un backports de stretch , nuance wink  et je sais pas pourquoi ils l'ont activé ci tôt  (depuis courant Février )
mais ici aussi pour me faire mentir  tongue  => http://ftp.fr.debian.org/debian/dists/t … backports/
je sais pas pourquoi , peut etre que quelque chose va changer dans le futur . (sur le fonctionnement des backports )
ou ce sera supprimé au passage de jessie en oldstable , je sais pas .........
en tout cas bien réel wink

@Antidentity

je saurai pas t'expliquer , mais au plus il y a de paquets au plus risque de bug
pour la courbe je pense que si absence de chiffre (valeur 0 ) au moment de la création d un point de la courbe ça donne ça (surement une base de données pour les statistiques ) , faut juste ignorer ces points.
ça donne juste une idée du volume de bug a traiter dans le temps mais pas forcément trés précis  hmm

Dernière modification par robert2a (13-05-2017 21:22:35)

Hors ligne

Pied de page des forums