Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-05-2017 14:54:09

FriXion
Membre
Inscription : 20-05-2017

[Résolu] Impossible de se connecter à Internet.

Bonjour, je suis nouveau sur ce site et c'est mon premier poste.

Voilà, Il y a quelques mois, j'ai monté un PC avec des potes et avant d'installer Windows j'ai d'abord installé Ubuntu, je lui ait alloué un quart de mon disque, je l'ait installé. Nickel ! Tout fonctionne. Ensuite, peut de temps après, j'ai installer Windows sur l'autre partie du disque dur (en ayant laissé le SWAP). Ensuite, le GRUB ne s'affichait pas et Windows 10 se lançait automatiquement, j'ai donc utilisé Super Grub 2 à parir de ma clé USB pour revenir sous Ubuntu. Et là, plus de connexion internet, ça cherche ensuite ça me dit que suis déconnecté et ça refait ça 3 fois avant de s'arrêter. Ensuite j'ai voulu installer un nouvel O.S. à la place d'Ubuntu, Parrot Security O.S. (basé sur Debian), j'ai réussi à l'installer mais là encore ça cherche sans se connecter. En cherchant un peu j'ai mis l'adresse ipv6 en automatique par "DHCP" (je ne suis plus sûr du nom mais c'était quelque chose comme ça) à la place de automatique et là il me marque que je suis connecté mais quand j'essaie de faire une recherche ou charger une page il me dit aucune connxion internet et les statisques me montre que je n'ait utilisé 0 octet de réseau. Bref j'ai chercher pendant des heures une solution sans y parvenir. J'espère que vous pourrez m'aider.

Merci d'avance pour vos réponses.

Dernière modification par FriXion (24-05-2017 14:46:40)

Hors ligne

#2 20-05-2017 23:39:23

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible de se connecter à Internet.

Peux-tu donner la sortie des commandes suivantes ?

ip a


/sbin/ifconfig -a


dmesg | grep -i eth


lspci -nnk | egrep -iA2 "eth|net"



Edit à toto :

Séparé les commandes user.

Hors ligne

#3 21-05-2017 10:19:44

FriXion
Membre
Inscription : 20-05-2017

Re : [Résolu] Impossible de se connecter à Internet.

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether d0:50:99:91:6e:26 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4de5:b083:b9dd:12c5/64 scope link
       valid_lft forever preferred_lft forever



/sbin/ifconfig -a
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::4de5:b083:b9dd:12c5  prefixlen 64  scopeid 0x20<link>
        ether d0:50:99:91:6e:26  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9  bytes 1370 (1.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Boucle locale)
        RX packets 28  bytes 1896 (1.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28  bytes 1896 (1.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0



dmesg | grep -i eth
dmesg: read kernel buffer failed: Opération non permise



(en root)

dmesg | grep -i eth
[    1.368797] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[    1.918629] forcedeth 0000:00:07.0: ifname eth0, PHY OUI 0x732 @ 1, addr d0:50:99:91:6e:26
[    1.918631] forcedeth 0000:00:07.0: highdma pwrctl mgmt gbit lnktim msi desc-v3
[   15.839748] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   15.840321] forcedeth 0000:00:07.0 eth0: MSI enabled
[   26.615437] NETDEV WATCHDOG: eth0 (forcedeth): transmit queue 0 timed out
[   26.615517]  aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd xhci_pci pata_amd sata_nv xhci_hcd ohci_hcd ehci_pci libata ehci_hcd forcedeth scsi_mod usbcore usb_common i2c_nforce2
[   26.615663] forcedeth 0000:00:07.0 eth0: Got tx_timeout. irq status: 00000032
[   36.427782] forcedeth 0000:00:07.0 eth0: Got tx_timeout. irq status: 00000032
[   41.547291] forcedeth 0000:00:07.0 eth0: Got tx_timeout. irq status: 00000032
[   42.340753] Bluetooth: BNEP (Ethernet Emulation) ver 1.3



lspci -nnk | egrep -iA2 "eth|net"
00:07.0 Bridge [0680]: NVIDIA Corporation MCP61 Ethernet [10de:03ef] (rev a2)
    Subsystem: ASRock Incorporation 939NF6G-VSTA Board [1849:03ef]
    Kernel driver in use: forcedeth
    Kernel modules: forcedeth
00:08.0 IDE interface [0101]: NVIDIA Corporation MCP61 SATA Controller [10de:03f6] (rev a2)
    Subsystem: ASRock Incorporation 939NF6G-VSTA Board [1849:03f6]

Hors ligne

#4 21-05-2017 11:00:28

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible de se connecter à Internet.

Il y a des erreurs dans les messages du noyau liés au pilote forcedeth de la carte réseau Nvidia.
Si le problème est apparu suite à l'installation de Windows, il est possible que le pilote pour Windows ait modifié la configuration de la carte réseau d'une façon qui n'est pas correctement gérée par le pilote Linux. Cette configuration peut rester en place tant que le PC est alimenté, même éteint. Pour vérifier, si ça n'a pas déjà été fait :
- éteindre le PC
- débrancher le câble d'alimentation
- attendre plusieurs minutes
- rebrancher le câble d'alimentation
- allumer le PC
- démarrer directement sous Linux sans passer par Windows.

Hors ligne

#5 21-05-2017 14:59:11

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Impossible de se connecter à Internet.

Bonjour
ta carte mère => http://www.asrock.com/mb/nvidia/939nf6g-vsta/
sinon pour etre compatible linux , tu a l option d une carte réseau discrète  en PCI ou PCIe 1x sur ta carte mère (en 1Gb/s meme au lieu de 100Mb/s)
regarder dans le bios la configuration de ta carte réseau.


LAN
- Realtek PHY RTL8201CL
- Speed: 10/100 Ethernet
- Supports Wake-On-LAN
- Supports PXE
 



ceci de 2012 => https://ubuntuforums.org/showthread.php?t=1974287

Dernière modification par robert2a (21-05-2017 15:07:09)

Hors ligne

#6 21-05-2017 16:18:06

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible de se connecter à Internet.

En second, j'aurais aussi tenté ces options msi=0 et msix=0 du module forcedeth. Mais ça marchait sans ces options avant l'installation de Windows.

Hors ligne

#7 21-05-2017 21:24:35

FriXion
Membre
Inscription : 20-05-2017

Re : [Résolu] Impossible de se connecter à Internet.

Rebonjour, j'ai testé la manipulation proposée par raleur mais elle ne fut malheureusement pas concluante. Je viens de mes souvenir que quand internet sous Ubuntu marchait j'était sur une autre carte mère et c'est sûrement dût à ça. Je suis désolé de ce stupide oubli. Du coup est-ce que ma carte mère peut se configurer ou elle est définitivement incompatible et est-ce que c'est possible que se soit juste Windows la source du problème ?

Dernière modification par FriXion (21-05-2017 21:26:37)

Hors ligne

#8 21-05-2017 21:46:42

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible de se connecter à Internet.

Si tu ne peux pas confirmer que le réseau a déjà fonctionné avec Linux sur cette carte mère avant l'installation de Windows, alors rien ne permet de supposer que Windows est en cause.

Tu peux essayer les paramètres mentionnés dans le fil du forum Ubuntu pointé par robert2a.
Créer un fichier /etc/modprobe.d/forcedeth.conf contenant :

options forcedeth msi=0 msix=0


Exécuter la commande suivante :

update-initramfs -u


et redémarrer.

Ou bien pour tester en live :

ifconfig eth0 down


modprobe -r forcedeth


modprobe forcedeth msi=0 msix=0


dhclient eth0



Edit à toto :
Séparation des commandes root les unes des autres.

Hors ligne

#9 22-05-2017 13:24:27

FriXion
Membre
Inscription : 20-05-2017

Re : [Résolu] Impossible de se connecter à Internet.

Je ne pense pas que le problème vienne de ma carte mère, regardez le site que j'ai trouvé en cherchant la référence de la carte mère.
http://www.linux-hardware-guide.com/fr/ … force-6100

En bas il y a écrit que cette carte mère à été utilisée par des personnes sur Ubuntu sans soucis (voir en bas de la page). Donc je pense que le problème viens de Windows 10.

Dernière modification par FriXion (22-05-2017 14:58:44)

Hors ligne

#10 24-05-2017 14:28:14

FriXion
Membre
Inscription : 20-05-2017

Re : [Résolu] Impossible de se connecter à Internet.

C'est bon, j'ai testé la commande de raleur après avoir crée le fichier puis j'ai redémarré et ça à marché !

Merci beaucoup pour votre précieuse aide, je n'y serais jamais arrivé sans vous !

Hors ligne

#11 24-05-2017 14:41:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Impossible de se connecter à Internet.

Peux-tu préciser exactement quelle est la procédure que tu as suivi ?
Et si c'est résolu, alors :

Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. wink

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 24-05-2017 14:45:31

FriXion
Membre
Inscription : 20-05-2017

Re : [Résolu] Impossible de se connecter à Internet.

Tu peux essayer les paramètres mentionnés dans le fil du forum Ubuntu pointé par robert2a.
Créer un fichier /etc/modprobe.d/forcedeth.conf contenant :

options forcedeth msi=0 msix=0


Exécuter la commande suivante :

update-initramfs -u (en root)

C'est la procédure de raleur que j'ai suivie et qui a marchée pour moi.

Et merci pour le lien j'étais en train de chercher comment afficher le sujet en [Résolu] !

Dernière modification par FriXion (24-05-2017 14:50:01)

Hors ligne

Pied de page des forums