Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-05-2017 15:50:56

djtlm13
Membre
Inscription : 21-05-2017

problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Bonjour

Merci de m'accepter comme utilisateur dans ce forum

Je viens d'installer Debain 8 sur ma machine, après avoir exécuter les fonctions apt-get update et apt-get upgrade, j'ai voulu installer les pré-requis pour l'installation de Asterisk 13 selon la ligne de commande suivante


apt-get install build-essential libxml2-dev libncurses-dev linux-headers-'uname -r' libsqlite3-dev libssl-dev


j'ai le message d'erreur suivant :


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Package build-essential is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libncurses-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'build-essential' has no installation candidate
E: Package 'libncurses-dev' has no installation candidate
E: Impossible de trouver le paquet linux-headers-uname -r



je n'ai pas su quoi faire car je suis nouveau avec debian et Asterisk et je suis en train de suivre une video sur youtube un tuto d'installation d'asterisk 13
le nom de la vidéo sur youtube est installer asterisk 13(debian8)

SVP c'est urgent car c mon projet pour soutenance et il ne me reste pas grand temps.

Dernière modification par djtlm13 (25-05-2017 01:49:51)

Hors ligne

#2 21-05-2017 17:38:24

èfpé
Membre
Inscription : 10-07-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Bonjour et bienvenue djtlm13,

Alors déjà ta commande n'est pas conforme au tuto suivi, tu as fait quelques petites erreurs de copier-coller :

apt-get install build-essential libxml2-dev libncurses-dev linux-headers-'uname -r' libsqlite3-dev libssl-dev

au lieu de

apt-get install build-essential libxml2-dev libncurses5-dev linux-headers-`uname -r` libsqlite3-dev libssl-dev


Ceci dit je n'ai pas d'explication pour build-essential ; à noter la version 11.13.1 dans les dépôts.

Hors ligne

#3 21-05-2017 18:30:09

raleur
Membre
Inscription : 03-10-2014

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Ça sent le dépôt manquant.
Que contient le fichier /etc/apt/sources.list ?

Hors ligne

#4 22-05-2017 09:37:33

djtlm13
Membre
Inscription : 21-05-2017

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Bonjour et merci pour vos réponses èfpé et raleur

Pour Raleur voici le contenu du fichier /etc/apt/sources.list

je pense bien qu'il me manque des trucs pour télécharger du contenu multimédia, je ne sais pas , merci d'avance pour votre aide


#

# deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official i386 DVD Binary-1 20160402-13:26]/ jessie contrib main

# deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official i386 DVD Binary-1 20160402-13:26]/ jessie contrib main

# Line commented out by installer because it failed to verify:
deb [url]http://security.debian.org/[/url] jessie/updates main contrib
# Line commented out by installer because it failed to verify:
deb-src [url]http://security.debian.org/[/url] jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
# Line commented out by installer because it failed to verify:
deb [url]http://ftp.fr.debian.org/debian/[/url] jessie-updates main contrib
# Line commented out by installer because it failed to verify:
deb-src [url]http://ftp.fr.debian.org/debian/[/url] jessie-updates main contrib

Hors ligne

#5 22-05-2017 12:42:32

èfpé
Membre
Inscription : 10-07-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Re-,

Comme suggéré par @raleur il te manque le dépôt principal (jessie, section main) :

deb http://ftp.fr.debian.org/debian/ jessie main contrib
deb-src http://ftp.fr.debian.org/debian/ jessie main contrib


Suivant la logique actuelle du fichier, mais qui pourrait aussi être :

# Debian Jessie, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
# Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ jessie-updates main contrib non-free


Tu trouveras sur le wiki local toutes les explications, subtilités et variantes.

Hors ligne

#6 22-05-2017 13:56:38

djtlm13
Membre
Inscription : 21-05-2017

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Bonjour

Voici ma source.list à présent

#

# deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official i386 DVD Binary-1 20160402-13:26]/ jessie contrib main

# deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official i386 DVD Binary-1 20160402-13:26]/ jessie contrib main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ jessie/updates main contrib
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
# Line commented out by installer because it failed to verify:
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib
# Line commented out by installer because it failed to verify:
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib
deb http://ftp.fr.debian.org/debian/ jessie main contrib
deb-src http://ftp.fr.debian.org/debian/ jessie main contrib
# Debian Jessie, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
# Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ jessie-updates main contrib non-free



mais après un apt-get update je crois qu'il ne prend pas en considération ce que j'ai ajouté

voici le résultat d'un apt-get update

root@debian-asterisk:~# apt-get update
Atteint http://ftp.fr.debian.org jessie-updates InRelease
Atteint http://ftp.fr.debian.org jessie-updates/main Sources     
Atteint http://ftp.fr.debian.org jessie-updates/contrib Sources                               
Réception de : 1 http://ftp.fr.debian.org jessie-updates/main i386 Packages/DiffIndex [7 900 B]
Atteint http://ftp.fr.debian.org jessie-updates/contrib i386 Packages             
Atteint http://ftp.fr.debian.org jessie-updates/contrib Translation-en                           
Réception de : 2 http://ftp.fr.debian.org jessie-updates/main Translation-en/DiffIndex [2 704 B]
Atteint http://security.debian.org jessie/updates InRelease                                                                                                 
Atteint http://security.debian.org jessie/updates/main Sources                                                                                               
Atteint http://security.debian.org jessie/updates/contrib Sources                                                                                           
Atteint http://security.debian.org jessie/updates/main i386 Packages                                                                                         
Atteint http://security.debian.org jessie/updates/contrib i386 Packages                                                                                     
Atteint http://security.debian.org jessie/updates/contrib Translation-en                                                                                     
Atteint http://security.debian.org jessie/updates/main Translation-en   

et tjrs aucune installation du build essentials

j'ai essayé une autre méthode en téléchargeant le build essential.tar.gz mais je peine la aussi à l'installer

c dur je souffre et je suis démoralisé là

Hors ligne

#7 22-05-2017 14:12:32

èfpé
Membre
Inscription : 10-07-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Re-,

Ok pas de souffrance inutile, modifie ton sources.list de façon à ce qu'il ne contienne que :

# Debian Jessie, dépôt principal + paquets non libres
deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
# Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free


Si ta connexion internet fonctionne, il n'y a aucune raison que ça plantouille smile

Hors ligne

#8 22-05-2017 15:06:47

djtlm13
Membre
Inscription : 21-05-2017

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Tjrs le même problème

j'ai modifié le source. list qui est le suivant

# Debian Jessie, dépôt principal + paquets non libres
deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
# Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free



et j'ai fais le apt-get update et apt-get upgrade

et en voulant installer build essential c toujours le même message

root@debian-asterisk:/home/ri-chekroun# apt-get install build-essential
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Package build-essential is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'build-essential' has no installation candidate

Merci de m'indiquer comment modifier le source.list peut être que je ne le fais pas correctement

Hors ligne

#9 22-05-2017 15:28:32

èfpé
Membre
Inscription : 10-07-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Re-,

Ton sources.list est bon ; par ailleurs j'ai vérifié la disponibilité du paquet pour Jessie 32 bits :

wget http://ftp.fr.debian.org/debian/pool/main/b/build-essential/build-essential_11.7_i386.deb

--2017-05-22 13:42:42--  http://ftp.fr.debian.org/debian/pool/main/b/build-essential/build-essential_11.7_i386.deb
Résolution de ftp.fr.debian.org (ftp.fr.debian.org)… 212.27.32.66, 2a01:e0c:1:1598::2
Connexion à ftp.fr.debian.org (ftp.fr.debian.org)|212.27.32.66|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 7124 (7,0K) [application/x-debian-package]
Sauvegarde en : « build-essential_11.7_i386.deb »

build-essential_11.7_i386.deb      100%[================================================================>]   6,96K  --.-KB/s    in 0,006s  

2017-05-22 13:42:42 (1,12 MB/s) — « build-essential_11.7_i386.deb » sauvegardé [7124/7124]


Tu peux tenter un coup de propre, suivi d'une mise à jour de la liste des paquets :

apt-get clean && apt-get update


Si cela ne suffit pas je passerai la main (parce que je suis sous Stretch 64 bits, là).

Hors ligne

#10 22-05-2017 15:39:56

djtlm13
Membre
Inscription : 21-05-2017

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

C'est bon il est téléchargé mais le problème c'est que je ne sais pas comment l'installer ??

Hors ligne

#11 22-05-2017 16:12:32

èfpé
Membre
Inscription : 10-07-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Re-,

Scrogneugneu, j'ai écrit que j'avais vérifié la disponibilité du paquet... pas qu'il faut procéder comme ça.
Pourrais-tu lire le post #9 jusqu'au bout ? J'y essaie de m'exprimer dans un français à peu près correct.

Hors ligne

#12 22-05-2017 16:16:27

djtlm13
Membre
Inscription : 21-05-2017

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

rien ne marche dsl et merci beaucoup pour votre aide

je ne sais plus quoi faire

Hors ligne

#13 22-05-2017 16:42:30

djtlm13
Membre
Inscription : 21-05-2017

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Re-bonsoir

Regardez ce qui s'affiche maintenat SVP je sais que je vous ai cassé la tête avec mon problème

root@debian-asterisk:~#

apt-get install build-essential libxml2-dev



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
libxml2-dev est déjà la plus récente version disponible.
build-essential est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 build-essential : Dépend: libc6-dev mais ne sera pas installé ou
                            libc-dev
                   Dépend: gcc (>= 4:4.9.1) mais il n'est pas installable
                   Dépend: g++ (>= 4:4.9.1) mais il n'est pas installable
                   Dépend: make mais il n'est pas installable
                   Dépend: dpkg-dev (>= 1.17.11) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).



Edit : ajout des balises codes pour une bonne lecture sur le forum.
Pour savoir comment faire :
Voir le tuto : Le code, ça pique moins les yeux en couleur

Hors ligne

#14 22-05-2017 20:51:36

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Bonjour djtlm13,

libxml2-dev est déjà la plus récente version disponible.
build-essential est déjà la plus récente version disponible.



C'est donc qu'ils sont installés. smile

que retournent les commandes:


apt-cache policy gcc


apt-cache policy make
 


apt-cache policy g++


apt-cache policy libc6-dev


apt-cache policy dpkg-dev

Hors ligne

#15 22-05-2017 21:28:26

golgot200
Membre
Inscription : 05-08-2007

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Bonsoir,

moi je ferais simplement ça :


apt-get -f install
 



smile

Hors ligne

#16 23-05-2017 09:46:55

djtlm13
Membre
Inscription : 21-05-2017

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Bonjour L'ami merci pour votre réponse

Voilà j'ai exécuté toutes les commandes et voilà ce qu'elles retournent :

ri-chekroun@debian-asterisk:~$ apt-cache policy gcc
gcc:
  Installé : (aucun)
  Candidat : (aucun)
Table de version :
ri-chekroun@debian-asterisk:~$ apt-cache policy make
make:
  Installé : (aucun)
  Candidat : (aucun)
Table de version :
ri-chekroun@debian-asterisk:~$ apt-cache policy g++
g++:
  Installé : (aucun)
  Candidat : (aucun)
Table de version :
ri-chekroun@debian-asterisk:~$ apt-cache policy libc6-dev
libc6-dev:
  Installé : (aucun)
  Candidat : 2.19-18+deb8u3
Table de version :
     2.19-18+deb8u3 0
        500 http://security.debian.org/ jessie/updates/main i386 Packages
ri-chekroun@debian-asterisk:~$ apt-cache policy dpkg-dev
dpkg-dev:
  Installé : (aucun)
  Candidat : 1.17.26
Table de version :
     1.17.26 0
        500 http://security.debian.org/ jessie/updates/main i386 Packages










deuchdeb a écrit :

Bonjour djtlm13,

libxml2-dev est déjà la plus récente version disponible.
build-essential est déjà la plus récente version disponible.



C'est donc qu'ils sont installés. smile

que retournent les commandes:


apt-cache policy gcc


apt-cache policy make
 


apt-cache policy g++


apt-cache policy libc6-dev


apt-cache policy dpkg-dev

Hors ligne

#17 23-05-2017 09:48:32

djtlm13
Membre
Inscription : 21-05-2017

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Bonjour Gloglot

Merci pour votre réponse

J'ai déjà fait la commande apt-get -f install mais ça ne donne rien elle me demande seulement de supprimer build-essential





golgot200 a écrit :

Bonsoir,

moi je ferais simplement ça :


apt-get -f install
 



smile

Hors ligne

#18 23-05-2017 11:44:37

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

djtlm13 a écrit :

ri-chekroun@debian-asterisk:~$ apt-cache policy make
make:
  Installé : (aucun)
  Candidat : (aucun)


Bonjour,
Visiblement, il y a toujours un problème avec le sources.list qui ne contient pas les bons dépôts. Il faut reprendre les explications données plus haut pour ajouter les dépôts qui manquent. Il est aussi possible d'utiliser Synaptic pour le faire avec le menu Configuration > Dépôts
Voir ici : https://debian-facile.org/doc:systeme:a … les-depots

Hors ligne

#19 23-05-2017 14:41:21

golgot200
Membre
Inscription : 05-08-2007

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

apt-cache policy Gloglot




Gloglot:
  Installé : (aucun)
  Candidat : (aucun)
 



apt-cache policy golgot:



 
  Installé : Bien sûr
  Candidat : 200
 



big_smile

Hors ligne

#20 23-05-2017 16:35:25

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Après avoir tout relu il me semble qu'il manque toujours cette ligne au sources.list:

deb http://deb.debian.org/debian/ jessie main contrib non-free

Hors ligne

#21 23-05-2017 17:04:04

èfpé
Membre
Inscription : 10-07-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Re-,

(@deuchdeb : mea maxima culpa ceci dit ftp.fr.debian.org fonctionne)

@djtlm13 : pourrais-tu poster les retours des commandes suivantes ?

cat /etc/apt/preferences.d/*

et

cat /etc/apt/sources.list.d/*


Juste dans l'optique de débrouiller cette situation très bizarre.

Hors ligne

#22 23-05-2017 19:08:11

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Oui on peut  mettre

deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free



ou

deb http://deb.debian.org/debian/ jessie main contrib non-free



Les deux fonctionnent, mais ils en faut bien une des deux et j'ai pas l'impression qu'une de ces deux lignes soit présente dans le sources.list

Hors ligne

#23 23-05-2017 19:14:14

èfpé
Membre
Inscription : 10-07-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

Re-,

@deuchdeb : ah bon ? c'est pourtant ce que je crois comprendre du post #8, mais je peux me tromper hmm

Hors ligne

#24 23-05-2017 19:20:57

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

@èfpé: Oui tu as raison, cette ligne a bien été ajouté.

Situation inédite ma foi!

Hors ligne

#25 23-05-2017 20:31:25

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : problème d'installation d'asterisk 13 sur Debian 8 [résolu]

comment on pourrait expliquer les retours avec aucun s'il ne manque pas cette ligne ?
On pourrait voir peut-être avec le retour de la commande :

apt-cache policy linux-image-3.16.0-4-686-pae
 


Avec elle j'ai un retour dans table de version pour les 3 depôts main, jessie/updates et jessie-updates

Il y a peut-être une faute de frappe

Hors ligne

Pied de page des forums