Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-05-2017 14:37:21

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Mate / Gdm3
Inscription : 11-03-2017

[clos] en parlant des différents kernels ...

bonjour ,

la commande suivante :

$ apt-cache search linux-image


me donne :

linux-headers-3.16.0-4-586 - Header files for Linux 3.16.0-4-586
linux-headers-3.16.0-4-686-pae - Header files for Linux 3.16.0-4-686-pae
linux-headers-3.16.0-4-amd64 - Header files for Linux 3.16.0-4-amd64
linux-image-3.16.0-4-586 - Linux 3.16 for older PCs
linux-image-3.16.0-4-686-pae - Linux 3.16 for modern PCs
linux-image-3.16.0-4-686-pae-dbg - Debugging symbols for Linux 3.16.0-4-686-pae
linux-image-3.16.0-4-amd64 - Linux 3.16 for 64-bit PCs
linux-image-3.16.0-4-amd64-dbg - Debugging symbols for Linux 3.16.0-4-amd64
linux-image-486 - Linux for older PCs (dummy package)
linux-image-586 - Linux for older PCs (meta-package)
linux-image-686-pae-dbg - Debugging symbols for Linux 686-pae configuration (meta-package)
linux-image-amd64 - Linux for 64-bit PCs (meta-package)
linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package)
linux-image-686-pae - Linux pour PC modernes - métapaquet
nvidia-kernel-3.16.0-4-586 - NVIDIA binary kernel module for Linux 3.16.0-4-586
nvidia-kernel-3.16.0-4-686-pae - NVIDIA binary kernel module for Linux 3.16.0-4-686-pae
nvidia-kernel-3.16.0-4-amd64 - NVIDIA binary kernel module for Linux 3.16.0-4-amd64
linux-headers-4.9.0-0.bpo.2-686 - Header files for Linux 4.9.0-0.bpo.2-686
linux-headers-4.9.0-0.bpo.2-686-pae - Header files for Linux 4.9.0-0.bpo.2-686-pae
linux-headers-4.9.0-0.bpo.2-amd64 - Header files for Linux 4.9.0-0.bpo.2-amd64
linux-headers-4.9.0-0.bpo.2-rt-686-pae - Header files for Linux 4.9.0-0.bpo.2-rt-686-pae
linux-headers-4.9.0-0.bpo.2-rt-amd64 - Header files for Linux 4.9.0-0.bpo.2-rt-amd64
linux-headers-4.9.0-0.bpo.3-686 - Header files for Linux 4.9.0-0.bpo.3-686
linux-headers-4.9.0-0.bpo.3-686-pae - Header files for Linux 4.9.0-0.bpo.3-686-pae
linux-headers-4.9.0-0.bpo.3-amd64 - Header files for Linux 4.9.0-0.bpo.3-amd64
linux-headers-4.9.0-0.bpo.3-rt-686-pae - Header files for Linux 4.9.0-0.bpo.3-rt-686-pae
linux-headers-4.9.0-0.bpo.3-rt-amd64 - Header files for Linux 4.9.0-0.bpo.3-rt-amd64
linux-image-4.9.0-0.bpo.2-686-pae-dbg - Debugging symbols for Linux 4.9.0-0.bpo.2-686-pae
linux-image-4.9.0-0.bpo.2-686-pae-unsigned - Linux 4.9 for modern PCs
linux-image-4.9.0-0.bpo.2-686-unsigned - Linux 4.9 for older PCs
linux-image-4.9.0-0.bpo.2-amd64-dbg - Debugging symbols for Linux 4.9.0-0.bpo.2-amd64
linux-image-4.9.0-0.bpo.2-amd64-unsigned - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-0.bpo.2-rt-686-pae-dbg - Debugging symbols for Linux 4.9.0-0.bpo.2-rt-686-pae
linux-image-4.9.0-0.bpo.2-rt-686-pae-unsigned - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-0.bpo.2-rt-amd64-dbg - Debugging symbols for Linux 4.9.0-0.bpo.2-rt-amd64
linux-image-4.9.0-0.bpo.2-rt-amd64-unsigned - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-0.bpo.3-686 - Linux 4.9 for older PCs
linux-image-4.9.0-0.bpo.3-686-dbg - Debug symbols for linux-image-4.9.0-0.bpo.3-686
linux-image-4.9.0-0.bpo.3-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-0.bpo.3-686-pae-dbg - Debug symbols for linux-image-4.9.0-0.bpo.3-686-pae
linux-image-4.9.0-0.bpo.3-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-0.bpo.3-amd64-dbg - Debug symbols for linux-image-4.9.0-0.bpo.3-amd64
linux-image-4.9.0-0.bpo.3-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-0.bpo.3-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-0.bpo.3-rt-686-pae
linux-image-4.9.0-0.bpo.3-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-0.bpo.3-rt-amd64-dbg - Debug symbols for linux-image-4.9.0-0.bpo.3-rt-amd64
linux-headers-4.6.0-1-grsec-686-pae - Header files for Linux 4.6.0-1-grsec-686-pae
linux-headers-4.9.0-2-grsec-686-pae - Header files for Linux 4.9.0-2-grsec-686-pae
linux-headers-4.9.0-2-grsec-amd64 - Header files for Linux 4.9.0-2-grsec-amd64
linux-image-4.6.0-1-grsec-686-pae - Linux 4.6 for modern PCs, Grsecurity protection
linux-image-4.9.0-2-grsec-686-pae - Linux 4.9 for modern PCs, Grsecurity protection
linux-image-4.9.0-2-grsec-amd64 - Linux 4.9 for 64-bit PCs, Grsecurity protection
linux-image-grsec-686-pae - Linux image meta-package, grsec featureset
linux-image-grsec-amd64 - Linux image meta-package, grsec featureset
linux-image-grsec-i386 - Linux image meta-package, grsec featureset (transition package)
linux-image-686 - Linux for older PCs (meta-package)
linux-image-686-dbg - Debugging symbols for Linux 686 configuration (meta-package)
linux-image-rt-686-pae - Linux for modern PCs (meta-package), PREEMPT_RT
linux-image-rt-686-pae-dbg - Debugging symbols for Linux rt-686-pae configuration (meta-package)
linux-image-rt-amd64 - Linux for 64-bit PCs (meta-package), PREEMPT_RT
linux-image-rt-amd64-dbg - Debugging symbols for Linux rt-amd64 configuration (meta-package)
linux-image-4.9.0-0.bpo.2-686 - Linux 4.9 for older PCs (signed)
linux-image-4.9.0-0.bpo.2-686-pae - Linux 4.9 for modern PCs (signed)
linux-image-4.9.0-0.bpo.2-amd64 - Linux 4.9 for 64-bit PCs (signed)
linux-image-4.9.0-0.bpo.2-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT (signed)
linux-image-4.9.0-0.bpo.2-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT (signed)
linux-image-4.11.3-amd64 - Linux kernel, version 4.11.3-amd64
linux-image-4.11.3-amd64-dbg - Linux kernel debugging symbols for 4.11.3-amd64
 



ce sont là tous les kernels disponibles dans le cache , je pense .

j'ai déjà installé

linux-headers-4.9.0-0.bpo.2-amd64 - Header files for Linux 4.9.0-0.bpo.2-amd64


c.a.d. kernel 4.9.0-0.2 (kernel 4.9.0-0 version 2) ?
est ce que

linux-image-4.9.0-0.bpo.3-amd64 - Linux 4.9 for 64-bit PCs


veut dire kernel 4.9.0-0 version 3 par opposition avec la version 2 précédemment ?

je suis allé trop vite en mettant le kernel 4.11.3 ?

si c'est ça , c'est ma windowsite qui me reprends. faut que je me calme .

Dernière modification par Debian Alain (30-05-2017 11:38:25)


1498826560.jpg 1498812139.jpg Bip ! Bip !

En ligne

#2 27-05-2017 14:53:58

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [clos] en parlant des différents kernels ...

Oui pour la version 3 plus récente :
linux-image-4.9.0-0.bpo.2-amd64 (4.9.18-1~bpo8+1
linux-image-4.9.0-0.bpo.3-amd64 (4.9.25-1~bpo8+1)
Si tu as le paquet linux-image-amd64 de Jessie-backports, sa mise à jour mettra aussi à jour le noyau.
En commande il faudra peut-être apt-get dist-upgrade pour la mise à niveau si tu utilises apt-get
Pour le 4.11, l'inconvénient c'est qu'il ne vient pas des dépôts Debian et donc c'est à toi de faire "la maintenance"
Comme robert2a te l'a dit, il n'y a rien qui presse par rapport à l'achat de ta carte graphique.
Tu pourras d'abord tester le noyau 4.9 fourni par Debian. smile

linux-headers-xx, ce sont les en-têtes de noyau utiles par exemple si tu veux compiler.
De base, le paquet n'est peut-être bien pas installé sur une Debian fraîche, à vérifier ... je doute !

Hors ligne

#3 27-05-2017 15:16:46

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Mate / Gdm3
Inscription : 11-03-2017

Re : [clos] en parlant des différents kernels ...

dans le doute , chalu , est ce que je désinstalle le kernel 4.11 ?

je viens de m'apercevoir que aucun de mes "recovery mode" ne fonctionne .

écran noir systématiquement . sur tous mes kernel :

3.16-4   4.9-2   4.9-3    et    4.11-3

curieusement , le jessie normal fonctionne parfaitement , lui .

bizzare . peut être une  histoire d'écran ?

on verra dans quelques jours .

Dernière modification par Debian Alain (27-05-2017 15:39:34)


1498826560.jpg 1498812139.jpg Bip ! Bip !

En ligne

#4 27-05-2017 15:39:25

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [clos] en parlant des différents kernels ...

Si tu as installé ce noyau en prévision de ta carte, comme dit par robert2a, oui tu peux le désinstaller.
Si j'ai bien compris. Il te fera tester ta carte graphique avec le noyau 4.9 avec migration sur stretch ou pas, je n'ai pas bien suivi ce point.
Pour supprimer le noyau tu supprimes comme pour les autres paquets :
Tu démarres sur le noyau 4.9 puis

apt-get remove linux-image-4.11.3-amd64

Hors ligne

#5 27-05-2017 15:48:07

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Mate / Gdm3
Inscription : 11-03-2017

Re : [clos] en parlant des différents kernels ...

voilà , j'ai suivi tes conseils , chalu .

kernel 4.11.3 désinstallé

1498826560.jpg 1498812139.jpg Bip ! Bip !

En ligne

#6 27-05-2017 15:55:35

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [clos] en parlant des différents kernels ...

oui avec synaptic tu peu enlever le 4.11 facilement , ou avec gdebi => désinstaller a partir des .deb que tu a installé.
il te faut les deux paquets linux-image-amd64 et linux-headers-amd64  installé , tu sera toujours sur d'etre a jours (méta-paquet )

tu peu tester le 4.11 (pas le feu pour l'enlever ) mais si problème avec la carte commencer par le 4.10 peu etre.
attention d installer des noyau autre que debian va te proposer d enlever ceux de debian (pas faire d autoremove )

ceci correspond a la version des backports du 4.9.0-3 de stretch => "linux-image-4.9.0-0.bpo.3-amd64 - Linux 4.9 for 64-bit PCs"
ps : il ne faut surtout pas l enlever  tongue

j'ai testé les 4.10 , 4.11 et 4.12 sans perdre l original  (en règle générale 2 noyau installé)
4.9 et 4.10
ou
4.9 et 4.11
ou
4.9 et 4.12
a ne pas faire
4.9 + 4.10 + 4.11 mauvais il va te proposer de virer le 4.9  tongue

une remarque l'autoremove ne suffit pas


linux-firmware-image-4.11.3-amd64_4.11.3-1_amd64.deb
linux-headers-4.11.3-amd64_4.11.3-1_amd64.deb
linux-image-4.11.3-amd64_4.11.3-1_amd64.deb
linux-image-4.11.3-amd64-dbg_4.11.3-1_amd64.deb
linux-libc-dev_4.11.3-1_amd64.deb
 



je sais pas quel .deb ont été installé sur les cinq

Dernière modification par robert2a (27-05-2017 16:07:51)

Hors ligne

#7 27-05-2017 16:04:24

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Mate / Gdm3
Inscription : 11-03-2017

Re : [clos] en parlant des différents kernels ...

ah ben ! , heureux que tu me le dises !

j'avais 3.16.4 , 4.9.2 , 4.9.3 , et ( mais je l'ai retiré ) 4.11.3

j'ai toujours ces 3 là pour l'instant. pas vraiment envie de les retirer .

mais pour mon problème de "recovery mode" ? un souci d'écran ? (je pense)

Ctrl + Alt + F1 ne fonctionne pas non plus . écran noir sans aucun texte .

j'ai trouvé ça :
https://forum.ubuntu-fr.org/viewtopic.php?id=35088
mais  ça ne m'a pas aidé

Dernière modification par Debian Alain (27-05-2017 16:42:39)


1498826560.jpg 1498812139.jpg Bip ! Bip !

En ligne

#8 27-05-2017 17:40:48

rodrigue7800
Membre
Lieu : beloeil
Distrib. : debian 9 / ubuntu 18.04
(G)UI : mate
Inscription : 01-03-2016
Site Web

Re : [clos] en parlant des différents kernels ...

moi fonctionne 4.11.3 aucun soucis
retiré 4.11.2 smile
signé rodrigue7800.

bonsoir, vous veuillez une excuse car il n'écrit pas bien le français donc ne tenais pas compte des faute quand il écrit
la groupe des linux amis sur ce facebook : https://www.facebook.com/groups/199571637321174/
la francorphone d'openmediavault https://www.facebook.com/groups/1533132290044409

Hors ligne

Pied de page des forums