Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-06-2017 05:53:43

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

[ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Bonjour,

J'ai tenté une mise à niveau. Stretch est opérationnel.
Voici ce que me renvoie le terminal:

root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre# apt update && apt upgrade
Atteint:1 http://www.deb-multimedia.org stretch InRelease
Réception de:2 http://ftp.fr.debian.org/debian stretch InRelease [194 kB]      
Atteint:3 http://security.debian.org stretch/updates InRelease                
Réception de:4 http://ftp.fr.debian.org/debian stretch-updates InRelease [88,5 kB]
Ign:5 http://ftp.fr.debian.org/debian/stretch-updates main InRelease        
Réception de:6 http://ftp.fr.debian.org/debian stretch-backports InRelease [46,8 kB]
Réception de:7 http://ftp.fr.debian.org/debian stretch/non-free Sources.diff/Index [27,8 kB]
Réception de:8 http://ftp.fr.debian.org/debian stretch/contrib Sources.diff/Index [27,8 kB]
Réception de:9 http://ftp.fr.debian.org/debian stretch/main Sources.diff/Index [27,9 kB]
Réception de:10 http://ftp.fr.debian.org/debian stretch/main amd64 Packages.diff/Index [27,9 kB]
Réception de:11 http://ftp.fr.debian.org/debian stretch/main Translation-en.diff/Index [27,9 kB]
Réception de:12 http://ftp.fr.debian.org/debian stretch/non-free amd64 Packages.diff/Index [27,8 kB]
Réception de:13 http://ftp.fr.debian.org/debian stretch/contrib amd64 Packages.diff/Index [27,8 kB]
Réception de:14 http://ftp.fr.debian.org/debian stretch/contrib Translation-en.diff/Index [27,8 kB]
Err:15 http://ftp.fr.debian.org/debian/stretch-updates main Release
  404  Not Found [IP : 212.27.32.66 80]
Réception de:16 http://ftp.fr.debian.org/debian stretch/non-free Sources 2017-06-04-0229.47.pdiff [241 B]
Réception de:16 http://ftp.fr.debian.org/debian stretch/non-free Sources 2017-06-04-0229.47.pdiff [241 B]
Réception de:17 http://ftp.fr.debian.org/debian stretch/contrib Sources 2017-06-04-0229.47.pdiff [30 B]
Réception de:17 http://ftp.fr.debian.org/debian stretch/contrib Sources 2017-06-04-0229.47.pdiff [30 B]
Réception de:18 http://ftp.fr.debian.org/debian stretch/main Sources 2017-06-04-0229.47.pdiff [6 477 B]
Réception de:18 http://ftp.fr.debian.org/debian stretch/main Sources 2017-06-04-0229.47.pdiff [6 477 B]
Réception de:19 http://ftp.fr.debian.org/debian stretch/main amd64 Packages 2017-06-04-0229.47.pdiff [18,2 kB]
Réception de:19 http://ftp.fr.debian.org/debian stretch/main amd64 Packages 2017-06-04-0229.47.pdiff [18,2 kB]
Réception de:20 http://ftp.fr.debian.org/debian stretch/main Translation-en 2017-06-04-0229.47.pdiff [55 B]
Réception de:20 http://ftp.fr.debian.org/debian stretch/main Translation-en 2017-06-04-0229.47.pdiff [55 B]
Réception de:21 http://ftp.fr.debian.org/debian stretch/non-free amd64 Packages 2017-06-04-0229.47.pdiff [3 629 B]
Réception de:21 http://ftp.fr.debian.org/debian stretch/non-free amd64 Packages 2017-06-04-0229.47.pdiff [3 629 B]
Réception de:22 http://ftp.fr.debian.org/debian stretch/contrib amd64 Packages 2017-06-04-0229.47.pdiff [440 B]
Réception de:22 http://ftp.fr.debian.org/debian stretch/contrib amd64 Packages 2017-06-04-0229.47.pdiff [440 B]
Réception de:23 http://ftp.fr.debian.org/debian stretch/contrib Translation-en 2017-06-04-0229.47.pdiff [40 B]
Réception de:23 http://ftp.fr.debian.org/debian stretch/contrib Translation-en 2017-06-04-0229.47.pdiff [40 B]
Réception de:24 http://ftp.fr.debian.org/debian stretch/main amd64 DEP-11 Metadata [3 068 kB]
Réception de:25 http://ftp.fr.debian.org/debian stretch/main DEP-11 64x64 Icons [6 829 kB]
Réception de:26 http://ftp.fr.debian.org/debian stretch/non-free amd64 DEP-11 Metadata [7 120 B]
Réception de:27 http://ftp.fr.debian.org/debian stretch/contrib amd64 DEP-11 Metadata [7 316 B]
Réception de:28 http://ftp.fr.debian.org/debian stretch/contrib DEP-11 64x64 Icons [100 kB]
Lecture des listes de paquets... Fait                                          
E: The repository 'http://ftp.fr.debian.org/debian/stretch-updates main Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre#


bloc à supprimer si la commande n’affiche rien



Dois-je comprendre qu'il n'y a rien de catastrophique et que mon système sera plus opérationnel dans les semaines qui suivront la sortie de Stretch ?
Merci.

Dernière modification par avinash (11-06-2017 19:46:35)

Hors ligne

#2 04-06-2017 07:55:54

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Bonjour,

Personnellement sur une installation neuve de stretch, je n'ai pas de stretch-updates.
Voici le sources.list:

deb http://ftp.fr.debian.org/debian/ stretch main
deb-src http://ftp.fr.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main



Il n'y a pas le dépôt stretch-updates.

http://ftp.fr.debian.org/debian/stretch-updates



D'ailleurs on retrouve ceci sur le manuel de référence Debian: 2.1.4. Bases concernant l’archive Debian

https://www.debian.org/doc/manuals/debi … 02.fr.html

On peut noter que ce manuel est déjà en version stretch, à lire sans retenue. wink

Hors ligne

#3 04-06-2017 09:24:14

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Stretch 9.x & Backports
Noyau : Noyau Linux 4.9.0-3-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 30-06-2008

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

salut,


2.7.4. Mises à jour et rétroportages

Les archives du stretch-updates et backports.debian.org fournissent des paquets mis à niveau pour stable (stretch).

Afin d’utiliser ces archives, placez la liste de toutes les archives nécessaires dans le fichier « /etc/apt/sources.list » de la manière suivante :

deb http://deb.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb http://deb.debian.org/debian/ stretch-backports main contrib non-free

Il n’est pas nécessaire de définir explicitement la valeur de Pin-Priority dans le fichier « /etc/apt/preferences ». Quand de nouveaux paquets sont disponibles, la configuration par défaut fournit les mises à niveau les plus saines (consultez Section 2.5.3, « Fichiers « Release » au niveau de l’archive »).

    Tous les paquets installés les plus anciens sont mis à niveau vers les plus récents à partir de stretch-updates.

    Seuls les paquets les plus anciens installés à partir de stretch-backports sont mis à niveau vers les plus récents à partir de stretch-backports.

Chaque fois que vous désirerez installer un paquet nommé « <nom_paquet> » avec ses dépendances depuis l’archive stretch-backports vous-même, vous utiliserez la commande suivante en changeant de version cible avec l’option « -t » :

$ sudo apt-get install -t stretch-backports <nom_paquet>

 



source : https://www.debian.org/doc/manuals/debi … management

Dernière modification par mksmn (04-06-2017 09:25:21)


Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#4 04-06-2017 10:17:28

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Merci. Je regarde.

Je constate également que je suis resté sur l'ancien noyau 3.16.04-amd64. Le nouveau noyau de Stretch étant la version 4.10. C'est même pour cela que la date de la release Stretch a été retardée. Je me demande s'il me sera possible d'installer ce noyau version 4.10 ?

Pour l'instant ma migration semble plutôt opérationnelle, mise à part les vidéos de France infos que mon système ne peut pas lire, puisque qu'il n'y a pas de version disponible de Flashplayer à installer pour Stretch. Je sais bien que l'installation est déconseillée, mais à mon modeste niveau de maîtrise de Debian, je n'ai pas trouvé d'autres solutions.

Hors ligne

#5 04-06-2017 10:27:36

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

à mon avis, il doit te manquer quelque chose pour rester avec le même noyau.

En ligne

#6 04-06-2017 10:31:20

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Je vais patienter et si je ne trouve pas de solution je réinstallerai . D'ailleurs une nouvelle installation d'après les notes de Debian est préférable à un upgrade.

Hors ligne

#7 04-06-2017 10:38:55

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

avinash a écrit :

Je vais patienter et si je ne trouve pas de solution je réinstallerai . D'ailleurs une nouvelle installation d'après les notes de Debian est préférable à un upgrade.


c'est surtout plus rapide mais pas indispensable.
si tu n'as pas fait de choses hors des règles et tu te retrouves pas avec un système exotique, ça devrait bien se passer.
à mon avis, solution 1) migration vers stretch et solution 2) réinstall complète

En ligne

#8 04-06-2017 10:41:11

zorzi
Membre
Lieu : Dijon
Distrib. : Debian Stretch - XFCE
Noyau : Linux 4.9.0-3-amd64
Inscription : 30-09-2015

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

puisque qu'il n'y a pas de version disponible de Flashplayer à installer pour Stretch



Flash est disponible pour Stretch. Dans le dépôt contrib non-free si ma mémoire est bonne.

Sinon, tu as la version flashplayer-mozilla ou flashplayer-chromium dans le dépot deb multimédia .

http://deb-multimedia.org/


Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, DD 500 Go) / Debian Stretch (XFCE)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Stretch

Hors ligne

#9 04-06-2017 11:16:19

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

A propos du nouveau noyau:

jean-pierre@jeanpierre-h67a-ud3h-b3:~$ su
Mot de passe :
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre# aptitude install linux-image-4.9.0-3-amd64
linux-image-4.9.0-3-amd64 est déjà installé avec la version demandée (4.9.25-1)
linux-image-4.9.0-3-amd64 est déjà installé avec la version demandée (4.9.25-1)
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
                                                       
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre# uname -a
Linux jeanpierre-h67a-ud3h-b3 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2 (2017-04-30) x86_64 GNU/Linux
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre#



bloc à supprimer si la commande n’affiche rien



J'ai un doute parce que le terminal me renvoie que le noyau 4.9 est déjà installé et la commande uname -a indique que c'est le noyau 3.16 .

Dernière modification par avinash (04-06-2017 11:36:29)

Hors ligne

#10 04-06-2017 11:42:27

raleur
Membre
Inscription : 03-10-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

avinash a écrit :

aptitude install linux-image-4.9.0-3-amd64


Mauvaise méthode. La bonne méthode pour bénéficier du dernier noyau disponible est d'installer le méta-paquet linux-image-<arch>, ici linux-image-amd64.

As-tu redémarré le système après la mise à niveau ? C'est nécessaire pour changer de noyau.

En ligne

#11 04-06-2017 11:52:48

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Le nouveau noyau est bien installé. Je redémarre pour vérifier.

root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre# aptitude install linux-image-amd64
linux-image-amd64 est déjà installé avec la version demandée (4.9+80)
linux-image-amd64 est déjà installé avec la version demandée (4.9+80)
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.


bloc à supprimer si la commande n’affiche rien

Dernière modification par avinash (04-06-2017 11:54:29)

Hors ligne

#12 04-06-2017 11:57:50

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Je viens de redémarrer, mais la commande uname -a m'indique que je suis toujours sur l'ancien noyau.

jean-pierre@jeanpierre-h67a-ud3h-b3:~$ uname -a
Linux jeanpierre-h67a-ud3h-b3 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2 (2017-04-30) x86_64 GNU/Linux
jean-pierre@jeanpierre-h67a-ud3h-b3:~$



 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#13 04-06-2017 12:05:09

raleur
Membre
Inscription : 03-10-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Le nouveau noyau est-il présent dans les options avancées du menu de démarrage de GRUB ?
Si non, exécuter update-grub. S'il n'apparaît toujours pas, le GRUB qui se lance au démarrage est-il bien celui qui dépend de cette installation de Debian ?

En ligne

#14 04-06-2017 12:51:31

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Bonjour
si la version du noyau n'est pas la bonne , c'est que tu n'a pas finit ton dist-upgrade.
un sources.list correct
un apt-get update
puis un apt-get ugrade
enfin un apt-get dist-upgrade
pour terminer un reboot
aprés le reboot tu peu vérifier si des choses a nettoyer par un apt-get update et apt-get upgrade (si il te propose de faire un autoremove)
pas d'erreur avec le sources.list complet


#debian stretch 9
deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ stretch-backports main contrib non-free
 




apt-get update
 


retour


Atteint:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://security.debian.org stretch/updates InRelease                                                
Atteint:3 http://ftp.fr.debian.org/debian stretch-updates InRelease                                          
Atteint:4 http://ftp.fr.debian.org/debian stretch-backports InRelease
Lecture des listes de paquets... Fait
 



quand ta migration est finit vers stretch tu dois obtenir


uname -a
 


retour


Linux debian21 4.9.0-3-amd64 #1 SMP Debian 4.9.25-1 (2017-05-02) x86_64 GNU/Linux
 



tu a peut etre des erreurs sur ton sources.list , le poster sur le forum (vérifier que ton /etc/apt/sources.list.d/ est vide pour la migration  et poster son contenu )

Hors ligne

#15 04-06-2017 13:03:50

raleur
Membre
Inscription : 03-10-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

robert2a a écrit :

si la version du noyau n'est pas la bonne , c'est que tu n'a pas finit ton dist-upgrade.


Aptitude dit que le noyau 4.9 est installé. As-tu une raison de le mettre en doute ?
Je pense que le problème est ailleurs, du côté du chargeur d'amorçage,

En ligne

#16 04-06-2017 13:12:41

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

j'ai pas fait attention , il suffit de vérifier dans /boot


ls
 


retour


config-4.9.0-3-amd64  grub  initrd.img-4.9.0-3-amd64  System.map-4.9.0-3-amd64  vmlinuz-4.9.0-3-amd64
 



que le noyau en version 4.9 ne soit pas le premier dans grub c'est pas normal (sur le dist-upgrade il y a eu une anomalie si le noyau n'a pas été installé par grub)
ps: j'ai pas fait attention qu il était présent sur le système .

Dernière modification par robert2a (04-06-2017 13:15:04)

Hors ligne

#17 04-06-2017 15:01:17

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

La situation est plus claire maintenant.

J'ai exécuté un update-grub. Puis j'ai redémarré. La situation n'avait toujours pas évolué car dans  la liste du menu qui m'était proposée rien n'avait changé:

_J'avais le choix entre Ubuntu 16.04, Jessie et SID.

Donc je suis allé faire des mises à jour sur Ubuntu, mises à jour que je n'avais pas fait depuis des mois,  puisque je m'en passe fort bien maintenant, étant de plus en plus à l'aise avec Debian. Ensuite j'ai effectué un redémarrage et j'ai eu la bonne surprise de voir proposé dans le menu de Grub, Stretch.
Maintenant je vais tenter de résoudre les difficultés avec le multimédia et je vous tiendrai au courant. Ouf ! L'upgrade s'est bien passé et je n'ai pas cassé le système.

Hors ligne

#18 04-06-2017 15:48:18

raleur
Membre
Inscription : 03-10-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

Le nouveau noyau n'était pas dans le menu de démarrage parce que c'est celui généré par Ubuntu, comme je le soupçonnais en #13.

En ligne

#19 04-06-2017 17:10:21

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

@ raleur,

Je n'imaginais pas que ce soit possible ! Je précise que j'ai un O.S par disque dur . Comment Stretch serait elle allée chercher le noyau d'Ubuntu 16.04 qui est sur un autre disque ? Zut ! Je n'ai plus en tête l'historique de ce que j'ai fait depuis la nuit... Il me semble me souvenir que mes premières tentatives pour mettre à jour le Grub je les ai faites lorsque je travaillais sur Stretch. C'est quand j'ai redémarrer pour aller sur Ubuntu et que j'ai fait les mises à jour que j'ai obtenu le bon noyau. J'aurai dû prendre des notes au fur et à mesure de mes actions. Toujours trop pressé ! Dommage il y avait un point intéressant à comprendre.

jean-pierre@jeanpierre-h67a-ud3h-b3:~$ su
Mot de passe :
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre# update-grub
Création du fichier de configuration GRUB…
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Image Linux trouvée : /boot/vmlinuz-4.9.0-3-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-3-amd64
Image Linux trouvée : /boot/vmlinuz-3.16.0-4-amd64
Image mémoire initiale trouvée : /boot/initrd.img-3.16.0-4-amd64
Ubuntu 16.04.2 LTS (16.04) trouvé sur /dev/sda1
Windows 7 trouvé sur /dev/sdc1
Debian GNU/Linux stretch/sid trouvé sur /dev/sdc6
fait
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre#
 


bloc à supprimer si la commande n’affiche rien

Dernière modification par avinash (04-06-2017 17:45:47)

Hors ligne

#20 04-06-2017 19:31:07

raleur
Membre
Inscription : 03-10-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

avinash a écrit :

Comment Stretch serait elle allée chercher le noyau d'Ubuntu 16.04 qui est sur un autre disque ?


Tu n'as pas compris. Stretch n'y est pour rien. Ce n'est pas le noyau d'Ubuntu qui est lancé, c'est le GRUB d'Ubuntu. Or le menu de ce GRUB n'est mis à jour que lorsqu'on exécute update-grub depuis Ubuntu. Tu peux exécuter update-grub depuis Debian autant de fois que tu veux, ça n'a aucun effet immédiat sur le menu de GRUB d'Ubuntu.

Quant au fait que les deux systèmes soient sur des disques différents, ça n'a strictement aucun impact sur ce sujet.

En ligne

#21 04-06-2017 19:39:46

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

une petite question , tu a combien de disques dur et combien d' OS installé ?
je vois jessie que tu a passé en stretch
Ubuntu
et Windows
il y en a d'autres ?

Hors ligne

#22 04-06-2017 19:59:31

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

@robert2a
J'ai 4 O.S sur 3 disques durs:
Ubuntu
Windows 7
Stretch
Debian sid

Hors ligne

#23 04-06-2017 20:01:44

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

@raleur
C'est pourquoi les maj d'ubuntu ont permis de mettre à jour le Grub.

Hors ligne

#24 04-06-2017 20:41:50

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

j'avais bien compris  wink
garder jessie jusqu'au passage a stable de stretch
modifier le sources.list de sid en stretch
pas toucher a Ubuntu et a win7

entre sid et stretch tu dois pas avoir beaucoup de différences  hmm

une remarque (a demander a raleur ) , si tu enlève Ubuntu ça risque pas de poser problème pour Grub ? (pour les mises a jours )

Hors ligne

#25 04-06-2017 20:54:15

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Stretch
Noyau : Linux 4.9-amd64
(G)UI : Gestionnaire de fenêtres Mutter ?
Inscription : 04-06-2013

Re : [ Résolu ] Mise à niveau depuis Debian 8 Jessie vers Stretch

@robert2a
Je n'ai plus jessie puisque je viens d'upgrader jessie en stretch.
Ton conseil est judicieux. En ce moment Stable est gelée, donc peu de changements d'ici la nouvelle release.
Donc très certainement entre Sid et Stretch il ne doit pas y avoir beaucoup de différences .
Par-contre  tu me conseilles de modifier les sources list de Sid en Stretch, si j'ai bien compris parce que il va y avoir beaucoup d'instabilité sur Sid si je ne le fais pas lorsque la nouvelle testing va être opérationnelle, c'est à dire le jour où Stretch va passer en Stable.

Voici le sources.list de ma Sid:

# stable
deb http://ftp.fr.debian.org/debian/ stable/main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ stable/main contrib non-free

# stable security
deb http://security.debian.org/ stable/updates main contrib non-free
#deb-src http://security.debian.org/ stable/updates main contrib non-free

#stable updates
deb http://ftp.fr.debian.org/debian/ stable-updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ stable-updates main contrib non-free

# stable proposed updates
#deb http://ftp.fr.debian.org/debian/ stable-proposed-updates main contrib non-free
#deb-src  http://ftp.fr.debian.org/debian/ stable-proposed-updates main contrib non-free

# stable proposed updates
#deb http://ftp.fr.debian.org/debian/ stable-proposed-updates main contrib non-free
#deb-src  http://ftp.fr.debian.org/debian/ stable-proposed-updates main contrib non-free

# stable-backports
deb http://ftp.fr.debian.org/debian/ stable-backports main contrib non-free
#deb-src  http://ftp.fr.debian.org/debian/ stable-backports main contrib non-free

# testing
deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free

# unstable
deb http://ftp.fr.debian.org/debian/ unstable main contrib non-free

# experimental
# deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free
 


bloc à supprimer si la commande n’affiche rien

Dernière modification par avinash (04-06-2017 21:39:56)

Hors ligne

Pied de page des forums