Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-06-2017 17:50:53

natsu
Membre
Distrib. : Debian 8.8.0 i386
Noyau : linux 3.16.0-4-586
(G)UI : xfce
Inscription : 05-06-2017

Apache2 prob droit 403 Forbidden You don't have permissions to access

Bonjour a tous,

Je viens de me remettre a linux (debian 8.8.0) après de nombreuse années (Amiga 500+ et c'est pas une blaque).

donc installe de debian8.8.0 sans UEFI nickel et plus performante que lubuntu (surement moins lourd).

penthium M 1.7Ghz avec 1.2Go DDR et HDD 100 Go

j'ai installé un serveur lamp :

mysql 5.5
apache 2
php5
phpmyadmin

le tout avec apt-get.

le tout semble fonctionner puisque phpmyadmin démarre et fonctionne correctement.

Mon problème vient du fait que dans firefox ESR Apache me renvoi un beau :

adresse navigateur : localhost/magnolia.fr
retour :
403
Forbidden you don't have permission to acces /magnolia.fr on this server.

après moult recherches je n'arrive pas a résoudre mon problème.
Ou alors je n ai pas trouvé les bonnes réponses.

j'ai mis un vhost dans /etc/apache2/sites-available
suivi de a2ensite magnolia.conf
prise en compte ok
redémarrage de apache2 ok

natsu fait partit du group www-data

les droit sur     /var/www sont             sur utilisateur www-data et group www-data
                /home/natsu/www    sur utilisateur www-data et group www-data


mon vhost est comme suivant (sauf erreur de frappe je poste pas depuis la mémé machine):


VHOST dans /etc/apache2/sites-available

<VirtualHost *:80>
    ServerAdmin     xxxx@gmail.com
    ServerName    www.magnolia.fr
    ServerAlias    magnolia.fr
    ServerAlias    *.magnolia.fr

    DocumentRoot /home/www/magnolia
    DireectoryIndex    index.php
    <Directory />
        Options FollowSymlinks
        AllowOverride None
    </Directory>

    <Directory /home/natsu/magnolia.fr>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Require all granted
    </Directory>

    ErrorLog /home/natsu/www/apache_log/error_magnolia.log
    LogLevel warn
    CustomLog /home/natsu/www/apache_log/access_magnolia.log combined

</VirtualHost>

j ai surement commis une petite voire un grosse boulettes quelques part mais je trouve pas.
Si une âme charitable et éclairée pouvait m'aider merci d'avance.

ps : Désolé pour les éventuelles fautes de français

Hors ligne

#2 05-06-2017 23:46:50

natsu
Membre
Distrib. : Debian 8.8.0 i386
Noyau : linux 3.16.0-4-586
(G)UI : xfce
Inscription : 05-06-2017

Re : Apache2 prob droit 403 Forbidden You don't have permissions to access

enfin de compte en remplaçant localhost par 127.0.0.1

j arrive a obtenir ma page.:D

un petite manip dans /etc/host

bon j aimerai bien y arriver par localhost.

la dessus je sèche.

Hors ligne

#3 24-06-2017 12:24:17

Walien_
Membre
Distrib. : Raspberry pi 3 (Raspbian jessie (fevrier 2017)
Inscription : 23-06-2017

Re : Apache2 prob droit 403 Forbidden You don't have permissions to access

Bonjour j'ai le même problème et je n'arrive pas à le résoudre alors que j'ai regardé sur beaucoup de forum
J'ai installé :
-appache 2
-php5
-mysql
-phpmyadmin

et sa marchais jusqu'a présent très bien
mais j'ai ensuite installer d'autre logiciel pour gérer le site depuis un autre ordinateur:
-Samba
-vncserver et je crois que c'est tout

sa ne marche ni en localhost ni en 127.0.0.1 ni avec l'ip de mon raspberry
merci d'avance pour votre aide
(P.S je crois que c'est Samba qui a fait tout bugé donc je l'ai désinstaller avec sudo apt-get purge Samba mais sa marche toujours pas)
sos.gif scratchhead.gif

Dernière modification par Walien_ (24-06-2017 12:26:02)

Hors ligne

#4 24-06-2017 20:33:49

Walien_
Membre
Distrib. : Raspberry pi 3 (Raspbian jessie (fevrier 2017)
Inscription : 23-06-2017

Re : Apache2 prob droit 403 Forbidden You don't have permissions to access

natsu a écrit :

enfin de compte en remplaçant localhost par 127.0.0.1

j arrive a obtenir ma page.:D

un petite manip dans /etc/host

bon j aimerai bien y arriver par localhost.

la dessus je sèche.



c'est quoi ta "petite manip" ??question.gif

Hors ligne

#5 01-07-2017 17:27:54

natsu
Membre
Distrib. : Debian 8.8.0 i386
Noyau : linux 3.16.0-4-586
(G)UI : xfce
Inscription : 05-06-2017

Re : Apache2 prob droit 403 Forbidden You don't have permissions to access

Désolé de ne pas avoir vu vos messages avant. hmm

J ai modifié le fichier /etc/hosts comme suit sur ma machine cela se fait en root
avec un bon nano vim ou autre du même genre depuis la ligne de commande.

Avant toute modification je fais une sauvegarde du dit fichier avec la date du jour avant modification par sécurité.

127.0.0.1     localhost
127.0.0.1     nom de ma machine.WORKGROUP    nom de ma machine

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

et modifier le fichier apache2.conf en modifiant :

ServerName nom de ma machine

cela m'a permis d’accéder au page web du serveur apache depuis d'autre ordinateur du réseau local ainsi que depuis la dite machine,
en utilisant le nom de la machine avec une adresse dans le navigateur comme suit :

nom de ma machine//Nom du Site/index.php

Attention pour ce qui suit c'est pas très sécurisé mais ça me dépanne je ne suis qu'en réseau local pour cette machine.

pour développer depuis une autre machine j'ai partagé le répertoire /var/www avec samba en lecture écriture je ne suis qu en local pour cette machine.

j'ai aussi modifier les droits sur ce dit répertoire pour les modifier depuis une autre machine de mon réseau : /www appartient au groupe : www-data et utilisateur : www-data.

penser a redémarrer l'ordinateur après modifications.

Voila si ça peut vous aider c'est ce que j'ai fait chez moi et ca marche.

Hors ligne

#6 01-07-2017 18:17:17

natsu
Membre
Distrib. : Debian 8.8.0 i386
Noyau : linux 3.16.0-4-586
(G)UI : xfce
Inscription : 05-06-2017

Re : Apache2 prob droit 403 Forbidden You don't have permissions to access

Informations  complémentaire j'ai peut être modifié le fichier suivant toujours avec nano en root comme ci dessous.

penser a créer les répertoires cible pour les fichiers de log d'apache sinon apache bloque au redémarrage cf fichier de conf plus bas

avant modification utiliser dans un terminal  en root depuis le repertoire /etc/apache2/ :

pour désactiver le fichier de configuration du site :  a2dissite nom du site.conf

après modification toujours en root :
pour activer le fichier de configuration du site :  a2ensite nom du site.conf

redémarrer le service apache toujours en root

service apache2 restart

/etc/apache2/sites-available/nom du site.conf :

<VirtualHost *:80>
        ServerAdmin adressemail
        ServerName      www.nom du site.fr
        ServerAlias     nom du site.fr
        ServerAlias     *.nom du site.fr

        DocumentRoot /var/www/nom du site   
                DirectoryIndex  index.php
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>

        <Directory /var/www/nom du site>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Require all granted
        </Directory>

        ErrorLog /var/www/apache_log/error_nom du site.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/www/apache_log/access_nom du site combined

</VirtualHost>

Ce coup ci je crois que c'est tout.

Dernière modification par natsu (01-07-2017 18:27:02)

Hors ligne

Pied de page des forums