Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-06-2017 21:10:01

wheezzy
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : KDE 5 Plasma
Inscription : 10-09-2016

Win10&grub

Bonsoir !
Alors voila, voulant redémarrer sous windows pour bosser sur illustrator, j'ai vu à ma grande surprise que il ne démarre pas à partir de grub.
Mon fdisk :

Disque /dev/sda : 119,2 GiB, 128035676160 octets, 250069680 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : AB23B89E-0286-4BEB-BE9D-A9D35E61CE48

Périphérique    Début       Fin  Secteurs Taille Type
/dev/sda1        2048    923647    921600   450M Environnement de récupération Windows
/dev/sda2      923648   1128447    204800   100M Système EFI
/dev/sda3     1128448   1161215     32768    16M Réservé Microsoft
/dev/sda4     1161216  20692991  19531776   9,3G Données de base Microsoft
/dev/sda5    20692992 250068991 229376000 109,4G Données de base Microsoft

                                                                                                                                     
Disque /dev/sdb : 931,5 GiB, 1000204886016 octets, 1953525168 secteurs                                                              
Unités : secteur de 1 × 512 = 512 octets                                                                                            
Taille de secteur (logique / physique) : 512 octets / 4096 octets                                                                    
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets                                                                      
Type d'étiquette de disque : dos                                                                                                    
Identifiant de disque : 0x6d255d24                                                                                                  
                                                                                                                                     
Périphérique Amorçage      Début        Fin   Secteurs Taille Id Type                                                                
/dev/sdb1                   2046 1871599615 1871597570 892,5G  f Étendue W95 (LBA)                                                  
/dev/sdb2    *        1871601664 1953519615   81917952  39,1G 83 Linux                                                              
/dev/sdb5                   2048   20479999   20477952   9,8G  7 HPFS/NTFS/exFAT                                                    
/dev/sdb6               20482048 1699633151 1679151104 800,7G  7 HPFS/NTFS/exFAT                                                    
                                                                                                                                     
La partition 1 ne commence pas sur une frontière de cylindre physique.                                                              
Les entrées de la table de partitions ne sont pas dans l'ordre du disque.  


Je possède un SSD m2 128gb (Windows +9gb useless) et un hdd 1tb(800gb données, 40 Debian, 10 données2 et le reste je dois allouer à debian).
Mon grub.d/40_custom ( /etc/grub.d/40_custom/ )

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "Windows 8 (BCD-UEFI configuration on system drive /dev/sda2)" --class windows --class os {
            insmod part_msdos
            insmod ntfs
            insmod search_fs_uuid
            insmod chain

            search --no-floppy --set=root --fs-uuid 1D584C40586B2873
            chainloader /EFI/Microsoft/Boot/bootmgr.efi
}
 



Update grub ne semble pas trouver Windows..

Création du fichier de configuration GRUB…                                                                                          
Found background image: /usr/share/images/desktop-base/desktop-grub.png                                                              
Image Linux trouvée : /boot/vmlinuz-4.9.0-2-amd64                                                                                    
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-2-amd64                                                                      
Image Linux trouvée : /boot/vmlinuz-4.9.0-2-amd64                                                                                    
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-2-amd64                                                                      
Image Linux trouvée : /boot/vmlinuz-4.9.0-2-amd64                                                                                    
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-2-amd64                                                                      
fait  


Contenu du dossier /boot/efi/EFI/Microsoft/Boot/

BCD             BOOTSTAT.DAT  es-ES  hu-HU           kd_02_1969.dll  lv-LV        Resources      sv-SE
BCD.LOG         boot.stl      es-MX  it-IT           kd_02_19a2.dll  memtest.efi  ro-RO          tr-TR
BCD.LOG1        cs-CZ         et-EE  ja-JP           kd_02_8086.dll  nb-NO        ru-RU          uk-UA
BCD.LOG2        da-DK         fi-FI  kd_02_10df.dll  kd_07_1415.dll  nl-NL        SecConfig.efi  updaterevokesipolicy.p7b
bg-BG           de-DE         Fonts  kd_02_10ec.dll  kd_0C_8086.dll  pl-PL        sk-SK          winsipolicy.p7b
bootmgfw.efi    el-GR         fr-CA  kd_02_1137.dll  kdstub.dll      pt-BR        sl-SI          zh-CN
bootmgr.efi     en-GB         fr-FR  kd_02_14e4.dll  ko-KR           pt-PT        sr-Latn-CS     zh-HK
bootspaces.dll  en-US         hr-HR  kd_02_15b3.dll  lt-LT           qps-ploc     sr-Latn-RS     zh-TW
 



Et quand j'essaye de démarrer Windows par grub avec l'entrée plus haut:

erreur : no such device 1D584C40586B2873
erreur : fichier << /EFI/Microsoft/Boot/bootmgr.efi >> non disponible.
Appuyez pour continuer...


Cependant, lors ce que j'ouvre la 'console grub', et que je quitte, le pc continue sous Windows.
Une idée?


Asus ROG GL502VS (Win10,Debian 9 Stretch,Kqli)
Dell ATG e6400 (Debian 9 Stretch)
RPi 3 Plex

Hors ligne

#2 05-06-2017 22:39:31

Maygo
Membre
Distrib. : MX-16 v17.4
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfwm4 (xfce)
Inscription : 26-05-2017

Re : Win10&grub

Bonjour,

Cependant, lors ce que j'ouvre la 'console grub', et que je quitte, le pc continue sous Windows.



A mon avis c'est parce que en quittant ton premier lecteur à amorcer, il doit passer dirrectement au second. Et le second doit être ton SSD...

A mon avis il doit falloir que tu fasse pointer grub vers un autre disque ...
mon  /boot/grub/grub.cfg


menuentry 'Windows Boot Manager (sur /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-efi-F26E-600B' {
  insmod part_gpt
  insmod fat
  set root='hd0,gpt2'
  if [ x$feature_platform_search_hint = xy ]; then
    search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  F26E-600B
  else
    search --no-floppy --fs-uuid --set=root F26E-600B
  fi
  chainloader /efi/Microsoft/Boot/bootmgfw.efi
}
 



(j'ai pas modifier les entrées, et Windows 10 est sur le meme disque dur)
à mon avis ça doit se faire en spécifiant le disque en plus de la partition de boot, ici hd0,gtp2...
Mais j'en sais pas plus, si ça peut t'aiguiller ...

Regarde peut etre par ici, au point 3.1
https://doc.ubuntu-fr.org/tutoriel/grub … age_manuel

Hors ligne

Pied de page des forums