Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-06-2017 02:33:35

Gedeon54
Membre
Distrib. : Handylinux 2.5 sous Debian 9 (Stretch)
Noyau : 4.9.0-3-amd64
(G)UI : XFCE + Gnome Shell
Inscription : 13-05-2017

[RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Bonsoir!

Je trouve le navigateur opera très sympa...sauf que je ne parviens pas à y intégrer le plug-in adobe flash dans sa dernière version (45).: mwahaha.gif
De ce fait impossible de lire du streaming genre "France TV" ou "deezer"... Pourtant j'ai téléchargé le flashplugin-non free et l'ai extrait dans "usr/lib/flashplugin-non free", mais Opera version 45 ne le détecte pas. Chaque fois, il me demande de télécharger "Flash"... roll
J'ai lu sur un autre forum qu'il fallait (peut-être) déplacer libflashplugin.so dans  un dossier intitulé "user/lib/opera/plugins"..OUI, mais!
Ce dossier n'existe pas !!! J'ai cherché où se trouvait opera/plugins avec "locate" sur mon terminal, nada!!crash.gif
Dois-je le créerquestion.gif
Tout ce que je sais, c'est que le chemin d'Opéra se trouve dans: "/usr/lib/x86_64-linux-gnu/opera", que l'on n'y trouve aucune trace d'un dossier plug-in également.
Aussi je fais appel à votre sagacité pour me sortir de ce guêpier!
Je signale aussi que Firefox fonctionne parfaitement avec mon "flashplayer-non free!
A vous de jouer ..Merci encore!ops.gif

PS: oui, dans réglages, j'ai bien coché la case "activer flash"!!!

Dernière modification par Gedeon54 (11-06-2017 01:11:22)

Hors ligne

#2 06-06-2017 17:01:59

Gedeon54
Membre
Distrib. : Handylinux 2.5 sous Debian 9 (Stretch)
Noyau : 4.9.0-3-amd64
(G)UI : XFCE + Gnome Shell
Inscription : 13-05-2017

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Bon...pas de réponse...J'ai essayé d'avancer tout seul...sans succès! J'ai téléchargé libpepflashplayer.tar.gz sur le site Adobe, l'ai décompressé dans le fichier /usr/lib/pepperflashplugin-nonfree entièrement.(comme indiqué dans "read me")
Je viens de vérifier dans le dossier /usr/lib/x86_64-linux-gnu/opera/resources/pepper_flash_config.json que le chemin du fichier est bien indiqué...parmi une longue liste.. C'est le cas... Et pourtant, rien ne fonctionne au re-démarrage!!!
Personne pour m'aider? kernal_panic.gif

Hors ligne

#3 06-06-2017 20:21:51

fiche
Membre
Lieu : Paris
Distrib. : Debian Testing
Noyau : Linux 4.11.0-1-686-pae
(G)UI : Xfce
Inscription : 11-07-2016

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Bonsoir,

J'ai essayé chez moi :
1) Copier libpepflashplayer.so sous /usr/lib/i386-linux-gnu/opera/plugins/
2) Copier libflashplayer.so sous /usr/lib/i386-linux-gnu/opera/plugins/

Dans les deux cas, Flash n'est pas activé malgré la case cochée dans les réglages "Autoriser les sites à exécuter Flash".

Effectivement, c'est pénible. On va bien y arriver...

Dernière modification par fiche (06-06-2017 20:27:02)

Hors ligne

#4 06-06-2017 21:01:34

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Bonjour,

J'ai suivi le readme de Adobe.

Installation instructions
-------------------------
Installing using the plugin tar.gz:
    o Unpack the plugin tar.gz and copy all the files to /usr/lib/adobe-flashplugin/


J'ai copier les fichiers libpepflashplayer.so et manifest.json dans /usr/lib/adobe-flashplugin et ça fonctionne. smile

Opera est avec la bonne version de flash.

Si le dossier /usr/lib/adobe-flashplugin n'existe pas, il faut le créer.

Hors ligne

#5 06-06-2017 22:12:10

fiche
Membre
Lieu : Paris
Distrib. : Debian Testing
Noyau : Linux 4.11.0-1-686-pae
(G)UI : Xfce
Inscription : 11-07-2016

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Merci deuchdeb !
Cela fonctionne aussi chez moi.
C'est simple, encore fallait-il trouver l'information. Dommage que cela ne soit pas indiqué dans l'aide d'Opéra.

Hors ligne

#6 06-06-2017 22:37:59

Antidentity
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Cool, j'essaierai votre soluce! J'avais justement un site d'une commune réalisé uniquement en flash mais qui était illisible chez moi probablement en raison du flash dépassé (je devrais d'ailleurs penser à leur proposer mes services pour refaire leur site sans flash...)

En passant, connaissez-vous une méthode pour connaître la version de flash installée sur opéra? Car le about:about ou le about:plugins ne fournit rien.

Hors ligne

#7 07-06-2017 01:50:19

Gedeon54
Membre
Distrib. : Handylinux 2.5 sous Debian 9 (Stretch)
Noyau : 4.9.0-3-amd64
(G)UI : XFCE + Gnome Shell
Inscription : 13-05-2017

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Je viens d'essayer la solution de Moderato non troppo.. j'ai donc créé un dossier flashplayer-plugin dans /us/lib, j'y ai copié libpepflashplayer.so et l'autre , manifest json...   Mais rien n'y fait!! Opera 45 refuse toujours de détecter flashplayer...
J'ai essayé avec Deezer, France TV... Rien n'y fait! Suis je maudit ou quoi? Ça marche peut-être chez vous, ici, nada! Une idée???

Hors ligne

#8 07-06-2017 08:39:49

zorzi
Membre
Lieu : Dijon
Distrib. : Debian Stretch - XFCE
Noyau : Linux 4.9.0-3-amd64
Inscription : 30-09-2015

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Salut,

Tu as bien pris la version ppapi (celle pour chromium et opera) ? La npapi ne marche que sous Firefox. Voir liens ci-dessous:

http://labs.adobe.com/downloads/flashplayer.html

Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, DD 500 Go) / Debian Stretch (XFCE)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Stretch

Hors ligne

#9 07-06-2017 08:45:54

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Bonjour Gedeon54,

Deux autres choses:

Le première pas compliquée, le plugin est il activé dans ton navigateur?
La deuxième, il faut être administrateur pour créer  /usr/lib/adobe-flashplugin et copier les deux fichiers dedans.

cd /usr/lib/
mkdir adobe-flashplugin
cp /CheminOuEstLeFichier/libpepflashplayer.so .
cp /CheminOuEstLeFichier/manifest.json .
exit



ou

cd /usr/lib/
sudo mkdir adobe-flashplugin
sudo cp /CheminOuEstLeFichier/libpepflashplayer.so .
sudo cp /CheminOuEstLeFichier/manifest.json .
exit



Test Flash: https://get.adobe.com/fr/flashplayer/about/

Oui, flash et Linux ne sont pas copains!! lol

Hors ligne

#10 07-06-2017 11:08:28

Gedeon54
Membre
Distrib. : Handylinux 2.5 sous Debian 9 (Stretch)
Noyau : 4.9.0-3-amd64
(G)UI : XFCE + Gnome Shell
Inscription : 13-05-2017

Re : [RESOLU] Deezer et le navigateur Opera: installation mystère !!!

Merci encore Moderato ma non troppo !
1/ Oui, le plugin est activé dans le navigateur, puisque j'ai vérifié; la case "autoriser flash" dans "Paramètres" est bien cochée!
2/ Non, je ne me suis pas trompé, j'ai bien téléchargé libpepflashplayer.so pour Opéra et Chromium (version bêta ce matin 26, et 25 hier).
3/ J'ai créé le dossier adobe-flashplugin en mode graphique en utilisant "sudo thunar", ce qui revient je pense à la même chose qu'avec un terminal.
D'ailleurs, en vérifiant, les dossiers et fichiers sont bien présents dans "usr/lib"...
4/ De plus, j'ai tenté l'aventure avec un autre navigateur, Vivaldi, qui, je crois, fonctionne avec le même plugin...et d'ailleurs, lui, il marche avec "mon" libpeopflashplugin.so...!!! C'est à n'y rien comprendre...!!!! Vais je devoir laisser Opéra de côté? Dommage!!!
Un indice peut -être? J'ai installé auparavant (via Synaptic) pepperflashplugin-non free version 1.8.1 et je viens de m'apercevoir que toujours dans synaptic, il existe un "Flashplayer for chromium" (Pepper) version 25 non installé....Bizarre? Mais dans ce cas, si je coche installer.. ils me demandent de supprimer pepperflashplugin-non free... Est ce une bonne piste???

Bon, je me réponds à moi-même... j'ai fait le ménage dans mes dossiers et fichiers, je me suis rendu compte que libpepflash... s'était installé à plusieurs endroits à force de tentatives multiples. J'ai donc supprimé plusieurs d'entr'eux, notamment à l'intérieur même du dossier opéra où j'avais placé un dossier plugin..Et là, miracle, opera s'est mis à faire fonctionner adobe flash!merci.gif Alors, je suis désolé, mais c'est en mettant les mains dans le cambouis que j'ai résolu le problème mais je suis incapable de donner les raisons précises...L'essentiel est là.idea.gif

cthulhu.gifMais comme je suis un gars perfectionniste et compliqué...Je n'ai pas réussi à faire marcher spotify!! Opéra m'indique que je n'ai pas activé les drm, ce qui est faux. Pour que cela fonctionne, je crois qu'il faut deux fichiers: "libwidevinecdm.so" et "libwidevinecdadapter.so" disponibles sur chromium ou chrome...Mais comme je n'ai ni l'un ni l'autre...Comment faire????? SOS Spotifier en détresse!!!mrgreen.gif

Dernière modification par Gedeon54 (09-06-2017 02:05:38)

Hors ligne

Pied de page des forums