Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-06-2017 19:39:01

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

[Résolu] problème de librairie : libpng12.so.0

Bonjour a tous,

Vue les réponses de qualité et la rapidité de la dernière fois , je me gène pas pour vous poser un nouveau problème qui commence a devenir problematique , je vais essayer de vous donnez un maximum d'information suceptible de vous aider a trouver une solution au problème.

Donc , voici mon problème j'ai voulu installer un jeu (Dofus 2) j'ai donc suivit la procédure indiquer sur la doc ubuntu :

1 . décompression de l'archive tzr.gz
2 . J'ai lancer le lanceur ./Dofus

et l'erreur arrive a ce moment :

/home/booskap/Dofus/transition/ankama-transition-dofus: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
Dofus launcher failed to start or encountered an error



J'ai déjà vérifié que la lib existait bien , elle existe mais dans une version supérieur libpng16 est-ce problématique ou non je ne sais pas !

Est-ce qu'une question de liens ? ( Je ne sais pas comment ça fonctionne exactement)

Si quelqu'un connait une solution autre que Wine je l'en remercie d'avance !

Dernière modification par Booskap (29-06-2017 20:37:03)

Hors ligne

#2 27-06-2017 22:48:59

eriicjii
Membre
Distrib. : Debian Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Kde
Inscription : 05-04-2017

Re : [Résolu] problème de librairie : libpng12.so.0

Bonsoir,

J'ai eu le même souci pour installer l'ancienne version de foobillard.

J'ai téléchargé le paquet libpng12 sur cette page : https://packages.debian.org/search?keywords=libpng12-0

Puis je l'ai installé (en root et dans un terminal) avec la commande dpkg -i

Si ça peut servir...

Hors ligne

#3 28-06-2017 12:14:21

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

Re : [Résolu] problème de librairie : libpng12.so.0

eriicjii a écrit :

Bonsoir,

J'ai eu le même souci pour installer l'ancienne version de foobillard.

J'ai téléchargé le paquet libpng12 sur cette page : https://packages.debian.org/search?keywords=libpng12-0

Puis je l'ai installé (en root et dans un terminal) avec la commande dpkg -i

Si ça peut servir...



C'est tout con mais ça doit être ça je teste ce soir puis j'edit merci a toi ! big_smile

EDIT : Je viens de remarqué que tu étais sous Jessie, je sais pas si il faut faire une manip ou pas du coups dans le sources.list ..?

Dernière modification par Booskap (28-06-2017 19:13:56)

Hors ligne

#4 28-06-2017 20:38:33

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

Re : [Résolu] problème de librairie : libpng12.so.0

J'ai finalement ajouter les dépots a mon source.list et fais un simple apt-get libpng12-0 et ça a bien fonctionner maintenant je vais essayer de trouver la solution pour mon nouveau problème ..kernal_panic.gif

Hors ligne

Pied de page des forums