Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-06-2017 20:36:22

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

Ia32-libs sous Debian 9 ?

Bonsoir, big_smile

Je viens de remarquer que le paquet ia32-libs était qualifié de "old-list" je ne sais pas si il y a un rapport avec les distrib ou non ? Mais est-il possible dans mon cas d'installer ce paquet en sachant que je dispose d'une version stable, comment procède t-on ? scratchhead.gif

Si vous avez des documentations ou une solution a suggérer je vous remercie de m'en faire part ! help.gif

ia32-libs :

https://packages.debian.org/search?lang … =ia32-libs

et voici l'erreur indiqué dans le terminal :

apt-get update
apt-get install ia32-libs


Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée



Conclusion faut-il que j'edit mon sources.list et que je rajoute un mirror Wheezy ?scratchhead.gif

Merci de vos réponses !merci.gif

Hors ligne

#2 29-06-2017 20:50:50

naguam
Membre
Distrib. : Plusieurs
Noyau : Un kernel
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Ia32-libs sous Debian 9 ?

Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5



Installes les et essayes d'installer ton appli 32bit ensuite. smile

apt install lib32z1 lib32ncurses5

Dernière modification par naguam (29-06-2017 20:51:05)

Hors ligne

#3 29-06-2017 21:02:18

vv222
Modérateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.13 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Ia32-libs sous Debian 9 ?

Houla, ce paquet est périmé depuis l’arrivée du multiarch au sein de Debian, ça fait maintenant des années.
Qu’est-ce que tu essayes d’installer qui te demande ce paquet ?

Jouer sous Debian ? Facile !

Hors ligne

#4 29-06-2017 21:06:10

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

Re : Ia32-libs sous Debian 9 ?

naguam a écrit :

Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5



Installes les et essayes d'installer ton appli 32bit ensuite. smile

apt install lib32z1 lib32ncurses5



Je vais faire plus simple je vais utiliser Wine pour installer Dofus kernal_panic.gif

Hors ligne

#5 29-06-2017 21:06:55

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

Re : Ia32-libs sous Debian 9 ?

vv222 a écrit :

Houla, ce paquet est périmé depuis l’arrivée du multiarch au sein de Debian, ça fait maintenant des années.
Qu’est-ce que tu essayes d’installer qui te demande ce paquet ?



Adobe Air 2.6 pour que Dofus 2 fonctionne et encore je suis pas sur que ce soit la sources de mon problème ..

Hors ligne

#6 29-06-2017 22:02:18

naguam
Membre
Distrib. : Plusieurs
Noyau : Un kernel
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Ia32-libs sous Debian 9 ?

Il me semble que le multiarch permet seulement d'installer des paquets d'une autre architecture (HS: ce qui est utile par exemple quand on bidouille du arm, le paquet armhf avec les binaires u-boot) mais cela (toujours il me semble) ne permet pas d'utiliser des paquets fonctionnels (je ne sais pas par exemple firefox) d'une autre architecture, seulement de les installer

D'ailleurs pour faire fonctionner des paquets d'une autre architecture, il faut la plupart du temps émuler un os avec cette architecture.

moi-même naguam a écrit :

Il y a des exceptions; L'architecture i386 (x86) et l'architecture amd64 (x86_64) ont la même architecture en interne physique mais ce qui fait leur différence pour leur sysème, c'est leur nombre de pointeurs mémoire, comme les noms entres parenthèses l'indique i386 (et dérivés comme i486 i586 i686) = x86 avec 32 pointeurs mémoire, le amd64 = x86 avec 64 pointeurs mémoires (d'où le x86_64)

Les programmes amd64 ne sont pas compatibles i386 sauf émulation car on ne peut pas inventer les 32 pointeurs mémoires manquantes pour le programme, mais par contre un programme i386 fonctionnera sous amd64 car 32 pointeurs mémoires < en nombre que 64 pointeurs mémoires

Windows 32bit est équivalent à x86 avant i686 voir avant i585 (car windows 32bit ne peut pas prendre plus de 3GB ram (enfin sous win7 il y a quelques années c'était le cas)) et les programmes windows 32bit, sans aucunes dépendances fonctionnent sous windows 64bit (d'expérience pour moi à moins que j'ai rèvé du moment où je l'ai fait)

Sous debian, depuis jessie les développeurs ont arrêtés le support i586 pour du i686 qui supporte le pae (pae = programmes 32bit fonctionnent mais c'est 36bits officieux pour que le proc supporte plus de ram (plus de 3GB voir mon explication pour windows) le i686 permet jusqu'à 64GB ram max.

Du coup pour cette histoire de pae il faut ajouter des paquets (maintenant ces nouveaux paquets post #1 et #2 qui remplaçent ia32libs maintenant dépacé) pour faire fonctionner des paquets dis i386 mais compilés i686-pae. (il me semble)

Je ne sais pas par contre des paquets i586 si ils fonctionnent amd64 natif ou pas surement pas non plus car ia32libs existitait

Pour mon explication, par contre sans aucune dépendance étranges tels un équivalent de ia32lib, les paquets i486 fonctionneront sur i586 et les i586 ne fonctionneront  sur i686 mais i686 ne fonctionnera pas sur i586 et i586 ne fonctionnera pas sur i486.

Bref ce que je dis là est de tête et je me suis peut-être contredis ou dis une erreur en essayant de simplifier, mais dans ma tête tout est clair j'ai essayé de faire passer ce que je sais du mieux que je peux, j'èspère que vous avez compris le gros du sujet.



Bref

Le système du multiarch sous debian permet d'installer un programme (et ses propres dépendance) de n'importe quelle architecture, mais pas d'être fonctionnel.

Pour certaines architectures il est quand même possible sans émulation de faire fonctionner les programmes d'une autre architecture installés grâce au multiarch grâce à une ou des dépendances (programme i386 fonctionnera (et pas seulement installé) sous amd64 grâce aux équivalent de ia32libs aujourd'hui)

Maintenant c'est très peu utilisé sauf pour des programmes propriétaires disponibles qu'en 32bits à faire fonctionner sur un amd64 tel steam à une époque (je ne sais pas si c'est toujours le cas).

vv222 a écrit :

:

    Houla, ce paquet est périmé depuis l’arrivée du multiarch au sein de Debian, ça fait maintenant des années.
    Qu’est-ce que tu essayes d’installer qui te demande ce paquet ?



vv222 d'après mon explication il semblerait que ce paquet est périmé pour être remplacé par deux autres ( sinon que penses-tu de mon explication smile ? )



Sinon, vv222 un lien qui peut t'intéresser: https://fr.wikipedia.org/wiki/X32_ABI debian est d'ailleurs en train de créer un portage cette architecture de ce lien.
Ps: ne regarder pas le lien si vous n'êtes pas à l'aise avec les architectures.

Dernière modification par naguam (29-06-2017 22:42:27)

Hors ligne

#7 30-06-2017 08:25:31

vv222
Modérateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.13 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Ia32-libs sous Debian 9 ?

naguam a écrit :

vv222 d'après mon explication il semblerait que ce paquet est périmé pour être remplacé par deux autres ( sinon que penses-tu de mon explication smile ? )


Tu n’y es pas tout à fait, il a été remplacé par des milliers de paquets wink

Maintenant pour installer la version 32-bit de libc6 par exemple, on peut utiliser :

apt install libc6:i386


Et c’est pareil pour n’importe quel paquet ayant une version 32-bit.

On peut donc installer individuellement les paquets dont on a besoin en version 32-bit, plus besoin de l’affreux ia32-libs.


Jouer sous Debian ? Facile !

Hors ligne

#8 30-06-2017 09:44:18

naguam
Membre
Distrib. : Plusieurs
Noyau : Un kernel
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Ia32-libs sous Debian 9 ?

Oui on peut installer et pour crosscompiler pas besoin de ia32libs (libc6 est une collection de librayrie il me semble)

Par contre sans ce qui maintenant remplace ia32libs on ne peut pas utiliser de paquets fonctionnels tel que steam i386 (librairy c'est passif steamfonctionnel tu vois)

Grace au multiarch on peut installer de n'importe quelle architecture mais installe firefox:armhf sur du amd64 ç'a s'installe mais ne fonctionne pas. Par contre avec libc6:armh on peut depuis amd64 (avec d'autres paquets et dépendances:armhf ou pas:armhf ) crosscompiler
(d'ailleurs essaye d'installer firefox:i386 sur amd64 (en vérifiant que les équivalent de ia32libs ne sont pas en dépendance; tu verra que cela s'installera mais je ne mettrait pas ma main a couper que cela fonctionne)


Mais tu as raison avec le multiarch, on peut installer
mais c'est toujours pour l'histoire de faire fonctionner les programmes qui'il faut prendre en compte. (voir les deux micros paragraphes précédants dans ce post)

PS: mais aujourd'hui on utilise très peu ia32lib (enfin ces équivalents) car à par certain rares programmes proprios. il est inutile car sinon aujourd'hui tout est quasiment disponible pour amd64.
C'est qu'aux tout débuts de amd64 (avec les athlon64 etc) on faisait souvent tourner des paquets avec ia32libs car la plupart paquets proprios à l'époque n'étaient pas encore portés.
Chez opensuse c'était flagrant http://frederic.bezies.free.fr/blog/?p=1901 (pour fllash qui n'était pas encore sorti en 64bit?)

Dernière modification par naguam (30-06-2017 09:53:49)

Hors ligne

#9 30-06-2017 09:56:49

cyrille
Membre
Lieu : Saint-Pierre la Mer
Distrib. : debian stable
(G)UI : Xfce
Inscription : 08-07-2016
Site Web

Re : Ia32-libs sous Debian 9 ?

Booskap a écrit :

vv222 a écrit :

Houla, ce paquet est périmé depuis l’arrivée du multiarch au sein de Debian, ça fait maintenant des années.
Qu’est-ce que tu essayes d’installer qui te demande ce paquet ?



Adobe Air 2.6 pour que Dofus 2 fonctionne et encore je suis pas sur que ce soit la sources de mon problème ..



pour l'installation d'adobe air, tu peux regarder ici je pense : https://cyrille-borne.com/article4149/i … ch-64-bits

je résous la problématique de adobe air pour faire fonctionner scratch

Hors ligne

#10 30-06-2017 10:16:48

vv222
Modérateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.13 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Ia32-libs sous Debian 9 ?

Merci cyrille pour l’exemple d’utilisation du multilib avec Debian, c’est plus clair comme ça qu’avec mon exemple déconnecté d’un cas réel wink

-----

naguam, je peux t’assurer que firefox:i386 fonctionnera sans souci sur une Debian amd64.
Dans le cas contraire, il y a un rapport de bug à ouvrir big_smile

En fait les paquets i386 sont très souvent nécessaires sur une Debian amd64 quand on cherche à installer des jeux non-libres, encore souvent compilés uniquement pour des systèmes 32-bit.

Jouer sous Debian ? Facile !

Hors ligne

#11 30-06-2017 15:18:33

cyrille
Membre
Lieu : Saint-Pierre la Mer
Distrib. : debian stable
(G)UI : Xfce
Inscription : 08-07-2016
Site Web

Re : Ia32-libs sous Debian 9 ?

bon je passe, j'ai réussi à lancer le jeu, je me fendrai d'un billet de blog demain certainement.

Hors ligne

#12 30-06-2017 23:49:21

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

Re : Ia32-libs sous Debian 9 ?

vv222 a écrit :

naguam a écrit :

vv222 d'après mon explication il semblerait que ce paquet est périmé pour être remplacé par deux autres ( sinon que penses-tu de mon explication smile ? )


Tu n’y es pas tout à fait, il a été remplacé par des milliers de paquets wink

Maintenant pour installer la version 32-bit de libc6 par exemple, on peut utiliser :

apt install libc6:i386


Et c’est pareil pour n’importe quel paquet ayant une version 32-bit.

On peut donc installer individuellement les paquets dont on a besoin en version 32-bit, plus besoin de l’affreux ia32-libs.

naguam a écrit :

Oui on peut installer et pour crosscompiler pas besoin de ia32libs (libc6 est une collection de librayrie il me semble)

Par contre sans ce qui maintenant remplace ia32libs on ne peut pas utiliser de paquets fonctionnels tel que steam i386 (librairy c'est passif steamfonctionnel tu vois)

Grace au multiarch on peut installer de n'importe quelle architecture mais installe firefox:armhf sur du amd64 ç'a s'installe mais ne fonctionne pas. Par contre avec libc6:armh on peut depuis amd64 (avec d'autres paquets et dépendances:armhf ou pas:armhf ) crosscompiler
(d'ailleurs essaye d'installer firefox:i386 sur amd64 (en vérifiant que les équivalent de ia32libs ne sont pas en dépendance; tu verra que cela s'installera mais je ne mettrait pas ma main a couper que cela fonctionne)


Mais tu as raison avec le multiarch, on peut installer
mais c'est toujours pour l'histoire de faire fonctionner les programmes qui'il faut prendre en compte. (voir les deux micros paragraphes précédants dans ce post)

PS: mais aujourd'hui on utilise très peu ia32lib (enfin ces équivalents) car à par certain rares programmes proprios. il est inutile car sinon aujourd'hui tout est quasiment disponible pour amd64.
C'est qu'aux tout débuts de amd64 (avec les athlon64 etc) on faisait souvent tourner des paquets avec ia32libs car la plupart paquets proprios à l'époque n'étaient pas encore portés.
Chez opensuse c'était flagrant http://frederic.bezies.free.fr/blog/?p=1901 (pour fllash qui n'était pas encore sorti en 64bit?)



ça veut dire que je ne peux pas installer adobeAir en utilisant les paquets qui remplace ia32-libs ?

cyrille a écrit :

Booskap a écrit :

vv222 a écrit :

Houla, ce paquet est périmé depuis l’arrivée du multiarch au sein de Debian, ça fait maintenant des années.
Qu’est-ce que tu essayes d’installer qui te demande ce paquet ?



Adobe Air 2.6 pour que Dofus 2 fonctionne et encore je suis pas sur que ce soit la sources de mon problème ..



pour l'installation d'adobe air, tu peux regarder ici je pense : https://cyrille-borne.com/article4149/i … ch-64-bits

je résous la problématique de adobe air pour faire fonctionner scratch



J'ai installé Scratch il se lance bien , ça prend la place de AdobeAir si j'ai compris ? j'ai de mauvaise installation et des dossiers qui ce sont créer dans opt les supprimer suffira ?

Mon jeux fonctionne toujours pas , j'essaye de comprendre ce qui ne va pas ..

Dernière modification par Booskap (01-07-2017 00:36:54)

Hors ligne

#13 01-07-2017 09:39:02

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

Re : Ia32-libs sous Debian 9 ?

cyrille a écrit :

bon je passe, j'ai réussi à lancer le jeu, je me fendrai d'un billet de blog demain certainement.



Il ne t'as pas demander de libpng12-0 ? ou autre a l'installation de Dofus ?
J'ai du l'installer sur mon ordinateur , je ne sais pas si c'est possible de demander a utilisé la dernière version de libpng la rendre compatible ?

Dernière modification par Booskap (01-07-2017 09:42:07)

Hors ligne

#14 01-07-2017 14:36:17

cyrille
Membre
Lieu : Saint-Pierre la Mer
Distrib. : debian stable
(G)UI : Xfce
Inscription : 08-07-2016
Site Web

Re : Ia32-libs sous Debian 9 ?

il ne me l'a pas demandé pour la librairie

https://cyrille-borne.com/article4169/i … ch-64-bits

Hors ligne

#15 02-07-2017 17:39:29

Booskap
Membre
Distrib. : Stretch
Noyau : Debian 9
(G)UI : Gnome 3.22.2
Inscription : 25-06-2017

Re : Ia32-libs sous Debian 9 ?

cyrille a écrit :

il ne me l'a pas demandé pour la librairie

https://cyrille-borne.com/article4169/i … ch-64-bits



Moi il me la demande , quand je télécharge cette lib ça continue mais autrement voici l'erreur que j'obtiens :

booskap@debian:~/Téléchargements/Ankama/Dofus$ ./Dofus
 


/home/booskap/Téléchargements/Ankama/Dofus/transition/ankama-transition-dofus:
error while loading shared libraries: libpng12.so.0:
cannot open shared object file:
No such file or directory



C'est peu être compliqué parce que je brûle un peu les étapes (je suis nouveau sous linux..), j'ai installer dofus a l'aide du ./Dofus mais j'arriver par a le désinstaller peut être que ça m'aiderai ?
sos.gif

Hors ligne

#16 03-07-2017 12:54:58

cyrille
Membre
Lieu : Saint-Pierre la Mer
Distrib. : debian stable
(G)UI : Xfce
Inscription : 08-07-2016
Site Web

Re : Ia32-libs sous Debian 9 ?

installe la librairie si elle te manque par contre ça doit être de la libpng12:i386

Hors ligne

#17 03-07-2017 18:31:27

vv222
Modérateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.13 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Ia32-libs sous Debian 9 ?

Le paquet libpng12 n’existe plus au sein de Stretch (il a été remplacé par libpng16-16), il faut aller le chercher dans une version précédente de Debian.

Jouer sous Debian ? Facile !

Hors ligne

#18 03-07-2017 22:08:32

cyrille
Membre
Lieu : Saint-Pierre la Mer
Distrib. : debian stable
(G)UI : Xfce
Inscription : 08-07-2016
Site Web

Re : Ia32-libs sous Debian 9 ?

j'ai dû le faire pour installer un logiciel, ça ne pose aucun problème.

Hors ligne

Pied de page des forums