Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-07-2017 14:21:10

fipon
Membre
Distrib. : Debian 9.0
Noyau : Linux 4.9.0-3-686-pae
(G)UI : lxde
Inscription : 27-06-2017

(Résolu) Pavé numérique non activé avec numlockx

Bonjour,
Sur mon portable le pavé numérique n'est pas activé au démarrage. Je suis sous lxde et debian 9.0 et j'ai installé numlockx. Je sais qu'il n'est pas activé par défaut et j'ai suivi plusieurs tutos mais rien ne fait pour le moment. Si quelqu'un a une idée je suis preneur.
Amicalement

Dernière modification par fipon (01-07-2017 18:27:13)

Hors ligne

#2 01-07-2017 14:33:13

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : (Résolu) Pavé numérique non activé avec numlockx

Re bonjour smile
Quelle est la marque et le modèle du portable ?
Le pavé n'est pas activé après la connexion de la session utilisateur ou avant ?

Hors ligne

#3 01-07-2017 14:41:16

Otrebla
Membre
Distrib. : Debian Stretch 9.0 - Bodhi Linux 4.3.1
Noyau : Linux 4.9.0-3-amd64
(G)UI : Xfce 4.12.3 - Moksha
Inscription : 05-01-2017

Re : (Résolu) Pavé numérique non activé avec numlockx

Bonjour,

Il faut installer le paquet ldmconf, qui n'est pas installé par défaut avec Debian 9. Puis activer le pavé numérique dans ldmconf.

Caribou22 a écrit:

LDMconf était un outil déveoloppé par les 3HG pour DFlinux, donc hors dépôts Debian. Il a été remplacé par LightDM GTK+ Greeter configuration qui ne gère plus numlockx.
Solution un peu bricolée pour récupérer LDMconf, récupérer et installer le .deb depuis le dépôt. Lien direct : http://lescahiersdudebutant.fr/DFrepo/d … -8_all.deb


J'espère que ça t'aide smile

Dernière modification par Otrebla (01-07-2017 14:50:47)

Hors ligne

#4 01-07-2017 14:42:32

èfpé
Membre
Inscription : 10-07-2016

Re : (Résolu) Pavé numérique non activé avec numlockx

Bonjour fipon,

Quand NumLockX est informé par le script laptop-detect que la machine est un portable, la commande 'numlockx on' n'est pas exécutée au démarrage. Le paquet laptop-detect est-il effectivement installé ?

apt-cache policy laptop-detect

laptop-detect:
  Installé : 0.13.8
  Candidat : 0.13.8
 Table de version :
 *** 0.13.8 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status


Si oui, que donne la commande suivante :

laptop-detect --verbose


Souhaites-tu que le pavé numérique soit activé dès l'écran de connexion (LXDM), ou après suffira ?

Dernière modification par èfpé (03-07-2017 22:54:32)

Hors ligne

#5 01-07-2017 15:47:03

fipon
Membre
Distrib. : Debian 9.0
Noyau : Linux 4.9.0-3-686-pae
(G)UI : lxde
Inscription : 27-06-2017

Re : (Résolu) Pavé numérique non activé avec numlockx

Déjà un grand merci pour vos réponses rapides smile
Laptop-detect est installé et la commande laptop-detect --verbose me renvoie : We're a laptop (dmidecode returned Notebook)

le pavé numérique actif dès l'écran de connexion lxdm serait bien.

Hors ligne

#6 01-07-2017 15:56:24

èfpé
Membre
Inscription : 10-07-2016

Re : (Résolu) Pavé numérique non activé avec numlockx

Re-,

Alors, je ne pense pas que la solution que j'ai à te proposer fonctionne dès l'écran de connexion, mais une fois la session ouverte, cela devrait le faire :

nano /etc/default/numlockx

# Configuration file for numlockx

# State of numlog on start of X session
# Accepts following options:
#  auto - turns numlock on unless ran on laptop
#  on - turns numlock on
#  off - turns numlock off
#  keep - does not change numlock state
#  toggle - toggles numlock state
NUMLOCK=auto


Remplace 'NUMLOCK=auto' par 'NUMLOCK=on' et valide la modification... c'est tout smile

edit: pour l'écran de connexion cela se passe dans le fichier de configuration de LXDM,

cat /etc/lxdm/default.conf

ou

cat /etc/lxdm/lxdm.conf


mais je ne peux pas tester, réfère-toi à la page man de lxdm ou attends d'autres avis.

Dernière modification par èfpé (02-07-2017 10:56:24)

Hors ligne

#7 01-07-2017 16:30:44

fipon
Membre
Distrib. : Debian 9.0
Noyau : Linux 4.9.0-3-686-pae
(G)UI : lxde
Inscription : 27-06-2017

Re : (Résolu) Pavé numérique non activé avec numlockx

Ta première solution fonctionne impecc smile
Les deux lignes en user ne me renvoient rien mais ce n'est pas grave : je ne mettrai pas de chiffre dans mon mot de passe !
Un grand merci !

Hors ligne

#8 01-07-2017 16:56:12

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : (Résolu) Pavé numérique non activé avec numlockx

Ce n'est pas lightdm mais lxdm pour lxde le manager de connexion ?
Si ton problème est résolu, il faut l'indiquer dans le titre wink

Hors ligne

#9 01-07-2017 17:18:32

èfpé
Membre
Inscription : 10-07-2016

Re : (Résolu) Pavé numérique non activé avec numlockx

Re-,

Oups, chalu doit avoir raison (d'ailleurs c'est simple, une modératrice a toujours raison neutral), que donne :

env | grep lightdm


Du coup ça se passe dans le fichier de configuration de LightDM (/etc/lightdm/lightdm.conf).

Hors ligne

#10 01-07-2017 18:04:54

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : (Résolu) Pavé numérique non activé avec numlockx

Solution "environement independant" c'est d'installer "numlockx" et de lancer "numlockx on" dans les applis au démarrage essaie de le faire dans un terminal et dis-nous ce qui sort wink.

Dernière modification par otyugh (01-07-2017 18:20:52)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#11 01-07-2017 18:06:14

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : (Résolu) Pavé numérique non activé avec numlockx

èfpé a écrit :

d'ailleurs c'est simple, une modératrice a toujours raison

non lol et c'est bien dommage peace_flag.gif

Hors ligne

#12 01-07-2017 18:28:42

fipon
Membre
Distrib. : Debian 9.0
Noyau : Linux 4.9.0-3-686-pae
(G)UI : lxde
Inscription : 27-06-2017

Re : (Résolu) Pavé numérique non activé avec numlockx

C'est beau la modestie !
En tous cas merci à tous wink

Hors ligne

Pied de page des forums