Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-07-2017 14:08:30

Gedeon54
Membre
Distrib. : Handylinux 2.5 sous Debian 9 (Stretch)
Noyau : 4.9.0-3-amd64
(G)UI : XFCE + Gnome Shell
Inscription : 13-05-2017

[RESOLU] Radiotray et Debian 9 problème d'installation

Bonjour !!!
Je suis fan de Radiotray, cette petite appli qui permet d'écouter ses radios préférées tout en surfant ou en travaillant. Or, depuis mon passage sous Debian 9 (stretch), je ne la retrouve plus. Je suis allé chercher la nouvelle version sur https://packages.debian.org/stretch/radiotray, j'ai tenté de l'installer via Gdebi ou Synaptic... Impossible! Apparemment , il me manquerait des dépendances (non satisfaites). Synaptic m'indique même  sur Radiotray version 0.7.3.6: "paquet cassé" (carré rouge).

J'ai essayé d'installer une à une les dépendances manquantes, mais la principale me  pose problème (il s'agit de gstreamer1.0-plugins-badbad). Voici ce que j'obtiens:

gstreamer1.0-plugins-bad:
  Dépend : libgstreamer-plugins-base1.0-0 (>=1.12.0) mais 1.10.4-1 doit être installé
  Dépend : libgstreamer1.0-0 (>=1.12.0) mais 1.10.4-1 doit être installé
Dépend : liblilv-0-0 mais ne doit pas être installé
Dépend : libmjpegutils-2.1-0 mais ne doit pas être installé
Dépend : libmpeg2encpp-2.1-0 mais ne doit pas être installé
Dépend : libmplex2-2.1-0 mais ne doit pas être installé
Dépend : libsbc1 mais ne doit pas être installé
Dépend : libserd-0-0 mais ne doit pas être installé
Dépend : libsord-0-0 mais ne doit pas être installé
Dépend : libsoundtouch1 mais ne doit pas être installé
Dépend : libsratom-0-0 mais ne doit pas être installé
Dépend : libsrtp0 mais ne doit pas être installé
Dépend : libwildmidi2 mais ne doit pas être installé


Que faire? Je n'y comprends rien. Merci de votre aide !!

Dernière modification par Gedeon54 (08-09-2017 00:00:21)

Hors ligne

#2 02-07-2017 14:25:13

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] Radiotray et Debian 9 problème d'installation

Bonjour smile
Tu as sans doute utilisé des dépôts non officiels et/ou installés des logiciels externes car la version demandée est supérieures à celle de stretch
Que retourne

apt-cache policy gstreamer1.0-plugins-bad radiotray

Hors ligne

#3 03-07-2017 02:11:01

Gedeon54
Membre
Distrib. : Handylinux 2.5 sous Debian 9 (Stretch)
Noyau : 4.9.0-3-amd64
(G)UI : XFCE + Gnome Shell
Inscription : 13-05-2017

Re : [RESOLU] Radiotray et Debian 9 problème d'installation

Bonsoir...
Voilà :

$ apt-cache policy gstreamer1.0-plugins-bad radiotray
gstreamer1.0-plugins-bad:
  Installé : (aucun)
  Candidat : 1:1.12.1-dmo1
Table de version :
     1:1.12.1-dmo1 500
        500 http://www.deb-multimedia.org testing/main amd64 Packages
     1:1.10.4-dmo2 500
        500 http://www.deb-multimedia.org stretch/main amd64 Packages
     1.12.1-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu devel-proposed/universe amd64 Packages
     1.10.4-1 500
        500 http://httpredir.debian.org/debian stretch/main amd64 Packages
radiotray:
  Installé : (aucun)
  Candidat : 0.7.3-6
Table de version :
     0.7.3-6 500
        500 http://httpredir.debian.org/debian stretch/main amd64 Packages



Edit à toto :

Voici comment on utilise les balises Commande user du forum pour l'écrire lisiblement sur le forum :
(Pour en voir l'écriture, cliquer sur Modifier en bas à droite du post.)

apt-cache policy gstreamer1.0-plugins-bad radiotray


gstreamer1.0-plugins-bad:
  Installé : (aucun)
  Candidat : 1:1.12.1-dmo1
Table de version :
     1:1.12.1-dmo1 500
        500 http://www.deb-multimedia.org testing/main amd64 Packages
     1:1.10.4-dmo2 500
        500 http://www.deb-multimedia.org stretch/main amd64 Packages
     1.12.1-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu devel-proposed/universe amd64 Packages
     1.10.4-1 500
        500 http://httpredir.debian.org/debian stretch/main amd64 Packages
radiotray:
  Installé : (aucun)
  Candidat : 0.7.3-6
Table de version :
     0.7.3-6 500
        500 http://httpredir.debian.org/debian stretch/main amd64 Packages

Hors ligne

#4 03-07-2017 08:52:36

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] Radiotray et Debian 9 problème d'installation

Donc effectivement tu as le dépôt multimédia sur testing et stretch et visiblement sans fichier de préférence pour qu'ils ne soient pas prioritaires, ils sont tous à 500,  et de même tu as un dépôt lubuntu. Tu as fait un dist-upgrade avec ces dépôts, ça doit être un peu le bazar dans les paquets. hmm
Tu peux faire un fichier de préférence pour tous tes dépôts externes afin qu'ils arrêtent de passer avant les dépôts stretch avec leurs versions plus récentes des paquets.
Le wiki pour faire ce fichier préférences (pinning) https://debian-facile.org/doc:systeme:apt:pinning
Maintenant à ta place je referais une installation propre de stretch, je pense que tu auras sans doute des soucis avec des paquets déjà installés provenant des dépôts externes et qui risquent de gêner des mises à jour ou des installations de logiciels.
Bon courage smile

Hors ligne

#5 15-07-2017 14:19:54

Gedeon54
Membre
Distrib. : Handylinux 2.5 sous Debian 9 (Stretch)
Noyau : 4.9.0-3-amd64
(G)UI : XFCE + Gnome Shell
Inscription : 13-05-2017

Re : [RESOLU] Radiotray et Debian 9 problème d'installation

Merci Chalu !merci.gif

Ma réponse est plutôt tardive, mais peu importe. En effet , je ne me hasardais pas à me lancer dans une aventure plutôt délicate. Il y avait conflit dans mes dépôts multimédia. Grâce à l'astuce que tu m'as indiquée, j'ai pu corriger cela dans le fichier /et/apt/ préférences. (j'en ai profité pour éliminer le dépôt lubuntu). En rechargeant les paquets tout s'est remis en ordre de marche, j'ai pu télécharger le paquet gstreamer-bad 10 qui faisait défaut sur radiotray.
De fait j'ai re-installé radiotray qui fonctionne à nouveau ! Merci donc !!!:D
Mais comme rien n'est parfait dans ce monde, j'ai pu constater qu'en voulant configurer les radios et notamment en voulant en ajouter qq unes, cela était devenu impossible. La touche "Ajouter"  est inefficiente, en d'autre terme elle marche pas J'ai cliqué x fois, sans résultat..les autres fonctions sont OK. !!!! Est ce quelqu'un a constaté le même bug sur cette version de Radiotray 0.7.3.6 ???scratchhead.gif

Hors ligne

#6 15-07-2017 15:48:48

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] Radiotray et Debian 9 problème d'installation

Bonjour,

Non aucun souci constaté pour ajouter une radio en version 0.7.3 (0.7.3-6) :

Clic droit > Configurer les radios... > Ajouter


Change de thème peut-être ? Sinon, édite le fichier bookmarks.xml.

Hors ligne

#7 18-07-2017 18:54:28

Gedeon54
Membre
Distrib. : Handylinux 2.5 sous Debian 9 (Stretch)
Noyau : 4.9.0-3-amd64
(G)UI : XFCE + Gnome Shell
Inscription : 13-05-2017

Re : [RESOLU] Radiotray et Debian 9 problème d'installation

Bonsoir !

Bon... et bien je suis apparemment une exception..bah.. je me débrouillerai en allant tripatouiller le fichier xml en attendant!

Hors ligne

Pied de page des forums