Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-07-2017 15:21:30

Jielelbis
Membre
Distrib. : Debian 9.0 stretch
Noyau : 4.9.0-3-amd64
(G)UI : Gnome 3.22.2
Inscription : 03-07-2017

Obtenir une connexion WiFi automatique

Bonjour à tous,
Je me suis inscrit récemment sur ce Forum pour dire un grand merci aux contributeurs de ce fil qui m’ont permis d’utiliser la clé wifi "Tinix" utilisant le chipset Realtek 8192eu. Je pensais que ce serait d’autant plus facile qu’un mini CD était fourni avec un driver Linux. Il n’en a bien sur rien été car impossible de lancer le shell "Install.sh" permettant l’installation, sans avoir un message d’erreur !
Quand j’ai commencé à lire les forums sur les problèmes posés par ce chipset, je me suis rendu compte que ma distribution ne convenait pas. Donc passage de 7 à 8, puis à 9.0  (noyau 4.9.0-3-amd64) qui semble être la seule à fonctionner avec le 8192eu.
Puis quelques ennuis pour arriver au bout de l’installation :
- Après installation de la partie "non-free" que je n’avais pas rajoutée à "sources.list", et upgrade qui se passait sans erreur, dkms apparaissait comme non installé.
- J’en ai déniché un qui s’est avéré mauvais, mais l’une autre :
"apt-get install linux-headers-$(uname -r) build-essential dkms git" fonctionnait correctement (merci à Clonezilla pour restaurer la partition et repartir sur une base propre)
Les différents étapes décrites dans la discussion se sont déroulées exactement de la même façon chez moi et le driver a donc bien été installé.

Le problème est arrivé quand j’ai voulu activer le wifi, après un redémarrage bien sûr  : En cliquant dans la zone de notification en haut à droite de l’écran, le wifi est allumé mais aucun réseau n’est visible. En cliquant sur paramètres, je tombe sur l’onglet réseau de Gnome et la aussi aucun réseau. (Bien sûr sous windows avec le même ordi car j’ai un dual boot les réseaux wifi sont visibles) En désespoir de cause je clique sur "Connection à un réseau masqué" et je rentre le SSID de ma box. Et là, miracle le réseau apparaît ! Je rentre la clé wpa et la connexion se fait sans aucun problème !
Donc je peux utiliser ma clé wifi, d’autant plus qu’après la première connexion la clé est bien mémorisée.

Par contre au démarrage suivant il faut refaire la manip qui est est cependant devenue un peu plus simple : Dans la fenêtre de ce qui doit être la partie Gnome de Network Manager, toujours aucun réseau, mais en cliquant sur "Connexion à un réseau masqué" et en cliquant sur la flèche basse dans la fenêtre où il y a écrit "New", le nom de mon réseau apparaît et en le validant il suffit après de cliquer sur "Se connecter" pour que tout fonctionne !

Maintenant si quelqu’un a une idée pour que la connexion wifi devienne automatique, le suis preneur, mais l’essentiel est que ça fonctionne. Je suppose fortement un bug dans Network manager. Peut être faut-il lancer la connexion en ligne de commande en utilisant le fichier "interfaces" ?
Encore merci  et désolé pour ce post un peu verbeux!!

Hors ligne

#2 04-07-2017 15:33:00

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-6-amd64
(G)UI : Mate 1.18
Inscription : 11-03-2016

Re : Obtenir une connexion WiFi automatique

Bonjour et bienvenue sur DF smile
Même si ton problème ressemble, il est différent et mérite son propre fil wink
Pour les présentations c'est par ici : https://debian-facile.org/viewforum.php?id=3

Hors ligne

#3 04-07-2017 16:52:26

èfpé
Membre
Inscription : 10-07-2016

Re : Obtenir une connexion WiFi automatique

Bonjour Jielelbis,

Alors pour ceux que le problème intéresserait, le fil originel est celui-ci (enfin peut-être, merci chalu pour la modération smile).
La version de NetworkManager intégrée à Debian 9 Stretch serait décidément pleine de surprise... il pourrait toutefois être intéressant de savoir si le nom de l'interface Wi-Fi est du type wlx<MAC> ou non :

nmcli device status


Par exemple, bien sûr... Configurer le réseau dans le fichier interfaces pourrait être une réponse à la question.

Dernière modification par èfpé (05-07-2017 12:54:26)

Hors ligne

#4 04-07-2017 17:03:10

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-6-amd64
(G)UI : Mate 1.18
Inscription : 11-03-2016

Re : Obtenir une connexion WiFi automatique

Oui c'est sur ce fil qu'il avait posté. Mais son problème n'étant pas la reconnaissance ou l'installation du driver mais la mémorisation du choix du réseau ou d'ailleurs comprendre pourquoi son réseau est masqué, un nouveau fil avec un titre, qu'il modifiera bien sûr à sa convenance, est le mieux je crois pour les recherches ensuite sur ce type de problème.
Bravo Jielelbis en tout cas pour avoir donner pleins d'infos utiles dans le premier message big_smile

Hors ligne

#5 05-07-2017 09:23:51

Jielelbis
Membre
Distrib. : Debian 9.0 stretch
Noyau : 4.9.0-3-amd64
(G)UI : Gnome 3.22.2
Inscription : 03-07-2017

Re : Obtenir une connexion WiFi automatique

Bonjour,
Pour èfpé, le résultat de la commande
/$ nmcli device status
PÉRIPHÉRIQUE     TYPE      ÉTAT          CONNEXION
wlx000fxxxxx871  wifi      connecté      SFR_xxxx 
eth0             ethernet  indisponible  --       
lo               loopback  non-géré      --     

J'ai oublié de dire qu'avant le lancement de gnome, il y a un message d'erreur, mais la encore je n'ai rien trouvé de particulier:
"failed to start windows manager wait on line"

merci d'avance pour vos remarques et suggestions

Hors ligne

#6 05-07-2017 12:32:26

èfpé
Membre
Inscription : 10-07-2016

Re : Obtenir une connexion WiFi automatique

Re-,

Que l'interface ethernet soit indisponible parce que le câble n'est pas branché, je comprends, mais qu'elle soit nommée eth0 m'étonne un peu plus ; nous avons là un curieux mélange de nomenclatures, ta machine serait-elle le théâtre d'une nouvelle querelle des Anciens et des Modernes ?

Quoi qu'il en soit, ce que tu décris pourrait être une variante d'un problème remonté -à plusieurs reprises- sur ce forum : la version de NetworkManager intégrée à Debian 9 ne gère pas correctement les interfaces wifi (re)nommées wlx<MAC> mad

Quelqu'un de motivé parviendrait peut-être certainement à reproduire ce bogue, afin de proposer une solution en interface graphique pure... quant à moi je ne vois pour le moment que deux ou trois trucs en ligne de commande :

  1. soit désactiver le (re)nommage de l'interface par le duo de choc systemd-udev ;

  2. soit désactiver NetworkManager et configurer le réseau dans le fichier interfaces.


La première proposition semble a priori plus simple à mettre en œuvre, mais certains retours laissent penser le contraire... bref c'est surtout la deuxième qui a fait ses preuves par icitte (cf. ce post par exemple). Enfin, puisque NetworkManager parvient tout de même à te connecter, une troisième voie possible (peu explorée) pourrait être la configuration via la commande nmcli, si tu as le temps... et l'envie de te plonger dans le man big_smile

Dernière modification par èfpé (12-07-2017 23:54:26)

Hors ligne

#7 05-07-2017 19:55:00

Jielelbis
Membre
Distrib. : Debian 9.0 stretch
Noyau : 4.9.0-3-amd64
(G)UI : Gnome 3.22.2
Inscription : 03-07-2017

Re : Obtenir une connexion WiFi automatique

Merci à èfpé pour tes suggestions. Je ne suis pas trop pressé, mais je vais explorer tout ça. Priorité: nouvelle sauvegarde de la partition système qui est de petite taille car /home et mes documents sont sur une autre. Ainsi il ne faut que 10 mn pour la restaurer et donc je ne risque pas grand chose.
Bonne soirée à tous, je vous fais un retour dès que j'entrevoie une solution
J'ai remis en forme le man pour que ce soit plus clair entre les commandes, les options, etc.. Puis je l'ai imprimé (20 pages quand même) J'espère en tirer quelque chose, mais pour l'instant je digère le texte...

Dernière modification par Jielelbis (07-07-2017 20:37:58)

Hors ligne

#8 11-07-2017 18:26:36

Jielelbis
Membre
Distrib. : Debian 9.0 stretch
Noyau : 4.9.0-3-amd64
(G)UI : Gnome 3.22.2
Inscription : 03-07-2017

Re : Obtenir une connexion WiFi automatique

Bonsoir à tous
Un message d’erreur avant l’ouverture de session m’avait intrigué :
"failed to start NetworkManager wail online"
demandant d’effectuer une vérification par la commande

systemctl status NetworkManager-wait-online.service


Unit NetwokManager-wait-online.service could not be found.
 



J’ai trouvé un lien décrivant cela comme un bug de la distribution :
https://bugs.debian.org/cgi-bin/bugrepo … bug=832093

je me suis alors tourné vers la commande nmcli à partir d’un terminal comme suggéré par èfpé, et effectivement celle-ci fonctionne (j’ai augmenté le time-out):

nmcli -w 180 connection up SFR_xxxx
 



Donc à partir de la il "suffisait" d’automatiser cette commande.

Au démarrage du système, en rajoutant un fichier de commande dans /etc/init.d, le système se plaint que ce fichier n’est plus aux normes requises
"Missing LSB tags and overides"
quand on valide les liens vers les fichiers de commandes lancés au démarrage par update-rc.d wifi-SFR_xxxx defaults.

Comme cela me semblait assez compliqué, j’ai essayé de lancer la connexion une fois la session ouverte en éditant le fichier .bashrc
J’ai un peu galéré car je voulais que cela se passe en tâche de fond et que je ne voulais avoir aucun message en sortie.
Donc j’ai rajouté les instructions:

# On efface le contenu du fichier nohup.out et on place la date en ligne 1
date > nohup.out
#
# puis on lance en tache de fond la commande nmcli pour lancer
# la connexion wifi, le message d'info de nohup
# étant mis à la poubelle
# Les infos de connexion seront écrites dans nohup.out en 2me ligne
nohup nmcli -w 180 connection up SFR_xxxx 2> /dev/null
 



Il suffit d’aller voir dans nohup.out pour vérifier si tout s'est bien passé…Et c’est là que j’ai besoin d’aide !

Quand on rentre en session, la connexion wifi ne se fait pas mais tout le reste fonctionne. On remarque le que fichier nohup.out n’est pas modifié.

J’ouvre un terminal. Le prompt n’apparaît pas tout de suite, mais au bout de quelques dizaines de secondes il s’affiche dans la fenêtre et on constate que la connexion wifi fonctionne.
Le fichier nohup.out contient alors ;
mardi 11 juillet 2017, 17:20:23 (UTC+0200)
Connexion activée (chemin D-Bus actif : /org/freedesktop/NetworkManager/ActiveConnection/1)

Mais tant qu’on ouvre pas un terminal, rien ne se passe.
Est ce que je suis dans l’impasse ?
Merci d’avance pour vos conseils

Hors ligne

#9 11-07-2017 22:54:04

èfpé
Membre
Inscription : 10-07-2016

Re : Obtenir une connexion WiFi automatique

Bonsoir,

L'outil graphique gnome-session-properties a été retiré du paquet gnome-session-bin depuis la version Jessie, mais une possibilité est de passer par la création d'un fichier Desktop (cf. man gnome-session) du type :

[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=<ce que tu veux>
Comment=<ce que tu veux>
Exec=nmcli -w 180 connection up SFR_xxxx
StartupNotify=false
Terminal=false
Hidden=true


Cette méthode a récemment été testée (avec succès, semble-t-il) sous GNOME 3.14 smile

Hors ligne

#10 19-07-2017 20:27:05

Jielelbis
Membre
Distrib. : Debian 9.0 stretch
Noyau : 4.9.0-3-amd64
(G)UI : Gnome 3.22.2
Inscription : 03-07-2017

Re : Obtenir une connexion WiFi automatique

Bonsoir,

La manip proposée par èfpé semblait "la solution" et j’ai essayé de la mettre en œuvre hélas sans succès.

J’ai écrit un fichier "lanceWIFIsurBoxSFR.desktop" que j’ai enregistré dans /etc/xdg/autostart et renfermant les lignes proposées :


[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=lanceWIFIsurBoxSFR
Comment=ce que tu veux
Exec=nmcli -w 180 connection up SFR_xxxx
StartupNotify=false
Terminal=false
Hidden=true
 




Malheureusement rien ne se passe au redémarrage et à l’ouverture de la session gnome.
Idem en plaçant ce fichier dans .config/autostart pour lancer le WIFI à l’ouverture de ma session utilisateur

J’ai l’impression que le fichier .desktop doit être cité ailleurs

en allant voir dans le fichier
/usr/share/doc/gnome-session/README.Debian
et dans la section "Applications at startup",
il semble effectivement indiqué que le nom du fichier "lanceWIFIsurBoxSFR.desktop" doit aussi figurer dans le fichier
/usr/share/gnome-session/sessions/gnome.session , à la rubrique "RequiredComponents". Ce que j’ai fait en supprimant le suffixe ".desktop" car les autres noms comme "org.gnome.Shell" et "gnome-settings-daemon" n’en avaient pas.

Et hélas aucun effet.

Je dois louper un truc gros comme une maison, mais je n’ai pas encore eu l’illumination !
Si quelqu’un a une idée …. un grand merci par avance!

Hors ligne

#11 19-08-2017 15:48:04

èfpé
Membre
Inscription : 10-07-2016

Re : Obtenir une connexion WiFi automatique

Up !

Alors le truc effectivement gros comme une maison, c'est qu'une erreur s'est glissée en #9 :

Hidden=true


Cela revient à désactiver le fichier... essaie donc plutôt avec :

Hidden=false


Désolé pour ce petit contretemps... bon tu avais dit que tu n'étais pas pressé hmm

Dernière modification par èfpé (19-08-2017 15:58:04)

Hors ligne

#12 23-08-2017 17:53:20

Jielelbis
Membre
Distrib. : Debian 9.0 stretch
Noyau : 4.9.0-3-amd64
(G)UI : Gnome 3.22.2
Inscription : 03-07-2017

Re : Obtenir une connexion WiFi automatique

Bonsoir,

Un grand merci à èfpé. (Pas grave du tout pour le délai, j’étais parti quelques jours et de toute façon il suffisait de cliquer sur terminal pour que le wifi se lance)
Donc la modification" Hidden=false" a suffit pour débloquer la situation et avoir la connexion automatique
Avant de clore le sujet, peut-être encore un truc à tirer au clair.
Le fait de placer le fichier  "lanceWIFIsurBoxSFR.desktop" dans le répertoire /etc/xdg/autostart
ne lance pas la connexion wifi. Je l’ai donc supprimé.
Ce fichier apparaît dans les répertoires /usr/share/applications et /home/nom_utilisateur/.config/autostart mais est cité aussi sans l’extension .desktop dans le fichier /usr/share/gnome-session/sessions/gnome.session

Avec tout ça la connexion WIFI automatique se fait toujours, mais on constate de manière plus ou moins aléatoire que :
- Soit la connexion se fait dès que gnome est lancé, soit rien ne se passe.
- Dans ce dernier cas la connexion se fait toujours à partir du moment où j’ouvre la session utilisateur.

J’ai peut être tendance à vouloir aller au fond des choses pour ne pas employer de terme péjoratif…
Peut être que je ferai des essais pour voir s’il y a bien des commandes redondantes, mais si quelqu’un a un avis, il sera le bienvenu
Bonne soirée.

Hors ligne

Pied de page des forums