Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-07-2017 22:10:30

Assimil
Membre
Inscription : 04-07-2017

Problème de clé usb wifi

Bonjour à tous et à toutes tout d'abord voilà je possède une clé wifi TP-LINK archer t2uh ac600, je la branche à mon ordi (debian 9.0 MATE)  via l'usb et rien y faire elle n'est pas détectée.
Je suis un tuto sur internet qui m'explique les étapes, mais à la première étape ça plante déjà.

l'étape sur le net me dit ça :
----------------------------------

sudo apt-get install git build-essential
git clone https://github.com/Myria-de/mt7610u_wif … 130916.git
cd mt7610u_wifi_sta_v3002_dpo_20130916
make
sudo make install
sudo mkdir -p /etc/Wireless/RT2870STA
sudo cp RT2870STA.dat  /etc/Wireless/RT2870STA/RT2870STA.dat


La première étape je reçois ça comme erreur :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
git is already the newest version (1:2.13.2-3).
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
build-essential : Dépend: libc6-dev mais ne sera pas installé ou
                            libc-dev
                   Dépend: g++ (>= 4:6.3) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

ma source liste contient:

#

# deb cdrom:[Debian GNU/Linux 9.0.0 _Stretch_ - Official amd64 NETINST 20170617$

#deb cdrom:[Debian GNU/Linux 9.0.0 _Stretch_ - Official amd64 NETINST 20170617-$

deb http://ftp.be.debian.org/debian/ stretch main
deb-src http://ftp.be.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.be.debian.org/debian/ stretch-updates main
deb-src http://ftp.be.debian.org/debian/ stretch-updates main


j'ai été voir sur internet pour modifier la source liste mais j'ai peur de faire une gaffe donc je m'adresse à vous pour m'éclairer sur ce problème.

Dernière modification par Assimil (04-07-2017 22:11:58)

Hors ligne

#2 06-07-2017 13:31:07

daufinsyd
Membre
Lieu : 68, 63, Karlsruhe
Distrib. : Manjaro + Debian Stable + Xubuntu
Noyau : Linux 4.9-amd64
(G)UI : Plasma 5.10
Inscription : 02-02-2013
Site Web

Re : Problème de clé usb wifi

Salut,

(tu es donc relié à internet par un câble?)
as tu mis à jour la liste de tes paquets après avoir modifié ton fichier sources.list ? (pour que les changements soient pris en compte)

apt update



Essaie d'installer g++ séparément

apt install g++



Si ça ne marche pas, peux-tu poster la sortie de

apt-cache policy g++


?


Aspire V3-772G + SSD 850Evo
Intel i7-4790 - 12Go RAM - GTX460
Intel i7-6700 - 8Go RAM - AMD R9 280X 3Go - SSD 850Evo
Odroid C2, Raspberry Pi Zero

Hors ligne

#3 06-07-2017 16:03:57

Assimil
Membre
Inscription : 04-07-2017

Re : Problème de clé usb wifi

avec apt install g++

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
g++ : Dépend: g++-6 (>= 6.3.0-9~) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

avec apt-cache policy g++
g++:
  Installé : (aucun)
  Candidat : 4:6.3.0-4
Table de version :
     4:6.3.0-4 500
        500 http://ftp.be.debian.org/debian stretch/main amd64 Packages
        500 http://deb.debian.org/debian stretch/main amd64 Packages

ça ne marche pas apparemment hmm

Hors ligne

#4 07-07-2017 08:59:02

daufinsyd
Membre
Lieu : 68, 63, Karlsruhe
Distrib. : Manjaro + Debian Stable + Xubuntu
Noyau : Linux 4.9-amd64
(G)UI : Plasma 5.10
Inscription : 02-02-2013
Site Web

Re : Problème de clé usb wifi

Es-tu connecté à internet ?

si oui

apt install g++-6


ou bien (on ne sait jamais)

apt -f install


Aspire V3-772G + SSD 850Evo
Intel i7-4790 - 12Go RAM - GTX460
Intel i7-6700 - 8Go RAM - AMD R9 280X 3Go - SSD 850Evo
Odroid C2, Raspberry Pi Zero

Hors ligne

#5 07-07-2017 10:37:48

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème de clé usb wifi

Bonjour
Y'avait se sujet sur le forum Handylinux , je sais pas si ça peut etre utile ?
https://handylinux.org/forum/viewtopic.php?id=2255

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 07-07-2017 12:30:55

Assimil
Membre
Inscription : 04-07-2017

Re : Problème de clé usb wifi

Le lien que tu m'as donné a va logiquement m'aider mais le hic c'est que j'ai encore ces foutus dépendances non satisfaite!

il me dit ça :
j'ai voulu mettre build-essential

Les paquets suivants contiennent des dépendances non satisfaites :
build-essential : Dépend: libc6-dev mais ne sera pas installé ou
                            libc-dev
                   Dépend: g++ (>= 4:6.3) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Sinon j'ai bien fait les commandes que tu m'as cité plus haut sauf la première qui ne fonctionnait pas!

Hors ligne

#7 07-07-2017 14:20:48

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème de clé usb wifi

Tu peux peut etre faire un

apt autoremove


avec une simulation avant

apt autoremove -s


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 07-07-2017 14:23:55

Assimil
Membre
Inscription : 04-07-2017

Re : Problème de clé usb wifi

quand je fais  apt-get install build-essential j'ai droit à ça :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
build-essential : Dépend: libc6-dev mais ne sera pas installé ou
                            libc-dev
                   Dépend: g++ (>= 4:6.3) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#9 07-07-2017 14:44:00

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème de clé usb wifi

tu a testé avec aptitude voir les solutions qu il propose


apt-get --reinstall install aptitude
 




aptitude install build-essential
 



nota : ton souces.list est correct  ?

que renvoie


apt-get update
 


et


apt-get upgrade
 



tu a synaptic installé ?

faut réparer les paquets cassés surement avant (tu a du faire quelque chose qui a cassé des paquets )

Hors ligne

Pied de page des forums