Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-07-2017 20:30:33

Zigzag
Membre
Inscription : 05-07-2017

Virtualbox s'installe mais ne se lance pas (message d'erreur)

Salut tout le monde,

J'essaye d'installer Virtualbox 5.1 sur Subgraph (Debian Stretch si j'ai bien compris), mais j'ai un message d'erreur quand je veux lancer l'application.

Pour info j'ai suivi la procédure présente sur le site de Virtualbox, qui est la même qu'un des membres d'ici avait cité et pour lequel ça avait marché :
https://linuxconfig.org/how-to-install- … bian-linux

J'ai donc modifier le fichier /etc/apt/sources.list avec :
sudo gedit /etc/apt/sources.list en rajoutant la ligne "deb http://download.virtualbox.org/virtualbox/debian stretch contrib"

Rajouter les deux clé:
wget -q https://www.virtualbox.org/download/ora … x_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -

Lancer l'installation :
sudo apt-get update
sudo apt-get install virtualbox-5.1

J'ai bien l'icone qui se rajoute dans mes programmes, mais quand je le lance voici la fenêtre qu'il affiche :
170531erreur.jpg

Ça vous dit quelque chose ?

Merci d'avance

Hors ligne

#2 14-07-2017 20:33:35

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Bonsoir

Virtualbox a écrit :

Ubuntu/Debian users might want to install the dkms package to ensure that the VirtualBox host kernel modules (vboxdrv, vboxnetflt and vboxnetadp) are properly updated if the linux kernel version changes during the next apt-get upgrade


apt-get install dkms


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#3 14-07-2017 23:28:31

Tristan07
Membre
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome
Inscription : 21-05-2016
Site Web

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Bonsoir,
Une méthode officielle est décrite ici :
https://wiki.debian.org/VirtualBox

apt-get install dkms


@ Croutons : Je remarque que dkms n'était pas installé - Est-ce préférable ? Ce n'est pas décrit dans cette documentation, mais il me semble que ce paquet était installé systématiquement sur d'autres distributions, ce que je viens de faire également ici.
merci

Hors ligne

#4 19-07-2017 15:40:31

Zigzag
Membre
Inscription : 05-07-2017

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Salut tout le monde et merci pour vos réponses,

Je viens de repartir de 0 vu que j'avais fait pas mal de test sur cet OS, je me suis dit que peut être j'avais plus foutu le bazard qu'autre chose.

Donc réinstallation de Subgraph OS, un apt-get update et apt-get upgrade, en suite voici mon installation via le terminal :

root@subgraph:/home/user# sudo apt-get install virtualbox-5.1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libmediaart-2.0-0 libmission-control-plugins0 libnm-gtk-common libnma-common
  telepathy-mission-control-5
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  libqt5opengl5
Paquets recommandés :
  libsdl-ttf2.0-0
Les NOUVEAUX paquets suivants seront installés :
  libqt5opengl5 virtualbox-5.1
0 mis à jour, 2 nouvellement installés, 0 à enlever et 34 non mis à jour.
Il est nécessaire de prendre 66,5 Mo dans les archives.
Après cette opération, 164 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://download.virtualbox.org/virtualbox/debian stretch/contrib amd64 virtualbox-5.1 amd64 5.1.24-117012~Debian~stretch [66,3 MB]
Réception de:2 http://cdn-fastly.deb.debian.org/debian stretch/main amd64 libqt5opengl5 amd64 5.7.1+dfsg-3+b1 [154 kB]
66,5 Mo réceptionnés en 4min 6s (269 ko/s)                                     
Préconfiguration des paquets...
Sélection du paquet libqt5opengl5:amd64 précédemment désélectionné.
(Lecture de la base de données... 174033 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libqt5opengl5_5.7.1+dfsg-3+b1_amd64.deb ...
Dépaquetage de libqt5opengl5:amd64 (5.7.1+dfsg-3+b1) ...
Sélection du paquet virtualbox-5.1 précédemment désélectionné.
Préparation du dépaquetage de .../virtualbox-5.1_5.1.24-117012~Debian~stretch_amd64.deb ...
Dépaquetage de virtualbox-5.1 (5.1.24-117012~Debian~stretch) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Paramétrage de libqt5opengl5:amd64 (5.7.1+dfsg-3+b1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
Traitement des actions différées (« triggers ») pour systemd (232-25) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.8-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
Paramétrage de virtualbox-5.1 (5.1.24-117012~Debian~stretch) ...
Ajout du groupe « vboxusers » (GID 121)...
Fait.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.
root@subgraph:/home/user# sudo apt-get install dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libmediaart-2.0-0 libmission-control-plugins0 libnm-gtk-common libnma-common
  telepathy-mission-control-5
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Paquets suggérés :
  python3-apport
Les NOUVEAUX paquets suivants seront installés :
  dkms
0 mis à jour, 1 nouvellement installés, 0 à enlever et 34 non mis à jour.
Il est nécessaire de prendre 74,8 ko dans les archives.
Après cette opération, 289 ko d'espace disque supplémentaires seront utilisés.
Réception de:1 http://cdn-fastly.deb.debian.org/debian stretch/main amd64 dkms all 2.3-2 [74,8 kB]
74,8 ko réceptionnés en 5s (12,5 ko/s)
Sélection du paquet dkms précédemment désélectionné.
(Lecture de la base de données... 174831 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../archives/dkms_2.3-2_all.deb ...
Dépaquetage de dkms (2.3-2) ...
Paramétrage de dkms (2.3-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
root@subgraph:/home/user#


Si j'essaye de lancer Virtualbox, j'ai le même message d'erreur qu'au début de mon post (photo d'écran)

Vous pensez que ça vient d'où ?

Hors ligne

#5 19-07-2017 15:57:20

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Bonjour

vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig


Comme dit le message le fichier log apportera un éclairssissement du pourquoi la config a échoué

cat /var/log/vbox-install.log

Dernière modification par Croutons (19-07-2017 15:59:13)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#6 19-07-2017 16:11:34

Yanatoum
Membre
Lieu : Dyle
Distrib. : Debian 9 Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : xfce
Inscription : 10-07-2016

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Vous pensez que ça vient d'où ?



Les NOUVEAUX paquets suivants seront installés :
  dkms
0 mis à jour, 1 nouvellement installés, 0 à enlever et 34 non mis à jour.



Refaire une mise à jour ?

Hors ligne

#7 19-07-2017 16:23:50

Zigzag
Membre
Inscription : 05-07-2017

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Yanatoum, j'ai déjà fait un apt-get update après l'installation, même problème.

Croutons, voici ce que donne le log:

user@subgraph:~$ cat /var/log/vbox-install.log
make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /lib/modules/4.8.15-grsec-amd64/build -j2 modules
make[1]: AVERTISSEMENT : -jN forcé dans un submake : désactivation du mode serveur de tâches.
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (    \
echo >&2;                            \
echo >&2 "  ERROR: Kernel configuration is invalid.";        \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";    \
echo >&2 ;                            \
/bin/false)
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f ./scripts/Makefile.build obj=/tmp/vbox.0
  gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-linux-gnu/6/include -I./arch/x86/include -I./arch/x86/include/generated/uapi -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -ffreestanding -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fno-delete-null-pointer-checks -Wno-maybe-uninitialized -Wno-frame-address -O2 --param=allow-store-data-races=0 -fplugin=./scripts/gcc-plugins/constify_plugin.so -fplugin=./scripts/gcc-plugins/kernexec_plugin.so -fplugin=./scripts/gcc-plugins/colorize_plugin.so -fplugin=./scripts/gcc-plugins/size_overflow_plugin/size_overflow_plugin.so -fplugin=./scripts/gcc-plugins/randomize_layout_plugin.so -fplugin=./scripts/gcc-plugins/latent_entropy_plugin.so -fplugin=./scripts/gcc-plugins/rap_plugin/rap_plugin.so -DCONSTIFY_PLUGIN -DKERNEXEC_PLUGIN -fplugin-arg-kernexec_plugin-method=bts -DSIZE_OVERFLOW_PLUGIN -fplugin-arg-size_overflow_plugin-check-fns -fplugin-arg-size_overflow_plugin-check-fields -fplugin-arg-size_overflow_plugin-check-fptrs -fplugin-arg-size_overflow_plugin-check-vars -DRANDSTRUCT_PLUGIN -fplugin-arg-randomize_layout_plugin-performance-mode -DLATENT_ENTROPY_PLUGIN -DRAP_PLUGIN -fplugin-arg-rap_plugin-check=call -fplugin-arg-rap_plugin-hash=abs-finish -Wframe-larger-than=2048 -fstack-protector -Wno-unused-but-set-variable -Wno-unused-const-variable -fomit-frame-pointer -fno-var-tracking-assignments -g -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/lib/modules/4.8.15-grsec-amd64/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DSUPDRV_WITH_RELEASE_LOGGER -Wno-declaration-after-statement -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS -fno-omit-frame-pointer -fno-pie  -DMODULE  -DKBUILD_BASENAME='"SUPDrv_linux"'  -DKBUILD_MODNAME='"vboxdrv"' -c -o /tmp/vbox.0/linux/.tmp_SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
  gcc -Wp,-MD,/tmp/vbox.0/.SUPDrv.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-linux-gnu/6/include -I./arch/x86/include -I./arch/x86/include/generated/uapi -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -ffreestanding -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fno-delete-null-pointer-checks -Wno-maybe-uninitialized -Wno-frame-address -O2 --param=allow-store-data-races=0 -fplugin=./scripts/gcc-plugins/constify_plugin.so -fplugin=./scripts/gcc-plugins/kernexec_plugin.so -fplugin=./scripts/gcc-plugins/colorize_plugin.so -fplugin=./scripts/gcc-plugins/size_overflow_plugin/size_overflow_plugin.so -fplugin=./scripts/gcc-plugins/randomize_layout_plugin.so -fplugin=./scripts/gcc-plugins/latent_entropy_plugin.so -fplugin=./scripts/gcc-plugins/rap_plugin/rap_plugin.so -DCONSTIFY_PLUGIN -DKERNEXEC_PLUGIN -fplugin-arg-kernexec_plugin-method=bts -DSIZE_OVERFLOW_PLUGIN -fplugin-arg-size_overflow_plugin-check-fns -fplugin-arg-size_overflow_plugin-check-fields -fplugin-arg-size_overflow_plugin-check-fptrs -fplugin-arg-size_overflow_plugin-check-vars -DRANDSTRUCT_PLUGIN -fplugin-arg-randomize_layout_plugin-performance-mode -DLATENT_ENTROPY_PLUGIN -DRAP_PLUGIN -fplugin-arg-rap_plugin-check=call -fplugin-arg-rap_plugin-hash=abs-finish -Wframe-larger-than=2048 -fstack-protector -Wno-unused-but-set-variable -Wno-unused-const-variable -fomit-frame-pointer -fno-var-tracking-assignments -g -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/lib/modules/4.8.15-grsec-amd64/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DSUPDRV_WITH_RELEASE_LOGGER -Wno-declaration-after-statement -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS -fno-omit-frame-pointer -fno-pie  -DMODULE  -DKBUILD_BASENAME='"SUPDrv"'  -DKBUILD_MODNAME='"vboxdrv"' -c -o /tmp/vbox.0/.tmp_SUPDrv.o /tmp/vbox.0/SUPDrv.c
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/constify_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/constify_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/colorize_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/colorize_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/rap_plugin/rap_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/rap_plugin/rap_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/kernexec_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/kernexec_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/size_overflow_plugin/size_overflow_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/size_overflow_plugin/size_overflow_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/latent_entropy_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/latent_entropy_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/randomize_layout_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/randomize_layout_plugin.so
scripts/Makefile.build:289 : la recette pour la cible « /tmp/vbox.0/linux/SUPDrv-linux.o » a échouée
make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Erreur 1
make[2]: *** Attente des tâches non terminées....
scripts/Makefile.build:289 : la recette pour la cible « /tmp/vbox.0/SUPDrv.o » a échouée
make[2]: *** [/tmp/vbox.0/SUPDrv.o] Erreur 1
Makefile:1478 : la recette pour la cible « _module_/tmp/vbox.0 » a échouée
make[1]: *** [_module_/tmp/vbox.0] Erreur 2
Makefile:305 : la recette pour la cible « vboxdrv » a échouée
make: *** [vboxdrv] Erreur 2
make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /lib/modules/4.8.15-grsec-amd64/build -j2 modules
make[1]: AVERTISSEMENT : -jN forcé dans un submake : désactivation du mode serveur de tâches.
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (    \
echo >&2;                            \
echo >&2 "  ERROR: Kernel configuration is invalid.";        \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";    \
echo >&2 ;                            \
/bin/false)
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f ./scripts/Makefile.build obj=/tmp/vbox.0
  gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-linux-gnu/6/include -I./arch/x86/include -I./arch/x86/include/generated/uapi -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -ffreestanding -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fno-delete-null-pointer-checks -Wno-maybe-uninitialized -Wno-frame-address -O2 --param=allow-store-data-races=0 -fplugin=./scripts/gcc-plugins/constify_plugin.so -fplugin=./scripts/gcc-plugins/kernexec_plugin.so -fplugin=./scripts/gcc-plugins/colorize_plugin.so -fplugin=./scripts/gcc-plugins/size_overflow_plugin/size_overflow_plugin.so -fplugin=./scripts/gcc-plugins/randomize_layout_plugin.so -fplugin=./scripts/gcc-plugins/latent_entropy_plugin.so -fplugin=./scripts/gcc-plugins/rap_plugin/rap_plugin.so -DCONSTIFY_PLUGIN -DKERNEXEC_PLUGIN -fplugin-arg-kernexec_plugin-method=bts -DSIZE_OVERFLOW_PLUGIN -fplugin-arg-size_overflow_plugin-check-fns -fplugin-arg-size_overflow_plugin-check-fields -fplugin-arg-size_overflow_plugin-check-fptrs -fplugin-arg-size_overflow_plugin-check-vars -DRANDSTRUCT_PLUGIN -fplugin-arg-randomize_layout_plugin-performance-mode -DLATENT_ENTROPY_PLUGIN -DRAP_PLUGIN -fplugin-arg-rap_plugin-check=call -fplugin-arg-rap_plugin-hash=abs-finish -Wframe-larger-than=2048 -fstack-protector -Wno-unused-but-set-variable -Wno-unused-const-variable -fomit-frame-pointer -fno-var-tracking-assignments -g -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/lib/modules/4.8.15-grsec-amd64/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DSUPDRV_WITH_RELEASE_LOGGER -Wno-declaration-after-statement -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS -fno-omit-frame-pointer -fno-pie  -DMODULE  -DKBUILD_BASENAME='"SUPDrv_linux"'  -DKBUILD_MODNAME='"vboxdrv"' -c -o /tmp/vbox.0/linux/.tmp_SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
  gcc -Wp,-MD,/tmp/vbox.0/.SUPDrv.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-linux-gnu/6/include -I./arch/x86/include -I./arch/x86/include/generated/uapi -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -ffreestanding -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fno-delete-null-pointer-checks -Wno-maybe-uninitialized -Wno-frame-address -O2 --param=allow-store-data-races=0 -fplugin=./scripts/gcc-plugins/constify_plugin.so -fplugin=./scripts/gcc-plugins/kernexec_plugin.so -fplugin=./scripts/gcc-plugins/colorize_plugin.so -fplugin=./scripts/gcc-plugins/size_overflow_plugin/size_overflow_plugin.so -fplugin=./scripts/gcc-plugins/randomize_layout_plugin.so -fplugin=./scripts/gcc-plugins/latent_entropy_plugin.so -fplugin=./scripts/gcc-plugins/rap_plugin/rap_plugin.so -DCONSTIFY_PLUGIN -DKERNEXEC_PLUGIN -fplugin-arg-kernexec_plugin-method=bts -DSIZE_OVERFLOW_PLUGIN -fplugin-arg-size_overflow_plugin-check-fns -fplugin-arg-size_overflow_plugin-check-fields -fplugin-arg-size_overflow_plugin-check-fptrs -fplugin-arg-size_overflow_plugin-check-vars -DRANDSTRUCT_PLUGIN -fplugin-arg-randomize_layout_plugin-performance-mode -DLATENT_ENTROPY_PLUGIN -DRAP_PLUGIN -fplugin-arg-rap_plugin-check=call -fplugin-arg-rap_plugin-hash=abs-finish -Wframe-larger-than=2048 -fstack-protector -Wno-unused-but-set-variable -Wno-unused-const-variable -fomit-frame-pointer -fno-var-tracking-assignments -g -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/lib/modules/4.8.15-grsec-amd64/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DSUPDRV_WITH_RELEASE_LOGGER -Wno-declaration-after-statement -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS -fno-omit-frame-pointer -fno-pie  -DMODULE  -DKBUILD_BASENAME='"SUPDrv"'  -DKBUILD_MODNAME='"vboxdrv"' -c -o /tmp/vbox.0/.tmp_SUPDrv.o /tmp/vbox.0/SUPDrv.c
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/constify_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/constify_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/colorize_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/colorize_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/rap_plugin/rap_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/rap_plugin/rap_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/kernexec_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/kernexec_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/size_overflow_plugin/size_overflow_plugin.so
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/size_overflow_plugin/size_overflow_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/latent_entropy_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/latent_entropy_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/randomize_layout_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/randomize_layout_plugin.so
scripts/Makefile.build:289 : la recette pour la cible « /tmp/vbox.0/linux/SUPDrv-linux.o » a échouée
make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Erreur 1
make[2]: *** Attente des tâches non terminées....
scripts/Makefile.build:289 : la recette pour la cible « /tmp/vbox.0/SUPDrv.o » a échouée
make[2]: *** [/tmp/vbox.0/SUPDrv.o] Erreur 1
Makefile:1478 : la recette pour la cible « _module_/tmp/vbox.0 » a échouée
make[1]: *** [_module_/tmp/vbox.0] Erreur 2
Makefile:305 : la recette pour la cible « vboxdrv » a échouée
make: *** [vboxdrv] Erreur 2

Hors ligne

#8 19-07-2017 19:06:38

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

ouch le pavé , utilise les balises du forum sinon c'est dur a suivre
tu as bien installé dkms sur la machine hote non sur la machine invité (ta VM)?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#9 19-07-2017 20:12:44

Zigzag
Membre
Inscription : 05-07-2017

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Désolé pour les balises sad

Oui j'ai bien installé dkms sur Subgraph, de toute façon Virtualbox ne se lance pas donc je ne peux même pas configurer de vm

Hors ligne

#10 20-07-2017 10:29:22

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Bonjour

5.8 Using virtual machines in Subgraph OS

Contrary to popular belief, there is nothing that stops the use of virtual machines in Subgraph OS. While the Grsecurity kernel is not compatible with VirtualBox, Qemu/KVM works as expected. However, you must install Qemu/KVM yourself if you want to run virtual machines.


Sources: https://subgraph.com/sgos-handbook/sgos … ubgraph-os


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#11 20-07-2017 11:01:41

Zigzag
Membre
Inscription : 05-07-2017

Re : Virtualbox s'installe mais ne se lance pas (message d'erreur)

Merci Croutons, tout s'explique ! Je vais voir pour installer Qemu/KVM, j'espère juste qu'il prend en charge les .vdi

Bonne journée

Hors ligne

Pied de page des forums