Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-07-2017 07:57:23

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Installation et utilisation de gdebi

Bonjour,

Debian stretch. Pas de mot de passe root.
gksu installé et réglé sur sudo
gdebi installé mais non fonctionnel

J'ai téléchargé Teamviewer.deb

Avant de l'installer via gdebi j'ai fait ceci :

dpkg --add-architecture i386


apt-get update


apt-get install libdbus-1-3:i386 libasound2:i386 libexpat1:i386 libfontconfig1:i386 libfreetype6:i386 libjpeg62:i386 libpng12-0:i386 libsm6:i386 libxdamage1:i386 libxext6:i386 libxfixes3:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libxtst6:i386 zlib1g:i386 libc6:i386


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « libjpeg62-turbo:i386 » au lieu de « libjpeg62:i386 »
E: Impossible de trouver le paquet libpng12-0:i386
 



Je ne peux pas utiliser gdebi.... le paquet teamviewer est prêt à installer mais quand je rentre mon mot de passe , il ne se passe rien .

Merci de votre aide


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#2 10-07-2017 08:07:08

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Installation et utilisation de gdebi

Je complète le message précédent :

dpkg -i teamviewer_12.0.76279_i386.deb
 


Sélection du paquet teamviewer:i386 précédemment désélectionné.
(Lecture de la base de données... 108342 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de teamviewer_12.0.76279_i386.deb ...
Dépaquetage de teamviewer:i386 (12.0.76279) ...
dpkg: des problèmes de dépendances empêchent la configuration de teamviewer:i386 :
 teamviewer:i386 dépend de libc6 (>= 2.11).
 teamviewer:i386 dépend de libgcc1.
 teamviewer:i386 dépend de libasound2.
 teamviewer:i386 dépend de libdbus-1-3.
 teamviewer:i386 dépend de libexpat1.
 teamviewer:i386 dépend de libfontconfig1.
 teamviewer:i386 dépend de libfreetype6.
 teamviewer:i386 dépend de libjpeg62.
 teamviewer:i386 dépend de libsm6.
 teamviewer:i386 dépend de libxdamage1.
 teamviewer:i386 dépend de libxext6.
 teamviewer:i386 dépend de libxfixes3.
 teamviewer:i386 dépend de libxinerama1.
 teamviewer:i386 dépend de libxrandr2.
 teamviewer:i386 dépend de libxrender1.
 teamviewer:i386 dépend de libxtst6.
 teamviewer:i386 dépend de zlib1g.

dpkg: erreur de traitement du paquet teamviewer:i386 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 teamviewer:i386
 


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#3 10-07-2017 08:14:40

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Installation et utilisation de gdebi

Installation teamviewer résolu par

apt-get -f install



Mais ne me dit pas pourquoi gdebi ne fonctionne pas....


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#4 10-07-2017 08:55:16

zorzi
Membre
Lieu : Dijon
Distrib. : Debian Stretch - XFCE
Noyau : Linux 4.9.0-3-amd64
Inscription : 30-09-2015

Re : Installation et utilisation de gdebi

Salut,

Je ne suis pas un expert de gdebi mais c'est pareil chez moi, ce dernier ne veut bien fonctionner qu'avec le mot de passe root.

Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, DD 500 Go) / Debian Stretch (XFCE)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Stretch

Hors ligne

#5 10-07-2017 09:51:38

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Installation et utilisation de gdebi

Bonjour,
le retour de commande suivant pourrait être utile

gdebi nom-du-paquet

Hors ligne

#6 10-07-2017 09:51:38

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Installation et utilisation de gdebi

Bonjour
c'est le comportement normale la demande du passe root sur gdebi
De maniére générale des qu'une action d'aministration du systéme est faite le passe root est demandé

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#7 10-07-2017 10:02:54

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Installation et utilisation de gdebi

chalu a écrit :

Bonjour,
le retour de commande suivant pourrait être utile

gdebi nom-du-paquet



Voici :

gdebi dropbox_2015.10.28_amd64.deb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done

cloud synchronization engine - CLI and Nautilus extension
 Dropbox is a free service that lets you bring your photos, docs, and videos
 anywhere and share them easily.
 .
 This package provides a command-line tool and a Nautilus extension that
 integrates the Dropbox web service with your GNOME Desktop.
Voulez-vous installer le paquet logiciel ? [o/N] :
 


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#8 10-07-2017 10:31:53

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Installation et utilisation de gdebi

tu mets N
en ligne de commande ça semble fonctionner
Et avec un clic droit ?
il faut patienter le temps qu'il y ait le téléchargement des dépendances, plus ou moins long suivant la connexion

Hors ligne

#9 10-07-2017 11:35:22

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Installation et utilisation de gdebi

Je me souviens d'un sujet recent ou quelqu'un avait un bug par rapport a la réponse attendu par le terminale
raleur avait donné la solution
il fallait répondre y (yes) avec o il se fesait jeté ou peut être c'était dans le sens inverse je sais plus, je retrouve plus le sujet

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#10 10-07-2017 12:36:07

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : Installation et utilisation de gdebi

bonjour,
perso avec gdebi sous stretch, si je clic sur un .deb, gdebi s'ouvre puis demande de mot de passe, et là, gdebi se ferme, et donc n'installe pas le paquet;

par contre, si d'une console:

gdebi-gtk


gdebi s'ouvre, je vais chercher le fichier .deb (fichier---->ouvrir.....) et là, pas de problème, gdebi me demande mon mdp et installe le paquet.
étrange

thierry

Hors ligne

Pied de page des forums