Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-07-2017 11:12:05

Maud
Membre
Lieu : Melle (79)
Distrib. : Debian GNU/Linux 9 Stretch
Noyau : Linux 4.9.0-3-amd64
Inscription : 07-03-2017

[résolu] problème de clé QGIS 2.18 sous debian 9 (stretch)

Bonjour,
Je tente d'installer la dernière version en release de QGIS sur ma Debian 9.
Voici ce que j'ai déjà effectué:
dans le source.list, j'ai ajouté et enregistré:

# répertoire pour dernière version de qgis release
deb http://qgis.org/debian stretch main


puis,

apt-get update


qui a terminé sans erreur.
Ensuite:

apt-get install qgis



et voici les erreurs reçues:

Err:47 http://ftp.fr.debian.org/debian stretch/main amd64 libxerces-c3.1 amd64 3.1.4+debian-2
  Somme de contrôle de hachage incohérente
  Hashes of expected file:
   - SHA256:962bc71575ada2cae35e695f7773db8fb00995bd5b012d1479a7c03dac777aa3
   - MD5Sum:b86c5adf7c24972d34eb0886c5154012 [weak]
   - Filesize:842684 [weak]
  Hashes of received file:
   - SHA256:0b46f490406e7d69c0458f30ce25b6d3bb1ea77f8d83b0659490aca83d0f13c3
   - MD5Sum:50f6837970119a0d5f8fb91c63d66d41 [weak]
   - Filesize:757168 [weak]
  Last modification reported: Mon, 19 Dec 2016 06:45:14 +0000
Err:136 http://ftp.fr.debian.org/debian stretch/main amd64 libopenscenegraph100v5 amd64 3.2.3+dfsg1-2+b4
  Somme de contrôle de hachage incohérente
  Hashes of expected file:
   - SHA256:77bfb25d5e35b1a5d728854be6ddd39121b7ac2af797f003c5a61a31ad1a1ac1
   - MD5Sum:1911f3f5f0154d6f10a505d16e089a50 [weak]
   - Filesize:5769560 [weak]
  Hashes of received file:
   - SHA256:eb2716438a873d35054ad079ccc01549e534877e534ec7c38483e65f4daaf745
   - MD5Sum:4e40ca186edd3a03fe5a8a10af2c3512 [weak]
   - Filesize:2277806 [weak]
  Last modification reported: Sat, 18 Mar 2017 20:28:47 +0000
Err:158 http://ftp.fr.debian.org/debian stretch/main amd64 libqtwebkit4 amd64 2.3.4.dfsg-9.1
  Somme de contrôle de hachage incohérente
  Hashes of expected file:
   - SHA256:bfd63dca3d12c9ddfdd16d895c4a90e0cd715f5c2e3f090c2f506df666dae779
   - MD5Sum:e8964e30084ff70e24453b9b079f7949 [weak]
   - Filesize:8882374 [weak]
  Hashes of received file:
   - SHA256:6d40919dbf2e3b5db7c9bf3e59af953a54f7ab5db91687cc93f343149e11e9ad
   - MD5Sum:5653d0c6a963cf022c1900c4e5310b85 [weak]
   - Filesize:7096046 [weak]
  Last modification reported: Wed, 23 Nov 2016 16:19:12 +0000
E: Impossible de récupérer http://ftp.fr.debian.org/debian/pool/main/g/grass/grass-doc_7.2.0-2_all.deb  Somme de contrôle de hachage incohérente
   Hashes of expected file:
    - SHA256:7e90e6fb568fad0c54426b85d3ee0701b38164a5ffed044ac0e9ab0309157ae7
    - MD5Sum:82f23fdd681002e276d60abeb6d0c785 [weak]
    - Filesize:23877538 [weak]
   Hashes of received file:
    - SHA256:bbd32bfe72b5b3701a987b8096ba4b04f4bf98d0a15ca4d1c59df3a1f3a597bc
    - MD5Sum:5778f73f444f792671cc7a6a0f313953 [weak]
    - Filesize:12490284 [weak]
   Last modification reported: Sun, 02 Apr 2017 23:11:21 +0000
E: Impossible de récupérer http://ftp.fr.debian.org/debian/pool/main/x/xerces-c/libxerces-c3.1_3.1.4+debian-2_amd64.deb  Somme de contrôle de hachage incohérente
   Hashes of expected file:
    - SHA256:962bc71575ada2cae35e695f7773db8fb00995bd5b012d1479a7c03dac777aa3
    - MD5Sum:b86c5adf7c24972d34eb0886c5154012 [weak]
    - Filesize:842684 [weak]
   Hashes of received file:
    - SHA256:0b46f490406e7d69c0458f30ce25b6d3bb1ea77f8d83b0659490aca83d0f13c3
    - MD5Sum:50f6837970119a0d5f8fb91c63d66d41 [weak]
    - Filesize:757168 [weak]
   Last modification reported: Mon, 19 Dec 2016 06:45:14 +0000
E: Impossible de récupérer http://ftp.fr.debian.org/debian/pool/main/o/openscenegraph/libopenscenegraph100v5_3.2.3+dfsg1-2+b4_amd64.deb  Somme de contrôle de hachage incohérente
   Hashes of expected file:
    - SHA256:77bfb25d5e35b1a5d728854be6ddd39121b7ac2af797f003c5a61a31ad1a1ac1
    - MD5Sum:1911f3f5f0154d6f10a505d16e089a50 [weak]
    - Filesize:5769560 [weak]
   Hashes of received file:
    - SHA256:eb2716438a873d35054ad079ccc01549e534877e534ec7c38483e65f4daaf745
    - MD5Sum:4e40ca186edd3a03fe5a8a10af2c3512 [weak]
    - Filesize:2277806 [weak]
   Last modification reported: Sat, 18 Mar 2017 20:28:47 +0000
E: Impossible de récupérer http://ftp.fr.debian.org/debian/pool/main/q/qtwebkit/libqtwebkit4_2.3.4.dfsg-9.1_amd64.deb  Somme de contrôle de hachage incohérente
   Hashes of expected file:
    - SHA256:bfd63dca3d12c9ddfdd16d895c4a90e0cd715f5c2e3f090c2f506df666dae779
    - MD5Sum:e8964e30084ff70e24453b9b079f7949 [weak]
    - Filesize:8882374 [weak]
   Hashes of received file:
    - SHA256:6d40919dbf2e3b5db7c9bf3e59af953a54f7ab5db91687cc93f343149e11e9ad
    - MD5Sum:5653d0c6a963cf022c1900c4e5310b85 [weak]
    - Filesize:7096046 [weak]
   Last modification reported: Wed, 23 Nov 2016 16:19:12 +0000
E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?
 



j'ai donc à nouveau lancé un:

apt-get update


voici la réponse complète:

Ign:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://security.debian.org/debian-security stretch/updates InRelease
Atteint:3 http://ftp.fr.debian.org/debian stretch-updates InRelease                              
Atteint:4 http://ftp.fr.debian.org/debian stretch Release                                        
Réception de:6 http://qgis.org/debian stretch InRelease [3 346 B]
Ign:6 http://qgis.org/debian stretch InRelease
3 346 o réceptionnés en 0s (5 054 o/s)
Lecture des listes de paquets... Fait
W: Erreur de GPG : http://qgis.org/debian stretch InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 073D307A618E5811
W: The repository 'http://qgis.org/debian stretch InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
 



Je suis allée voir dans le fichier http://qgis.org/debian/lists/qgis2_stre … 4_Packages
voici ce que je trouve comme information (je n'ai copié que le premier paquet pour plus de détails vous pouvez y accéder:http://qgis.org/debian/lists/qgis2_stre … 4_Packages):

Package: libqgis-analysis2.18.10
Source: qgis
Version: 1:2.18.10+14stretch
Architecture: amd64
Maintainer: QGIS developers <qgis-developer@lists.osgeo.org>
Installed-Size: 1800
Depends: gdal-abi-2-1-2, libc6 (>= 2.14), libexpat1 (>= 2.0.1), libgcc1 (>= 1:3.0), libgdal20 (>= 1.8.0), libgeos-c1v5 (>= 3.4.2), libproj12 (>= 4.8.0), libqca2 (>= 2.0.2), libqgis-core2.18.10, libqt4-network (>= 4:4.6.1), libqt4-sql (>= 4:4.5.3), libqt4-svg (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.5.3), libqtwebkit4 (>= 2.1.0~2011week13), libspatialindex4v5 (>= 1.8.1), libspatialite7 (>= 2.4.0), libsqlite3-0 (>= 3.5.9), libstdc++6 (>= 4.9)
Replaces: libqgis2.18.10
Homepage: http://qgis.org/
Priority: optional
Section: libs
Filename: pool/main/q/qgis/libqgis-analysis2.18.10_2.18.10+14stretch_amd64.deb
Size: 1421152
SHA256: e6212ec6dce363774e18d0a29c5d7f65b52d5329d710d2ae618ed082465bcb00
SHA1: c4bd0d7bd595889789c0806816176d6de2ef0cd1
MD5sum: eea9430969a4e277cbc2a5daff39e556
Description: QGIS - shared analysis library
 QGIS is a Geographic Information System (GIS) which manages, analyzes and
 display databases of geographic information.
 .
 This package contains the shared analysis library.
 


Du coup st-ce un problème de clé ou de téléchargement? Comment obtenir ces clés?
Merci pour votre aide.

Maud

Dernière modification par Maud (10-07-2017 12:20:43)

Hors ligne

#2 10-07-2017 11:52:36

Maud
Membre
Lieu : Melle (79)
Distrib. : Debian GNU/Linux 9 Stretch
Noyau : Linux 4.9.0-3-amd64
Inscription : 07-03-2017

Re : [résolu] problème de clé QGIS 2.18 sous debian 9 (stretch)

Pour info, j'ai essayé de récupérer la clé par ces méthodes (https://debian-facile.org/doc:systeme:apt:signatures?s:

 apt-get install deb-multimedia-keyring


E: Impossible de trouver le paquet deb-multimedia-keyring



et

gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys 073D307A618E5811


gpg: directory '/root/.gnupg' created
gpg: can't open '/usr/share/gnupg/dirmngr-conf.skel': Aucun fichier ou dossier de ce type
gpg: new configuration file '/root/.gnupg/gpg.conf' created
gpg: keybox '/root/.gnupg/pubring.kbx' created
gpg: failed to start the dirmngr '/usr/bin/dirmngr': Aucun fichier ou dossier de ce type
gpg: connecting dirmngr at '/root/.gnupg/S.dirmngr' failed: Aucun fichier ou dossier de ce type
gpg: keyserver receive failed: Pas de dirmngr
 



Installation du paquet dirmngr ok:

apt-get install dirmngr



puis nouvelle tentative:

gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys 073D307A618E5811


gpg: keyserver receive failed: No name



donc essaie avec la commande suivante:

gpg --keyserver hkp://wwwkeys.pgp.net --recv-keys 073D307A618E5811



après un temps assez long ça a fonctionné. Puis

gpg --armor --export 073D307A618E5811 | apt-key add


ok



apt-get update


ok

apt-get install qgis


téléchargements en cours. Je pense que mon sujet est résolé. Désolée pur la gène occasionnée

Dernière modification par Maud (10-07-2017 12:19:39)

Hors ligne

#3 28-09-2017 21:14:48

mendia
Membre
Inscription : 28-09-2017

Re : [résolu] problème de clé QGIS 2.18 sous debian 9 (stretch)

Bonjour et merci Maud pour le tuto
Mêmes erreurs initiales, étapes suivies pas à pas et même réussite.

Je rajoute juste pour compléter l'info que la clé :
gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys 073D307A618E5811

doit être remplacée par celle, individuelle, listée dans ligne d'erreur

W: Erreur de GPG : http://qgis.org/debian stretch InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY ################

Encore merci pour le suivi !

Hors ligne

Pied de page des forums