Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-07-2017 15:13:22

gegeours
Membre
Inscription : 12-08-2015

Erreurs synaptic au rechargement - problème de clés

Bonjour à tous,

je viens d'installer gnome-stretch et voici le retour de synaptic au rechargement :


W: http://ftp.fr.debian.org/debian/dists/stretch-updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://security.debian.org/dists/stretch/updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://ftp.fr.debian.org/debian/dists/stretch/Release.gpg: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
 



si je fais un apt-get :


root@debian:/home/gerard# apt-get update
Atteint:1 http://ftp.fr.debian.org/debian stretch-updates InRelease
Atteint:2 http://security.debian.org stretch/updates InRelease                
Ign:3 http://ftp.fr.debian.org/debian stretch InRelease                        
Atteint:4 http://ftp.fr.debian.org/debian stretch Release      
Lecture des listes de paquets... Fait
W: http://ftp.fr.debian.org/debian/dists/stretch-updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://security.debian.org/dists/stretch/updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://ftp.fr.debian.org/debian/dists/stretch/Release.gpg: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
 




Mon sources.list est le suivant :


Dépots principaux
deb http://ftp.fr.debian.org/debian/ stretch main non-free contrib
# deb-src http://ftp.fr.debian.org/debian/ stretch  main non-free contrib

#Mises à jour de sécurité
deb http://security.debian.org/ stretch/updates main contrib non-free
# deb-src http://security.debian.org/ stretch/updates main contrib non-free

# Mises à jour volatiles
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
 



Comment puis-je procéder pour retrouver une mise à jour sans problème ?
Merci d'avance pour votre aide.

Dernière modification par gegeours (14-07-2017 15:48:52)

Hors ligne

#2 14-07-2017 15:59:05

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreurs synaptic au rechargement - problème de clés

Bonjour
Y'a eu un sujet qui parlait de probléme avec trusted.gpg il en est resorti que on pouvait le supprimer sans danger
Je retrouve plus le post ( et j'ai la fleme de chercher big_smile )
pour + de sécurité tu le garde sous un autre nom comme ça au cas ou il sera toujours la

mv /etc/apt/trusted.gpg /etc/apt/trusted_save


apres tu refais

apt update && apt updrade


Si jamais tu dois restaurer le fichier comme avant

mv /etc/apt/trusted_save /etc/apt/trusted.gpg


du coup j'ai retrouvé le post
https://debian-facile.org/viewtopic.php … 64#p225664
le mieux c'est de s'en inspirer

Dernière modification par Croutons (14-07-2017 16:07:07)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

Pied de page des forums