Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-07-2017 18:44:55

ricardo
Membre
Distrib. : Stretch
Noyau : Le plus à jour
(G)UI : KDE
Inscription : 29-01-2016

[RÉSOLU] Suite autre fil : Kernel panic Debian9

robert2a a écrit :

    @hector
    tu a fait comment l installation de stretch ?
    en 2 temps , serveur pur aprés reboot puis bureau + driver non free et reboot ?
    ou tu a blacklisté nouveau pour forcer le mode vesa ?
    ça peu intéresser d'autres membres qui ont le meme souci  smile

    nota : ou tu pense que le souci vient du dernier installateur stretch rc5 et que l ancien n'a pas ce souci  (rc3 ou rc4 )



Eh oui, ça intéresse d'autres utilisateurs qui ont exactement le même souci, Ricardo, en en l'occurrence. mad

Même cheminement, à peu près :
Après une dizaine d'années à jouer avec Sid, l'âge agissant sur la comprenette, depuis 3 ans, je me suis rangé et je suis "Stable" uniquement.
Donc j'étais sous Jessie et, il y a environ 15 jours, j'ai voulu mettre à jour et passer sous Stretch, lequel a été installé classiquement et avec KDE, mais sans autres ajouts, donc les pilotes natifs sous Debian9.
Sur ma machine principale, où Stretch a été installé, Kernel panic avec le noyau 4.9 = Kernel panic 8 fois sur 10, les deux autres, ça passe après un temps de chargement assez long, mais ensuite, une fois connecté, pas de problèmes. Si je charge le noyau 3.16, vestige de Jessie, j'atterris  bien sous Debian9 et je n'ai aucun problème de K.Panic.
Je vais donc tester le passage au pilote propriétaire Nvidia, pour voir si mon problème se résout aussi.
Par contre, j'aimerais une aide pour la façon de trouver le pilote qui va bien et ensuite, de l'installer.
J'ai fait ça il y a très longtemps, mais ma mémoire ressemble aujourd'hui à un emmenthal.

Pour la carte graphique installée, lpci donne ;

    01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 620] (rev a1)



Merci de l'aide.

Dernière modification par ricardo (20-07-2017 01:21:30)


Informatique depuis 1986, Linux depuis2001, Debian exclusivement depuis 2002.
Stretch à jour sur plusieurs machines bureau et un portable. KDE.

Hors ligne

#2 18-07-2017 15:28:35

hector
Membre
Distrib. : Debian Sid
Noyau : 4.11.0-2-amd64
(G)UI : KDE Plasma 5
Inscription : 13-12-2011

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

Bonjour ricardo,

Je crois comprendre que tu veux installer le pilote proprio Nvidia car tu penses que comme la mienne ta CG ne supporte plus le pilote 'nouveau', d'où le 'kernel panic' et sur une Strectch déjà installée.
Je n'avais pas vraiment le même problème puisque j'avais un 'kernel panic' à l'install avec le CD netinstall

A ta place, voilà ce que je ferais :

- Désactiver le module 'nouveau' lors du démarrage du noyau :

nano /etc/default/grub


Modifier :

GRUB_CMDLINE_LINUX_DEFAULT="quiet nouveau.modeset=0 modprobe.blacklist=nouveau"


update-grub


reboot



- Au redémarrage, installer le driver nvidia, voir sur le wiki :
https://debian-facile.org/doc:materiel: … -avec-dkms


PS : J’ai été content de te lire, cela me rappelle tant de souvenirs : mes débuts (2005) sous Debian et le  forum auquel nous avons participé ( moi avec un autre pseudo ) pendant des années, même si je n'ai jamais été un grand posteur !. Bonne continuation. wink

Dernière modification par hector (18-07-2017 15:29:14)

Hors ligne

#3 18-07-2017 18:42:55

ricardo
Membre
Distrib. : Stretch
Noyau : Le plus à jour
(G)UI : KDE
Inscription : 29-01-2016

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

Merci de ta réponse et du gentil commentaire qui l'accompagne.
En effet, ça ne nous rajeunit pas, moi encore moins.
Je vais tester ce que tu me proposes ce soir ou demain et je posterai la réponse ici.
Bonne soirée.

EDIT à 18:50 :
Le tuto sur Nvidia à installer semble clair mais ...

Puis avec nano éditez le fichier /etc/X11/xorg.conf ainsi :



Je n'ai pas de xorg.conf sur ma Stretch, je suppose qu'il a changé de nom mais lequel ???

Dernière modification par ricardo (18-07-2017 18:53:31)


Informatique depuis 1986, Linux depuis2001, Debian exclusivement depuis 2002.
Stretch à jour sur plusieurs machines bureau et un portable. KDE.

Hors ligne

#4 18-07-2017 19:14:45

romain
Membre
Lieu : Suisse
Distrib. : Debian, "Stretch" ou "Sid"
Noyau : Linux 4.9.0-3-amd64 ou 4.11.0-1-amd64
(G)UI : openbox forever
Inscription : 31-01-2013

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

Bonjour,

Je me suis posé la même question du pourquoi, je n'avais pas de xorg.conf. La réponse se trouve ici: https://wiki.debian.org/fr/Xorg

En gros, il te faut le générer:
Quitter le mode graphique:

# /etc/init.d/gdm stop || /etc/init.d/gdm3 stop || /etc/init.d/kdm stop || /etc/init.d/xdm stop || /etc/init.d/lightdm stop


$ cd /etc/X11/


Générer le fichier:

$# Xorg -configure



Salutation

Hors ligne

#5 18-07-2017 19:19:24

hector
Membre
Distrib. : Debian Sid
Noyau : 4.11.0-2-amd64
(G)UI : KDE Plasma 5
Inscription : 13-12-2011

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

ricardo a écrit :

... EDIT à 18:50 :
Le tuto sur Nvidia à installer semble clair mais ...

Puis avec nano éditez le fichier /etc/X11/xorg.conf ainsi :



Je n'ai pas de xorg.conf sur ma Stretch, je suppose qu'il a changé de nom mais lequel ???



Non il n'y a pas de fichier xorg.conf, mais avec la commande :

nano /etc/X11/xorg.conf


tu vas créer le fichier xorg.conf vide dans lequel tu ajoutes :

Section "Device"
Identifier  "Video Card"
Driver    "nvidia"
Option          "NoLogo"                    "1"
Option          "RenderAccel"               "1"
EndSection


Puis tu enregistres ( Ctrl +O ) et tu quittes ( Ctrl + Q )

Etc ...
wink

Dernière modification par hector (18-07-2017 19:21:27)

Hors ligne

#6 18-07-2017 19:26:36

ricardo
Membre
Distrib. : Stretch
Noyau : Le plus à jour
(G)UI : KDE
Inscription : 29-01-2016

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

Merci, je ferai ça ce soir, certainement.
Suite demain.

Informatique depuis 1986, Linux depuis2001, Debian exclusivement depuis 2002.
Stretch à jour sur plusieurs machines bureau et un portable. KDE.

Hors ligne

#7 19-07-2017 00:42:29

ricardo
Membre
Distrib. : Stretch
Noyau : Le plus à jour
(G)UI : KDE
Inscription : 29-01-2016

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

Ben ce soir, pas possible car orage et micro-coupures de courant à répétition, donc, demain.

Informatique depuis 1986, Linux depuis2001, Debian exclusivement depuis 2002.
Stretch à jour sur plusieurs machines bureau et un portable. KDE.

Hors ligne

#8 19-07-2017 06:18:32

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

Bonjour
aprés avoir fait ce qui est noté en #2  (éviter le panic kernel du noyau )
plusieurs méthodes (meme utiliser le gpu intel si il existe pour installer le driver puis mettre la carte nvidia en place )

en #4 , inutile de créer un xorg.conf avec stretch (ce fichier n'est plus utile , sauf pour utiliser des options spécifiques ) donc je te conseille de faire l installation sans.

modifier le sources.list


#stretch 9
deb http://deb.debian.org/debian stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb http://deb.debian.org/debian stretch-backports main contrib non-free
 


mettre a jour le cache


apt-get update
 


installer nvidia-detect


apt-get install nvidia-detect
 


vérifier que le driver de stretch est compatible avec ta carte


nvidia-detect
 


installer le driver


apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 


reboot


reboot
 

Hors ligne

#9 19-07-2017 12:48:17

ricardo
Membre
Distrib. : Stretch
Noyau : Le plus à jour
(G)UI : KDE
Inscription : 29-01-2016

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

Merci à vous deux, Super, ça fonctionne parfaitement et plus de kernel panic (en espérant que ça soit pérenne).
En fait, je viens juste de lire la réponse de Robert2a, mais ce ce que j'avais fait.
Le fichier se crée automatiquement.
Je préciserai dans la soirée car je dois partir.

Informatique depuis 1986, Linux depuis2001, Debian exclusivement depuis 2002.
Stretch à jour sur plusieurs machines bureau et un portable. KDE.

Hors ligne

#10 19-07-2017 19:56:24

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

tu peu passer ton post en [resolu] en éditant ton #1 et ajouter devant le titre =>  [resolu]

Hors ligne

#11 20-07-2017 01:24:55

ricardo
Membre
Distrib. : Stretch
Noyau : Le plus à jour
(G)UI : KDE
Inscription : 29-01-2016

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

oui, je viens de faire.
Je voulais seulement ajouter que j'ai suivi le conseil d'Hector, sauf l'ajout du fichier xorg dont on n'a plus besoin. Il se crée automatiquement.
Merci à tous pour l'aide.

Informatique depuis 1986, Linux depuis2001, Debian exclusivement depuis 2002.
Stretch à jour sur plusieurs machines bureau et un portable. KDE.

Hors ligne

#12 20-07-2017 09:11:15

hector
Membre
Distrib. : Debian Sid
Noyau : 4.11.0-2-amd64
(G)UI : KDE Plasma 5
Inscription : 13-12-2011

Re : [RÉSOLU] Suite autre fil : Kernel panic Debian9

Bonjour ricardo,
Merci pour le retour. wink
Bonne journée.
@+

Hors ligne

Pied de page des forums