Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-09-2009 21:23:19

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Synaptic : blocage version paquet inopérant

Bjr,
Suite au problème du moment avec xserver-xorg-core, j'ai bloqué ce paquet, avec synaptic, sur la version précédente de testing. (en veillant bien à "forcer" sur cette version).
Update/upgrade d'aujourd'hui et bing ! ça m'installe la version unstable (la pourrie pour mon pc).

Des idées ?

Merci

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#2 30-09-2009 21:31:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Synaptic : blocage version paquet inopérant

Salut,

Ça :

Marque <package> comme étant àconserver : annule toute action d'installation, de mise àjour ou de suppression, et empêche ce paquet d'être mis àjour automatiquement dans le futur.

<paquet>:


Trouuvé là :
http://www.tayo.fr/aptitude-man-linux-astuce.php

Amitié, Jojo


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 30-09-2009 21:40:24

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Synaptic : blocage version paquet inopérant

re-
Ah, l'affreux...qui veut que je passe à l'ennemi..

Ben tiens je vais essayer, voir si apt-get reconnait les commandes de l'autre là (comment y s'appelle déjà ? apt-titube, un truc comme ça....)

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#4 30-09-2009 21:56:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Synaptic : blocage version paquet inopérant

Alors ça :

--no-upgrade
    Aucune mise à niveau~; quand elle est utilisée avec install, cette commande empêche les paquets listés sur la ligne de commande d'être mis à niveau. Élément de configuration~: APT::Get::Upgrade.


De là :
http://pwet.fr/man/linux/administration_systeme/apt_get

Et a p'ti tube, mais il fait le maximum !

Tchibâââ ! big_smile

Dernière modification par smolski (30-09-2009 22:08:15)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 30-09-2009 22:08:30

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Synaptic : blocage version paquet inopérant

re-
Merci.
Mais ça ne bloque rien. Qu'aptitude n'agisse pas sur apt-get, à la limite c'est normal. Par contre les options apt-get, elles devraient.

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#6 01-10-2009 04:07:40

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Synaptic : blocage version paquet inopérant

Salut

Pour ton problème de paquet, j'ai lu sur debian-fr.org que certains avaient résolu le problème en allant chercher ce qu'il faut dans experimental. C'est peut-être la solution pour toi aussi.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 01-10-2009 13:45:36

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Synaptic : blocage version paquet inopérant

Bjr,
C'est bon le paquet est passé en 2:1.6.4-2.
Bon ça ne résout pas la question : peut être le fait d'avoir installer une version, puis d'avoir downgradé empêche un blocage complet. J'aurais dû essayer en virant le paquet lui-même. Si ça se représente...

Par contre à propos d'expérimental, il est dans mon sources.list et je n'ai pas de proposition dans synaptic. Vais voir dans le wiki..

Merci

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#8 01-10-2009 14:38:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Synaptic : blocage version paquet inopérant

Phlinux,

Commande :

~$ apt-cache madison paquet xserver-xorg-core
xserver-xorg-core | 2:1.6.99.903-1 | http://ftp.fr.debian.org experimental/main Packages


Fait l'affaire !

Yop...

Dernière modification par smolski (01-10-2009 14:41:21)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 01-10-2009 16:05:01

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Synaptic : blocage version paquet inopérant

re-

phlinux:/home/phlinux# apt-cache madison paquet xserver-xorg-core
xserver-xorg-core |  2:1.6.4-2 | http://ftp.fr.debian.org sid/main Packages
xserver-xorg-core | 2:1.6.3.901-1 | http://ftp.fr.debian.org testing/main Packages
xserver-xorg-core | 2:1.4.2-10.lenny2 | http://ftp.fr.debian.org stable/main Packages
xorg-server | 2:1.6.3.901-1 | http://ftp.fr.debian.org testing/main Sources
xorg-server | 2:1.4.2-10.lenny2 | http://ftp.fr.debian.org stable/main Sources
xorg-server |  2:1.6.4-2 | http://ftp.fr.debian.org sid/main Sources


Vois pas d'expérimental.

Mauvais fichier préférences ?

Package: *
Pin: release o=Unofficial Multimedia Packages,a=experimental,l=Unofficial Multimedia Packages
Pin-Priority: 1


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#10 01-10-2009 16:44:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Synaptic : blocage version paquet inopérant

Plutôt mauvais sources.list phlinux, là...

Tu es sûr d'avoir les sources experimental non commentées ?
Je te mets la totalité de ma commande :

~$ apt-cache madison paquet xserver-xorg-core
xserver-xorg-core | 2:1.6.99.903-1 | http://ftp.fr.debian.org experimental/main Packages
xserver-xorg-core |  2:1.6.4-1 | http://ftp.fr.debian.org sid/main Packages
xserver-xorg-core | 2:1.6.3.901-1 | http://ftp.fr.debian.org testing/main Packages
xserver-xorg-core | 2:1.4.2-10.lenny2 | http://ftp.fr.debian.org lenny/main Packages


Mon sources list experimental :

## Depot experimental
deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ experimental main contrib non-free

## Debian-multimedia-experimental
deb http://www.debian-multimedia.org/ experimental main
# deb-src http://www.debian-multimedia.org/ experimental main


Et le preferences qui s'y rapporte est identique au tien. Je n'en ai pas fait pour l'experimental officiel, puisqu'il est à 1 d'office !

Amitié et jugeote, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 01-10-2009 18:36:12

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Synaptic : blocage version paquet inopérant

re-
Compris : c'est un paquet amd64

Bon à suivre, pour le sujet

Merci , Joel

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#12 09-10-2009 12:25:03

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Synaptic : blocage version paquet inopérant

re-
Dès que possible :

phlinux a écrit :

Re-
A essayer.
Pour chacun des paquets à bloquer sur la version choisie.
Dans le /etc/apt/preferences

Package: nom_du_paquet #tel que dpkg -l le donne
Pin: version 2.0.0.6-1  #les chiffres sont un exemple
Pin-priority: 1001


De toute façon, toujours essayer avec "apt-get -s upgrade", ou encore faire un "apt-cache policy nom_du_paquet"


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#13 09-10-2009 12:39:17

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Synaptic : blocage version paquet inopérant

phlinux a écrit :

Bjr,
Suite au problème du moment avec xserver-xorg-core, j'ai bloqué ce paquet, avec synaptic, sur la version précédente de testing. (en veillant bien à "forcer" sur cette version).
Update/upgrade d'aujourd'hui et bing ! ça m'installe la version unstable (la pourrie pour mon pc).

Des idées ?

Merci


Tu veux dire l'upgrade via synaptic ?

quand tu bloques un paquet via synaptic, et qu'ensuite tu utilises apt-get en ligne de commandes, il en tient pas compte, pour que tous les outils apt prennent en  compte
le bloquage d'une version ça se passe dans le preferences d'apt, quand tu bloques via synaptic
il fait un preferences dans /var/lib/synaptic/preferences.

Hors ligne

#14 09-10-2009 13:18:06

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Synaptic : blocage version paquet inopérant

re-
Ah, enfin un grand frère..
Non pas l'upgrade via synaptic, mais en console. Et donc oui blocage dans synaptic = pas de blocage par apt-get.

Bon à la limite pour mon cas peu importe. Je confirme la manip du dessus, finalement plus pratique, notamment pour un serveur sans X.

Par l'exemple, pour le paquet "phonon". Proposition de mise à jour de la 4:4.5.3-1 > 4:4.5.3-2.
Blocage

Package: phonon
Pin: version 4:4.5.3-1
Pin-Priority: 1001


Donc apt-get update/upgrade et pas de paquet phonon mis à jour. A noter que les paquets dépendants de phonon, semblent aussi gardés en l'état (à vérifier)

Autres remarques : on peut constater dans synaptic, qu'aucun blocage visible n'apparait (Etiquetage) mais que subtilement la colonne "Dernière version" affiche la version installée.De plus la petite flèche indiquant une maj possible n'apparait plus.


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

Pied de page des forums