Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-07-2017 02:02:37

bundy
Membre
Distrib. : stretch
Noyau : 3.2
(G)UI : gnome 3 shell
Inscription : 14-09-2010

[RESOLU] problême de dépendances driver nvidia

Bonjour,

Suite à ma migration sous stretch, j'ai un problème de dépendance non satisfaite avec le driver nvidia.

Il veut pas me le mettre à jour. aptitude propose plusieurs options. La première est de laisser le paquet en l'état. C'est à dire non mis à jour. Ça me plaît pas trop.
autrement il propose soit de le virer, soit de virer celui avec lequel il est en conflit. Je ne sais pas trop quoi faire. On dirais que c'est deux drivers qui se marchent dessus, mais je sais pas trop. Si quelqu'un peut m'éclairer.


1500767482.png

Dernière modification par bundy (23-07-2017 12:13:03)

Hors ligne

#2 23-07-2017 12:10:40

bundy
Membre
Distrib. : stretch
Noyau : 3.2
(G)UI : gnome 3 shell
Inscription : 14-09-2010

Re : [RESOLU] problême de dépendances driver nvidia

La logithèque m' aproposé de redémarer et mettre à jour ce matin. Elle à redémaré, viré libgl-nvidia-glx, chargé nvidia-vulkan-common puis redémaré une seconde fois. Et tout est à jour maintenant. smile .

Hors ligne

#3 24-07-2017 15:03:39

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] problême de dépendances driver nvidia

Bonjour

c'est normal , j'ai eu la meme chose sur certaines machines avec le paquet glx installé (le nom exact du paquet libgl1-nvidia-glx ) qui a été retiré
ce paquet a été remplacé par libgl1-glvnd-nvidia-glx et libgl1-nvidia-glvnd-glx

mise a jour du paquet nvidia-vulkan-common  (ce paquet est en conflit avec libgl1-nvidia-glx ).

toujours la meme chose , patience , ne pas forcer , le système c'est mit a jour tout seul

nota : j'ai forcé le paquet libgl1-nvidia-glx a cause de Steam

nota : pour information cette mise a jour du driver nonfree est une mise a jour de sécurité (appliqué sur Stretch (directement , pas dans les backports ) , Buster et Sid )

ps : mise a jour effectué avec synaptic

Dernière modification par robert2a (25-07-2017 11:29:47)

Hors ligne

#4 25-07-2017 11:27:53

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] problême de dépendances driver nvidia

Bonjour

j'ai toujours le poblème avec Steam et le paquet  libgl1-glvnd-nvidia-glx (a la place du paquet libgl1-nvidia-glx ) , donne une erreur au démarrage
par contre si j' installe le paquet libgl1-nvidia-glx , il faut que je supprime Vulkan-common (et Vulkan)  qui est en conflit avec ce paquet .
faut que je regarde ce souci , pas trop le temps pour l'instant roll  (je pensais que c'etait résolu avec la dernière version  a priori non )

PS: Steam fonctionne avec libgl1-glvnd-nvidia-glx:i386 et libgl1-nvidia-glvnd-glx:i386
sur ma plate forme stretch + mate avec Ryzen il fonctionne , sur ma machine avec gnome (stretch aussi ) ces 2 paquets ne sont pas installés (pourtant le multiarch devrait etre activé roll  et steam etait fonctionnel avant la mise a jour ).
une recherche avec synaptic ne donne rien , on fera une simulation avec apt-get ou aptitude de l installation de ces 2 paquets  hmm

ceci devrait résoudre le problème


apt-get -s install libgl1-glvnd-nvidia-glx:i386 libgl1-nvidia-glvnd-glx:i386
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
The following additional packages will be installed:
  libgldispatch0-nvidia:i386 libglx-nvidia0:i386 libglx0-glvnd-nvidia:i386 libnvidia-glcore:i386
Les NOUVEAUX paquets suivants seront installés :
  libgl1-glvnd-nvidia-glx:i386 libgl1-nvidia-glvnd-glx:i386 libgldispatch0-nvidia:i386 libglx-nvidia0:i386 libglx0-glvnd-nvidia:i386 libnvidia-glcore:i386
0 mis à jour, 6 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst libgldispatch0-nvidia:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Inst libglx0-glvnd-nvidia:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Inst libgl1-glvnd-nvidia-glx:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Inst libnvidia-glcore:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Inst libglx-nvidia0:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Inst libgl1-nvidia-glvnd-glx:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Conf libgldispatch0-nvidia:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Conf libglx0-glvnd-nvidia:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Conf libgl1-glvnd-nvidia-glx:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Conf libnvidia-glcore:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Conf libglx-nvidia0:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
Conf libgl1-nvidia-glvnd-glx:i386 (375.66-2~deb9u1 Debian:9.1/stable [i386])
 



je pense pas etre hors sujet smile  si quelqu'un a un souci après la mise a jour du driver ça peu aider
pas encore effectué la commande en réel , mais je pense que Steam va fonctionner correctement  smile
comme quoi a chaque machine son lot de surprises hmm

Dernière modification par robert2a (25-07-2017 12:12:42)

Hors ligne

Pied de page des forums