Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-07-2017 16:19:12

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Activer le profil root

Bonjour à tous smile

La question est récurrente, je sais, mais désolé de la poser.
Ds l'association dont je suis bénévole, nous avons un serveur sous Debian 8. Un serveur Apache, monté par des cadors : je m'incline. Et tout cela en ligne de commande. Chapeau !

J'y accède en root, donc : au logon, je saisis : root, et son psw. Evidemment, j'ai créé d'autres profils utilisateurs, à moindre risque.

Or... je ne sais pas comment activer ce profil chez moi.
J'ai bien suivi des tutos, attribué un psw à root... mais il n'est pas possible d'y entrer, donc de l'activer, et donc d'y travailler. Tant sous Debian que sous les autres distrib. Là, j'installe Debian 9.

Je connais les risques du travail en root. Je suis assez maniaque sur les sauvegardes et surtout les images  Acronis et Clonezilla. Pouvez-vous m'aider, s'il vous plaît ?

Merci :hello:

Hors ligne

#2 31-07-2017 16:32:12

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Activer le profil root

Bonjour et bienvenue smile

Est-ce que tu trouverait une réponse dans ce tuto ? https://debian-facile.org/doc:systeme:superutilisateur

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 31-07-2017 22:00:14

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : Activer le profil root

Bonsoir, Admin Stagiaire smile
Je vois ça tout de suite et donne le retour. Désolé pour le retard de ma réponse, mais j'ai dû courir partout, aujourd'hui !

Hors ligne

#4 31-07-2017 22:03:32

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Activer le profil root

Lupa a écrit :

Désolé pour le retard de ma réponse, mais j'ai dû courir partout, aujourd'hui !

Pas d'inquiétude, la vraie vie a bien plus d'importance que nos tas de puces électroniques tongue


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#5 06-08-2017 15:43:11

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : Activer le profil root

Bonjour.
@Bendia : je en suis vraiment pas doué. Je planche que la question depuis des jours et des jours. Sans résultat. Merci pourle tuto, mais il ne me dit pas comment activer le compte root.

Du coup, je suis tjrs obligé de lancer un terminal, me loguer en root, et appeler MC, par exemple, en root MAIS à travers le terminal. Debian 9 ne permet-il pas d'activer ce fichu compte ? Ca marche sur le serveur, mais c'est Debian 8, en graphique aussi. 

J'ai attribué un password à root, et ça a marché. Mais... au logon, lorsque l'OS me dit "Absent de la liste ?", je dis oui et saisis root, puis son psw. Ca tourne, et l'OS me répond "Désolé, ça n'a pas fonctionné".

Autre piste : éditer /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf .
3) Ajouter la ligne suivante :
greeter-show-manual-login=true

4) sudo gedit /root/.profile

Modifier :
mesg n
Par :
if `tty -s`; then
   mesg n
fi
puis reboot ou shutdown -r now.

Mais je ne le trouve pas ce fichier... Que faire ? Merci :hello:
Précision : cette astuce est fournie pour Ubuntu. Et pour la tester, je vais déjà faire une image Acronis.

Dernière modification par Lupa (06-08-2017 15:44:26)

Hors ligne

#6 07-08-2017 14:22:31

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : Activer le profil root

Bonjour à tous.

J'ai modifié ce fichier comme indiqué. Mais sans résultat. Debian me propose de me loguer sous MON profil, et il y a une image "Absent de la liste ?'. Je clique dessus. J'arrive sur une interface de logon. Je saisis root comme "user", et le mot de passe root. Deux fois : l'OS répond "Ca n'a pas marché".

Que faire ?

Hors ligne

#7 07-08-2017 14:25:09

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Activer le profil root

C'est normal de ne pas pouvoir se loguer dans une session graphique en root, puisque c'est une énorme faille de sécurité wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#8 07-08-2017 16:06:09

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : Activer le profil root

Solutionné.
@Modération : ai-je le droit d'afficher la solution ? Autrement, je ne fais pas. Là, ce n'est pas à moi de décider.
@bendia : faille de sécurité. A quel niveau, exactement : tout casser, ou intrusion ?

Hors ligne

#9 07-08-2017 16:52:37

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Activer le profil root

Lupa a écrit :

@Modération : ai-je le droit d'afficher la solution ?

Non seulement le droit, mais presque le devoir tongue C'est le rôle même du forum que de présenter le fruit de ses trouvailles smile

Lupa a écrit :

@bendia : faille de sécurité. A quel niveau, exactement : tout casser, ou intrusion ?

Les 2. Dans ce cas, tout logiciel lancé l'est en tant que root. Donc, ton navigateur web par exemple. Ce qui implique que n'importe quel script s’exécute avec tous les droits sur le système.

Idem pour ton explorateur de fichier. Tu peux alors supprimer n'importe quel fichier indispensable au fonctionnement du système sans t'en apercevoir.


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#10 07-08-2017 18:07:47

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : Activer le profil root

La solution : j'ai suivi ce tuto. https://www.youtube.com/watch?v=XXHV7VcXUmc
Sous Debian 9, il est là : /etc/pam.d/common-password .
Et j'ai juste désactivé (#) la ligne indiquée par le tuto.
Du coup, au logon, Debian me propose de me loguer avec un profil utilisateur, et le fameux message "Absent de la liste ?" Je clique sur "Absent...", j'ai une case à remplir dans la quelle je saisis root, puis son psw. Et je suis root.

Hors ligne

#11 07-08-2017 18:15:44

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Activer le profil root

Merci pour ton retour smile

Mais, il y a les dangers que j'ai cité précédemment (il est probable que j'en oublie), et c'est une mauvaise pratique d'utiliser sa machine de la sorte. Ça annule tous les avantages de la séparation stricte qui existe entre root et les autres utilisateurs.

C'est pour cela que cette option est désactivée par défaut wink

A la place, il est de loin préférable de gagner des privilèges uniquement lorsque c'est nécessaire, grâce aux commandes du tuto indiqué en lien dans mon premier message (je le remet https://debian-facile.org/doc:systeme:superutilisateur), donc avec su ou sudo et gksu/kdesu pour les applications graphiques nécessitant ce type de droits smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#12 07-08-2017 21:20:44

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : Activer le profil root

Oui : nous sommes bien d'accord là-dessus. C'est très risqué. D'où un autre compte utilisateur pour les TP sur le shell. rm, en root, hum ! roll

Hors ligne

Pied de page des forums