Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-08-2017 13:02:50

clonador
Membre
Distrib. : Debian 9.1
Noyau : Linux 4.9.0-3-amd64
(G)UI : xfce4
Inscription : 13-04-2016

Accueil Erreur Debian 9.1

Cette erreur est affiché sur le premier écran avant d'entrer dans l'environnement graphique

ACPI Error: Method parse/execution failed




0010.jpg


Le bios de mon ordinateur me permet de démarrer en mode HD mode AHCI ou IDE.

Si vous choisissez le mode IDE n'affiche pas ce pas d'erreur

Merci, bon jour.

EDIT: Je ne sais pas si cette question est semblable à la mienne: https://debian-facile.org/viewtopic.php?id=17677

Dernière modification par clonador (06-08-2017 13:06:22)

Hors ligne

#2 06-08-2017 13:40:56

raleur
Membre
Inscription : 03-10-2014

Re : Accueil Erreur Debian 9.1

Et à part ça, le système fonctionne normalement ? Si oui, il n'y a pas lieu de s'inquiéter, certaines erreurs sont "normales".
Le mode IDE est moins performant que le mode AHCI, et ne permet pas d'utiliser les fonctionnalités natives du SATA (NCQ, hotplug...).
Désactiver le support de l'ACPI est aussi une solution (ou un plutôt un contournement) un peu trop extrême qui a des inconvénients puisque l'ACPI sert notamment à gérer l'alimentation de la machine (arrêt, mise en veille...).

Si le message d'erreur est lié au mode ahci du contrôleur SATA, tu peux essayer de désactiver l'ACPI uniquement pour les pilotes libata en ajoutant l'option suivante à la ligne de commande du noyau dans le menu de GRUB :

libata.noacpi=1

Hors ligne

#3 06-08-2017 14:03:51

robertjl
Membre
Lieu : La Chaux-de-Fonds (Suisse)
Distrib. : Portable = Stretch / Tour = Stretch
Noyau : 4.9.0-3-amd64
(G)UI : Portable Cinnamon 3.2.7 / Tour Gnome
Inscription : 26-06-2017

Re : Accueil Erreur Debian 9.1

Et bien moi j'ai aussi ce type de message avant l'écran de connexion.
Je suis content de n'être pas le seul.
Chez moi le PC fonctionne bien et je n'ai pas de problème de fonctionnent Debian.

Jena-Luc

Hors ligne

#4 06-08-2017 14:27:06

clonador
Membre
Distrib. : Debian 9.1
Noyau : Linux 4.9.0-3-amd64
(G)UI : xfce4
Inscription : 13-04-2016

Re : Accueil Erreur Debian 9.1

raleur a écrit :

Et à part ça, le système fonctionne normalement ? Si oui, il n'y a pas lieu de s'inquiéter, certaines erreurs sont "normales".
Le mode IDE est moins performant que le mode AHCI, et ne permet pas d'utiliser les fonctionnalités natives du SATA (NCQ, hotplug...).
Désactiver le support de l'ACPI est aussi une solution (ou un plutôt un contournement) un peu trop extrême qui a des inconvénients puisque l'ACPI sert notamment à gérer l'alimentation de la machine (arrêt, mise en veille...).

Si le message d'erreur est lié au mode ahci du contrôleur SATA, tu peux essayer de désactiver l'ACPI uniquement pour les pilotes libata en ajoutant l'option suivante à la ligne de commande du noyau dans le menu de GRUB :

libata.noacpi=1



Merci beaucoup, mon système Debian 9 fonctionne bien malgré l'erreur.

Je ne sais pas mettre cette ligne dans le menu de GRUB:

libata.noacpi=1



Où se trouve le fichier de configuration du menu de GRUB?

Merci mes amis debian facile.
Pardon par mon pessime français.

Hors ligne

#5 06-08-2017 14:30:03

clonador
Membre
Distrib. : Debian 9.1
Noyau : Linux 4.9.0-3-amd64
(G)UI : xfce4
Inscription : 13-04-2016

Re : Accueil Erreur Debian 9.1

robertjl a écrit :

Et bien moi j'ai aussi ce type de message avant l'écran de connexion.
Je suis content de n'être pas le seul.
Chez moi le PC fonctionne bien et je n'ai pas de problème de fonctionnent Debian.

Jena-Luc




Mais oui, chez mon PC fontionne aussi très bien Debian 9.
Cette notification d'erreur il n'y a pas jamais dans Debian 8

Hors ligne

#6 06-08-2017 14:33:57

raleur
Membre
Inscription : 03-10-2014

Re : Accueil Erreur Debian 9.1

Pour essayer l'option, il ne faut pas la mettre dans un fichier. Il faut d'abord la taper directement dans le menu de GRUB au démarrage :
- sélectionner l'entrée du menu à modifier
- appuyer sur la touche "e" pour l'éditer
- ajouter l'option à la fin de la ligne qui commence par "linux" (selon la largeur de l'affichage elle peut revenir à la ligne suivante)
- appuyer sur la touche F10 ou Ctrl+x pour démarrer

Attention : le clavier est interprété en QWERTY US, donc sur un clavier AZERTY FR le "a" s'obtient avec la touche "q" et le point s'obtient avec la touche ":".

Hors ligne

#7 06-08-2017 14:49:58

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Accueil Erreur Debian 9.1

Bonjour

raleur a écrit :

Si le message d'erreur est lié au mode ahci du contrôleur SATA, tu peux essayer de désactiver l'ACPI uniquement pour les pilotes libata en ajoutant l'option suivante à la ligne de commande du noyau dans le menu de GRUB :

libata.noacpi=1



Si j'ai bien suivis on edite le menu grub

nano /etc/default/grub


Et on ajoute l'option a la ligne GRUB_CMDLINE_LINUX, pour plusieurs options sur une meme ligne il faut séparer par un point virgule
exemple sur mon Grub ça donnerait

GRUB_CMDLINE_LINUX="initrd=/install/gtk/initrd.gz"; "libata.noacpi=1"


Sauvegarde du fichier en sortant (Ctrl+o , Ctrl+x)
Puis générer le nouveau fichier grub.cfg

update-grub


@raleur....Est ce que j'ai tout bon ? smile
Ah oui test avant j'avais tardé a poster pas vu ton dernier message

Dernière modification par Croutons (06-08-2017 14:52:27)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 06-08-2017 15:05:37

raleur
Membre
Inscription : 03-10-2014

Re : Accueil Erreur Debian 9.1

Croutons a écrit :

Et on ajoute l'option a la ligne GRUB_CMDLINE_LINUX, pour plusieurs options sur une meme ligne il faut séparer par un point virgule


Non, pas de point-virgule et pas de groupes de guillemets. Séparation  avec une simple espace à l'intérieur des mêmes guillemets.

Hors ligne

#9 06-08-2017 23:58:39

clonador
Membre
Distrib. : Debian 9.1
Noyau : Linux 4.9.0-3-amd64
(G)UI : xfce4
Inscription : 13-04-2016

Re : Accueil Erreur Debian 9.1

raleur a écrit :

Pour essayer l'option, il ne faut pas la mettre dans un fichier. Il faut d'abord la taper directement dans le menu de GRUB au démarrage :
- sélectionner l'entrée du menu à modifier
- appuyer sur la touche "e" pour l'éditer
- ajouter l'option à la fin de la ligne qui commence par "linux" (selon la largeur de l'affichage elle peut revenir à la ligne suivante)
- appuyer sur la touche F10 ou Ctrl+x pour démarrer

Attention : le clavier est interprété en QWERTY US, donc sur un clavier AZERTY FR le "a" s'obtient avec la touche "q" et le point s'obtient avec la touche ":".




Je ne travaille pas ce test.
Mais si, quand j'éditer le fichier:

nano /etc/default/grub




Et plus d'erreurs ne sont plus affichés

wink

Hors ligne

Pied de page des forums