Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-08-2017 17:40:10

Chente
Membre
Distrib. : Debian stable 9.1
Noyau : Linux 4.9.0-3-686-pae
(G)UI : xfmw4
Inscription : 07-08-2017

[RÉSOLU] Jessie à Stretch : Perte du Wifi

Bonjour,
Je suis nouveau sous Debian : j'ai installé Jessie, à travers Debian-Facile bien sûr, au printemps dernier sur un ordinosaure, un Dell Latitude D400 de 2004 (Ordi portable).
Comme tout se passait bien, j'ai fait une mise à niveau vers Stretch la semaine dernière. À priori, elle s'est bien déroulée (apt-get update, upgrade et dist-upgrade ne signalent aucun défaut).
Cependant, je n'ai plus de wifi : l'applet Networkmanager signale "le wifi est désactivé par un commutateur matériel".
J'ai testé plusieurs solutions :
  1/ redémarrer sur ma clé USB d'installation contenant debian jessie, option tester Debian : le réseau wifi est reconnu et fonctionnel. Le problème ne vient ni du BIOS ni du matériel mais bien de la mise à niveau
  2/ j'ai démarré, grâce à GRUB, le noyau 3.16 (datant de jessie) à la place du 4.9 (par défaut depuis stretch) : le wifi n'est pas fonctionnel et j'ai toujours le même message dans l'applet networkmanager. Le problème est logiciel, vient des mises à jour, mais pas de celle du noyau (ou pas seulement d'elle)
  3/ ma carte est identifiée :

lspci -nn | grep Network


01:03.0 Ethernet controller [0200]: Qualcomm Atheros AR5212/5213/2414 Wireless Network Adapter [168c:0013] (rev 01)


  4/ Le pilote ath5k est installé :

sudo lsmod | grep ath


ath5k                 135168  0
ath                    24576  1 ath5k
mac80211              548864  1 ath5k
cfg80211              450560  3 mac80211,ath,ath5k


  5/ Ce pilote est bien associé à ma carte wifi :

sudo dmesg | grep ath5k


[   13.965884] ath5k 0000:01:03.0: registered as 'phy0'
[   14.347152] ath5k: phy0: Atheros AR5212 chip found (MAC: 0x56, PHY: 0x41)
[   14.347158] ath5k: phy0: RF5111 5GHz radio found (0x17)
[   14.347163] ath5k: phy0: RF2111 2GHz radio found (0x23)


  6/ Ce pilote prend bien en charge ma carte [168c:0013], d'après ce lien sous Debian : https://wiki.debian.org/ath5k#Supported_Devices
  7/ Mon réseau wifi est actif (mon téléphone y accède) et toujours défini dans l'application "Connexions Réseau", sans doute par héritage de Jessie
  8/ J'ai lu les discussions suivantes ( https://debian-facile.org/viewtopic.php?id=14635 et https://debian-facile.org/viewtopic.php?id=12940), mais elles concernent un autre pilote que le mien  (ath10K_pci alors que j'ai ath5k) et je n'ai pas trouvé de pilote équivalent à ath5k chez github

Bref, je galère et j'en appelle à la générosité et la solidarité légendaire du monde libre.

Merci pour l'attention portée à ma requête, et pardon pour la longueur du message, je suis un incorrigible bavard.

Dernière modification par Chente (08-08-2017 13:25:06)

Hors ligne

#2 07-08-2017 19:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RÉSOLU] Jessie à Stretch : Perte du Wifi

Bonjour et bienvenue Chente smile

Tu peux éventuellement ajouter les retours des commandes :

nmcli device status

ip address show

sudo rfkill list all


Et, pour voir l'état des paramètres du module ath5k :

sudo modinfo -p ath5k

nohwcrypt:Disable hardware encryption. (bool)
fastchanswitch:Enable fast channel switching for AR2413/AR5413 radios. (bool)
no_hw_rfkill_switch:Ignore the GPIO RFKill switch state (bool)


ls -l /sys/module/ath5k/parameters

total 0
-r--r--r-- 1 root root 4096 août   7 19:32 fastchanswitch
-r--r--r-- 1 root root 4096 août   7 19:32 nohwcrypt
-r--r--r-- 1 root root 4096 août   7 19:32 no_hw_rfkill_switch


cat /sys/module/ath5k/parameters/*

N
N
N


Note : il s'agit de retours sous Jessie et non Stretch.

Dernière modification par èfpé (07-08-2017 21:24:42)

Hors ligne

#3 08-08-2017 00:03:36

Chente
Membre
Distrib. : Debian stable 9.1
Noyau : Linux 4.9.0-3-686-pae
(G)UI : xfmw4
Inscription : 07-08-2017

Re : [RÉSOLU] Jessie à Stretch : Perte du Wifi

Merci èfpé pour ton aide,
Voici mes commandes et retours de commande :

nmcli device status


PÉRIPHÉRIQUE  TYPE      ÉTAT          CONNEXION          
eth0          ethernet  connecté      Connexion filaire 1
wlan0         wifi      indisponible  --                  
lo            loopback  non-géré      --


Là, j'ai compris que le wifi n'est pas fonctionnel big_smile

ip address show


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:0f:1f:fe:eb:ec brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.58/24 brd 192.168.1.255 scope global dynamic eth0
       valid_lft 86074sec preferred_lft 86074sec
    inet6 fe80::20f:1fff:fefe:ebec/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether fa:a0:70:c6:3f:0e brd ff:ff:ff:ff:ff:ff


État Down pour wlan0 ne doit pas être bon signe pour le fonctionnement du wifi sad

sudo rfkill list all


rfkill : commande introuvable


Il faudrait que j'installe rfkill, je vais essayer

L'état des paramètres du module ath5k semble identique à celui que tu me communiques :

sudo modinfo -p ath5k


nohwcrypt:Disable hardware encryption. (bool)
fastchanswitch:Enable fast channel switching for AR2413/AR5413 radios. (bool)
no_hw_rfkill_switch:Ignore the GPIO RFKill switch state (bool)


ls -l /sys/module/ath5k/parameters


total 0
-r--r--r-- 1 root root 4096 août   7 23:48 fastchanswitch
-r--r--r-- 1 root root 4096 août   7 23:48 nohwcrypt
-r--r--r-- 1 root root 4096 août   7 23:48 no_hw_rfkill_switch


cat /sys/module/ath5k/parameters/*


N
N
N



Je ne sais que penser de tout ça car je ne suis pas capable d'interpréter toutes ces données

Hors ligne

#4 08-08-2017 00:16:40

Chente
Membre
Distrib. : Debian stable 9.1
Noyau : Linux 4.9.0-3-686-pae
(G)UI : xfmw4
Inscription : 07-08-2017

Re : [RÉSOLU] Jessie à Stretch : Perte du Wifi

Avec le paquet installé, c'est mieux :

sudo rfkill list all


0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes


Le blocage serait matériel ? Ça correspond bien  à l'intitulé de l'applet networkmanager cité dans mon premier message.
J'ai lu lors de mes recherches que ça ne voulait pas dire que j'avais un commutateur physique sur mon portable pour activer ou éteindre la wifi, mais la formulation surprend quand même. En effet, je n'ai aucun moyen physique pour agir sur la wifi : aucun commutateur sur mon portable ni même par les touches bleues Fn.

Hors ligne

#5 08-08-2017 08:58:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RÉSOLU] Jessie à Stretch : Perte du Wifi

Re-,

Ces retours ont-ils effectivement été obtenus avec le noyau 3.16 ? Mais que retourne :

sudo ip link set wlan0 up


Bien plus moderne que 'sudo ifconfig wlan0 up' ; note aussi la commande,

grep -r [[:alnum:]] /sys/module/ath5k/parameters

/sys/module/ath5k/parameters/no_hw_rfkill_switch:N
/sys/module/ath5k/parameters/fastchanswitch:N
/sys/module/ath5k/parameters/nohwcrypt:N


Bien plus cholie que la précédente... Quelques pistes sur bbs.archlinux.org ?

Hors ligne

#6 08-08-2017 13:23:50

Chente
Membre
Distrib. : Debian stable 9.1
Noyau : Linux 4.9.0-3-686-pae
(G)UI : xfmw4
Inscription : 07-08-2017

Re : [RÉSOLU] Jessie à Stretch : Perte du Wifi

Merci èspé pour le temps consacré à mon problème qui, tout compte fait, ne provenait pas de Debian mais de ma box : je l'ai redémarrée ce matin et j'ai maintenant le wifi fonctionnel sur mon ordinausore. Je suis désolé pour la perte de temps mais, à ma décharge, la panne était vicieuse : tous les récepteurs wifi de la maison pouvaient utiliser le réseau, sauf mon viel ordinateur portable.
J'ai repassé toutes les commandes qui témoignent désormais d'un fonctionnement normal. Je donne uniquement celles qui ont changé depuis les messages 3 et 4 :

nmcli device status


PÉRIPHÉRIQUE  TYPE      ÉTAT      CONNEXION          
eth0          ethernet  connecté  Connexion filaire 1
wlan0         wifi      connecté  XXXXXXXXX          
lo            loopback  non-géré  --


Mon ordinateur est désormais connecté à mon réseau wifi dont j'ai transformé le nom.

ip address show


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:0f:1f:fe:eb:ec brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.58/24 brd 192.168.1.255 scope global dynamic eth0
       valid_lft 86379sec preferred_lft 86379sec
    inet6 fe80::20f:1fff:fefe:ebec/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:0b:cd:5c:02:56 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.84/24 brd 192.168.1.255 scope global dynamic wlan0
       valid_lft 82210sec preferred_lft 82210sec
    inet6 fe80::20b:cdff:fe5c:256/64 scope link
       valid_lft forever preferred_lft forever


L'état du récepteur/émetteur wifi de mon ordinateur est désormais UP et il gère le protocole internet v4 (je n'ai pas activé v6 sur ma box)

sudo rfkill list all


1: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
3: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no


Il n'y a plus ce blocage matériel sur la carte wifi de mon ordi.

L'état des paramètres du module ath5k n'a pas changé. J'ai passé tous ces tests, aussi bien hier (messages 3 et 4) qu'aujourd'hui (ce message) avec le noyau 4.9. Je n'ai utilisé le noyau 3.16 qu'une fois pour cerner la panne, mais j'ai ensuite toujours travaillé, mesuré et testé avec le 4.9

J'ai quand même passé les deux commandes que tu me recommandes dans le message 5. La première (ip link....) ne renvoie rien. La seconde (grep...) renvoie exactement les même infos que celles que tu proposes.

Grâce à la solidarité et la disponibilité de la communauté du monde libre, ce problème est résolu. Merci à èspé pour son aide. J'aurai au moins découvert les paramètres de ma carte wifi et appris à utiliser ce forum. merci.gif

Hors ligne

Pied de page des forums