Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-08-2017 11:03:48

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

[Résolu] Apt ne fonctionne plus après ajout du dépôt security

J'ai ajouté ce dépôt deb http://security.debian.org/debian-security/ stretch/updates contrib main avec synaptic et maintenant un paquet est cassé et ne peut se réparer comment faire à partir de synaptic uniquement? c'est à dire réparer le paquet cassé sans trouvé une solution de contournement à la mano via le fichier sources.list

# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/debian-security/ stretch/updates contrib main
# Line commented out by installer because it failed to verify:
# deb-src http://security.debian.org/debian-security/ stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.

# deb http://deb.debian.org/debian/ stretch-updates main contrib
# deb-src http://deb.debian.org/debian/ stretch-updates main contrib

Dernière modification par yole1 (09-08-2017 15:32:32)

Hors ligne

#2 09-08-2017 11:59:02

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Apt ne fonctionne plus après ajout du dépôt security

Salut smile

J'ai déplacé sont message pour créer une nouvelle discussion. Tu avais posté dans celle épinglé où on indique les sources.list qui fonctionne, et manifestement, tu n'es pas dans ce cas wink

Il manque le dépôt principal au moins dans ton sources.list pour que ça fonctionne. Tu peux jeter un œil à ce tuto https://debian-facile.org/doc:systeme:a … st-de-base pour voir le fichier minimal smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#3 09-08-2017 12:10:50

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [Résolu] Apt ne fonctionne plus après ajout du dépôt security

Ok merci
J'ai supprimé un fichier lock dans ~/vat/lib/dpkg qui était vide
Il n'y a plus de paquet cassé
par contre je n'arrive pas à installer filezilla ni vrms

# apt-get update && apt-get install vrms
Atteint:1 http://deb.debian.org/debian stretch-updates InRelease
Atteint:2 http://security.debian.org/debian-security stretch/updates InRelease    
Lecture des listes de paquets... Fait                                            
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
E: Impossible de trouver le paquet vrms



Même si le cache synaptic à été rechargé et une MAJ faite
filezilla-common existe mais n'est pas dans la base de données

Bon je vais suivre tes conseils bendia et modifier sources-list en supposant qu'il manquait des dépendances à filezilla

Dernière modification par yole1 (09-08-2017 12:56:15)

Hors ligne

#4 09-08-2017 13:07:04

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [Résolu] Apt ne fonctionne plus après ajout du dépôt security

C'est une chose faite modification du fichier sources-list et sur synaptic je me suis positionné sur filezilla et ai sélectionné ses dépendances et l'installation s'est bien faite. Filezilla estr fonctionnel mais pendant le téléchargement le mot firefox est apparu?
vrms je verrais par la suite

Hors ligne

#5 09-08-2017 13:22:55

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Résolu] Apt ne fonctionne plus après ajout du dépôt security

Puisque la mise à jour de ton sources.list t'as permis d'installer filezilla, tu peux passer le sujet en résolu.
Tu peux installer vrms, il ne pèse que 39.0 kB

Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

Merci

Hors ligne

#6 09-08-2017 15:32:02

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [Résolu] Apt ne fonctionne plus après ajout du dépôt security

Ouui c'est résolu et pour vrms c'est après un reboot que celà a été possible (avant non).

Hors ligne

#7 09-08-2017 15:34:04

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Résolu] Apt ne fonctionne plus après ajout du dépôt security

Parfait

Hors ligne

Pied de page des forums