Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-10-2009 16:10:01

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Suite au passage de grub1 vers grub2, plus moyen de booter.

Voilà je résume rapidement j'ai voulu basculer de grub1 vers grub2.
j'ai donc lancer l'install de grub2.
J'ai pas encore virer grub1.

Car depuis plus moyen de booter, même en passant par grub1.

En fait je pense que sa viens pas de sa vu le message d'erreur.
un petit récap.

J'ai un serveur perso neuf, en raid5 + LVM.

jusqu'à présent je booter depuis un clé usb, car pas noyen d'installer grub1 sur le raid.
J'ai donc monter lors de l'install de lenny, ma clé en /boot

Tout marcher très bien. Depuis la tentative de passage à grub2, C'est le drame, plus moyen de booter.

Sur le raid en /dev/md0 sont présent les 3 volumes suivants.
/home
/swap
/

Sur la clé usb reconnu comme /dev/sdd1 est monter /boot ou est installer grub1 (et donc logiquement grub 2 aussi).

J'ai pas eu de message d'erreur lors de sont install.

Par contre au premier reboot aie aie.
Voilà le message après avoir choisi grub1 et l'un des deux noyau, faut dire que sa fait pareil si, je choisi grub2 et après n'importe quel noyau. Voilà pourquoi je crois que ces pas un problème de grub, mais de BIOS. C'est con, j'ai rien toucher depuis la fois ou sa marcher.

Aperture beyond 4 GB Ignoing
your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
PCI: Not using MMconfix

la suite des messages me dit que les 3 disques dur sata du raid sont ok est que le raid est ok.

INIT : 2.86 booting
[il y a des fiches ici ] sd 4:0:0:0 sdd Assunig drive cache write through 
[il y a des fiches ici ] sd 4:0:0:0 sdd Assunig drive cache write through 

Est j'ai le pc qui bloque.

JE tiens a ajouter que ma clé marche sur mon portable et j'ai bien accès au données de la partition en ext3 depuis ma fédora 11. Donc sa viens pas de la clé a priori qui serait défectueuse.

Si vous avez une idée je prend. Mon cpu est un AMD sur carte mère MSI et chipset AMD KA780G.

Dernière modification par chiwawa (11-10-2009 16:11:47)


Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#2 11-10-2009 18:00:03

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Suite au passage de grub1 vers grub2, plus moyen de booter.

Bjr,
1 - Please enable the IOMMU option in the BIOS setup : regarde si tu peux activer IOMMU dans ton bios
2 - vérifie les fichiers de config de grub2 : par exemple la notations des partitions a changé, elle débute à 1 et non à 0 comme l'ancien grub
3 - il y a une option possible à mettre en bout de ligne du kernel. Exemple :

kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=c78c5e0e-d325-4ed9-8c18-aa2bfc9de1cd ro quiet splash iommu=noaperture


Mais il faut trouver dans quel fichier
4 - de la doc : http://www.linuxpedia.fr/doku.php/expert/grub2
5 - bon courage


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 11-10-2009 18:37:26

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : Suite au passage de grub1 vers grub2, plus moyen de booter.

Ok, je vais voir : mais j'ai regarder dans mon BIOS pas d'option IOMMU de trouver désoler.

Par contre voilà mon fichier /boot/86f39e4f-9349-48e6-9571-8e007188/grub/menu.lst

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-legacy-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default         0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout        5

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title        Windows 95/98/NT/2000
# root        (hd0,0)
# makeactive
# chainloader    +1
#
# title        Linux
# root        (hd0,1)
# kernel    /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/mapper/Vol_lvm_raid-vol_racine ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd3,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(single-user) single
# altoptions=(single-user mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title        Chainload into GRUB 2
root        (hd3,0)
kernel        /grub/core.img

title        ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ
root
       
title        When you have verified GRUB 2 works, you can use this command to
root

title        complete the upgrade:  upgrade-from-grub-legacy
root

title        ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ
root

title        Debian GNU/Linux, kernel 2.6.26-2-amd64
root        (hd3,0)
kernel        /vmlinuz-2.6.26-2-amd64 root=/dev/mapper/Vol_lvm_raid-vol_racine ro quiet
initrd        /initrd.img-2.6.26-2-amd64

title        Debian GNU/Linux, kernel 2.6.26-2-amd64 (single-user mode)
root        (hd3,0)
kernel        /vmlinuz-2.6.26-2-amd64 root=/dev/mapper/Vol_lvm_raid-vol_racine ro single
initrd        /initrd.img-2.6.26-2-amd64

title        Debian GNU/Linux, kernel 2.6.26-1-amd64
root        (hd3,0)
kernel        /vmlinuz-2.6.26-1-amd64 root=/dev/mapper/Vol_lvm_raid-vol_racine ro quiet
initrd        /initrd.img-2.6.26-1-amd64

title        Debian GNU/Linux, kernel 2.6.26-1-amd64 (single-user mode)
root        (hd3,0)
kernel        /vmlinuz-2.6.26-1-amd64 root=/dev/mapper/Vol_lvm_raid-vol_racine ro single
initrd        /initrd.img-2.6.26-1-amd64

### END DEBIAN AUTOMAGIC KERNELS LIST

Si sa peut aider.

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#4 11-10-2009 18:40:51

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : Suite au passage de grub1 vers grub2, plus moyen de booter.

il a aussi le fichier grub.cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/update-grub using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
set default=0
set timeout=5
terminal console
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=cyan/blue
set menu_color_highlight=white/blue
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_hurd ###
### END /etc/grub.d/10_hurd ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Debian GNU/Linux, linux 2.6.26-2-amd64" {
    set root=(hd3,1)
    search --fs-uuid --set 86f39e4f-9349-48e6-9571-8e00f188c8e9
    linux    /vmlinuz-2.6.26-2-amd64 root=/dev/mapper/Vol_lvm_raid-vol_racine ro 
    initrd    /initrd.img-2.6.26-2-amd64
}
menuentry "Debian GNU/Linux, linux 2.6.26-2-amd64 (single-user mode)" {
    set root=(hd3,1)
    search --fs-uuid --set 86f39e4f-9349-48e6-9571-8e00f188c8e9
    linux    /vmlinuz-2.6.26-2-amd64 root=/dev/mapper/Vol_lvm_raid-vol_racine ro single
    initrd    /initrd.img-2.6.26-2-amd64
}
menuentry "Debian GNU/Linux, linux 2.6.26-1-amd64" {
    set root=(hd3,1)
    search --fs-uuid --set 86f39e4f-9349-48e6-9571-8e00f188c8e9
    linux    /vmlinuz-2.6.26-1-amd64 root=/dev/mapper/Vol_lvm_raid-vol_racine ro 
    initrd    /initrd.img-2.6.26-1-amd64
}
menuentry "Debian GNU/Linux, linux 2.6.26-1-amd64 (single-user mode)" {
    set root=(hd3,1)
    search --fs-uuid --set 86f39e4f-9349-48e6-9571-8e00f188c8e9
    linux    /vmlinuz-2.6.26-1-amd64 root=/dev/mapper/Vol_lvm_raid-vol_racine ro single
    initrd    /initrd.img-2.6.26-1-amd64
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file is an example on how to add custom entries
### END /etc/grub.d/40_custom ###

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#5 15-10-2009 14:10:15

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Suite au passage de grub1 vers grub2, plus moyen de booter.

Bjr,
Tiens j'en profite pour préciser/rappeler que le grub.cfg n'est pas un fichier à modifier, comme l'indique l'entête

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/update-grub using templates
# from /etc/grub.d and settings from /etc/default/grub
#


Les modifs sont à faire dans les fichiers des répertoires > /etc/grub.d et /etc/default/grub/


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

Pied de page des forums