Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-08-2017 19:01:18

Adrnnc
Membre
Lieu : Lyon
Distrib. : DEBIAN 8 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 24-01-2016

[Résolu] PHP 7.0 - Debian Stretch

Salut à tous!

Je viens à vous en espérant trouver de l'aide : j'essaye d'install php7.0 depuis dotdeb mais impossible sad

sudo apt install php7.0 php7.0-mysql php7.0-cli php7.0-common php7.0-curl php7.0-opcache php7.0-json php7.0-xml


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 php7.0 : Dépend: libapache2-mod-php7.0 mais ne sera pas installé ou
                   php7.0-fpm mais ne sera pas installé ou
                   php7.0-cgi mais ne sera pas installé
 php7.0-cli : Dépend: libssl1.0.0 (>= 1.0.1) mais il n'est pas installable
 php7.0-common : Dépend: libssl1.0.0 (>= 1.0.0) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Jamais vu cette erreur, en tout cas aucun souvenir. J'ai bien ajouté les répos dans sources.list

Par avance merci wink

Dernière modification par Adrnnc (28-08-2017 11:05:55)


“Chaque début d’écriture est un retour à la case départ. Et la case départ, c’est un endroit où l’on se sent très seul. Un endroit où aucun de vos accomplissements passés ne compte.” QT

Hors ligne

#2 27-08-2017 22:17:04

jce76350
Membre
Lieu : Rouen
Distrib. : Debian 8.x Handylinux++ , Debian9_DF linux
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : [Résolu] PHP 7.0 - Debian Stretch

Pourquoi passer par dotdeb c'est prévu en natif PHP 7.0 dans  Debian Stretch (mais c'est MariaDB et non mysql-server)
voir http://jc.etiemble.free.fr/abc/index.ph … s/deb9php7

Hors ligne

#3 28-08-2017 11:05:41

Adrnnc
Membre
Lieu : Lyon
Distrib. : DEBIAN 8 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 24-01-2016

Re : [Résolu] PHP 7.0 - Debian Stretch

Effectivement, merci smile

“Chaque début d’écriture est un retour à la case départ. Et la case départ, c’est un endroit où l’on se sent très seul. Un endroit où aucun de vos accomplissements passés ne compte.” QT

Hors ligne

Pied de page des forums