Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-08-2017 00:12:35

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

[Résolu] problème partition suite à installation de solus

Bonjour,
sur mon pc, j'ai 2 disques durs; sur le premier (sda), debian et autres (9 partitions), sur le deuxième (sdb), 2 partitions en ntfs
et à la suite de l'installation de solus dans sda, la deuxième partition de sdb n'est plus accessible.
voilà ce que m'indique fdisk pour la partie sdb

fdik -l
Disque /dev/sda : 232,9 GiB, 250059350016 octets, 488397168 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'
étiquette de disque : dos
Identifiant de disque : 0x000a08d1

Périphérique Amorçage     Début       Fin  Secteurs Taille Id Type
/dev/sda1    *             2048  41027583  41025536  19,6G  7 HPFS/NTFS/exFAT
/dev/sda2              41027584  71776255  30748672  14,7G 83 Linux
/dev/sda3              71776256  73857023   2080768  1016M 82 partition d'échange Linux / Sol
/dev/sda4              73859070 488396799 414537730 197,7G  5 Étendue
/dev/sda5              88827904 103213055  14385152   6,9G 83 Linux
/dev/sda6             161359872 488396799 327036928   156G  7 HPFS/NTFS/exFAT
/dev/sda7             103215104 132282367  29067264  13,9G 83 Linux
/dev/sda8             132284416 161357823  29073408  13,9G 83 Linux
/dev/sda9              73859072  88827903  14968832   7,1G 83 Linux

Les entrées de la table de partitions ne sont pas dans l'
ordre du disque.


Disque /dev/sdb : 465,8 GiB, 500107862016 octets, 976773168 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'
étiquette de disque : dos
Identifiant de disque : 0xa6d9497f

Périphérique Amorçage     Début       Fin  Secteurs Taille Id Type
/dev/sdb1                  2048 513783807 513781760   245G  7 HPFS/NTFS/exFAT
/dev/sdb2    *        513783808 976773119 462989312 220,8G  7 HPFS/NTFS/exFAT



pour sdb l'on voit bien ces 2 partitions en nrfs cela semble tout à fait normal. A part sdb2 qui serait amorçable alors qu'il n'en est rien; et concernant sda, le désordre de ces partions a eu lieu à la suite de la suppression d'une partition afin d'augmenter la taille de la partition précédente (je crois); mais je ne pense pas que mon problème avec sdb2 sont lié à cela.

par contre, avec cfdisk, j'ai plus d'infos concernant ce sdb2


cfdisk /dev/sdb
>>  /dev/sdb2      *            513783808   976773119  462989312  220,8G   7 HPFS/NTFS/exFAT
Type de la partition : HPFS/NTFS/exFAT (7)                                        │
 │                  Attributs : 80                                                         │
 │UUID du système de fichiers : 67e697fd-9750-4f48-ad4e-36fc795a0f2b                       │
 │        Système de fichiers : ext4                                                       │
 │           Point de montage : /media/sauvegarde


 


et là, ça se corse; partition ntfs et systeme de fichiers ext4, y'a un lézard ( ce sdb, était initialement sda et donc j'avais x partitions dont la plupart en ext4)

et donc, j'ai lancé testdisk (nolog, puis disk /dev/sdb,intel, et enfin  analyse:et voilà le résulat:

testdisk
 Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63
Current partition structure:
     Partition                  Start        End    Size in sectors

 1 P HPFS - NTFS              0  32 33 31981 143 34  513781760
Invalid NTFS or EXFAT boot
 2 * HPFS - NTFS          31981 143 35 60801  80 15  462989312
 2 * HPFS - NTFS          31981 143 35 60801  80 15  462989312
*=Primary bootable  P=Primary  L=Logical  E=Extended  D=Deleted

*=Pr      





testdisk voit effectivement un problème sur sdb2

je continue avec testdisk: quick search


 Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63

The harddisk (500 GB / 465 GiB) seems too small! (< 3180 GB / 2962 GiB)
Check the harddisk size: HD jumpers settings, BIOS detection...

The following partition can't be recovered:
     Partition               Start        End    Size in sectors
>  FAT16 >32M           241407 199 53 386704  34 13 2334185871
[ Continue ]
1195 GB / 1113 GiB  



comme il n'y aurait pas ces problèmes invoqués, je continue:


    Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63
     Partition               Start        End    Size in sectors
>* HPFS - NTFS              0   1  1  5098 254 63   81915372
 P Linux                31981 143 35 60801  80 15  462989312

Structure: Ok.  Use Up/Down Arrow keys to select partition.
Use Left/Right Arrow keys to CHANGE partition characteristics:
*=Primary bootable  P=Primary  L=Logical  E=Extended  D=Deleted
Keys A: add partition, L: load backup, T: change type, P: list files,
     Enter: to continue
NTFS, blocksize=4096, 41 GB / 39 GiB    



sur le terminal

>* HPFS - NTFS    0   1  1  5098 254 63   81915372  et  P Linux  31981 143 35 60801  80 15  462989312 sont en vert

je continue:


Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63

     Partition                  Start        End    Size in sectors

 1 * HPFS - NTFS              0   1  1  5098 254 63   81915372
 2 P Linux                31981 143 35 60801  80 15  462989312
 [  Quit  ] >[Deeper Search]  [ Write  ]
                          Try to find more partitions
   




le dd sdb etait initialement en sda, et donc, avec des multiples partitions ext4 et quelques ntfs; et donc ces anciennes partitions réapparaissent.Ne sachant pas trop quoi faire avec ces infos, ben: deeper search (et c'est reparti pour 2 heures)

j'ai l'impression que c'est la table de partition qui a un problème; est-il possible de la réparer sans détruire ces 2 partitions; avec gparted, par exemple, d'ailleurs gparted m'indique: sdb1; ntf; 244.99gio et sdb2; ext4 220.77gio et seulement 8.91gio utilisé. je pensais pouvoir le faire avec testdisk, mais j'ai pas trouvé comment

merci en tout cas de vous pencher sur mon problème

Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63
     Partition               Start        End    Size in sectors
>D HPFS - NTFS              0   1  1  5098 254 63   81915372
 D HPFS - NTFS              0  32 33 31981 143 34  513781760
 * Linux                31981 143 35 60801  80 15  462989312

Structure: Ok.  Use Up/Down Arrow keys to select partition.
Use Left/Right Arrow keys to CHANGE partition characteristics:
*=Primary bootable  P=Primary  L=Logical  E=Extended  D=Deleted
Keys A: add partition, L: load backup, T: change type, P: list files,
     Enter: to continue
NTFS, blocksize=4096, 41 GB / 39 GiB

 



>D HPFS - NTFS              0   1  1  5098 254 63   81915372  ------>P: list files me répends:Can't open filesystem. Filesystem seems damaged.
>D HPFS - NTFS              0  32 33 31981 143 34  513781760 --------P : liste ma sda
* Linux                31981 143 35 60801  80 15  462989312  ---------P :
>drwxr-xr-x     0     0      4096 27-Aug-2017 23:08 .
drwxr-xr-x     0     0      4096 27-Aug-2017 23:08 ..
drwx------     0     0     16384 15-Aug-2017 00:52 lost+found
drwxr-xr-x     0     0      4096 14-Aug-2017 22:00 sys
drwxr-xr-x     0     0      4096 27-Aug-2017 23:07 run
drwxrwxrwt     0     0      4096 27-Aug-2017 23:07 tmp
drwxr-xr-x     0     0      4096 15-Aug-2017 00:55 lib64
drwxr-xr-x     0     0      4096 27-Aug-2017 23:50 root
drwxr-xr-x     0     0      4096 15-Aug-2017 00:57 var
drwxr-xr-x     0     0      4096 27-Aug-2017 23:07 home
drwxr-xr-x     0     0      4096 15-Aug-2017 00:53 bin
drwxr-xr-x     0     0      4096 28-Aug-2017 00:13 etc
drwxr-xr-x     0     0      4096 15-Aug-2017 00:55 sbin
drwxr-xr-x     0     0      4096 15-Aug-2017 00:55 usr
                                                   Next


les dates indiquées m'interpellent, disk select ne me trouve toujours pas sdb2-ntfs; je commence à désespérer à récupérer cette partition

Dernière modification par solar66 (02-09-2017 14:27:30)

Hors ligne

#2 31-08-2017 15:34:30

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] problème partition suite à installation de solus

Que disent

file -sk /dev/sdb2
blkid /dev/sdb2
wipefs /dev/sdb2
grep sdb /proc/mounts

Dernière modification par raleur (31-08-2017 15:35:18)

En ligne

#3 31-08-2017 16:15:25

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : [Résolu] problème partition suite à installation de solus

[


 file -sk /dev/sdb2
/dev/sdb2: Linux rev 1.0 ext4 filesystem data, UUID=67e697fd-9750-4f48-ad4e-36fc795a0f2b (extents) (64bit) (large files) (huge files)\012- data  





blkid /dev/sdb2
/dev/sdb2: UUID="67e697fd-9750-4f48-ad4e-36fc795a0f2b" TYPE="ext4" PARTUUID="a6d9497f-02"

 




wipefs /dev/sdb2
offset               type
----------------------------------------------------------------
0x438                ext4   [filesystem]
                     UUID:  67e697fd-9750-4f48-ad4e-36fc795a0f2b

 




grep sdb /proc/mounts
/dev/sdb1 /media/films fuseblk rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096 0 0

 

Hors ligne

#4 31-08-2017 16:34:26

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] problème partition suite à installation de solus

Toutes les réponses convergent : cette partition contient un système de fichiers ext4. Si elle était vraiment en NTFS avant, elle a été reformatée en ext4.

Actuellement, elle n'est pas montée. Tu peux la monter pour examiner son contenu.

mount /dev/sdb2 /mnt

En ligne

#5 31-08-2017 18:56:52

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : [Résolu] problème partition suite à installation de solus

-sous debian
j'ai fait: mount /dev/sdb2 /essai (dossier que j'ai créée dans /, car /mnt a déjà des dossiers (home-solus; solus,......)
et chose très étrange; cela semble être le / de solus précédemment installé et qui a mis le boxon. Solus a été installé en sda2, et étrange également mon dossier /mnt/solus est vide.

-sous solus,
les commandes précédentes indiquent les même résultats
et,  mount /dev/sdb2 /essai2  (dossier créée dans /) et c'est bien le / de solus qui se monte dans essai 2;  alors que solus est bien installé en sda2.

et sous solus gparted pour sdb m'indique cela:
(j'arrive pas à rajouter une image)

partition        système de fichier        etiquette                                             taille
/dev/sdb        iso9660                       Linux Mint UPS MATE 64-bit               465.76 Gio


et sous debian


blkid /dev/sda2
/dev/sda2: LABEL="solus" UUID="4c3e5351-1cec-4bf1-ba64-345e3a814a53" TYPE="ext4" PARTUUID="000a08d1-02"

 




et sous debian:
mount /dev/sda2 /essai2      le dossier essai2 est vide comme /mnt/solus

j'y comprends rien

Dernière modification par solar66 (31-08-2017 19:00:58)

Hors ligne

#6 31-08-2017 20:24:53

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] problème partition suite à installation de solus

Les noms de périphériques de disques et partitions (/dev/sda...) ne sont pas stables, ils peuvent changer d'un démarrage à l'autre, d'un système à l'autre et on ne peut pas s'y fier. C'est pour cela qu'on utilise plutôt des identifiants persistants comme les UUID quand on veut être sûr d'identifier correctement une partition, comme dans /etc/fstab.

Si sda2 est vide et sdb2 contient Solux, Il faut croire que tu as fait une erreur et qu'au lieu de sda2 tu as installé Solux dans ce qui est actuellement sdb2, et qui était peut-être sda2 lors de l'installation.

Quant à Gparted qui voit une étiquette ISO9660 dans sdb, c'est peut-être un reste d'une ancienne image ISO de Linux Mint qui avait été copiée sur ce disque (comme on l'aurait fait avec une clé USB bootable). Gparted a un gros défaut : il gère assez mal les situation anormales comme celle-ci où un disque contient plusieurs structures de méta-données enchevêtrées.

Comme montré plus haut, on peut utiliser la commande "wipefs" pour localiser et supprimer des méta-données "parasites". Pour localiser :

wipefs /dev/sdb

Dernière modification par raleur (02-09-2017 09:49:59)

En ligne

#7 02-09-2017 00:57:29

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : [Résolu] problème partition suite à installation de solus

tu as raison; j'ai du faire une fausse manip, lors de l'install; mais, si effectivement c'est le cas, je ne m'explique pas pourquoi sous solus, sdb apparait en iso avec gparted.,
gparted devrait montrer en sdb, 2 partitions sdb1 en ntfs et sdb2 en ext4

bref, je suis en train d'essayer de récupérer l'ancien contenu de cette partition sdb2 avec photorec; il récupère pas mal, mais c'est difficilement exploitable; il me récupère que des fichiers;pas du temps classés par dossiers,  certain incomplets  d'autres complets, mais tous sont nommés du genre f562132.extension (txt ou zip ou mp3.....) Et comme cette partition avait essentiellement de la musique, je ne vais pas pouvoir en tirer grand chose.
en tout cas, merci

Dernière modification par solar66 (02-09-2017 00:58:14)

Hors ligne

#8 02-09-2017 10:05:19

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] problème partition suite à installation de solus

solar66 a écrit :

j'ai du faire une fausse manip, lors de l'install; mais, si effectivement c'est le cas, je ne m'explique pas pourquoi sous solus, sdb apparait en iso avec gparted.


Les deux ne sont probablement pas liés. La présence de l'étiquette ISO 9660 sur sdb doit résulter d'une fausse manip (antérieure) pour copier l'image de Mint sur une clé USB.
Comme je l'ai écrit, Gparted ne gère pas bien les situations anormales. Or la présence simultanée d'une table de partition et d'un label ISO 9660 est une situation anormale. Tu ne veux pas montrer le résultat de la commande wipefs ci-dessus ?

En ligne

#9 02-09-2017 11:52:21

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : [Résolu] problème partition suite à installation de solus


wipefs /dev/sdb
offset               type
----------------------------------------------------------------
0x1fe                dos   [table de partitions]

0x8001               iso9660   [filesystem]
                     LABEL: Linux Mint UP8 MATE 64-bit
                     UUID:  2014-02-28-01-03-38-00

 



hé bien, cela apparait toujours;
et pourtant,après avoir récupéré ce que j'ai pu, j'ai reformaté sous debian sdb2 en ntfs avec gparted, et mes 2 partitions apparaissent bien sdb1 en ntfs et sdb2 en ntfs; et sont exploitable sous debian (j'ai remis mes "fichiers" perdu dans cette partition)
Ce DD sdb était initialement en sda (il y a pas mal de temps) avec x partition dessus (ext4 et ntfs)

j'ai démarré avec solus en live cd, (car après l'avoir supprimé (sdb2) j'ai perdu également grub.(d'ailleurs le topic de debian facile pour restauré grub est au top);
et gparted (solus) me montre toujours sdb en iso.
donc, effectivement il y a un autre problème

Dernière modification par solar66 (02-09-2017 11:56:02)

Hors ligne

#10 02-09-2017 12:19:16

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] problème partition suite à installation de solus

Tu peux reformater les partitions ou même recréer une table de partition vierge tant que tu veux, cela n'effacera pas la signature ISO 9660 car celle-ci se trouve à un emplacement qui n'est pas modifié par ces opérations. La seule chose qui pourrait occuper cet emplacement, c'est GRUB.
Tu peux l'effacer avec wipefs.

wipefs -o 0x8001 /dev/sdb



Visiblement l'image ISO de Linux Mint MATE qui a laissé cette signature n'est pas récente, elle date de 2014. Cela ne te rappelle rien qui pourrait expliquer sa présence sur ce disque ?

Dernière modification par raleur (02-09-2017 12:22:35)

En ligne

#11 02-09-2017 13:14:05

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : [Résolu] problème partition suite à installation de solus


umount /dev/sdb1
umount /dev/sdb2
wipefs -o 0x8001 /dev/sdb
/dev/sdb : 5 octets ont été effacés à l'index 0x00008001 (iso9660) : 43 44 30 30 31




et je refait la commande:


wipefs /dev/sdb
offset               type
----------------------------------------------------------------
0x1fe                dos   [table de partitions]

 



houa, y'a plus d'iso; trop fort

Hors ligne

#12 02-09-2017 13:23:03

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : [Résolu] problème partition suite à installation de solus

et je viens de véifié sous solus live cd, et gparted m'indique bien mes 2 partitions sdb1 et sdb2,
je crois que je peux mettre en résolu,
et merci encore

Hors ligne

#13 02-09-2017 13:28:29

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] problème partition suite à installation de solus

"Trop fort" ? C'est le but de wipefs et c'est le résultat attendu. Rien d'exceptionnel donc.

Cette commande est injustement méconnue. Quand on réutilise un disque ou une clé USB, wipefs est aussi très utile pour détecter et effacer les éventuels restes de table de partition MBR ou GPT, superbloc RAID, en-tête LUKS (chiffrement), LVM (volumes logiques), UDF... et bien sûr ISO 9660. Je la recommande avant de repartitionner et reformater de façon normale une clé USB qui a précédemment été formatée avec une image ISO bootable.

PS : il n'était pas nécessaire de démonter les partitions, d'autant plus que la zone à effacer se situe dans un espace en dehors de toute partition.

Dernière modification par raleur (02-09-2017 13:36:47)

En ligne

Pied de page des forums