Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-09-2017 09:42:35

dorajim
Membre
Inscription : 29-08-2017

[Résolu] Apache automatique

Bonjour,

Ma question  : comment faire démarrer Apache2 automatiquement ?
J'ai essayé de lire le fichier rc.local. Mais il n'est pas présent.

Merci d'avance pour vos réponses

Dernière modification par dorajim (05-09-2017 15:30:48)

Hors ligne

#2 05-09-2017 10:59:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Apache automatique

dorajim a écrit :

comment faire démarrer Apache2 automatiquement ?


Avec un cron peut-être ?
Le tuto :
https://debian-facile.org/doc:systeme:crontab


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 05-09-2017 11:55:20

dorajim
Membre
Inscription : 29-08-2017

Re : [Résolu] Apache automatique

Merci pour cette réponse. J'ai lu le tuto, mais étant un vrai débutant j'ai du mal à comprendre.

J'ai bien compris ce qu'est un cron mais pas comment le programmer.

de plus quand je lance : cat /etc/crond.allow j'ai un message d'erreur : cat: /etc/crond.allow: Aucun fichier ou dossier de ce type

Je vais chercher encore.

Hors ligne

#4 05-09-2017 12:02:38

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Apache automatique

À la reflexion, pour lancer apache automatiquement au démarrage, il me semble qu'on le fait dans la configuration.

Toutefois, je laisse un bout d'explication pour le cron, c'est pas inutile.
Pour programmer le cron, on l'édite ainsi :
user :

crontab -e


root (pour apache par exemple) :

crontab -e



Puis tu écris un script avec la commande que tu veux voir se réaliser ainsi que son délai pour s'exécuter.
https://debian-facile.org/doc:systeme:crontab#exemples

Pour les scripts, voir le tuto :
https://debian-facile.org/doc:programmation:scripts

N'hésite pas à demander des précisions ici.

Force et courage

Dernière modification par smolski (05-09-2017 12:07:43)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 05-09-2017 12:14:08

dorajim
Membre
Inscription : 29-08-2017

Re : [Résolu] Apache automatique

Merci pour toutes ces infos. Je vais tester tout ça.

Je te tiendrai au courant de mes avancées

Merci encore pour ton aide

Hors ligne

#6 05-09-2017 12:15:54

trentanel
Membre
Lieu : Comtat Venaissin
Distrib. : Archlinux DFLinux
(G)UI : Gnome-shell XFCE
Inscription : 17-09-2016

Re : [Résolu] Apache automatique

Bonjour,
Tous les chemins mènent à Rome, mais tu pourrais regarder utilement du côté de systemd.

systemctl enable apache2.service

Dernière modification par trentanel (05-09-2017 12:19:00)

Hors ligne

#7 05-09-2017 12:44:50

dorajim
Membre
Inscription : 29-08-2017

Re : [Résolu] Apache automatique

Impec. Ca a marché en faisant la commande : systemctl enable apache2.service

Merci pour l'aide.

Je vais tacher de faire de même avec Mysql car je viens de voir que j'ai le même problème.

Merci encore

Hors ligne

#8 05-09-2017 13:25:17

dorajim
Membre
Inscription : 29-08-2017

Re : [Résolu] Apache automatique

En tapant la commande : systemctl enable mysql.service

Ca a corriger le problème avec mysql.

C'est top.

Hors ligne

#9 05-09-2017 14:25:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Apache automatique

/me ignore encore tout de systemd...
Si c'est résolu, alors :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums