Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-09-2017 16:15:02

jettero
Membre
Lieu : Lausanne (suisse)
Distrib. : Debian GNU/Linux stretch/sid \n \l
Noyau : Linux 4.6.0-1-amd64
(G)UI : gdm3
Inscription : 09-03-2016

OpenGPG - timing

Bonjour à tous,

Je crypte les dossiers sensibles que j'utilise tous les jours avec Encfs.

Par contre, les données sauvegardées dans mon HDD ne sont pas cryptées. J'ai installé OpenGPG et j'ai une paire de clés. J'arrive à crypter à volonté les dossiers que je veux garder en backup.

Cependant, je n'arrive pas à régler un point. Quand je veux décrypter un fichier, le système me demande ma phrase de passe. Mais une fois mise, je peux à volonté déchiffrer n'importe quel autre fichier crypté car c'est comme si le système maintenait une "session" ouverte pour OpenGPG, est ça c'est pas top.

Je voudrais qu'à chaque fois que je veux décrypter un fichier, il me demande la phrase de passe, même si ça ne fait que 20 secondes que je viens de le faire.

Avez-vous une idée où je peux faire un réglage de ce genre ?

Dernière modification par jettero (13-09-2017 16:18:37)

Hors ligne

#2 13-09-2017 21:20:42

èfpé
Membre
Inscription : 10-07-2016

Re : OpenGPG - timing

Bonsoir jettero,

Qu'entends-tu exactement par « OpenGPG » ? GnuPG (alias GPG), qui est l'implémentation GNU du standard OpenPGP ? Dans ce cas tu peux regarder du côté de l'option --default-cache-ttl de gpg-agent :

nano ~/.gnupg/gpg-agent.conf

default-cache-ttl 0


La valeur par défaut étant 600 (secondes) ; consulte le man de gpg-agent et/ou wiki.gentoo.org.

Hors ligne

#3 14-09-2017 09:42:09

jettero
Membre
Lieu : Lausanne (suisse)
Distrib. : Debian GNU/Linux stretch/sid \n \l
Noyau : Linux 4.6.0-1-amd64
(G)UI : gdm3
Inscription : 09-03-2016

Re : OpenGPG - timing

Bonjour èfpé,

Merci de ta réponse. En effet il s'agit bien de GnuPG de openPGP.

Mon dossier ~/.gnupg ne contient pas le fichier de conf

maurizio@deboffice:~/.gnupg$ ls


gpa.conf           pubring.kbx   random_seed  trustdb.gpg
private-keys-v1.d  pubring.kbx~  S.uiserver
 



En utilisant dconf-editor j'ai trouvé deux options en ce qui concerne la gestion du cache dans : /desktop/gnome/crypto/cache/

gpg-cache-method : session
gpg-cache-ttl : 0 (il y avait bien en option 600 secondes).

Mais hélas ces modifications ne changent rien à mon problème de départ !

Hors ligne

#4 14-09-2017 12:24:42

èfpé
Membre
Inscription : 10-07-2016

Re : OpenGPG - timing

Re-,

Que le fichier gpg-agent.conf n'existe pas par défaut ne t'empêche pas de le créer, via nano ou autre :

echo default-cache-ttl 0 > ~/.gnupg/gpg-agent.conf


Il semble que tu utilises GPA (GNU Privacy Assistant) ; à l'occasion je testerai sous GNOME.

Hors ligne

#5 14-09-2017 13:35:06

jettero
Membre
Lieu : Lausanne (suisse)
Distrib. : Debian GNU/Linux stretch/sid \n \l
Noyau : Linux 4.6.0-1-amd64
(G)UI : gdm3
Inscription : 09-03-2016

Re : OpenGPG - timing

Ah ! ça à l'air simple en effet. Je ne maîtrise pas vraiment cette partie de linux, suis surtout un utilisateur têtu !

J'ai donc créé le fichier, mais comment je sais qu'il sera pris en charge par GnuPG ?

GPA je l'ai installé puis désinstallé. En fait j'ai installé openPGP et l'applet ainsi que seahorse. Le tout devrait me suffire.

Dernière modification par jettero (14-09-2017 13:35:30)

Hors ligne

#6 14-09-2017 13:45:15

jettero
Membre
Lieu : Lausanne (suisse)
Distrib. : Debian GNU/Linux stretch/sid \n \l
Noyau : Linux 4.6.0-1-amd64
(G)UI : gdm3
Inscription : 09-03-2016

Re : OpenGPG - timing

big_smile MERCI èfpé !!

C'est parfait ! C'est exactement ce que je voulais... ça marche au poil !

Hors ligne

Pied de page des forums