Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-09-2017 15:58:27

Privateer2
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome 3 au moins
Inscription : 04-09-2017

[Résolu] Vous avez dit completion ?

Bonjour,
Après une longue matinée pleine de rebondissements et d'imprévus, je décidais d'utiliser la ligne de commande pour une chose ou l'autre.

Las, le terminal n’apprécie pas visiblement l'ajout de l’auto-complétion :

su



Mot de passe :
bash: enable: bash : ceci n'est pas une primitive du shell
bash: enable: completion : ceci n'est pas une primitive du shell
bash: enable: in : ceci n'est pas une primitive du shell
bash: enable: interactive : ceci n'est pas une primitive du shell
bash: enable: shells : ceci n'est pas une primitive du shell
root@xx



sans arrêt

// Autocomplétion installée selon l'excellent tuto : Tuto sur l'autocomplétion

Dernière modification par Privateer2 (20-09-2017 16:53:09)


Bonjour et merci
(L'impression d'être dans un salon de lecture)

(Pourquoi 32 Go ? 16 Go pour l'usage , plus 16 Go pour une trentaine d'onglets/tuto ouverts en permanence smile)

Hors ligne

#2 20-09-2017 16:27:11

dejieres
Membre
Lieu : Moselle
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14+3 amd64
Inscription : 07-02-2017

Re : [Résolu] Vous avez dit completion ?

Hum, j'ai l'impression que tu as décommenté la ligne de commentaire... smile
bash: enable: bash : ceci n'est pas une primitive du shell
bash: enable: completion : ceci n'est pas une primitive du shell
bash: enable: in : ceci n'est pas une primitive du shell
bash: enable: interactive : ceci n'est pas une primitive du shell
bash: enable: shells : ceci n'est pas une primitive du shell

Hors ligne

#3 20-09-2017 16:40:12

Privateer2
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome 3 au moins
Inscription : 04-09-2017

Re : [Résolu] Vous avez dit completion ?

Ah bon ? a l'insu de moi-même alors smile



Rechercher la ligne # enable bash completion in interactive shell et supprimer les dièses (#) sur la portion de code après cette ligne jusqu'au dernier fi. Ce qui doit donner au final :



Extrait de bash.bashrc

   

# enable bash completion in interactive shells
    if ! shopt -oq posix; then
      if [ -f /usr/share/bash-completion/bash_completion ]; then
        . /usr/share/bash-completion/bash_completion
      elif [ -f /etc/bash_completion ]; then
        . /etc/bash_completion
      fi
    fi



Ce serait ceci ?

Dernière modification par Privateer2 (20-09-2017 16:45:38)


Bonjour et merci
(L'impression d'être dans un salon de lecture)

(Pourquoi 32 Go ? 16 Go pour l'usage , plus 16 Go pour une trentaine d'onglets/tuto ouverts en permanence smile)

Hors ligne

#4 20-09-2017 16:47:25

dejieres
Membre
Lieu : Moselle
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14+3 amd64
Inscription : 07-02-2017

Re : [Résolu] Vous avez dit completion ?

D'après le tuto, il faut modifier le fichier .bashrc en décommentant (c'est-à-dire ôter le # qui se trouve en début de ligne) certaines lignes.

Sauf bien entendu pour la première ligne qui est un commentaire et doit le rester :

# enable bash completion in interactive shells
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi


Je pense que, emporté par l'élan, tu as dû retirer le # aussi sur cette première ligne parce que bash semble vouloir l'exécuter.

Hors ligne

#5 20-09-2017 16:49:21

dejieres
Membre
Lieu : Moselle
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14+3 amd64
Inscription : 07-02-2017

Re : [Résolu] Vous avez dit completion ?

Oui, voilà, on s'est croisés smile

Hors ligne

#6 20-09-2017 16:51:22

Privateer2
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome 3 au moins
Inscription : 04-09-2017

Re : [Résolu] Vous avez dit completion ?

Bien vu, c'était ça, en plus c'est indiqué wink

Merci (deux points chocolats)

Bonjour et merci
(L'impression d'être dans un salon de lecture)

(Pourquoi 32 Go ? 16 Go pour l'usage , plus 16 Go pour une trentaine d'onglets/tuto ouverts en permanence smile)

Hors ligne

#7 20-09-2017 18:16:23

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Vous avez dit completion ?

Privateer2 a écrit :

(deux points chocolats)


Holà holà.. la gestion des points choco df revient à son admira.. administrateur en chef.
Ça serait trop facile sinon de piller tout le stock ou de se comporter en despote inique dans sa distribution...

big_smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums