Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-09-2017 11:14:34

Dédé
Membre
Inscription : 29-09-2017

(résolu) installer des logiciels (budgetview, java)

Bonjour ,
je viens de quitter windows pour handylinux. Mes connaissances en informatique sont rudimentaires et empiriques (étant d'une génération qui n'est pas née avec cet outil : j'ai 60 ans).
J'étais assez fier d'avoir pu installer le système handylinux sans aide mais mes premiers ennuis ont commencé quand j'ai voulu installer un logiciel de gestion de budget (BudgetView-4.036en.deb). Le terminal me demande apparemment d'installer un logiciel JAVA (No suitable Java Virtual Machine could be found on your system.The version of the JVM must be at least 1.8. Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.). Là je coince ... J'ai cherché sur le net et cela m'a paru très compliqué. S'il existe un tuto pas à pas je suis preneur. Merci de votre aide éventuelle.
caractéristiques de mon système :
-linux 3.16.0-4-686-pae
-processeur intel celeron D 3,06 GHz
-mémoire vive 1 Go (c'est un peu faible mais je vais la monter à 3 GO bientôt)

Dernière modification par Dédé (04-10-2017 16:25:20)

Hors ligne

#2 30-09-2017 12:41:37

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : (résolu) installer des logiciels (budgetview, java)

Bonjour smile
Peux tu nous copier coller la commande exacte que tu as faite pour installer ce logiciel et aussi le message complet obtenu

Hors ligne

#3 30-09-2017 13:34:43

èfpé
Membre
Inscription : 10-07-2016

Re : (résolu) installer des logiciels (budgetview, java)

Bonjour Dédé,

C'est juste que la version d'OpenJDK installée (openjdk-7-jre) par HandyLinux 2.5 est obsolète :

BudgetView

No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 1.8.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.


Pas de souci, tu as la possibilité d'installer la version rétroportée pour Jessie :

sudo apt-get -t jessie-backports install openjdk-8-jre

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  ca-certificates-java openjdk-8-jre-headless
Paquets suggérés :
  icedtea-8-plugin libnss-mdns fonts-ipafont-gothic fonts-ipafont-mincho ttf-wqy-microhei ttf-wqy-zenhei fonts-indic
Les NOUVEAUX paquets suivants seront installés :
  openjdk-8-jre openjdk-8-jre-headless
Les paquets suivants seront mis à jour :
  ca-certificates-java
1 mis à jour, 2 nouvellement installés, 0 à enlever et 409 non mis à jour.
Il est nécessaire de prendre 27,1 Mo dans les archives.
Après cette opération, 100 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de : 1 http://http.debian.net/debian/ jessie-backports/main ca-certificates-java all 20161107~bpo8+1 [14,8 kB]
Réception de : 2 http://http.debian.net/debian/ jessie-backports/main openjdk-8-jre-headless amd64 8u131-b11-1~bpo8+1 [27,0 MB]
Réception de : 3 http://http.debian.net/debian/ jessie-backports/main openjdk-8-jre amd64 8u131-b11-1~bpo8+1 [69,8 kB]      
27,1 Mo réceptionnés en 31s (855 ko/s)                                                                                      
(Lecture de la base de données... 126437 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../ca-certificates-java_20161107~bpo8+1_all.deb ...
Dépaquetage de ca-certificates-java (20161107~bpo8+1) sur (20140324) ...
Sélection du paquet openjdk-8-jre-headless:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../openjdk-8-jre-headless_8u131-b11-1~bpo8+1_amd64.deb ...
Dépaquetage de openjdk-8-jre-headless:amd64 (8u131-b11-1~bpo8+1) ...
Sélection du paquet openjdk-8-jre:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../openjdk-8-jre_8u131-b11-1~bpo8+1_amd64.deb ...
Dépaquetage de openjdk-8-jre:amd64 (8u131-b11-1~bpo8+1) ...
Traitement des actions différées (« triggers ») pour ca-certificates (20141019+deb8u1) ...
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....
done.
done.
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
Paramétrage de ca-certificates-java (20161107~bpo8+1) ...
Installation de la nouvelle version du fichier de configuration /etc/ca-certificates/update.d/jks-keystore ...
Traitement des actions différées (« triggers ») pour ca-certificates (20141019+deb8u1) ...
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....
done.
done.
Paramétrage de openjdk-8-jre-headless:amd64 (8u131-b11-1~bpo8+1) ...
update-alternatives: utilisation de « /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/jjs » pour fournir « /usr/bin/jjs » (jjs) en mode automatique
Paramétrage de openjdk-8-jre:amd64 (8u131-b11-1~bpo8+1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u4) ...
 


Et c'est tout. Par contre tu dois préalablement adapter/modifier le fichier sources.list.

7eE887z8H.BudgetView.s.png

Note qu'une version française du logiciel (BudgetView-4.03-fr.deb) est disponible, .

Hors ligne

#4 30-09-2017 17:53:34

Dédé
Membre
Inscription : 29-09-2017

Re : (résolu) installer des logiciels (budgetview, java)

Merci.
ça n'a pas marché. Je pense que c'est la modification de source list qui bloque. Je n'ai pas trop su quoi en faire (je débute en linux et je ne comprends pas grand chose en informatique. Je fonctionne en essai erreur car j'ai beaucoup de temps). J'ai donc écrit le fichier source.list dans le terminal. Puis j'ai essayé la commande que vous m'avez envoyée. Le terminal ne trouve pas openjdk-8-jre. Voilà ce qu'il m'écrit :
andre@handylinux ~
$ BudgetView
No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 1.8.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.
andre@handylinux ~
$ # Debian Jessie, dépôt principal
andre@handylinux ~
$ deb http://deb.debian.org/debian/ jessie main
No command 'deb' found, did you mean:
Command 'debc' from package 'devscripts' (main)
Command 'derb' from package 'icu-devtools' (main)
Command 'debi' from package 'devscripts' (main)
Command 'dwb' from package 'dwb' (main)
deb: command not found
andre@handylinux ~
$ # Debian Jessie, mises-à-jour de sécurité
andre@handylinux ~
$ deb http://security.debian.org/ jessie/updates main
No command 'deb' found, did you mean:
Command 'debc' from package 'devscripts' (main)
Command 'derb' from package 'icu-devtools' (main)
Command 'debi' from package 'devscripts' (main)
Command 'dwb' from package 'dwb' (main)
deb: command not found
andre@handylinux ~
$ # Debian Jessie, mises-à-jour "volatiles"
andre@handylinux ~
$ deb http://deb.debian.org/debian/ jessie-updates main
No command 'deb' found, did you mean:
Command 'debc' from package 'devscripts' (main)
Command 'derb' from package 'icu-devtools' (main)
Command 'debi' from package 'devscripts' (main)
Command 'dwb' from package 'dwb' (main)
deb: command not found
andre@handylinux ~
$ # Debian Jessie, dépôt de rétroportages ("backports")
andre@handylinux ~
$ deb http://deb.debian.org/debian jessie-backports main
No command 'deb' found, did you mean:
Command 'debc' from package 'devscripts' (main)
Command 'derb' from package 'icu-devtools' (main)
Command 'debi' from package 'devscripts' (main)
Command 'dwb' from package 'dwb' (main)
deb: command not found
andre@handylinux ~
$ sudo apt-get -t jessie-backports install openjdk-8-jre
[sudo] mot de passe pour andre :       
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet openjdk-8-jre

Hors ligne

#5 30-09-2017 18:16:42

èfpé
Membre
Inscription : 10-07-2016

Re : (résolu) installer des logiciels (budgetview, java)

Re-,

OK ; ma faute, je n'ai pas suffisamment détaillé... pas grave ; on recommence :

gksu mousepad /etc/apt/sources.list

te retourne,

deb http://deb.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://deb.debian.org/debian/ jessie-updates main contrib non-free

tu ajoutes :

deb http://deb.debian.org/debian/ jessie-backports main contrib non-free


Puis tu enregistres la modification (Fichier > Enregistrer ou Ctrl+S) smile

Vérifie que la modification est effective avec :

cat /etc/apt/sources.list

deb http://deb.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
deb http://deb.debian.org/debian/ jessie-backports main contrib non-free


Puis « recharge » les listes de paquets avec :

sudo apt-get update


Pour finir, installe openjdk-8-jre (avec la commande citée au post #3).

Dernière modification par èfpé (30-09-2017 18:24:42)

Hors ligne

#6 03-10-2017 17:07:14

Dédé
Membre
Inscription : 29-09-2017

Re : (résolu) installer des logiciels (budgetview, java)

Merci, ça a marché, je peux utiliser budgetview.

Hors ligne

#7 04-10-2017 09:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : (résolu) installer des logiciels (budgetview, java)

Bonjour,

Sauf erreur de ma part, l'installation du paquet Debian ne crée pas d'entrée de menu :

sudo cp /opt/budgetview/BudgetView.desktop /usr/share/applications


crée une entrée Menu des applications > Autres > BudgetView ;

cp /opt/budgetview/BudgetView.desktop /home/$USER/Bureau


fait apparaître une icône (un genre de raccourci) sur le bureau...

Quoi qu'il en soit, passer le fil en [Résolu] est un jeu d'enfant : tu édites ton premier message en cliquant sur 'Modifier' et tu en préfixes le titre en ajoutant '[Résolu] ' au début, et hop !

Hors ligne

#8 04-10-2017 10:13:16

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : (résolu) installer des logiciels (budgetview, java)

Bonjour
Le fichier budgetview.desktop est il bien rendu exécutable?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 04-10-2017 10:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : (résolu) installer des logiciels (budgetview, java)

Re-,

@Croutons : un fichier .desktop n'étant pas un script n'a donc pas à être 'exécutable' ;

ls -l /usr/share/applications


Pourra éventuellement te convaincre de la chose, en cas de doute persistant.

Hors ligne

#10 04-10-2017 11:04:48

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : (résolu) installer des logiciels (budgetview, java)

arf oui my bad ops.gif

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#11 04-10-2017 16:19:21

Dédé
Membre
Inscription : 29-09-2017

Re : (résolu) installer des logiciels (budgetview, java)

Je ne comprends pas ce que veut dire " passer le fil en résolu". Mais j'intuite que quand on soulève une difficulté il est nécessaire de confirmer que la solution proposée a résolu le problème. En fait mon terminal n'a pas donné tout à fait les réponses que vous aviez annoncées. Mais intuitivement j'ai remplacé les réponses données par celles que vous aviez prévues et ça a marché même si le terminal a indiqué que certains dossiers n'étaient pas installés correctement.
Comme vous le voyez je fonctionne beaucoup à l'intuition : parfois ça marche, parfois ça casse...
En tout cas merci pour votre aide et il est fort probable que j'aurai encore besoin d'être soutenu.

Hors ligne

Pied de page des forums