Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-10-2017 00:42:34

Gryffon
Membre
Inscription : 06-10-2017

problème installation gcompris

Bonjour,

J'ai installé DF-Linux et via synaptic, j'ai voulu installer la suite Gcompris. Sauf que la version proposée n'est pas la dernière disponible.
J'ai donc téléchargé une version plus récente sur le site de l'éditeur et suivi la procédure jusqu'au moment où dans la console, j'ai une suite d'erreurs. Le jeu se lance, mais une fois fermé, il n'est pas installé.

Voici ce que j'obtiens dans la console :
------------------------
root@debian:~#

cd ~/Téléchargements/gcompris-qt-0.81-Linux/bin


root@debian:~/Téléchargements/gcompris-qt-0.81-Linux/bin#

 sudo sh ./gcompris-qt.sh


QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
exeCount set to:  4
qml: enter main.qml (run #4, ratio=2.076923076923077, fontRatio=2.2470433639947434, dpi=102, sharedWritablePath=/root/.local/share/GCompris)
Downloading resource file "data2/voices-ogg/voices-fr.rcc"
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback
qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init
qt.network.ssl: QSslSocket: cannot resolve sk_new_null
qt.network.ssl: QSslSocket: cannot resolve sk_push
qt.network.ssl: QSslSocket: cannot resolve sk_free
qt.network.ssl: QSslSocket: cannot resolve sk_num
qt.network.ssl: QSslSocket: cannot resolve sk_pop_free
qt.network.ssl: QSslSocket: cannot resolve sk_value
qt.network.ssl: QSslSocket: cannot resolve SSL_library_init
qt.network.ssl: QSslSocket: cannot resolve SSL_load_error_strings
qt.network.ssl: QSslSocket: cannot resolve SSL_get_ex_new_index
qt.network.ssl: QSslSocket: cannot resolve SSLv2_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv2_server_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_server_method
qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get_chain
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
qt.network.ssl: QSslSocket: cannot resolve SSLeay
qt.network.ssl: QSslSocket: cannot resolve SSLeay_version
qt.network.ssl: Incompatible version of OpenSSL
Local resource is up-to-date: "voices-fr.rcc"
Successfully registered resource "/root/.cache/KDE/gcompris-qt/data2/voices-ogg/voices-fr.rcc"

** (gcompris-qt:2148): CRITICAL **: file gstaudioringbuffer.c: line 1993 (gst_audio_ring_buffer_set_channel_positions): should not be reached
DownloadManager: shutting down, 0 active jobs
DownloadManager: shutting down, 0 active jobs
root@debian:~/Téléchargements/gcompris-qt-0.81-Linux/bin#


------------------------------------------------------------------
J'ai cru comprendre qu'il y avait des dépôts alternatifs (backports je crois) avec des versions plus récentes, mais je n'ai pas encore compris comment y accéder...ops.gif

J'espère que quelqu'un pourra m'aider et pourra m'expliquer de manière simple si possible, vu que je suis vraiment novice!!
Merci par avance!

Hors ligne

#2 07-10-2017 07:39:24

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : problème installation gcompris

Bonjour,
Gcompris n'est pas dans le dépôt stretch-backports.
As-tu un souci de fonctionnement avec la version des dépôts ? Souvent il n'y a pas de changements importants d'une version à l'autre et la version du dépôt stable est à préférer alors pour la stabilité du système plutôt que d'installer un logiciel hors dépôt.

Hors ligne

#3 07-10-2017 10:19:35

Gryffon
Membre
Inscription : 06-10-2017

Re : problème installation gcompris

Bonjour !

J'ai installé la version du dépôt et malheureusement, il manque des jeux et l'interface fait vraiment très datée.
Mis à part cela je trouve vraiment dommage d'avoir une nouvelle version et de ne pas pouvoir en profiter...

Hors ligne

#4 07-10-2017 11:16:18

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : problème installation gcompris

Gryffon a écrit :

Mis à part cela je trouve vraiment dommage d'avoir une nouvelle version et de ne pas pouvoir en profiter...

Dans ce cas, c'est que Debian Stable n'est pas la distribution qu'il te faut wink Tourne toi plutôt vers des distribution avec un cycle de publication plus court, comme Ubuntu, Fedora, OpenSuse ..., voire, des distributions à publication continue (Rolling Release), par exemple Archlinux ou Manjaro

Peut-être peux-tu proposer ton aide au mainteneur bénévole Yann Dirson afin de l'aider à avoir Gcompris-qt dans les dépôts pour la prochaine verision Stable de Debian ? https://tracker.debian.org/pkg/gcompris-qt


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#5 07-10-2017 13:15:30

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : problème installation gcompris

bendia a écrit :

Dans ce cas, c'est que Debian Stable n'est pas la distribution qu'il te faut


Oui effectivement si c'est important pour toi d'avoir la dernière version des logiciels, Debian stable ne te conviendra pas.

Hors ligne

#6 07-10-2017 13:44:49

Gryffon
Membre
Inscription : 06-10-2017

Re : problème installation gcompris

Je comprends tout à fait ce point de vue. Ce n'est pas forcément une obsession de ma part d'avoir la dernière version des logiciels. C'est seulement que dans ce cas precis, je trouverais cela intéressant.
J'ai également eu un souci avec Libreoffice Impress(en version 5.2 sur le dépôt)  Et cela s'est réglé en installant la version 5.3 dispo sur le site de Libreoffice.

Hors ligne

#7 07-10-2017 14:14:58

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : problème installation gcompris

Pour le coup libreoffice 5.4 est disponible dans stretch-backports. Il aurait été intéressant de poser la question sur ce souci car l'installation d'un paquet externe pouvait être éviter peut-être et c'est toujours mieux wink
Complète ton profil comme indiqué dans ta présentation, ça ne pourra qu'aider à t'aider. Distribution, Version du noyau et bureau.

Hors ligne

Pied de page des forums