Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-10-2017 12:51:58

H4X0R
Membre
Distrib. : Debian GNU/Linux 9.2 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Xfce4
Inscription : 14-09-2017

[Résolu] démarrage super rapide

bonjour,
j'ai désinstaller KDE et maintenant quand je démarre il me mais en ligne de commande et je doit entrée mon login et mon mdp et faire startx.
Donc j'aimerais que ma session xfce s'ouvre automatiquement sans mdp et que mon pc démarre le plus rapidement possible.

basename $(cat /etc/X11/default-display-manager)

me renvoie

lightdm


devrait-je supprimer lightdm ?
j'ai rajoute les lignes ci-dessous au fichier ~/.bash_profil

if [ -z "$DISPLAY" ] && [ $(tty) == /dev/tty1 ]; then
 /usr/bin/startxfce4
 fi

mais rien ne change.

Dernière modification par H4X0R (18-10-2017 13:43:02)

Hors ligne

#2 14-10-2017 20:58:40

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] démarrage super rapide

Le supprimer ou le désactiver via sysemd revient au même, ça ralentira pas le démarrage, il servira pas.

Là ça te lance startx au login, faut que tu mettes en place l'autologin.  Y a une chiée de tuto, on passe généralement plutôt par systemd pour ça aussi (genre : http://forums.debian.net/viewtopic.php?t=123694)

On gagne pas plus de temps qu'en utilisant un lightdm en autologin, mon ressenti. Mai bon, je l'ai fait aussi, vois par toi-même.

Dernière modification par otyugh (14-10-2017 20:59:16)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#3 15-10-2017 12:55:41

H4X0R
Membre
Distrib. : Debian GNU/Linux 9.2 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Xfce4
Inscription : 14-09-2017

Re : [Résolu] démarrage super rapide

merci de ta réponse, l'autologin fonctionne bien startx s'execute automatiquement mais il est un peut long. Pendant l’exécution de startx il m'affiche des erreurs:

(EE)
Fatal serveur error:
(EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)
(EE) Server terminated with error (1), Closing log file.

Dernière modification par H4X0R (15-10-2017 12:56:46)

Hors ligne

#4 15-10-2017 13:30:39

H4X0R
Membre
Distrib. : Debian GNU/Linux 9.2 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Xfce4
Inscription : 14-09-2017

Re : [Résolu] démarrage super rapide

en fait s'est bon j'avais oublie d'enlever se que j'avais mis dans ~/.bashrc
sinon y'a du texte qui s'affiche au début, s'est normal je pense.

Vous savez comment dopez encore plus le démarrage ?

Hors ligne

#5 15-10-2017 14:40:41

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] démarrage super rapide

Bonjour
Passer ton PC en hibernation au lieu de l'éteindre le rendra peut être encore plus rapide au démarrage
ou carrément installer le système sur un SSD

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 15-10-2017 14:58:42

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] démarrage super rapide

H4xor : utilise systemd-analyze.

Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#7 15-10-2017 15:19:52

H4X0R
Membre
Distrib. : Debian GNU/Linux 9.2 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Xfce4
Inscription : 14-09-2017

Re : [Résolu] démarrage super rapide

je comprend pas metasploit prend tout

systemd-analyze blame


         36.223s metasploit.service
          7.138s NetworkManager-wait-online.service
          6.446s dev-sda5.device
          6.249s vboxdrv.service
          4.712s systemd-rfkill.service
          4.397s ModemManager.service
          4.090s NetworkManager.service
          3.043s networking.service
          2.371s udisks2.service
          1.973s pppd-dns.service
          1.966s avahi-daemon.service
          1.947s systemd-logind.service
          1.604s systemd-udevd.service
          1.341s rsyslog.service
          1.272s bluetooth.service
          1.134s systemd-tmpfiles-setup-dev.service
          1.109s lm-sensors.service
          1.062s systemd-modules-load.service
          1.030s keyboard-setup.service
           949ms polkit.service
           944ms upower.service
           921ms console-setup.service
           759ms dev-disk-by\x2duuid-7fef29a3\x2d89e3\x2d47f6\x2daea7\x2d224f35c80c
           698ms systemd-tmpfiles-setup.service
           631ms systemd-remount-fs.service



Edit à toto :

Séparer la commande user de son retour sur le forum il faut, jeune padawan...

Dernière modification par H4X0R (15-10-2017 15:20:40)

Hors ligne

#8 15-10-2017 21:15:47

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] démarrage super rapide

Ben voilà ta piste d'amélioration.

Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#9 16-10-2017 07:08:31

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] démarrage super rapide

Bonjour,
C'est quoi metasploit.service ?

Hors ligne

#10 16-10-2017 07:35:22

IceF0x
Membre
Distrib. : Jessie 8.7
Noyau : Linux 3.16.0-4-amd64
(G)UI : OpenBox
Inscription : 05-02-2012

Re : [Résolu] démarrage super rapide

un framework de pentesting, inutile de lancer le service au boot.

Tu peux disable metasploit.service sans problème, surtout qu'on utilise pas ce genre d'outil tout les jours.

1475862269.gif

Hors ligne

#11 16-10-2017 08:10:58

H4X0R
Membre
Distrib. : Debian GNU/Linux 9.2 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Xfce4
Inscription : 14-09-2017

Re : [Résolu] démarrage super rapide

Mercie encore de vôtre aide
je peut supprimer quel  service dans mon cas ?
comment on fait pour disable un .service ?

Dernière modification par H4X0R (16-10-2017 08:21:21)

Hors ligne

#12 16-10-2017 08:30:50

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] démarrage super rapide

H4X0R a écrit :

comment on fait pour disable un .service ?


Le tuto systemd peut aider ?
https://debian-facile.org/doc:system:systemd


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 16-10-2017 10:18:47

H4X0R
Membre
Distrib. : Debian GNU/Linux 9.2 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Xfce4
Inscription : 14-09-2017

Re : [Résolu] démarrage super rapide

j'ai supprimer network-manager et j'ai configurer le fichier Network/interfaces pour utiliser mon wifi, maintenant le network.service prend 20s a se chargé s'est normal ?

Hors ligne

Pied de page des forums