Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-10-2017 23:47:27

Walker29
Membre
Lieu : Bretagne (Finistère)
Distrib. : Debian 9.2 (Stretch)
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Xfce 4.12
Inscription : 23-04-2016

[Résolu] - [FAILED] Load kernel modules

Bonsoir à toutes et à tous,

Je viens vers vous car là je bloque sur ce problème. Après avoir écumé des pages et des pages je ne parvient pas à trouver la solution. Peut-être qu'une âme charitable pourra m'aider ? Depuis deux jours, je suis passé de Jessie (où je n'avais aucun soucis) à Stretch. J'ai choisi la facilité en faisant une réinstallation complète. Pour infos, mon PC portable est un Toshiba Satellite C660D. A la fin de l'installation, au reboot j'ai eu plusieurs messages concernant l'ACPI. Donc je fais quelques recherches sur le Net et après avoir testé plusieurs solutions (en modifiant le fichier /etc/default/grub) rien n'y fait. Du coup, comme certains l'on fait, j'ai tout désactiver...

Voici mon fichier "/etc/default/grub

# cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off apm=power_off"
 

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
 



bloc à supprimer si la commande n’affiche rien



Du coup, je reboot et tout va bien ! Mais quelques secondes après un nouveau message d'erreur apparaît.
[FAILED] Load kernel modules
Après quelques recherches, je trouve le moyen d'identifier le problème avec les commandes suivantes :

$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2017-10-21 22:23:17 CEST; 57min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 188 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 188 (code=exited, status=1/FAILURE)
 



Et ensuite la commande suivante :

# journalctl -b _PID=188
-- Logs begin at Sat 2017-10-21 22:23:16 CEST, end at Sat 2017-10-21 23:34:47 CEST. --
oct. 21 22:23:17 debian-C660D systemd-modules-load[188]: Inserted module 'lp'
oct. 21 22:23:17 debian-C660D systemd-modules-load[188]: Inserted module 'ppdev'
oct. 21 22:23:17 debian-C660D systemd-modules-load[188]: Inserted module 'parport_pc'
oct. 21 22:23:17 debian-C660D systemd-modules-load[188]: Failed to find module 'apm power_off=1'
 



Je vous met le résultat de la commande dmesg

# dmesg | grep ACPI
[    0.000000] BIOS-e820: [mem 0x00000000a7a9c000-0x00000000a7af4fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000a7b24000-0x00000000a7b2bfff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000a7b51000-0x00000000a7b93fff] ACPI NVS
[    0.351851] PM: Registering ACPI NVS region [mem 0xa7a9c000-0xa7af4fff] (364544 bytes)
[    0.351892] PM: Registering ACPI NVS region [mem 0xa7b24000-0xa7b2bfff] (32768 bytes)
[    0.351896] PM: Registering ACPI NVS region [mem 0xa7b51000-0xa7b93fff] (274432 bytes)
[    0.392557] ACPI: Interpreter disabled.
[    0.443541] pnp: PnP ACPI: disabled
 



Vu la dernière ligne "PnP ACPI: disabled", je suis repartis fouiller dans le BIOS, histoire de voir si il n'y avait pas une option dans ce dernier à activer ? Mais malheureusement je n'ai rien trouvé... Et maintenant je bloque en étant persuadé que je ne suis pas loin de la solution. Ce qui est encore plus frustrant ! hmm
Si quelqu'un à une idée, je suis preneur... Merci par avance big_smile

Dernière modification par Walker29 (22-10-2017 02:16:30)


- La logique vous conduira d'un point A à un point B, l'imagination et l'audace vous conduiront où vous le désirez ! (A. Einstein)
- Quelle époque terrible que celle ou des idiots dirigent des aveugles ! (W. Shakespeare)
- Si vous ne faites pas aujourd'hui ce que vous avez dans la tête, demain vous l'aurez dans le c... (Coluche) big_smile

Hors ligne

#2 22-10-2017 01:23:43

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] - [FAILED] Load kernel modules

systemd-modules-load essaie de charger le module "apm".
Tu ne l'aurais pas ajouté dans le fichier /etc/modules ?
Mais apparemment ce module n'existe que dans les noyaux 32 bits (686), pas dans les noyaux 64 bits (amd64).

Hors ligne

#3 22-10-2017 01:52:15

Walker29
Membre
Lieu : Bretagne (Finistère)
Distrib. : Debian 9.2 (Stretch)
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Xfce 4.12
Inscription : 23-04-2016

Re : [Résolu] - [FAILED] Load kernel modules

Bonsoir Raleur,
Merci pour ta réponse, mais je t'avouerais que je suis un peu larguer là ! J'ai regardé, et voilà le résultat

# cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
apm power_off=1
 



Faut-il que je commente la ligne contenant "apm power_off=1" et faire un reboot après ? scratchhead.gif


- La logique vous conduira d'un point A à un point B, l'imagination et l'audace vous conduiront où vous le désirez ! (A. Einstein)
- Quelle époque terrible que celle ou des idiots dirigent des aveugles ! (W. Shakespeare)
- Si vous ne faites pas aujourd'hui ce que vous avez dans la tête, demain vous l'aurez dans le c... (Coluche) big_smile

Hors ligne

#4 22-10-2017 02:21:44

Walker29
Membre
Lieu : Bretagne (Finistère)
Distrib. : Debian 9.2 (Stretch)
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Xfce 4.12
Inscription : 23-04-2016

Re : [Résolu] - [FAILED] Load kernel modules

Encore merci pour ta réponse Raleur ! big_smile

Finalement, j'ai commenté la dernière ligne du fichier "/etc/modules", puis rebooté et le message d'erreur à disparu.

# cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
#apm power_off=1
 



P.S. : Je vais continuer à chercher pour activer la prise en charge de l'ACPI.


- La logique vous conduira d'un point A à un point B, l'imagination et l'audace vous conduiront où vous le désirez ! (A. Einstein)
- Quelle époque terrible que celle ou des idiots dirigent des aveugles ! (W. Shakespeare)
- Si vous ne faites pas aujourd'hui ce que vous avez dans la tête, demain vous l'aurez dans le c... (Coluche) big_smile

Hors ligne

#5 22-10-2017 11:16:40

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] - [FAILED] Load kernel modules

Walker29 a écrit :

Merci pour ta réponse, mais je t'avouerais que je suis un peu larguer là


Qu'est-ce que tu ne comprends pas ?
C'est bien toi qui a modifié ce fichier, sur les instructions mentionnées dans les discussions que tu as trouvées, comme pour la modification dans /etc/default/grub ? Par défaut il ne contient que des commentaires.

Note : si tu désactives complètement la prise en charge de l'ACPI mais que l'APM n'est pas disponible, l'extinction logicielle risque de ne pas fonctionner.
Les messages d'erreur ACPI ont-ils vraiment des conséquences sur le fonctionnement de la machine ?

Hors ligne

#6 22-10-2017 14:16:25

Walker29
Membre
Lieu : Bretagne (Finistère)
Distrib. : Debian 9.2 (Stretch)
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Xfce 4.12
Inscription : 23-04-2016

Re : [Résolu] - [FAILED] Load kernel modules

Bonjour Raleur,

Qu'est-ce que tu ne comprends pas ?
C'est bien toi qui a modifié ce fichier, sur les instructions mentionnées dans les discussions que tu as trouvées, comme pour la modification dans /etc/default/grub ? Par défaut il ne contient que des commentaires.


Oui tout à fait c'est bien moi qui ai modifié /etc/default/grub en suivant des instructions postées sur le net sans vraiment savoir, ni comprendre ce que je faisait (du copier/collé en fait). Mais après une bonne nuit de sommeil tout est plus clair. tongue

Note : si tu désactives complètement la prise en charge de l'ACPI mais que l'APM n'est pas disponible, l'extinction logicielle risque de ne pas fonctionner.


Effectivement je ne peut plus éteindre le PC de manière logicielle, je dois toujours appuyer sur le bouton de mise sous tension... C'est pas top !

Les messages d'erreur ACPI ont-ils vraiment des conséquences sur le fonctionnement de la machine ?


Donc, comme tu le dis si bien ces messages d'erreurs n'empêche en rien le bon fonctionnement du système. Mais tu sais bien que nous aimons bien, nous les debianeux, avoir un système qui tourne comme une horloge big_smile. Mais en tout cas, merci pour ton aide. Je vais réactiver l'ACPI et APM car j'ai le ventilo du PC qui tourne sans cesse...


- La logique vous conduira d'un point A à un point B, l'imagination et l'audace vous conduiront où vous le désirez ! (A. Einstein)
- Quelle époque terrible que celle ou des idiots dirigent des aveugles ! (W. Shakespeare)
- Si vous ne faites pas aujourd'hui ce que vous avez dans la tête, demain vous l'aurez dans le c... (Coluche) big_smile

Hors ligne

#7 22-10-2017 17:39:28

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] - [FAILED] Load kernel modules

Walker29 a écrit :

c'est bien moi qui ai modifié /etc/default/grub


Tu l'as déjà écrit dans ton message initial. Je parlais du fichier /etc/modules que tu as dû modifier en même temps.

Walker29 a écrit :

en suivant des instructions postées sur le net sans vraiment savoir, ni comprendre ce que je faisait


Ce n'est pas une pratique que je recommanderais, au contraire. Quand on ne comprend pas ce qu'on fait et ce que ça fait, on s'expose davantage aux erreurs et aux conséquences inattentues et inexplicables.

Walker29 a écrit :

Mais tu sais bien que nous aimons bien, nous les debianeux, avoir un système qui tourne comme une horloge


Je ne dis pas que c'est le cas ici, mais il faut accepter le fait que certains messages d'erreur peuvent être normaux. Par exemple lorsque le firmware de la carte mère est buggé.

Walker29 a écrit :

Je vais réactiver l'ACPI et APM


Je ne voudrais pas raconter de bêtises, mais il me semble qu'on ne peut pas activer les deux en même temps.

Dernière modification par raleur (22-10-2017 17:41:56)

Hors ligne

#8 22-10-2017 20:29:17

Walker29
Membre
Lieu : Bretagne (Finistère)
Distrib. : Debian 9.2 (Stretch)
Noyau : Linux 4.13.0-0.bpo.1-amd64
(G)UI : Xfce 4.12
Inscription : 23-04-2016

Re : [Résolu] - [FAILED] Load kernel modules

Oui tu as raison sur les trois premiers points, pour ce qui est de ACPI et APM en même temps effectivement ils ne vont pas ensembles. Je continue à creuser, et dès que j'aurai la solution, je la posterai dans ce fil de discussion histoire que ceux qui possède des Toshiba puissent en profiter. D'après ce que j'ai vu c'est assez particulier sur ces bécanes.

- La logique vous conduira d'un point A à un point B, l'imagination et l'audace vous conduiront où vous le désirez ! (A. Einstein)
- Quelle époque terrible que celle ou des idiots dirigent des aveugles ! (W. Shakespeare)
- Si vous ne faites pas aujourd'hui ce que vous avez dans la tête, demain vous l'aurez dans le c... (Coluche) big_smile

Hors ligne

Pied de page des forums